~]
Pix4D

simply powerful

~L]

DiX4p
[Mdpper

O AR

Getting Started Manual

Pix4Dmapper 2.1

www.pixdd.com

EPFL Innovation Park - Building D CO N VE RT + D E I_I VE R
1015 Lausanne, Switzerland You g+l
171559 0563 i) £l s din



Index © Previous | Next ©

The following description shows the minimum and recommended Hardware and Software requirements:

Minimum:

Windows 7, 8, 10, Sener 2008, Sener 2012, 64 bits (PC or Mac computers using Boot Camp).
Any CPU (Intel i5/ i7/ Xeon recommended).

Any GPU that is compatible with OpenGL 3.2. (integrated graphic cards Intel HD 4000 or abowe).
Small projects (under 100 images at 14 MP): 4 GB RAM, 10 GB HDD Free Space.

Medium projects (between 100 and 500 images at 14 MP): 8 GB RAM, 20 GB HDD Free Space.
Large projects (between 500 and 2000 images at 14 MP): 16 GB RAM, 40 GB HDD Free Space.
Very Large projects (over 2000 images at 14 MP): 16 GB RAM, 80 GB HDD Free Space.

Recommended:

Windows 7, 8 64 bits.

CPU quad-core or hexa-core Intel i7/Xeon.

GeForce GPU compatible with OpenGL 3.2 and 2 GB RAM.

Hard disk: SSD.

Small projects (under 100 images at 14 MP): 8 GB RAM, 15 GB SSD Free Space.

Medium projects (between 100 and 500 images at 14 MP): 16GB RAM, 30 GB SSD Free Space.
Large projects (over 500 images at 14 MP): 32 GB RAM, 60 GB SSD Free Space.

Very Large projects (over 2000 images at 14 MP): 32 GB RAM, 120 GB SSD Free Space.

@ Information:
An SSD hard drive can speed up processing.
The graphic card may have an improvement on the processing speed for step 1 and step 2 (if the graphic card is compatible with CUDA (NVIDIA Graphic
Cards). Processing time of step 3 is not affected by the GPU. The GPU affects considerably the visualization of the rayCloud. For more information about
the use of the GPU: 203405619.
For more information about Hardware components usage when processing with Pix4Dmapper: 202559519.
For recommendations for a Hardware and Software Configuration: 202559159.
For more information regarding: Mac / Windows XP / Linux / Remote Access - Virtual machine / Distributed - Parallel processing: 202556809.
For more information about processing speed: 204191535.
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@ Important: Interet connection is required to download and install the software.

Download the software following:

1. Go to http://pix4d.com/download/
2. Click Download.

Once the software has been downloaded, install it using the following steps:

1. Double click the downloaded file. The Pix4Dmapper Setup wizard starts.
2. (optional): If the Open file - Security Waming pop-up appears, click Run.

Open File - Security Warning *

The publisher could not be verified. Are you sure that you want to run this
software?

_|Z| Name: D:\Downloads\Pix4Dmapper.msi

o
Publisher: PDdD SA

i

Type: Windows Installer Package

From: D:\Downloads)Pixd C'mapper.msi

Run i Cancel

[~] Always ask before opening this file

This file does not have a valid digital signature that verifies its
|@J publisher. You should only run software from publishers you trust.
How can | decide what software to run?

3. In the Pix4Dmapper Setup pop-up, in the Welcome to the Pix4Dmapper Setup Wizard screen, click Next >.

ﬁ PredDmapper Setup >
- Welcome to the PixdaDmapper
2.1.27 Setup Wizard

The Setup Wizard will allow you to change the way
Pix4Dmapper features are installed on your computer or
even to remove Pix4Dmapper from your computer. Click
"Mext” to continue or "Cancel” to exit the Setup Wizard.

4. (optional) Click Browse... to change the destination path for the installation.
5. Click Next >.
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ﬁ! PixdDmapper Setup - *

Select Installation Folder
= |

This is the folder where Pix4Dmapper will be installed. &

To install in this folder, dick "Mext™, To install to a different folder, enter it below or dick

"Browse",
|

Folder:

| IC:\Program Files\Pix4Dmapper, Browse...

Advanced Installer

6. Click Install.
ﬁ! PixdDmapper Setup x
Ready to Install
The Setup Wizard is ready to begin the Pix4Dmapper installation e

Click "Install” to begin the installation. If you want to review or change any of your
installation settings, dick "Back”™. Click "Cancel” to exit the wizard.

Advanced Installer

< Back “ Cancel

7. (optional) In the software information window: "Do you want to allow the following program to install software on this computer?", Click Yes.
8. Click Finish .

ﬁ! PixdDmapper Setup x

Completing the Pix4Dmapper
Setup Wizard

Click the "Finish"™ button to exit the Setup Wizard.

Launch Pix4Dmapper

< Badk Cancel




9. A shortcut is created on your desktop and the software opens automatically once the installation is completed.

~]

x40

10. The first time you open the software, the Pix4Dmapper Login window appears:

(If a proxy sener is used to connect to intemet, click Proxy... and follow these instructions: 202560089)

B PixdDmapper Login X

A
Bix4p

simply powerful

.—5 | Email |
['Tj | Password |

Login | 1 forgot my password

Don't have an account? Sign up now

Redeem license key

Proxy... | | Help |

11. If you already have an account, type your Email and Password and click Login.

l[]:] Note: If there is already a license assigned to your account: 207948656.

L/ PixdDmapper Legin *

A~
Bix4p

simply powerful

,ﬂ_‘a, |john@mapper.com |

[?] |......... |
1 forgot my password

Don't have an account? Sign up now

Redeem license key

Proxy... | | Help |

12. Read the End-User License Agreement, select "I accept the terms in the License Agreement” and click Next.


https://support.pix4d.com/hc/en-us/articles/202560089
https://support.pix4d.com/hc/en-us/articles/edit?return_to=%2Fhc%2Fen

[ PixdDmapper - End-User License Agreement H

Please read the following License Agreement.

PIX4DMAPPER END USER LICENSE AGREEMENT o)
GENERAL

Please carefulty read and review this end user license Agreement. This
Agreement is a legal agreement between Pix4D SA, a corporation
registered in Switzerland under number CHE207 .009.701 with its seat at
EPFL Innowvation Park, Batiment D, 1015 Lausanne, and you (either an
individual or an entity).

This Agreement specifies the terms and conditions under which Pix4D
allows you to use the PixdDmapper Software to input, process, assess,
anatyze, edit, output and deliver data for mapping and modelling
purposes, and the Documentation accompanying the Software.

IMPORTANT

By installing or using the Software, you are confirming your
complete and unconditional acceptance of the terms and
conditions set forth in this Agreement and agreeing to become
bound by this Agreement. If you do not agree to the terms and
conditions of this Agreement, you may not install or use the
Software and are formally requested either to promptly

remove the Software from your device, computer or server

and to return any delivered media containing the Software, and w

(®) T accept the terms in this license agreement
() 1do not accept the terms in this license agreement

Mext

13. Select:

Start Pix4Dmapper Pro nowto activate a 15-day trial.
Use Pix4Dmapper Discovery, to activate the limited version. For more information: 202559479.
Choose a license that is already assigned to your account.

Welcome

(®) start Pix4Dmapper Pro now (Free Trial)

Time limited {15 days), unlimited functionalities. Mor

m

O Use Pix4Dmapper Discovery

Unlimited time, limited functionalities, More

Choose a license

Mo full license available.

CK Help

14. Click OK.
If you do not have an account:

1. Click Sign up now.

2. Complete the online form.

3. You will receive a confirmation email to activate the account. Open the email and click Confirm my email.
4. Go back to the Pix4Dmapper Login window, type your Email and Password and click Login.

Pix4Dmapper opens and you are now ready to start using the software!


https://support.pix4d.com/hc/en-us/articles/202559479
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A Waming: A dataset of insufficient quality will lead to poor results or may even lead to processing failure. This requires taking a new dataset on the field.

The dataset (compulsory. images, optional but recommended: images geolocation and GCPs "Ground Control Points") have to be obtained on the field before
using Pix4Dmapper. A good dataset is required in order to automatically produce results with high quality and accuracy. In order to take a good dataset, follow
the steps below:

1. Designing the Images Acquisition Plan: It is very important to design a good images acquisition plan considering:

Type of project (aerial, terrestrial, mixed).

Type of terrain / object.

Type of camera.

Purpose of the project.

Image rate that the images are taken.

Distance (flight height) at which the images are taken and with which angle to take the images.
Path(s) to follow to take the images.

etc.

For aerial projects, this also implies:

Selecting corridor path or regular grid and/or circular grid.
Deciding whether terrestrial images will be used.
If more than one flights are needed to cower the full area: designing the area to cover with each flight.

2. Configuring the Camera Settings: The camera settings used to acquire the images need to be configured. Wrong configuration can result in images with
blur, noise, distortions, etc.

3. Georeferencing the Images (optional but recommended): The images can be georeferenced using a camera with built-in GPS or using extemal GPS
devices.

4. Getting GCPs on the field or through other sources (optional but recommended): Using GCPs (Ground Control Points) requires planning how many GCPs
have to be acquired, as well as where and how they have to be measured.

Index © Previous | Next ©
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In order to automatically get high accuracy results, a high overlap between the images is required. Therefore, the image acquisition plan has to be carefully
designed in order to have enough overlap. The image acquisition plan depends on the required GSD by the project specifications and the terrain type / object to be
reconstructed. A bad image acquisition plan will lead to inaccurate results or processing failure and will require to acquire images again.

When designing the image acquisition plan the following factors need to be taken into consideration:

Image acquisition plan type: The image acquisition plan type depends on the type of terrain / object to be reconstructed.
Ground Sampling Distance (GSD): The required GSD by the project specifications will define the distance (flight height) at which the images hawe to be taken.
Owerlap: The owverlap depends on the type of terrain that is mapped and will determine the rate at which the images hawe to be taken.

Nowadays, technologically advanced UAVs come with very good software that can design the image acquisition plan given some parameters (area of interest, the
percentage of overlap between the images, the desired GSD, etc). In this case, the images are taken automatically by the UAV according to the selected images
acquisition plan without any user intenention.

@ Important: Pix4Dmapper allows the user to process using a Processing Template. The templates with the label Rapid/Low Res produce fast results at
low resolution that can be used on the field as an indicator of how good the dataset is.

If the Rapid/Low Res processing does not yield to good results, very probably, the dataset is not adequate and it is necessary to acquire images again.
In some cases, the Rapid/Low Res may fail but the Full processing works.

For more information about the difference between Rapid/Low Res and Full processing: 202558949.

The design of the image acquisition plan consists of 3 steps:

a. Selecting the Image Acquisition Plan Type
b. Computing the Flight Height for a given GSD
c. Computing the Image Rate for a given Frontal Overlap
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Pix4Dmapper is an image processing software that is based on automatically finding thousands of common points between images. Each characteristic point
found in an image is called a keypoint. When 2 keypoints on 2 different images are found to be the same, they are matched keypoints. Each group of

correctly matched keypoints will generate one 3D point. When there is high overlap between 2 images, the common area captured is larger and more keypoints
can be matched together. The more keypoints there are, the more accurately 3D points can be computed. Therefore, the main rule is to maintain high overlap
between the images.

As the image acquisition plan has a high impact on the quality of the resullts, it is important to design it carefully.

@ Important: Pix4Dmapper allows the user to process using a Processing Template. The templates with the label Rapid/Low Res produce fast results at
low resolution that can be used on the field as an indicator of how good the dataset is.

If the Rapid/Low Res processing does not yield to good results, very probably, the dataset is not adequate and it is necessary to acquire images again.
In some cases, the Rapid/Low Res may fail but the Full processing works.

For more information about the difference between Rapid/Low Res and Full processing: 202558949.

Ideal image acquisition plan
The ideal image acquisition plan depends on the type of terrain / object to be reconstructed.:

General case: For projects that do not include forests, snow, lakes, agricultural fields and/or other terrain that is difficult to reconstruct.
Forest and dense vegetation: For project with areas covered by forest or dense vegetation.

Flat terrain with agriculture fields: For flat terrain with homogeneous visual content such as agriculture fields.
Building reconstruction: For 3D modelling of buildings.

Special cases: For snow, sand, and water surfaces (oceans, lakes, rivers, etc).

Corridor mapping: For projects with linear area of interest (roads, rivers, etc).

Multiple flights: For projects with images taken using multiple flights.

City reconstruction (visible facades): For 3D modelling of urban areas.

3D interior reconstruction: For 3D modelling of the interior of buildings.

Mixed reconstruction: For combined datasets (interior/exterior and/or aerial/terrestrial and/or nadir/oblique).
Large Vertical Objects recontsruction: For 3D modelling of objects like power towers, wind turbines, etc.
Tunnel reconstruction: For 3D modelling of a tunnel.

Important: Below it is described the recommended different image acquisition paths and overlap for different cases, despite it may work with lower overlap
than the suggested ones, in order to obtain the best possible resullts, it is suggested to use the recommended overlaps.

General case

The recommended overlap for most cases is at least 75% frontal overlap (with respect to the flight direction) and at least 60% side overlap (between flying tracks).
It is recommended to take the images with a regular grid pattem (Figure 1). The camera should be maintained as much possible at a constant height over the
terain / object to ensure the desired GSD.

image width
-— Area of interest
image
height
side
overlap |
frontal
overlap ™

Figure 1. Ideal Image Acquisition Plan - General case.

Forest and dense vegetation
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Trees and dense vegetation often have a very different appearance between overlapping images due to their complex geometry (thousands of branches and
leaves). Therefore, it is difficult to extract common characteristic points (keypoints) between the images. In order to achieve good results, it is recommended to
use a grid image acquisition plan as the one described in the General Case section by applying the following changes:

Increase the overlap between images to at least 85% frontal overlap and at least 70% side overlap.

Increase the flight height: At higher altitude, there is less perspective distortion (therefore causing less appearance problems) and the dense vegetation has
better \isual properties. In other words, it is easier to detect visual similarities between overlapping images in such areas. The flight height in combination
with the image pixel resolution and the focal length determine the Ground Sampling Distance (spatial resolution) of the images. Best results are obtained
with a GSD higher than 10cm/pixel.

For more information about how to improve the results of dense vegetation areas selecting the correct processing options: 202560159.

Flat terrain with agriculture fields

In cases where the terrain is flat with homogeneous visual content such as agriculture fields, it is difficult to extract common characteristic points (keypoints)
between the images. In order to achieve good results, it is recommended to use a grid image acquisition plan as the one described in the General Case section
by applying the following changes:

Increase the overlap between images to at least 85% frontal overlap and at least 70% side overlap.
Fly higher. In most cases, flying higher improwes the results.
Hawve accurate image geolocation and use the Agriculture template. For more information about the Agriculture (Ag) template: 205319155.

Building reconstruction
Reconstructing 3D buildings requires a specific image acquisition plan (Figure 2):

Fly around the building a first time with a 45° camera angle.
Fly a second and third time around the building increasing the flight height and decreasing the camera angle with each round.

l[_]] Note: For more information about oblique imagery: 202559859.

It is recommended to take one image every 5-10 degrees to ensure enough owverlap, depending on the size of the object and distance to it. Shorter distance
and larger objects require images every less degrees.

Note:

The flight height should not be increased more than twice between the flights, as different heights lead to different spatial resolution. For

more information: 202558979.

Pix4Dmapper generates a high quality point cloud for oblique images of buildings. However, no orthomosaic is generated, when the selected template is
3D Models: 05319155.

‘ Important: By default, Pix4Dmapper generates orthomosaics that are parallel to the (XY) plane. Therefore, to generate mosaics of facades, the
Orthoplane tool needs to be used. For more information: 202559889.

height 2

height 1

Figure 2. Ideal Image Acquisition Plan - Building.

@ Note: It is possible to combine aerial nadir and/or aerial oblique and/or terrestrial images.

The images should have enough overlap in each dataset and between datasets. For such cases it is strongly recommended to use GCPs or Manual Tie
Points to properly adjust the different sets of images. For more information: 202561599
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Special cases
This section presents some hints for terrain that is difficult to map such as terrains with snow, sand, lakes, etc.

Snow and sand
Snow and sand hawe little visual content due to large uniform areas. Therefore:

Use a high overlap: At least 85% frontal overlap and at least 70% side overlap.
Set the exposure settings accordingly to get as much contrast as possible in each image.
Water

Water surfaces have almost no visual content due to large uniform areas. Sun reflection on the water and waves cannot be used for visual matching.

Oceans are impossible to reconstruct.
To reconstruct other water surfaces such as rivers or lakes, each image needs to have land features. Flying higher may help to include more land features.

Corridor mapping

Mapping corridors such as railways, roads or rivers requires at least 2 flight lines (Figure 3). GCPs are not required, but are recommended to improve the
georeference and accuracy of the reconstruction. For more information about the number and distribution of GCPs in corridor mapping: 202559299.

For a dual track it is recommended to use at least 85% frontal overlap and at least 60% side overlap.

It is possible to use nadir images or oblique images (with an angle between 0° and 45° pointing in both tracks to the center of the corridor). For flat terrain it is
recommended to use nadir images.

Figure 3. Dual track image acquisition plan for corridor mapping.

If a dual track image acquisition plan is not possible, a single track image acquisition plan can be used if (Figure 4):

Owerlap is high enough: At least 85% frontal overlap.
Ground control points (GCPs) are defined along the flight line in zig zag.

<jp—00-0090000096

Figure 4. Single track flight NOT RECOMMENDED.

Multiple flights
Pix4Dmapper can process images taken from multiple flights. When designing the different image acquisition plans, make sure that:

Each plan captures the images with enough owerlap.
There is enough overlap between 2 image acquisition plans (Figures 5 and 6).
The different plans are taken as much as possible under the same conditions (sun direction, weather conditions, no new buildings, etc.).

@ Important: The flight height should not be too different between the flights, as different height leads to different spatial resolution. For more information:
202558979.

There is a special way to process datasets taken from multiple flights, for step by step instructions: 202558579.


https://support.pix4d.com/hc/en-us/articles/202559299
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i
v P 4

Enough overlap between 2 flights Not enough overlap between 2 flights
Figure 5. Overlap between 2 flights.

Flight 2

Total area

Figure 6. Recommended image acquisition plan for 2 flights.

City reconstruction (visible facades)

The 3D reconstruction of urban areas requires a double grid image acquisition plan, so that all the facades of the buildings (north, west, south, east) are \isible on
the images. The owerlap should be the same as in the General Case.

Figure 7. Double grid image acquisition plan.



For the facades to be visible, the images should be taken with an angle between 10° and 35°, for more information about the definition of the angles: 202559859)
and not pointing to the nadir. If much detail is needed, aerial and terrestrial images should be combined.
l[_ﬂ Note: It is possible to combine aerial nadir and/or aerial oblique and/or terrestrial images.

The images should have enough overlap in each dataset and between datasets. For such cases it is strongly recommended to use GCPs or Manual Tie
Points to properly adjust the different sets of images. For more information: 202561599

3D Interior reconstruction

For interior reconstruction, it is strongly recommended to use temrestrial images. High overlap is needed (90%). Therefore, it is recommended to use a fisheye lens
camera.

Manual Tie Points improve the reconstruction and help to properly adjust the model. For more information: 202970309.

Mixed reconstruction
It is possible to combine interior/exterior and/or aerial/terrestrial and /or nadir/oblique. Any combination is possible.

The images should have enough owerlap in each dataset and between datasets. For such cases it is strongly recommended to use GCPs or Manual Tie Points to
properly adjust the different sets of images. For more information: 202561599.

Large Vertical Objects reconstruction
The 3D reconstruction of objects like power towers, wind turbines etc requires a specific image acquisition plan (figure 8):

Fly close to the structure.

Tumn seweral times around the structure at sewveral heights.

Images should be taken with high overlap: 90% of overlap between images taken at the same height and 60% of overlap between images taken at different
heights.

The optimal camera angle for the top circle is 45 degrees. By pointing to the ground, the content of the images is easier to be matched and the results are better.
The images should be as focused as possible (both the main object and the background should be focused).

Having image geolocation is recommended. For more information about the image geolocation: 202557499.

)
¥

y \°a
=g
Power Tower Power Tower reconstructed in the rayCloud

Figure 8. Image Acquisition Plan - Power tover.

l[_]] Note: For more information on how to map and measure pole and tower structures: 202560479

Tunnel reconstruction

Pix4Dmapper can reconstruct tunnels. The biggest challenge for tunnel reconstruction is the lighting conditions. If the lighting is good either with natural light (if
the tunnel is not too long) or with technical light, the reconstruction could be very good.


https://support.pix4d.com/hc/en-us/articles/202559859
https://support.pix4d.com/hc/en-us/articles/202561599
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In case of very dark tunnels, a tripod is recommended.

@ Tip: It is recommended to:
Use fisheye lens camera.
Take images in more than one line (avoid single track shooting). If a multiple tracks image acquisition plan is not possible, a single track could work.
GCPs are highly recommended in this case.

Properties
~ Selection

GP00_20141103_133222_0_550.JPG (Camera]
Camera Model: HERO3+BlackEdition_2.8_4000x3000 (RGB)(4)
Number of Marked MTPs and GCPs: 0
Number of Automatic Tie Points: 25835
Computed Position[-]: -25.05,-91.70, 1.19

GP00_20141103_133222_0_550.JPG

|_Disable | | uncalibrate | | 1

Figure 9. Automatic Tie Points of a tunnel.
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The Ground Sampling Distance (GSD) is the distance between the center of two consecutive pixels on the ground. It influences the accuracy and the quality of

the final results as well as the details that are \visible in the final Orthomosaic.

The flight height H that is needed to obtain a given GSD can be computed and depends on the camera focal length, the camera sensor width [mm], and the image

width [pixels].

—Sw Sw = real sensor width [mm]

S
E v
v

Fn’.'; Fr = real focal length [mm]

H = flight height [m]

Dw = distance covered on the ground by one image in the width direction (footprint width) [m]

Some lens manufacturers give the focal length (F3s) in the 35 mm equivalent. It is the real focal length that should be used in Pix4Dmapper. In order to find the

real focal length, some computations are needed. In the case of a 4:3 ratio, the formula for the real focal length FRis given by:

Fr[mm] = (F35*Sy)/34.6 (1)
Where
F35 = focal length that corresponds to the 35 mm equivalent
Fr = real focal length
Sw= the real sensor width
For more information about the 35mm equivalent focal length concept: Wikipedia article.
Using the fact that
H/Fr=Dy/ Sy,
the flight height H is given by:
H=0Ow*Fr)/Sw. (2
The distance cowered on the ground by one image in the width direction (footprint width) is given:
Dy = (imW *GSD)/ 100. (3
where
Dy = distance covered on the ground by one image [m] in the width direction (footprint width)
imW = image width [pixel]
GSD = desired GSD [cnvpixel]
Combining equation (2) and (3), the flight height is given by:

H [m] = (imW * GSD *Fr) / (S * 100)  (4)

l[l] Note: The result is given in [m], considering that the GSD is in [cm/pixel].

Example: Computation of the flight height to get a GSD of 5 [cm/pixel] using a camera with a real focal length of 5 [mm)] and a real sensor width of 6.17

[mm]. Assuming that the image width is 4000 [pixels] and using the equation (4), the flight height should be 162 [m].

H = (imW * GSD* Fg)/(Sw* 100) = (4000 * 5 * 5) / (6.17 * 100) = 162.07 [m]

l[B Tools: The GSD Calculator is available to make this computation easier: 202560249.
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The image shooting rate to achieve a given frontal overlap depends on the speed of the UAV/plane, the GSD and the pixel resolution of the camera.

D = distance covered on the ground by one image in the flight direction [m]

LY overiap = percentage of desired frontal overiap between two images
e P = pel ge P ge.
‘:{: od = overlap between two images in the flight direction [m]
x = distance between two camera positions in the flight direction [m]
v = flight speed [m/s]
X od t = elapsed time between two images (image rate) [s]

Figure 1.

From Figure 1, we obtain the following equations:
od=overlap *D (1)
x=D-od 2

t=x/v 3

Two cases are possible:

Camera oriented with the sensor width (long dimension) perpendicular to the flight direction (usual case)
Camera oriented with the sensor width (long dimension) parallel to the flight direction

Camera oriented with the sensor width (long dimension) perpendicular to the flight direction (usual case)
A D=Dp=(imH*GSD)/ 100 (4)
Where:

Dy, = distance covered on the ground by one image in the height direction
(footprint height) [m]

imH = image height [pixel]
D GSD = desired GSD [cn/pixel]

Figure 2. Sensor width placed perpendicular to the flight direction.
Combining Equations (1) and (4) into Equation (2):

x = Dy, - overlap * Dy

x =Dy * (1 - overlap)

x= ((imH*GSD)/ 100) * (1 - overiap)  (5)
[m Note: x is given in [m], considering that the GSD is in [cm/pixel].

Combining the equations (3) and (5):

t=x/v=((imH*GSD)/100) * (1-overlap) /v  (6)
Example: In order to achieve an overlap of 75% (overlap = 0.75) and a GSD of 5 [cm/pixel], supposing that the image height is 4000 [pixels] and the
speed of the UAV/plane is 30 [km/h] = 8.33 [m/s], based on the equation (6), the image rate should be 6 seconds:

t = ((imH * GSD) / 100) * (1 - overtap) / v = (4000 * 5 )/ 100) *(1-0.75)/8.33 = 6 [s]

Camera oriented with the sensor width (long dimension) parallel to the flight direction

If the camera is placed on the plane / UAV having the sensor width (long dimension) parallel to the flight direction:
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]

Figure 3. Sensor width placed parallel to the flight direction.

Combining equations (1) and (7) into the equation (2):
X = Dyy - overlap * Dy
x =Dy * (1 - overlap)
x= ((imW *GSD)/ 100) * (1 - overlap)  (8)
[[B Note: The result is given in [m], considering that the GSD is in [crm/pixel].

Combining equations (3) and (8):

t=x/v=((imW *GSD)/100) * (1 - overtap) /v (9)

Index > Step 1. Before Starting a Project > 1. Designing the Images Acquisition Plan

D =Dy = (imW*GSD)/ 100 (7)

Where:

Dy = distance covered on the ground by one image in the width direction
(footprint width) [m]

imW = image width [pixel]
GSD = desired GSD [cn/pixel]

© Previous | Next ©
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Pix4Dmapper is able to process images taken with any camera:

Lightweight compact cameras.
DSLR cameras.

Large format cameras.

Action cameras.

Camera Rigs.

Compact DSLR Large format

&)

Using any lens:

Perspective (narrow and wide focal length)
Ultra wide focal length (Fisheye).

The cameras can be loaded on any platform:

UAVs from the hobby world.

Professional UAVs.

Manned aircratts.

Helicopters.

Terrestrial vehicles.

No platform, for terrestrial imagery (taken by hand).

Pix4Dmapper can process images regardless of the spectral specifications of the camera:

RGB cameras.
NIR cameras
Thermal cameras.
etc.

Summary

Camera body and lens

Perspective and fisheye lens supported.

The zoom should be stable.

Fixed focal length is recommended.

Video frames are not recommended due to rolling shutter and low resolution.

Camera settings

Stabilization settings should be off.

Shutter/aperture/ISO should be on automatic.

If images are blurry or noisy, manually set shutter/aperture/ISO. For more
information: Camera settings.

Select Manual Focus on Infinity.

Camera Body

As a rule of thumb: Heavier cameras (higher pixel resolution) provide better results but require a flying platform with a higher payload.

Recommended Cameras

Camera Type Recommendation Tips
Compact Canon IXUS 220HS (135 g) Let parameters on automatic and disable image stabilization.
Sony RX 100 (240 g)
DSLR Sony Nex 5/7 (270 g - 350 g) Canon  Use a fixed focal length lens to improve the results.
5D mark ii (>800 g)
Action GoPro Hero 4 Recommended for close range (up to 50 meters). Take the images with the widest angle and highest

resolution possible.

Video cameras
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Videos are not recommended for accurate mapping: The quality of the results will almost always be inferior to the results from still imagery.
4K video from camera such as GoPro 4 and DJI provides reasonable results.

Full HD \ideo is usually not sufficient to get good results.

When using a video for processing, it is important to consider the following: 205294735.

Recommended Camera Focal Length

There is no limit in the focal length that can be used with Pix4Dmapper.

Application Recommendation Why

Mapping: aerial project with a flight Perspective lens: between 22 mm and 80 mm focal length (in To ensure a good GSD that will lead to higher accuracy
height above 50 meters. 35 mm equivalent). results.

Indoor / close range reconstruction. Fisheye lens: very small focal length. Flexibility in data acquisition: Ensuring higher overlap.

Most lens manufacturers give the focal length (F35) that corresponds to 35 mm equivalent. In order to find the real focal length:
Fr=(F35* Swgr) / 34.6 (mm)
where:

F35 = focal length that corresponds to 35 mm equivalent [mm]
FR = real focal length [mm]
Swg = the real sensor width [mm]

For a given height, the wider the field of view (small focal length), the fewer the images to achiewve sufficient overlap. This is especially useful if a regular and dense
flight plan cannot be setup. The spatial resolution, though, will be low leading to less accurate results.

If the field of view is narrow (large focal length), more images will be required to ensure enough overlap when mapping the same area. The spatial resolution will be
higher in this case, leading to more accurate results.

For more information about how to select camera focal length and flight altitude considering the desired spatial resolution (GSD) and the area to map: 202558849.

Q Tip: Use a fixed focal length lens, as it will usually result in sharper images with reduced noise.

Camera Settings
The shutter speed, aperture and ISO should be set on automatic. If images are blurry or naisy, it is recommended to manually set these parameters.

There is a tradeoff between the shutter speed, the aperture, and the ISO sensitivity. For processing, the images should be sharp and have the least amount of
noise. Such images can be obtained when the scene is well illuminated (scattered clouds should be awided) and the parameters of the camera are well adjusted.
If the scene is not sufficiently illuminated, images will be more noisy and less sharp, thus lowering the accuracy of the resullts.

As a rule of thumb, the shutter speed should be fixed, the ISO needs to be set at a low value that does not produce noisy images, and the aperture should be set
to automatic to adjust for varying levels of brightness in the scene. If the tradeoff is not correct you may also obtain overexposed or underexposed images.

The shutter speed should be fixed and set to a medium speed (as an indication: between 1/300 second and 1/800 second), but fast enough to not produce blurry
images. If more than 5% of the images are subject to a directional blur, it is a good indication that the shutter speed should be slightly increased.

The ISO should be set as low as possible (minimum 100). High ISO settings generally introduce noise into images and drastically reduce the quality of processed
results.

The aperture minimum and maximum values depend on the lens. High aperture is translated into low numbers, for example f2.7 (which will capture a lot of light). if
both the shutter speed and ISO are adjusted, it is better to leave the aperture (f) on automatic.

The electronic and mechanical stabilization should be disabled as it interferes with the algorithms.

The recommended focus mode is Manual Focus on Infinity. This mode of focusing should always give focused images for aerial projects. For terrestrial projects,
this mode will probably lead to out of focus results, if a long focal length is used.

Q Tip: For temrestrial projects it is recommended to use a wide angle lens.

Problems with images due to wrong camera parameters or inadequate equipment that interfere with the processing:



https://support.pix4d.com/hc/en-us/articles/205294735
https://support.pix4d.com/hc/en-us/articles/202558849

Blur due to slow shutter speed.

Index > Step 1. Before Starting a Project

Noise due to high ISO sensitivity.

Owerexposed Distortions Distortions due to

or due the rolling shutter.
underexposed to electronic Pix4Mapper
(wrong or models the rolling

aperture and/ormechanical shutter improving
shutter speed). image the
stabilization. results:202558159.

© Previous | Next ©
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>> Skip this step if no Georeferencing will be used for the images <<

Pix4Dmapper can process images both with and without geolocation. However, it is strongly recommended to know the position of the camera for at least 50% of
the images to get high quality and faster results. Pix4Dmapper does not require the IMU parameters. Orientation parameters are computed during the
processing.

Images without geolocation
Images with known position using a camera with built-in GPS tagging
Images with known position using an extemal GPS logger

Images without geolocation

Pix4Dmapper can process images without geolocation. When images have no geolocation, Pix4Dmapper needs additional information to locate, scale and orient
correctly the model. Ground Control Points (202557489) will place the model at the correct location, scale and orient it. If no GCPs are used, then the scale
(205360375) and orientation (205360385) constraints can be used.

Waming: If neither GCPs no constraints are used, the final results have no scale, orientation and absolute position information. Therefore, they cannot be
used for measurements, overlay and comparison with previous results. Besides, they may produce an inverted 3D model in the rayCloud.

Images with known position using a camera with built-in GPS tagging

Most of the major manufacturers push their weight behind GPS tagging; Panasonic, Sony, and Canon are some well known camera manufacturers that have
released such cameras so far. Most of these cameras save the GPS coordinates in the images' EXIF data. Pix4Dmapper reads this information from the EXIF
data in order to automatically import the image geolocation into the software. For more information about the EXIF information read by Pix4Dmapper: 205732299.

A Waming: If the GPS refresh rate is lower than the shooting images rate, more than one image will have the same GPS position and the processing may
fail or may not calibrate correctly some of the images.

Images with known position using an extemnal GPS logger

GPS loggers are \ery light devices (easily placed on a UAV) that can collect position information for the images. They register latitude, longitude and altitude
values for each camera position while shooting. These values are saved to a file that can be imported into Pix4Dmapper if it has the correct file format. Otherwise,
the file requires some editing before being imported in order to comply with Pix4Dmapper's geolocation file format.

Figure 1. GPS logger

Recommended GPS Logger
RTK GPS can capture accuracy of 2-4 cm at a high refresh rate. Having a RTK GPS, no GCPs are needed to obtain high accuracy.
o Information: Some loggers come with image geotagging software. If not, GPS data and images can be synchronized by using other software such as:
GPicSync (free)

Geosetter (free)
RoboGeo (commercial)

A list of available loggers is maintained by OpenStreetMap.
For more information about geolocation file formats supported by Pix4Dmapper 202558539.

For more information about how the onboard GPS affects the accuracy of a project: 202558909.
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>> Skip this step if no GCPs will be added <<

A Waming: Using GCPs is HIGHLY RECOMMENDED when processing a project with no image geolocation.
If no Ground Control Points are used:

The final results have no scale, orientation, and absolute position information. Therefore they cannot be used for measurements, overlay, and comparison
with previous results.

They may produce an inverted 3D model in the rayCloud.

The 3D reconstruction may not presene the shape of the suneyed area. For more information: 202561199.

Ground Control Points (GCPs) are points of known coordinates in the area of interest. Their coordinates have been measured with traditional surneying methods or
have been obtained by other sources (LIDAR, older maps of the area, Web Map Senice). They are not required for processing a project with Pix4Dmapper, but
they increase significantly the absolute accuracy of the project. GCPs can also be used as Check points to verify the accuracy of the results. They can be used:

In projects with image geolocation: GCPs increase the absolute accuracy of a project, placing the model at the exact position on the Earth. They reduce the shift
due to GPS from meters to centimeters. For more information about the shift due to GPS: 202558909.

In projects without image geolocation: GCPs are required if there is need for georeferenced outputs. In this case, the GCPs will scale, oriente and position the
final results. Additionally, they are very useful for increasing the relative accuracy of the outputs, i.e. the reconstruction of the 3D model.

When using GCPs the following points need to be taken into consideration:

Number and distribution of GCPs
GCP acquisition

Number and distribution of GCPs

The GCPs should be placed homogeneously in the area of interest. Imagine the area as a large table and the GCPs as the legs that will support it. If all the "legs"
are placed at the same location of the "table," then it will tilt. If the legs are homogeneously spread, then the "table" will be stable. Additionally, it is also
recommended to place one GCP in the center of the area in order to further increase the quality of the reconstruction (figure 1).

@ mportant:
A minimum number of 3 GCPs is required so as to take them into account in the reconstruction. Each one should be clicked in at least 2 images.

A minimum number of 5 GCPs is recommended. 5 to 10 GCPs are usually enough, even for large projects. More GCPs do not contribute significantly to
increasing the accuracy.

In cases that the topography of the area is complex, then more GCPs will, indeed, lead to better (more accurate) reconstruction.

It is recommended to use at least 5 GCPs, each of which is identified in 5 images, as it minimizes the measurement inaccuracies and helps to detect
mistakes that may occur when inserting the GCPs.

The GCPs should be placed evenly on the landscape to minimize the error in Scale and Orientation.

Do not place the GCPs exactly at the edges of the area, as they will only be visible in few images.

For corridor mapping: 202559299.

Area of
interest

® ccP

Figure 1. Distribution of the GCPs.

GCP acquisition
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The Ground Control Points can be:

GCPs measured in the field
GCPs defined from other sources

GCPs measured in the field

Measuring GCPs in the field requires spending some time in the area and locating the position where the GCPs should be measured. This process requires the
terrain to be accessible. Before measuring the GCPs coordinates, the following items must be defined:

GCP coordinate system

GCP accuracy

Topographic equipment

GCP coordinate system

A coordinate system is a set of numbers and parameters that is used in order to define the position of any object in the 2D or 3D space. The chosen GCP
coordinate system depends on the needs of the end-user. Usually the coordinate systems can be:

Global coordinate systems: They are defined using 3D ellipsoid coordinates (latitude, longitude, altitude).
National coordinate systems: They are usually defined using a projection defined for a specific country (X Y, altitude).
Local coordinate systems: They are defined using a projection. The user sets the origin and orientation where it is most convenient (X Y, altitude).

L[.I] Note: The altitude can be either geometric (using as reference the level of the ellipsoid) or orthometric (using as reference level the Mean Sea Lewel).

GCP accuracy
In order to define the accuracy with which the GCPs will be measured, the following factors must be taken into account:

Accuracy needed for the final results: The accuracy of the GCPs should correspond to the final absolute accuracy the user needs. For example, for projects
for which an accuracy of some meters is acceptable (e.g. fast assessment tasks), then the accuracy of the GCPs is NOT required to be of some centimeters.
For projects for which the accuracy is very important (e.g. construction sites) then the GCPs should be measured with an accuracy of some centimeters in order
to comply with the project requirements. In general, the accuracy of the GCPs should be slightly better than the expected accuracy of the final results.

Ground Sampling Distance of the images: The GCPs should:

Be visible in the images. The GCP photogrammetric target (figure 2) should have about five to ten times the dimensions of the GSD. If the GCP is natural (a
characteristic point in the area that is not signed by a photogrammetric target), then the GCP can be even more difficult to identify and mark.

Figure 2. GCP photogrammetric target.

Not be more accurate than 1/10 of the GSD. For example, if the GSD is 10 cm, the GCP accuracy should not be below 1 cm, since they cannot be marked in
the images with such accuracy.

Important: The accuracy of the GCPs must be known in order to correctly set the GCP accuracy (Horizontal and Vertical) for processing. For more
information about the GCP accuracy: 202557919.

Topographic equipment

Total station accuracy: They can reach millimeters accuracy (depending on the distance of the measured points from the station).
GPS system accuracy: They can reach several centimeters accuracy (depending on the equipment, the area, and the country).

GCPs defined from other sources
If no GCPs have been measured in the field, they can be extracted from other sources. The advantage of such GCPs is that they can be extracted at any time

while being at the office. The disadvantage is that they give no control over the accuracy and that the coordinate system is the coordinate system of the GCP
source.

GCPs can be extracted from 2 type of sources:

GCPs extracted from high accuracy sources: GCPs can be extracted from sources such as existing maps and laser scanning outputs of the same area. If these
sources are updated, then the GCPs can be very accurate. The coordinate system and the accuracy of these points depend on the source.

GCPs extracted from Web Map Services: \Web Map Senices provide online georeferenced maps using a standard protocol called Web Map Senice (WMS). Some
seners hawe their GIS databases publicly available and free-of-charge. Well-known free WMS seners are Google Maps and Bing Maps. They cover the whole
planet but the accuracy of the map georeference may not be high enough. In addition, their data is not available with the same accuracy for different parts of the
world. It is recommend to use GCPs derived from such sources when:

The images are not geolocated and therefore the project has no georeference.

The desired output is a .kml file, which can align perfectly with Google Maps.

For more information about how to obtain the georeference using 2D or 3D GCPs taken from a Web Map Senice sener: 202560149.
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To create a project, follow these steps:

1. Creating a New Project.
2. Importing the Images.
3. Configuring the Image Properties:

If the images have geolocation:

Define the coordinate system and import the image geolocation information.

If the software cannot recognize the camera model or it is needed to use different camera parameters:
Edit the camera model.

4. Selecting the Output / GCP Coordinate System.
5. Selecting the Processing Options Template.

Index © Previous | Next ©
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To create a new project:

1. Start Pix4Dmapper.
2. On the Menu bar, click Project > New Project...

| PixdDmapper Pro

Project  Process  View Help

5 Mew Project... Ctrl+M
7 Open Project... Ctrl+0
Recent Projects »

Close Project

&> Download Project Files...

Upload Project Files...

Image Properties Editor...
GCP/MTP Manager...
Select Output Coordinate System...

Save Project Ctrl+S
Save Project As... Ctrl+Shift+S
Split into Subprojects...

Exit Ctrl+Q

3. The New Project wizard opens:

5 MNew Project

This wizard creates a new project.
Choose a name, a directory location and a type for your new project.

Mame: | |

Create In: |S:‘|, || Browse. .. |

[ use As Default Project Location

Project Type
@ Mew Project
(") Project Merged from Existing Projects

4. In Name: type a name for the project.
5. (optional) In Create in: click Browse... On the Select project location pop-up, navigate to select the folder where the project and results will be stored and
click Select Folder.

A Warning: Ensure that:
The project name DOES NOT use special character(s).
The path where the project will be created DOES NOT use special character(s).
The project name and the path together contain less than 128 characters.

[[B Note: When the wizard is completed, a folder named after the project will be created in the selected folder and it will store all the resullts.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In Project Type, keep the default option New Project selected.
8. Click Next.
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On the Select Images window:

1. Click Add Images... to add the images.

A Waming:

Images should not contain any symbol such as time and date stamps. Images that contain such symbols cannot be processed.
Images should not be edited manually, i.e. should not be scale, rotated, etc.
Images taken during take-off or landing should not be used.

5 New Project
Select Images

o At least 3 images in JPG or TIFF format are required.

0 images selected. Add Images... | |Add Directories. .. | |A|::Id Videos... | |Rernove Selectedl | Clear List

o R [ o

2. On the Select Images pop-up, navigate to select the folder where the images are stored, select the images to be imported (it is possible to select multiple
images), and click Open.

Note:

l[D Images can be imported as *.jpg, *.jpeg, *.tif, or *.tiff. By default all supported image formats can be selected. To filter images according to their
format change the input format to JPEG images (*.jpg,*.jpeg) or to TIFF images (*.tif, *.tiff).
It is possible to select images stored in different folders. Once images are imported from one folder, click Add images again to add more images
from another folder.

3. (optional) It is possible to remove images by selecting them in the image list (use Ctri+click or Shift+click for multiple selection) and clicking Remove
Selected.

4. (optional) It is possible to clear the list of images that have been added by clicking Clear List.

5. Click Next.
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The New Project wizard displays the /mage Properties window which contains 3 sections:

Image Geolocation:

Sets the coordinate system to which the image geolocation refers.

Imports/exports the coordinates and, optionally, the orientation of the images and/or the accuracy of the coordinates.

Sets the accuracy of the image geolocation.

Selected Camera Model: Sets and configures the camera model associated to the images.

Images table: Displays the selected images, as well as the group, position, position accuracy and orientation of each image and if the image is enabled or not (an
enabled image will be taken into account for processing).

>
I Mew Project
Image Properties

Image Geolocation
Coordinate System

o dfp Datum: World Geodetic System 1984; Coordinate System: WGS 84 Edit...
Geolocation and Orientation

o Geolocated Images: 127 out of 127 Clear From EXIF From File... To File...
Geolocation Accuracy: (@ Standard () Low () Custom
Selected Camera Model

@ B CanonIXU5220H5_4.3_4000x3000 (RGE) Edit...

N Latitude Lengitude Altitude Accuracy Accuracy &
Enabled Image Group [degree] [degree] [m] Harz [m] Vert [m]
IMG_1146.JPG groupl 4665611625 £.54326042 784961 5.000 10.000
IMG_1147.JPG groupl 46.65603320 £.54238450 780.934 5.000 10.000
IMG_1148JPG groupl 46.65600420 6.541557%6 T81.793 5.000 10.000
IMG_1145.JPG groupl 46.65608730 6.54070200 780951 5.000 10.000
IMG_1130JPG groupl 46.65613320 £.53933380 780,71 5.000 10.000
IMG_1131.JPG groupl 4665617870 £.53898330 Tr9.r02 5.000 10.000
IMG_1132.JPG groupl 46.65620580 £.53813780 781.09 5.000 10.000
IMG_1133.JPG groupl 46.65624120 £.53729250 781.454 5.000 10.000
IMG_11534.JPG groupl 4665627930 6.53641060 780.826 5.000 10.000
IMG_1135.JPG groupl 4665633030 6.53354040 T78.801 5.000 10.000 v
< >

Help Back Mext Cancel

There are 3 optional steps to follow before clicking Next:

a. (optional) Select Image Coordinate System
On Coordinate System, click Edit... if the image geolocation is given in a coordinate system other than WGS84 (default).

For more information and step by step instructions about how to select/change the Image Coordinate System: 202560029.

b. (optional, recommended) Import Image Geolocation and Orientation
If the image geolocation (position) information is stored in the EXIF of the images, it will be loaded automatically.

For more information and step by step instructions about how to select/change the Image Geolocation and Orientation: 202560019.
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@ Note:
The software considers the Date Taken field of the EXIF to set up the order in which the images are taken.
Step 1. Initial Processing is faster for projects with image geolocation. In the case of not sufficient overlap, image geolocation helps calibrating
the images.

c. (optional) Edit Selected Camera Model

A camera model needs to be defined in order to run a project in Pix4Dmapper. The parameters of this model depend on the camera that was used to
capture the image. Most cameras sawe their name in the metadata of the image in EXIF format. This field is used to associate a given camera model to
all the images captured with this camera.

The Selected Camera Model section, on the Image Properties window displays the selected camera model. The camera model can be:

(@] Valid: A green check is displayed if the camera model is valid. A camera model is valid if it already exists in the camera model database of

Pix4Dmapper or if there is sufficient information in the EXIF data of the images to create a new camera model that will be saved into the user camera model
database. If the camera model is retrieved from the EXF data, it is recommended to check the camera model parameters and, if needed, to edit them.
(x] Invalid: A red cross is displayed if the camera model is not valid. A camera model is invalid if it is not in the camera model database of Pix4Dmapper

and if there is not enough information in the EXIF data of the images. In this case the camera model needs to be defined manually.
For more information and step by step instructions about how to edit the camera model: 202560169.
[]] Note: Grouping the images:
When the project contains images with different spectral signatures (RGB, NIRGB, etc) usually the images are grouped automatically. In case

that they are not grouped by default, group them manually following: 202560509.
In this case one orthomosaic is generated per group.
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In the Select Output Coordinate System window:

1. (optional) Change the output / GCP coordinate system: 202560029.

l[ﬂ Note: For more information about the Output/GCP coordinate System section: 202558239.

@ Note:

By default, the output and GCP coordinates system will be the same. To select a different coordinate system for the outputs: 202558099. To select
different coordinate system for the GCPs: 202557749.

By default, the Unit is m (meters).

If the images have geolocation, by default, Auto detected is selected, displaying the comesponding UTM or Nad83 zone of the images.

If the images do not have geoloacation, by default, Arbitrary Coordinate System is selected.

2. Click Next.

5 Mew Project

Select Output Coordinate System

Selected Coordinate System

Datum: World Geodetic System 1984
v Coordinate System: WGS &4 [ UTM zone 32N

Qutput/GCP Coordinate System

unit: fm =1

() arbitrary Coordinate System [m]

(® Auto Detected:  WGES84 / UTM zone 32N

() Known Coordinate System [m]

Q

[ Advanced Coordinate Options

Help Back | Next || Cancel
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Index > Step 2. Creating a Project

In the Processing Options Template window:

1. Select the desired template (which can be

© Previous | Next ©

modified or changed before processing).

" Mew Project

Processing Options Template

{2 3D Maps 3D Maps
= 3D Models
8 Ag Multispectral Generate a DSM and an orthomosaic for mapping applications.
B Ag Maodified Camera Saput: Riusges
B AgRGB
B 3D Maps - Rapid/Low Res Aerial images acquired using a grid flight plan with high overlap, mostly oriented towards the ground.
B 3D Models - Rapid/Low Res
Outputs

B Ag Madified Camera - Rapid/Low Res P
& AgRGE - Rapid/Low Res Orthomosaic DsM
& Thermal Camera

£

Point Cloud
Application examples

* Measure volumes

* Digitize houses and roads

* Generate contour lines

* Google Maps and Mapbox overlay

|:| Start Processing Mow
Help Back . Finish . Cancel

By default, 3D Maps is selected, and the following Processing Options Templates appear:

Processing Options Template
3D Maps

3D Models

Ag Multispectral

Ag Modified Camera

Ag RGB

3D Maps - Rapid/Low Res
3D Models - Rapid/Low Res
Ag Modified Camera - Rapid/Low Res

Characteristics

Generates a 3D model (point cloud, 3D textured mesh) as well as a DSM and an orthomosaic.

Typical input: aerial images acquired using a grid flight plan.

Applications examples: quarries, cadaster, etc.

Generates a 3D model (point cloud, 3D texture mesh).

Typical input: any images with high overlap.

Application examples: 3D models of buildings, objects, ground imagery, indoor imagery, inspection, etc.
Generates reflectance, index (such as NDVI), classification and application maps.

Typical input: images from multispectral cameras (Sequoia, Micasense RedEdge, Multispec 4C, etc).
Application examples: precision agriculture.

Generates reflectance, index (such as NDVI), classification and application maps.

Typical input: images taken with modified RGB cameras.

Application examples: precision agriculture.

Generates an orthomosaic.

Typical input: images taken with RGB cameras for agriculture (Sequoia RGB).

Application examples: digital scouting, report claiming for precision agriculture.

Faster processing of the 3D Maps template generating lower accuracy as well as lower resolution outputs.
Faster processing of the 3D Models template generating lower accuracy as well as lower resolution outputs.
Faster processing of the Ag Modified Camera template generating lower accuracy as well as lower resolution
outputs.


/hc/en-us/articles/202557359

Faster processing of the Ag RGB template generating lower accuracy as well as lower resolution outputs.

Ag RGB - Rapid/Low Res
Thermal Camera Generates a thermal reflectance map.
Typical input: images taken with thermal cameras (such as Tau 2 based cameras: FLIR Vue Pro, thermoMAP,

etc.).
Application examples: irrigation, solar panels, etc.

l[l] Note: For more information about the Processing Options Templates, their outputs and their selected processing options: 205319155.

@ Note:
g Refers to Processing Options Templates existing by default.
&, Refers to Processing Options Templates created by the user.

& Refers to Processing Options Templates (existing by default or created by the user) that have been edited but are not saved.

2. (optional) Select the Start processing now! box to start automatically the processing.
3. Click Finish to finish the wizard and start the project.
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Once the project is created, the Map Viewis displayed.

[ PixdDmapper Pro - mining_quarry - O *
Project Process View Map View Help

m @ B g 0@ @ Qs
l el

Project Process View

Project Information 5 X

¥ Project Summary

Project:
Mame: mining_guarry
Type: Standard
Workspace: 5:f
Qutput Datum: World Geodetic System 1984
Output Coordinate System: WGS 84 / UTM zone
32N
Output Georeferenced: YES

Processing:
1. Initial Processing Done: YES
Average Ground Sampling Distance (G5D)
[em/pixel]: 8.74304
Parameter Files Generated: YES
2. Point Cloud and Mesh Done: YES
| Image Scale: multiscale, 1/2 (Half image
I | size, Default)
y Point Density: Optimal
3. D3M, Orthomosaic and Index Done: YES
Resolution [cm/pixel]: 8. 74304
Raster DSM Generated: YES
Grid DSM Generated: NO
Orthomosaic Generated: YES
Google Maps Tiles and KML Generated:

YES

Images:
Enabled Images: 127 out of 127
Geolocated Images: 127 out of 127
Datum: Werld Geodetic System 1984
Coordinate System: WGES 84

W Layers

» Images
GCP=z
[ Processing Area

There are some optional steps that can be done before processing:
1. (optional) Selecting the Processing Area

By default, the area selected for processing corresponds to the entire area cowered by all the images that are calibrated. It is possible to restrict the
processing area to the area of interest, but it is not compulsory. This option can be useful to generate the outputs only for an area of interest instead of the
entire area.

For step by step instructions about creating a Processing Area: 202560179.

2. (optional) Changing the Processing Options Template and / or the Process Options

Change the output results files (types and format), change some processing options to improve the quality of the results when needed, or change some
processing options for advanced use. For more information: 202560009.

l[j] Note: For more information about the Processing Options Templates, the outputs they generate and their selected processing options: 205319155.

3. (optional) Adding GCPs

Add Ground Control Points (GCPs) to improve the global accuracy of the project (georeference). GCPs can be measured in the field using topographic
methods, taken from existing geospatial data or Web Map Senice (WMS).


/hc/en-us/articles/202557359
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A Waming: Using GCPs is HIGHLY RECOMMENDED when processing images without image geolocation.
If no Ground Control Points are used:

The final results are not scaled, oriented or georeferenced. Therefore they cannot be used for measurements, owverlay, and comparison with previous
results.

They may produce an inverted 3D model in the rayCloud.

The final 3D model may be shifted (this problem can be corrected using Manual Tie Points: 202560349).

For step by step instructions about how to include GCPs in the project: 202560239.
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When processing a project it is recommended to go through the following steps:

1. Initial Processing

2. Analyzing the Quality Report
3. Point Cloud and Mesh

4. DSM, Orthomosaic and Index

Index © Previous | Next ©
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To start processing the project:

1. On the Menu bar, click View > Processing.

. PixdDmapper Pro - mining_quarry
Project Process | View Map View Help
||=@ ~  Show View Toolbar
Bﬁ{’&ﬂ Proj E Show Sidebar
|
i) i Welcome
Welcome I Map View
_——
m I rayCloud
Map View F  Maosaic Editor
I.i) 5 Index Calculator
rayCloud Ol Processing
0 45 Log Output

2. The Processing bar opens on the bottom of the main window.

W Processing x
1. Initial Processing 2. Paint Cloud and Mesh 3. D5M, Orthomasaic and Index
Current: 0%

Total: 1. | 2. | 3. 0/23

Output Status... Cancel Help

3. Ensure that 1. Initial Processing is selected and that 2. Point cloud and Mesh and 3. DSM, Orthomosaic and Index are unselected:

W Processing x
1. Initial Processing [ 2. Point Cloud and Mesh [ 3. pSM, Orthomosaic and Index

Current: 0%
Total: L 08
Output Status. .. Cancel Help

4. Click Start.

For more information about the outputs resulting from 1. Initial Processing. 202558519.
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Index > Step 4. Processing

@ mportant:

For a detailed description about how to analyze the Quality Report: 202558689.
For a detailed description about any parameter described in the Quality Report: 202558679.
Example of a Quality Report available at the following link: Quality Report.

© Previous | Next ©

Once step 1. Initial Processing is completed, the Quality Report is automatically displayed. To not be displayed automatically, unselect the Display Automatically
after Processing box at the bottom of the Quality Report.

It is recommended to verify the following information in the Quality Report:

1. Quality Check
Verify that:

All the checks are green.

All or almost all the images are calibrated in one block.
The relative difference between initial and optimized intemal camera parameters is below 5%.
(optional) If using GCPs, the GCP error is below 3xGSD.

Quality Check

@ Images

@ pataset

@ Camera Optimization
@) matching

@ Georeferencing

2. Preview

For projects with nadir images and for which the orthomosaic preview has been generated, \erify that the orthomosaic:

Does not contain holes.
Does not hawe distortions.

median of 35858 keypoints perimage

127 out of 127 images calibrated (100%), all images enabled

0.44% relative difference between initial and optimized internal camera parameters

median of 13945 5 matches per calibrated image

yes, 7 GCPs (¥ 3D), mean error = 0.046 m

(optional) If GCPs or image geolocation has been used, it has the correct orientation.

@ Preview

Figure 1: Orthomosaic and the corresponding sparse Digital Surface Model {D5M) before densification.

3. Initial Image Positions

(optional) If the images have geolocation, verify that the Initial Image Positions figure comesponds to the flight plan.
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@ Initial Image Positions

4. Computed Image/GCPs/Manual Tie Points Positions
Verify that :
(optional) If using images with geolocation, the computed image geolocation is good.

(optional) If using GCPs, the GCPs' error is low (the difference between input and computed GCPs is small).

@ Computed Image/GCPs/Manual Tie Points Positions
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5. 3D Points from 2D Keypoints Matches
Verify that:

Enough matches have been computed between the images.
The graph consists of one block. If multiple blocks exist, each block will have a different color. For more information: 207932643.


https://support.pix4d.com/hc/en-us/articles/207932643

@ 20 Keypoint Matches

25 222 444 666 888 1111 1333 1555 1777 2000

Mumber of matches

6. Geolocation Details
(optional) If using GCPs, \erify that:

All GCPs are taken into account (not displayed with red color on the Geolocation and Ground Control Points table).
All marked GCPs have been \erified.
The green circle representing the reprojected GCP 3D point is inside the yellow circle representing the marked GCP.

@ Ground Control Points i ]
GCP MName Accuracy XY/Z [m] Error X [m] Error Y [m] Error Z [m] Projection Error [pixel] Verified/Marked
9001 (3D) 0.020/ 0.020 -0.010 -0.011 -0.004 0.647 TIT
9002 (3D) 0.020/ 0.020 0.021 -0.019 0.041 0.6592 414
9004 (3D) 0.020/ 0.020 -0.009 0.005 0.007 1.210 8i/8
9011 (3D} 0.020/ 0.020 -0.008 -0.035 -0.114 0.948 9/9
9016 (3D) 0.020/ 0.020 -0.031 0.022 -0.098 0.936 10/10
9017 (3D) 0.020/ 0.020 0.024 0.016 -0.113 0.922 10/10
9012 (3D) 0.020/ 0.020 0.030 0.013 0.180 1.051 14714
Mean [m] 0.002547 -0.001266 -0.014592
Sigma [m] 0.0210565 0.019540 0.098809

RMS Error [m] 0.021208 0.019581 0.099881



GCP Mame: 9011 (312064.388,5169799.361,523.326)
e

GCP 9011 was not marked on the following images
{only up to 6 images shown). If the circle is too far away
from the initial GCP position, also measure the GCP in

these images to improve the accuracy.

IMG_1147.JPG

IMG_1221.JPG

7. Processing Options
Verify that:

(optional) If using GCPs, the Ground Control Point (GCP) Coordinate System is correct.
(optional) If using images with geolocation, the Image Coordinate System is correct.

Processing Options (i ]

CPU: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHzZ

Hardware RAM: 16GB
GPLU: Intel(R) HD Graphics 4600 (Driver: 20.19.15.4331)
Operating System Windows 10 Home, G4-bit
Camera Model Mame CanonlXUS220HS_4.3_4000x3000 (RGB)
Image Coordinate System WGESa4

Ground Control Point (GCP)

Coordinate System wess4

Output Coordinate System WGES84 /UTM zone 32N

Detected template: Mo template available

Keypoints Image Scale Full, Image Scale: 1

Advanced: Matching Image Pairs Aerial Grid or Carridor

Advanced: Matching Strategy Use Geometrically Verified Matching: no

Advanced: Keypoint Extraction Targeted Mumber of Keypoints: Automatic

Avancad: Calibrafion Calibration Method: Standard, Internal Parameters Optimization: All, External Parameters Optimization:

All, Rematch: Auto yes
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To process step 2. Point Cloud and Mesh:

1. On the Menu bar, click View > Processing.

. PixdDmapper Pro - mining_quarry

Project Process | View Map View Help

B % Show View Toolbar
pixin froj & Show Sidebar

|
i) i Welcome
Welcome I Map View
—
m I rayCloud
Map View F  Maosaic Editor
I.i) 5 Index Calculator
rayCloud Ol Processing
0 45 Log Output

2. The Processing bar opens on the bottom of the main window.
3. Ensure that 2. Point Cloud and Mesh is selected, and that 1. Initial Processing and 3. DSM, Orthomosaic and Index are unselected.

W Processing X
[] 1. Initial Processing 2. Point Cloud and Mesh ' [_] 3. DSM, Orthomasaic and Index

Current: 0%
Total: 2. 0/10
4. Click Start.

For more information about the outputs resulting from 2. Point Cloud and Mesh: 202558549.
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To process step 3. DSM, Orthomosaic and Index:

1. On the Menu bar, click View > Processing.

| Pix4Dmapper Pro - mining_quarry
Project Process | View Map View Help
(8 |~ Show View Toolbar
Dix4 broj & Show Sidebar
|
) 1 Welcome
Welcome I Map View
—
m I rayCloud
Map View F  Maosaic Editor
T 5 Index Calculator
rayCloud [ Processing
4 Leg Output
| 9 P!

2. The Processing bar appears in the bottom of the main window.
3. Ensure that 3. DSM, Orthomosaic and Index is selected, and that 1. Initial Processing, and 2. Point Cloud and Mesh are unselected.

W Processing x
[ ] 1. mnitial Processing [_]| 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index

Current: 0%
Total: 3. 0f2
4. Click Start.

For more information about the outputs resulting from 3. DSM, Orthomosaic and Index. 202558559.
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Index

Once the project has been processed, it is possible to use the results:

Using the rayCloud

Using the Mosaic Editor

Using the Index Calculator
Uploading Project Files

Using output files in other software

Using the rayCloud

The use of the rayCloud is optional and it can be used to:

© Previous

Visualize the different elements of the reconstruction (Camera Positions, Reprojections (rays), GCPs, Manual / Automatic Tie Points, Processing Area, Clipping

Box, Densified Point Cloud, Terrain / Objects / other Point Groups, 3D Textured Mesh, Video Animation Trajectories) and their properties.
Visualize point clouds / triangle meshes created in other projects or with other software.

Georeference a project using GCPs and /or Scale and Orientation constraints.

Create Orthoplanes to obtain mosaics of any selected plane (for example, building facades).

Verify / improve the accuracy of the reconstruction.

Assign points of the point cloud to different point groups.

Improwe the visual aspect.

Create objects and measure distances (polylines), surfaces, and volumes (stockpiles).

Create 3D fly-through animations (Video Animation Trajectories).

Export different elements (GCPs, Manual / Automatic Tie Points, Objects, Video Animation Trajectories).
Export point cloud files using points belonging to one or seweral classes.

For more information: 202558639.

" Pix4Dmapper Pro - mining_guarry ] x
Project Process View rayCloud Help
= o 2 2 ¢ 7 5 _
EO S T < R < S = <1 Y <ar -%) @ @ @ @f [# ~ || ~|Undassified Assign & ]|
Project Process View Na d Clipping Point Cloud Ex
O W Create Properties & x
— e = 2 2
Welome |3 ||FD)| =] &S| N|E| 2 e
T Densified Point
Mumber of Images Visible In: 30
Map View
— V" Layers Computed Position [m]: 31197591, 5169680.91, 524,64
ta
e Cameras Help
rayCloud Rays
@ [®] Tie Points
! Point Clouds
fseic | v [ Point Groups
¥ & Unclassifie
& Unclassified
[0 @ Deleted
o [ Triangle Meshes
Calaultor Objects b
s . ImageSize ZoomLevel s
@ & [l ol 'z|,l [ @ e X
[
Processing
o
|
Log Output
Processing
Options | € >

Using the Mosaic Editor
The use of the Mosaic Editor is optional and it can be used to:

Visualize the DSM (raster GeoTIFF Digital Surface Model).
Visualize the Orthomosaic.
Improwe the visual aspect of the Orthomosaic.

For more information: 202558709.
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Project Process

o)

. PixdDmapper Pro - mining_quarry

View  Mosaic Editor

s e >
O I o

Project Process

Help

&

@ @

View

KA
(']

I;Vlosaig_@roupl} -

Edit Mosaic

&¢I

Log Output
P

Processing

Maosaic Editing 5 X
W Regions
|Region1 v|| Draw | | Delete | | Delete all
¥ Images
() Ortho Projection (®) Planar Projection
~
W
Save | | Reset | | Export | | Help

WGS84 / UTM zone 32N - (312232.42, 5169845.70, -10000.00) [m]

Using the Index Calculator

The use of the Index Calculator is optional and it can be used to:

Generate an Index Map / Index Grid where the color of each pixel is computed using a formula that combines different bands of the Reflectance Map(s).
Provide information about the bands of the Reflectance Map(s) and Index Map.
Visualize the Index Map as a Colored Index Map by applying a color mapping to it.

Export a georeferenced Colored Index Map.

Annotate the classes of the Index Map to generate an Application Map.

Export an Application Map as a shape file to be imported in any Tractors Consoles.

For more information: 202558729.


https://support.pix4d.com/hc/en-us/articles/202558729

. PixdDmapper Pro - O *
Project Process View Index Calculator Help
= {:} [4 ﬁ L—j {rﬂ} @ @ oI |R.eﬂed3noe Map [red] = | Show Index Map Lock Regions & m
p@ﬁ Project Process View Reflectance Map Index Map Regions
Index Calculator g x
W 1. Reflectance Map
Generate | | Help

Band nm Min Avag Max Stdev Var
red 625 0.00 99.72 251.78 2B.04 786.19
green 560 0.00 99.03 268.31 28.78 828.31
nir 850 0.00 9330 190.32 23.72 5b2.66

W 3. Regions

|R_egiov|| Draw || Clear | (v ] |'-Egi°f15--|| Help |

¥ 3. Index Map

Name Formula

= |(nir -red) [ {nir +red) °
Edit.. | Indces.. | o/ | Generate | Help |

Band Min Avg Max Stdev Var

band1 -0.50 -0.02 0.94 0.07 0,00

W 4. Color Maps and Prescription

Number of Classe: | 5 E |Jenks v| | Help |

MinMax |—0,23 | - |0,18 | Clamped
Color Min Max Area[ha] Area[%]
0.11 0.18 0.50 19.38
0.03 0.11 0.27 10.46
-0.04 0.03 0.78 30,08
B 0.12 0.04 1.02 39.14
B 0.23 0.12 0.02 0.96
B e < Oiner
-
L@ 5. Export
Log Output Index Values and Rates as Polygon Shapefiles |
—
0 Colored Index Map (GeoTIFF) and GeaIPG (JPC
Prn@s"lg Help
Options

WG584 / UTM zone 17N - (510125.00, 4853580.08) [m]

Uploading Project Files
The use of the Upload Project Files feature is optional and it can be used to:

Upload Files to the Pix4D Cloud, in order to:

Store files in the Pix4D online account.

Process projects online.

Provide project information to the support team.

Upload files to Mapbox.

Upload 3D Textured Mesh to Sketchfab, for viewing, interacting and sharing.

For a full description about the File Upload pop-up: 202557689.

For step by step instructions about how to Upload project files into Pix4D Cloud: 202558589.



https://support.pix4d.com/hc/en-us/articles/202558589

File Upload File Upload

Pix4D Cloud Mapbox
p M Upload Files p "A Account
) ’X4D Project and Image Files ’X4D Upload to “johnmapper” Mapbox account
PixdD Cloud PixdD Cloud
[] start Processing Progress
Log Fil
Mapbox| [OtogFie Mapbox e
Maphbox [ Quality Report Mapbox
[] Google Maps and KML Files
[ psM Files {GeaTIFF) wWhat is Mapbox?

[ paint Cloud Files (LAS)

Reflectance Map Files (GeoTIFF)
Sketchfab Sketchfab

Progress

Cancel

Upload Files to the Pix4D Cloud Upload Files to Mapbox Upload
Files to
Sketchfab

Using output files in other software

Pix4Dmapper outputs are compatible with many software (GIS, CAD, etc.) and can be used for many different applications. For more information about how to
use Pix4Dmapper output files in other software: 202558499.
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The software manual describes all the options that can be found in the Pix4Dmapper software. Offline version: pdf. The following links contain a detailed

description of these options:

Table View

Interface
Menu bar

Floating License
Shortcuts

Menu Bar
Menu Project
New Project...
Open Project...
Recent Projects
Close Project&

Download Project Files...

Upload Project Files...

Image Properties Editor...

Image Geolocation
Selected Camera Model
Edit Camera Model
Images Table
GCP/MTP Manager...
GCP Coordinate System
GCP/MTP Table

Import GCPs...

Export GCPs...

Add Point

Remowe Points

Import Marks...

Export Marks...
GCP/MTP Editor
rayCloud

Basic GCP/MTP Editor
GCP/MTP Table
Images

Preview

Select Output Coordinate System...

Sawe Project

Sawe Project As...

Split into Subprojects...
Exit

Views
Map View

Blocks View

Index View

View toolbar

Menu Process

Reoptimize

Rematch and Optimize
Quality Report...

Open Results Folder...
Outputs Status...&

Generate Quality Report

Sawe Undistorted Images

Run Terrain/Object Point Cloud Classification (beta)
Generate 3D Textured Mesh

Generate DTM (beta)

Import Point Cloud for DSM Generation...

Generate Google Maps Tiles, KML and Mapbox Tiles
Generate Contour Lines

Send Elevation Data (DSM) to eMotion
Send Map to eMotion

Processing Options...

Initial Processing

Point Cloud and Mesh

DSM, Orthomosaic and Index
Resources and Notifications
Templates

Mosaic Editor

Main view

Index Calculator

Menu View
Show View Toolbar
Show Sidebar
Welcome
Projects

Help

Demo Project
Map View
rayCloud
Mosaic Editor
Index Calculator

Processing

Log Output&
Menu Help

Help Contents
Online Support
Forum

Personal Support

Settings...
About...
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https://support.pix4d.com/hc/en-us/articles/202557989
https://support.pix4d.com/hc/en-us/articles/202558109
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Menu bar entry
Processing Area

Toolbar
2D View
Project Information sidebar

Project Summary
Layers
Status bar

Menu bar entry Menu bar entry
Viewpoint View
Navigation Modes Mosaic Editing
Perspective/ Orthographic Visualization
Change Background...

Display Sky Toolbar
New Scale Constraint Mosaic View
New Orientation Constraint Sidebar

New Orthoplane Status bar
New Polyline

New Surface

New Volume

New Video Animation Trajectory...

Toolbar
Left sidebar

Create

Layers

Cameras

Rays

Tie Points
Processing Area
Point Clouds

Point Groups
Triangle Meshes
Objects

3D View

Right sidebar
Clipping Box
Cameras

GCPs and Manual Tie Points
Automatic Tie Points
Processing Area
Point Clouds
Objects

Status bar

Menu bar entry
Toolbar

Index View
Sidebar

1. Reflectance Map
2. Regions

3. Index Map
Formula Editor
Index List

4. Color Maps and Prescription
5. Export

Status bar
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When Pix4Dmapper opens, 4 sections appear:

Menu bar
Toolbar
View toolbar
Main view

. PixdDmapper Pro - O X

Project  Process  View Help

I R e =
- L | |

Project Process

Map View

Tz,
rayCloud

Pix4D

pro

mapper

- Help Demo Project

Index
Calculator

I_h New Project... N Open Project...
+ _I Follows the wizard to create a new D Open an existing project.

project with your own dataset.

mining_quarry.p4d

110 images
Last modified: Fri Mar 4 2016

mining_quarry.p4d

127 images
Last modified: Tue Mar 1 2016

small_prj.p4d building .p4d
5 images Last modified: Tue Mar 1 2016
Last modified: Fri Mar 4 2016 p ’X4D

O

Processing

Did you know...

Volume Difference of an Area Surveyed Ower Different Time Periods

&

Processing
Options

Figure 1. Menu bar (yellow), toolbar (red), viewtoolbar (green) and main view (blue).

Menu bar
There are 4 items:

Project: This menu allows the user to create, open, close, save or split a project. It also allows the user to view and define the properties of the images, GCPs,
and output coordinate system.



Process: This menu gives access to all processing options and actions.

View: This menu gives access to the different views of the software. Depending on the selected view, a new item will appear on the Menu bar: Map, rayCloud,
Mosaic Editor or Index Calculator. This extra menu bar item contains options specific for the selected view.

Help: This menu:

Gives access to the Manual, Support Site and Forum.

Allows the user to set some settings (proxy, camera model database, language)

Gives information about the installed release.

The different options within the menu bar items may be active or grayed out depending on the status of the project and the selected options.

Toolbar

The different buttons within the toolbar may be active or grayed out depending on the status of the project and the selected options. Each button's action can also
be accessed through the Menu bar and is explained in more details in the next articles.

The toolbar buttons are:
On the left:
Project

(@ Image Properties Editor...

{E} GCP/Manual Tie Point Manager...

Process

Quality Report...
Open Results Folder...

Reoptimize

e e

Rematch and Optimize

On the right:

& User Options: There are 4 items that can be selected:

Logged In as USERNAME: Displays the usemame.

Cloud Projects: Opens the user website account, displaying the Projects page, where the user can access the uploaded projects
(https://mapper.pix4d.com/projects/).

Manage Licenses: Opens the user website account, displaying the Licenses page, where the user can access the Licenses and Devices information
(https://mapper.pix4d.com/licenses/).

Log Out...: Option to deactivate the license in the installed computer.

2 Show / Hide the Sidebar: Shows /hides the sidebar relative to the selected view. The Welcome view does not hawe a sidebar.
o

When activating the different views using the View Menu bar item (Map View; rayCloud, Mosaic Editor and Index Calculator) some extra buttons appear. These
extra buttons are specific for the selected view (see Figures 2-5 below).

View toolbar

Appears on the left and allows to select the view, bars (Processing and/or Log Output bar) and the Processing Options window. Depending on the status of the
project and the selected options, the different options may be active or grayed out. When starting the software, only the Welcome View and the Log Output bar
are active.

The following Views are available:

O Welcome

m Map View

iz, rayCloud

] Mosaic Editor
Index Calculator

The following bars are available:

[} Processing
Log Output

The following windows are available:

Processing Options...



In order to show / hide the view toolbar, on the Menu bar click View > Show View Toolbar.

Main view
When Pix4Dmapper opens, the Welcome View appears.

When opening a project the Map View is selected by default and the 2D View appears. When the rayCloud is selected, the 3D View appears. When the Mosaic
Editor is selected, the Mosaic View appears and when the Index Calculator is selected, the Index View appears.
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Figure 1. Menu bar, toolbar buttons, view toolbar and main view when starting the software.
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Figure 2. Menu bar, toolbar buttons, viewtoolbar and main view when the Map Viewis selected.
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Figure 3. Menu bar, toolbar buttons, viewtoolbar and main view when the rayCloud is selected.
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Figure 4. Menu bar, toolbar buttons, viewtoolbar and main view when the Mosaic Editor is selected.
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Figure 5. Menu bar, toolbar buttons, viewtoolbar and main viewwhen the Index Calculator is selected.
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Index > Interface

& Access: On the Menu bar, click Project.

There are 13 items that can be selected:

New Project...

Open Project...

Recent Projects

Close Project

Download Project Files...
Upload Project Files...
Image Properties Editor...
GCP/MTP Manager...
Select Output Coordinate System...
Sawe Project

Sawe Project As...

Split into Subprojects...
Exit

Depending on whether there is a project loaded/created, different options will be enabled or grayed out:

© Previous | Next ©

. Pix4Dmapper Pro

Project  Process View Help

5 Mew Project... Ctrl+N

7 Open Project... Ctrl+Q
Recent Projects

Close Project

©»  Download Project Files...
Upload Project Files...

Image Properties Editor...
GCP/MTP Manager...
d  Select Qutput Coordinate Systern...

Save Project Ctrl+5

Split into Subprojects...

Exit Ctrl+Q

Available options before a project is loaded or created.

New Project...

Opens the wizard to create a new project.

For step by step instructions about how to create a new project: 202557309.

Open Project...

Save Project As... Ctrl+5Shift+5

. Pix4Dmapper Pro - mining_quarry

Project  Process  View  Map View
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MNew Project...
Open Project...
Recent Projects
Close Project

Download Project Files...

Upload Project Files...

Image Properties Editor...
GCP/MTP Manager...

Select Output Coordinate System...

Save Project
Save Project As...
Split into Subprojects...

Exit

Help
Ctrl+MN
Ctrl+0

Ctrl+5
Ctrl+5hift+5

Ctrl+ O

Available options once a project is loaded or created.

Opens an existing project. By clicking Open Project, a pop-up will appear to navigate and select a .p4d project file (Pix4Dmapper project file format).

Recent Projects

Displays a menu with the 10 last projects that have been opened. By clicking on one of them, the project will open.

Close Project

Closes the current project.

Download Project Files...



Allows the user to download and load a Pix4Dmapper project previously uploaded to Pix4D Cloud. This option is enabled when the software is opened and
disabled once a project is loaded or created.

For step by step instructions: 205751415.

Upload Project Files...
Allows the user to:

Upload and process a project to Pix4D Cloud Sener.
Upload Files to Mapbox.
Upload Files to Sketchfab.

For more information: 202557689.

Image Properties Editor...

Allows the user to change the properties of the project's images such as: coordinate system, geolocation, orientation and the associated camera model. For
more information: 202557849.

GCP/MTP Manager...

Allows the user to set up and edit the properties of the GCPs / Manual Tie Points / Check Points such as: Select the GCP coordinate system, import GCPs, add
/ remowe points, import / export the marks, open the rayCloud or Basic Editor for marking. For more information: 202558329.

Select Output Coordinate System...

Allows the user to select the coordinate system of the results. For more information: 202558099.

Sawe Project

Sawes the status/properties and configuration of the current project.

@ Important: This option saves any change made since the project was opened and saved for the last time. The .p4d project file will be updated with the
current state of the project. This has no impact on other files such as input files or output files. Output files will be modified/created only when
processing.

Sawe Project As...

Sawe the status/properties, configuration, and results of the current project into another location and/or with a different name.

@ Important: If a different project name or path is selected, this option will save a copy of the project in the new location using the new project name.

A new .p4d project file will be created and saved with the same information as the current project. Once this new project is created, any changes made
and saved with the option Save Project will not be saved in the original project. Only the new project will include all the changes.

Split into Subprojects...
Allows the user to automatically split the project into subprojects by creating different .p4d files.
Each .p4d file contains the images for the created subproject.

The different subprojects overlap, therefore, some images will appear in more than one subproject.
@ Important: Only aerial projects with geolocated images can be split.

By clicking Split into Subprojects... the Split the Project into Subprojects pop-up will open:


https://support.pix4d.com/hc/en-us/articles/205751415

. Split the Project into Subprojects *

Subproject Settings

Maximum Number of Images: | 127 |

Suffix of the Subproject's Mame: |Jja|'t |

o [ Gl |[ b

It contains the following options:

Maximum Number of Images: Defines the area to be used to split the terrain into subprojects. When selecting for example 100, a subproject will cover the area
from 100 images plus some area and images from neighboring subprojects so as to ensure there will be overlap between them.
Suffix of the Subproject's Name: Text to use as suffix for the subprojects. Each subproject will be named as projectname + Suffix + Number.

@ Important: All the Manual Tie Points, GCPs, Check Points and Objects created in the original project will be copied into all the generated subprojects.

Exit

Closes the project and exits the software.

@ Important: If changes have been made and the project was not saved, the following pop-up appears:

| PixdDmapper *

Cluestion gd019:

Do you want to save your changes?

I Save Il Discard || Cancel

Click Sawe to sawe the changes and exit, Discard to exit without saving, and Cancel to keep the software open.
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& Access: On the Menu bar, click Process > Upload Project Files... (active once a project has been loaded or created).

File Upload
Pix4D Cloud
p’%ﬁ Upload Files
[] Project and Image Files
PiedD Cloud
Start Processing
Mapbox|| [Otegrie
Mapbox [ Quality Report
[] Google Maps and KML Files
(] DSM Files (GedTIFF)
[ Point Cloud Files (LAS)
Reflectance Map Files (GeaTIFF)
Sketchfab
Progress
Upload Cancel

The File Upload pop-up appears, which allows the user to:

Upload and process a project to Pix4D Cloud Sener.
Upload Files to Mapbox.
Upload Files to Sketchfab

File Upload File Upload File Upload
Pix4D Cloud Mapbox Sketchfab
p Upload Files p "" Account p "" Easy and fast upload of the 3D Textured Mesh to Sketchfab
for viewing, interacting and sharing.
’X4U [] Praject and Image Files ’X4D Upload to ohmmappe " Mapbox accont ’X4D —
Pix4D Cloud . Pix4D Cloud Pix4D Cloud ceoun
At rocessng Progress Log into or create (free of charge) your Sketchfab
Mapbox|| [ igrie Mapbox Mapbox| | account hitps://sketchfab.com.
Mapbox Quality Report Mapbox Mapbox Upload
Eer LS L I s el Sy SRR
DSM Files (GeoTIFF) What is Maphosx? as follows:
Point Cloud Files (LAS) 1. In your Sketchfab account, click Upload
2. Choose the folder *_3d_mesh.zip of your
Sketchfab Reflectance Map Files (GeoTIFF) Sketchfab Sketchfab project (saved in your results folder under
2_densification/3d_mesh).
Frogress 3. The mesh and texture are uploaded directly.
Upload Cancel For more information: 203282189
What is Sketchfah?

Upload and process a project to Pix4D Cloud Sever



The Upload Project window contains 2 sections:

Upload Files
Progress

and the action buttons:

Close: Closes the window.

Upload Files

The Upload Files section contains the following boxes:

Project and Image Files: To upload the .p4d file and the images of the project.
Start Processing: To start processing on Pix4D Cloud Sener. It is enabled when Project and Image Files has been selected. For more information and step by
step instructions: 202558589.

l[_]] Note: When sending a project to Pix4Dmapper Support Team, there is no need to select Start Processing.

Log File (.log): To upload the log file of the project.

Quality Report (.pdf): To upload the quality report of the project.

Google Maps and KML Files: To upload the Google Maps and .kml files of the project.
DSM Files (GEOTIFF): To upload the DSM files of the project.

Point Cloud Files (LAS): To upload the point cloud files of the project.

Reflectance Map Files (GEOTIFF): To upload the reflectance map file of the project.

L[B Note: The boxes are enabled if the coresponding files have been generated.

Progress
The Progress section contains:

Progress bar: Displays the upload status in percentage.
Upload: Allows the user to upload the selected files to the cloud.
Cancel: Cancels the upload.

L[_J] Note: When the project is uploading, the following information is displayed:
MB already uploaded.
Size of files to be uploaded for the project.
Estimated time remaining.
Upload speed.

Upload Files to Mapbox

The Upload Project window contains 2 sections:
Account
Progress

and the action button:

Close: Closes the window.

Account

It displays:

"A new authorization will be requested" if no Mapbox account is logged in.

Upload to "USER" Mapbox account: If a Mapbox account is already logged in Pix4Dmapper .

The button Change: Allows the user to log out of the associated Mapbox account in Pix4Dmapper.
Progress

The Progress section contains:

Progress bar: Displays the upload status in percentage.
Upload: Allows the user to upload the selected files to the cloud.
Cancel: Cancels the upload.

L[J] Note: When the project is uploading, the following information is displayed:
MB already uploaded.
Size of files to be uploaded for the project.
Estimated time remaining.

Upload speed.

Upload Files to Sketchfab


https://support.pix4d.com/hc/en-us/articles/202558589

L[B Note: In order to use the 3D Textured Mesh in Sketchfab: 203282189.

The Upload Project window contains 2 sections:

Account
Upload

and the action button:
Close: Closes the window.
Account

It displays the URL to log in or create (free of charge) a Sketchfab account.

L[_J] Note: There is a limit on the size of the files that can be imported:

Basic (free account): 50MB per model.
Pro: 200MB per model.
Business: 500MB per model.

Upload
It displays the instructions to upload files to Sketchfab: 204963595.

Index > Interface > Menu Process
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https://support.pix4d.com/hc/en-us/articles/203282189
https://support.pix4d.com/hc/en-us/articles/204963595

Index > Interface > Menu Project

& Access: On the Menu bar, click Project > Image Properties Editor...

& Access via the New Project wizard: When creating a new project, after loading the images.

The Image Properties Editor window contains 3 sections:

Image Geolocation:

Selects the coordinate system used for the images' geolocation.
Imports/exports the coordinates and, optionally, the orientation of the images and/or the accuracy of the coordinates.
Selects the accuracy of the geolocation.
Selected Camera Model: Selects and configures the camera model associated to the images.
Images Table: Displays the selected images, as well as each image's group, position, position accuracy, orientation, and if the image is enabled or not (an
enabled image will be taken into account for processing).

© Previous | Next ©

.| Image Properties Editor *

Image Geolocation
Coordinate System

o i Datum: World Geodetic System 1984; Coordinate System: WGS 84 Edit...
Geolocation and Crientation

° Geolocated Images: 127 out of 127 Clear From EXIF From File... To File...
Geolocation Accuracy: (@) Standard () Low () Custom
Selected Camera Model

° B Canonl¥US220HS_4.3_4000x3000 (RGE) Edit...

- . . . . ~
Enabled  Image  Group [L::::.:; L&'E;'L“L'f it Bl s l{d}:;x] [de|;l:::e] [dK:;PeT:]
IMG_1146JPG groupl 654318705 46.65611328 783.649 5.000 10.000 1.89489 671999  00.81948
IMG_1147JPG groupl 654235243 46.65602724 778432 5.000 10.000 -0.68792 437147 100.75500
IMG_1148JPG groupl 654153660 46.65600830 730.023 5.000 10.000 478740 296335  94.67381
IMG_1149.JPG groupl 654066732 4665609371 779.133 5.000 10.000 4.56705 4.41950 101.12925
IMG_1150JPG groupl 6.53881693 46.65614777 720.264 5.000 10.000 4.35986 3.08310  90.84544
IMG_1151JPG groupl 6.53893543 46.65619302 779.011 5.000 10.000 441374 2.92741 93.45951
IMG_1152JPG groupl 653810604 46.65621426 721.004 5.000 10.000 4.89944 2.05931 94.70718
IMG_1153.JPG groupl 653723190 46,65624990 780.753 5.000 10.000 845570 347016 9057305,

Cancel Help

Index > Interface > Menu Project
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Index > Interface > Menu Project > Image Properties Editor...

& Access: On the Menu bar, click Project > Image Properties Editor...

& Access via the New Project wizard: When creating a new project, after loading the images.

The Image Geolocation section contains:

Coordinate System: Selects the coordinate system used for the images' geolocation.
Geolocation and Orientation: Imports/exports the coordinates and, optionally, the orientation of the images and/or the accuracy of the coordinates.
Geolocation Accuracy: Selects the accuracy of the geolocation.

© Previous | Next ©

[ Image Properties Editor *

Image Geolocation
Coordinate System

° ffF Datum: World Geodetic System 1984; Coordinate System: WGS 84 Edit...
Geolocation and Crientation

° Geolocated Images: 127 out of 127 Clear From EXIF From File... To File...
Geolocation Accuracy: (®) Standard () Low () Custom
Selected Camera Model

@) B CanonIxUs220HS_4.3_4000%3000 (RGE) Edit...

N Latitude  Longitude  Altitude Accuracy Accuracy Omega Phi Kappa "
Enabled Image Group [degree] [degree] [m] Horz[m] Vert[m] [degree] [degree] [degree]
IMG_1146JPG groupl 654318705 46.65611328 783.649 5.000 10.000 1.85439 671999  90.81948
IMG_1147JPG groupl 654235243  46.65602724 778.432 5.000 10.000 -0.68732 43147 100.75500
IMG_1148JPG groupl 654153660 46.65609830 720.023 5.000 10.000 478740 296335 9467381
IMG_1149JPG groupl 654066732 46.65609371 779153 5.000 10.000 4.56705 441950 101.12925
IMG_1150JPG groupl 653981693 46.65614777  780.264 5.000 10.000 4,35936 3.08310  90.84544
IMG_1151JPG groupl 653895543 46.65619302 779.011 5.000 10.000 441374 292741 93.45951
IMG_1152JPG groupl 653810604 46.65621426 781.004 5.000 10.000 4.89944 205931 94.70718
IMG_1153.JPG groupl 653723190 46.65624990 730.753 5.000 10.000 845570 347016 90.57303 |,

Cancel Help
Coordinate System

Datumm: Displays the selected image datum. By default the selected datum is World Geodetic System 1984.

Coordinate System: Represents the selected image coordinate system. By default the selected coordinate system is WGS 84.

Vertical coordinate system or Geoid Height Above the Ellipsoid: It is displayed in parenthesis. It represents the ertical coordinate system / Geoid Height Above
the Ellipsoid that will be used to convert image height from geoidal to ellipsoidal. For more information about when to use this function: 202559459.

Edit...: Opens the Select Image Coordinate System pop-up that allows the user to change the selected coordinate system.

For more information: 202558239.

Geolocation and Orientation

@ Important: Pix4Dmapper can process images with or without geolocation. If less than 3 images are geolocated, lower precision results are expected.

The left icon indicates the status:

@: If less than 3 images are geolocated, lower precision results are expected.

9: More than 3 images are geolocated.

The number of geolocated images is displayed next to the status indicator icon.

There are 4 options available for this section:


https://support.pix4d.com/hc/en-us/articles/202559459
https://support.pix4d.com/hc/en-us/articles/202558239

Clear: Deletes the images' coordinates that are already loaded.

From EXF: Imports the image geolocation (coordinates) written in the EXIF data of the images if they are available.

From File...: Imports from a file the coordinates of the images and, optionally, the orientation of the images and/or the accuracy of the coordinates using

the Select Geolocation File pop-up.

To file: Exports to a file the coordinates of the images and, optionally, the orientation of the images and/or the accuracy of the coordinates using the Export Image
Geolocation pop-up.

Geolocation Accuracy
Defines the horizontal and vertical accuracy values (Accuracy Horz, Accuracy Vert).

The horizontal accuracy (Accuracy Horz) refers to the first and second coordinates (latitude and longitude or Xand Y) of the images.
The wertical accuracy (Accuracy Vert) refers to the third coordinate (altitude or Z) of the images.

There are 3 options:

Standard: Useful when having very accurate image geolocation. Sets the values to:

Accuracy Horz: 5 (m or ft).

Accuracy Vert: 10 (m or ft).

Low: Useful when having non accurate image geolocation. Sets the values to:

Accuracy Horz: 50 (m or ft).

Accuracy Vert: 100 (m or ft).

Custom: Allows the user to set other values or edit the accuracy of each individual image or of a group of images.

The higher the accuracy numerical value (m or ft), the less influence the image's coordinates will have in the Initial Processing when compared to other images or
GCPs with lower accuracy numerical values (m or ft). The accuracy is a value between 0.001 and 10'000.

A Waming: The accuracy must be given in meters or feet according to the selected coordinate system.
To edit the accuracy of one image, double click on the corresponding cell and enter the new value. For more information about editing the accuracy of multiple

images, see Actions on the table.

Index > Interface > Menu Project > Image Properties Editor... © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/205320215
https://support.pix4d.com/hc/en-us/articles/204606405
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& Access: On the Menu bar, click Project > Image Properties Editor...

& Access via the New Project wizard: When creating a new project, the Image Properties window appears after loading the images.

The Selected Camera Model section is used to describe the selected camera model(s) associated with the images.

[ Image Properties Editor *

Image Geolocation

Coordinate System

° A5 Datum: World Geodetic System 1984; Coordinate System: WGS 84 Edit...
Geolocation and Crientation

o Geolocated Images: 127 out of 127 Clear From EXIF From File... To File...

Geolocation Accuracy: (®) Standard () Low () Custom

Selected Camera Model

@ © CanonIxUs220HS_4.3_4000x3000 (RGE) Edit...
Enabled ~ Image  Group ll:te::; Lf:g:::f it Bl s [do:;g] [de|;|:iee] ldK:;?lel :
IMG_1146JPG groupl 654318705 46.65611328 733.649 5.000 10.000 1.88489 B.719%9 90.81948
IMG_1147JPG groupl 654233243 46.65602724 778.432 5.000 10,000 -0.68792 437147 100.73300
IMG_1148JPG groupl 654153660 46.65609830 720.023 5.000 10,000 4.78740 2.96335 94.67581
IMG_114%JPG groupl 654066732 46.65609371 779153 5.000 10,000 4.56705 441950 101.12925
IMG_1150JPG groupl 653981693 46.65614777  780.264 5.000 10,000 4,35986 3.08310 90.84544
IMG_1151JPG groupl 653895543 46.65619302 779.011 5.000 10,000 441374 2.92TM1 93.45951
IMG_1152JPG groupl 653810604 46,65621426  781.004 5.000 10,000 4,89944 2.055831 94.70718
IMG_1153.JPG groupl 653723190 46,65624990 730.753 5.000 10,000 845570 347016 90.57303 -

Gl | [ e

The status indicator is represented with the left icon:

O The camera model is valid, if it is retrieved from Pix4Dmapper's camera model database, from the user's camera model database, from a project file, or

from the image EXF data if enough information exists in the data.

O: The camera model is invalid if the camera model does not correspond to any model of the camera model databases and if the EXIF data of the images

does not hawe sufficient information about the camera model.
On the right of the status indicator, there is an icon that describes the source of the camera model:

g : Camera model taken from the Pix4Dmapper's camera model database.

£ Camera model taken from the Pix4Dmapper's camera model database with some user-edited values.

,: Camera model taken from the user's camera model database.

5 : Camera model taken from the image EXIF data when the camera model does not exist in the Pix4Dmapper's or the user's database and there is valid

information in the EXIF data.
[ : Camera model taken from the .p4d project file when a .p4d file is opened and its camera model does not exist in the Pix4Dmapper's or the user's

database.
Beside the status indicator appears the Exif ID (CameraModel_ FocallLength ResolutionWidthxResolutionHeight) and the band configuration.
On the right of the Selected Camera Model section there are the following buttons:

Edit...: Opens the Edit Camera Model pop-up which allows the user to edit the corresponding camera model. For more information about the Edit Camera
Model window: 202558159.

Assign (optional): Appears if more than one camera models are detected (e.g. multiple flights with different cameras or merged projects). By clicking it, the
corresponding camera model is assigned to other detected camera models that have the same image width and height.
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Index > Interface > Menu Project > Image Properties Editor... > Selected Camera Model
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Access: On the Menu bar, click on Project > Image Properties Editor..., the Image Properties Editor window appears, in the Selected Camera

Model section, click Edit...

Access via the New Project wizard: When creating a new project, the Image Properties window appears after loading the images, in

the Selected Camera Model section, click Edit...

I Image Properties Editor *
Image Geolocation
Coordinate System
° ffF Datum: World Geodetic System 1984; Coordinate System: WGS 84 Edit...
Geolocation and Crientation
) Geolocated Images: 127 out of 127 Clear From EXIF From File... To File...
Geolocation Accuracy: (@) Standard () Low () Custom
Selected Camera Model
@ © CanonIXUs220HS_4.3_4000%3000 (RGE) Edit...
fabled Image  Group T AR M Mol Veriinl  legoel ldegree] ldemeel |
IMG_1146.JPG groupl 654318705 46.65611328 743.649 5.000 10.000 1.89489 6.719%9 9081948
IMG_1147JPG groupl 654235243 46.65602724 778.432 5.000 10.000 -0.68792 437147 100.75500
IMG_1148JPG groupl 654153660 46.65609830 730.023 5.000 10.000 478740 296335  94.67381
IMG_1149.JPG groupl 654066732 46.65609371 779153 5.000 10.000 4.56705 441950 101.12925
IMG_1150JPG groupl 653981693 46.65614777  730.264 5.000 10.000 4.35986 3.08310  90.84544
IMG_1151JPG groupl 653893543 46.65619302 779.011 5.000 10.000 441374 2.92741 93.45951
IMG_1152JPG groupl 653810604 46,65621426  731.004 5.000 10.000 4.89944 2.05931 94.70718
IMG_1153.JPG groupl 653723190 46.65624990 730.733 5.000 10.000 8.45570 347016 90.57303 |,
Cancel Help

The Edit Camera Model window is used to define or edit the camera model.

The camera model can be set to a perspective or fisheye lens.



. Edit Camera Model H
Camera Model
EXIF ID: CanonIXUS220HS_4.3_4000x3000
Camera Model Mame: CanonIXUS220HS_4.3_4000x3000 - |
Edit | | Mew |
Camera Model Bands
Bands: |RGB v | Edit...
Camera Model Parameters
Clear Estimate from EXIF Load Optimized Parameters

Warning: wrong parameters can cause failure in the reconstruction. Read the Help for more information.

Perspective Lens Fisheye Lens Shutter Model: | Global Shutter or Fast Readout -

Image Width [pixel]: 4000 Sensor Width [mm]: 6.1976

Image Height [pixel]: 3000 Sensor Height [mm]: 4,6482

Pixel Size [um]: 15494

Focal Length [pixel]: 2339.64 Focal Length [mm]: 4,39974

Principal Point x [pixel]: 2019.76 Principal Point x [mm]: 3.12942

Principal Paint v [pixel]: 1547 Principal Point v [mm]: 2.39692

Camera Model with Distortions: |5 o

Radial Distortion R.1: -0.042563 Tangential Distortion T1: | 0.00119999

Radial Distortion R2: 0.0259073 Tangential Distortion T2: | 0,00159852

Radial Distortion R.3: -0.00608853

ok || cancel | Hep

There are 3 sections:

Camera Model: Displays the current EXIF ID and the associated camera model.
Camera Model Bands: Displays the configuration band selected for the camera model.
Camera Model Parameters: Describes the camera parameters for the selected camera model.

and 3 action buttons:

OK: Confirms/applies the changes:

Uses the camera model selected in the Camera Model section if saved into the camera model database.

Uses the camera model name and parameters displayed in the Camera Model Parameters section if pressed while editing or creating a new camera model. The
currently displayed camera parameters are not saved into the camera model database but they are saved only in the project .p4d file.

Cancel: Does not sawe the changes.

Help: Opens the Pix4Dmapper help.

Camera Model

Camera Model

EXIF ID: CanonPowerShotS110_5.2_4048x3048

Camera Model Name: | Bl CanonPowerShotS110_5.2_4048x3048 - |

The following items are displayed:

EXIF ID: Displays the current EXIF ID (CameraModel_ Focallength_ResolutionWidthxResolutionHeight) of the camera. No user intervention is possible.

Camera Model Name: Displays the currently selected camera model. The corresponding drop-down list allows the user to select another known camera model
with the same image width and height.

Beside on the left of the selected camera model name, an icon appears that describes the source of the camera model:

g : Camera model taken from the internal camera model database.

£+ Camera model taken from the intermal camera model database with some user-edited values.

g,: Camera model taken from the user camera model database.

i@ Camera model taken from the image EXIF data when the camera model does not exist in the intemal or the user database and there is valid



information in the EXIF data.
[ : Camera model taken from the .p4d file when a .p4d file is created and its camera model does not exist in the intemal or the user camera database.

l[j] Note: There are 2 camera databases: intemnal camera database (with the cameras and values from Pix4Dmapper), and user camera database (with
the cameras added or modified by the user).
The intemal camera database cannot be edited, modified or deleted.
The user camera database can be:
Edited Menu Project > Image Properties Editor... > Selected Camera Model > Edit Camera Model.
Cleared, imported or exported from Help > Settings..., under the tab Camera database.

Click the drop-down list to display the available camera models. The drop-down list only displays camera models with the same image width and height as
the one detected in the EXIF ID. The drop-down list displays camera models using perspective lenses if Perspective lens (Camera Mode!
Parameters section) is selected and it displays camera models using fisheye lenses if Fisheye lens (Camera Model Parameters section) is selected.

l[j] Note: No information is displayed if no camera model exists with the same image width and height.

The following buttons are displayed:

Edit: Edit the Camera Model Bands and/or the Camera Model Parameters for the selected camera model. To edit the camera parameters: 202560169.
New: Create a new camera model. To create a new camera model: 202560169.

Restore: It is displayed only for camera models that exist in the intemal camera database and have been edited by the user and stored in the user camera
database. It remowes the camera model from the g user database and restores the parameters from the g intemal database.

Sawe to DB: Visible when clicking on Edit or New. Save the camera model in the user camera model database.

[m Note:
When editing g, and saving to DB, it changes to &

When editing 4, and saving to DB, it creates

When editing g,, and saving to DB, it creates g,

When editing [z, and saving to DB, it creates g,

When editing g or @ or g or [z, and clicking in OK without saving to DB, it creates

When creating new and Saving to DB, it creates g

When creating new and clicking in OK without saving to DB, it creates 3

Cancel edit: Visible when clicking on Edit or New. Cancel the editing or creating of a new camera model.

Camera Model Bands

Camera Model Bands

Bands: |Red,Green,NIR v Edt.

The section contains 2 items:

Bands: Displays the band configuration selected for the project. If the band configuration is in the EXIF, and it is one of the bands listed below, it is selected
automatically. It allows the user to change the band configuration when more bands have been added to the camera model.

Edit...: Opens the Edit Camera Model Band Configurations pop-up:

. Edit Carnera Model Band Configurations ? *
Band configurations
Default N&:‘[‘.lfr Name |LI
Edit...
2 [0 3 Red edge,Green,Blue
[ ok ] cancel || Heb

& Access: It is enabled if Edit or New has been clicked in the Camera Model section.

Allows to add/edit/remove Band configurations.


https://support.pix4d.com/hc/en-us/articles/202560169
https://support.pix4d.com/hc/en-us/articles/202560169

There is one section:

Band configurations table:

Band configurations

Bands

Default LSt

Name

Each row displays information for one band configuration:

Default: Displays which band configuration is selected by default when using the selected Camera Model.
Bands Number: Number of bands for the Camera Model.
Name: Name of the band configuration, double click on the cell to edit the name.

and the action buttons:

Add..: Opens the pop-up band configuration window to add a new band configuration.

| Edit Band Configuration 7 ®
Bands:
Enabled Mame Ic_::tgr;: ﬁla:]e Ba n[i 1::]| dth Weight Add
Red 660.0 0.0 0.2126
" Green 550.0 0.0 0.7152
Blue 470.0 0.0 0.0722
€ >
I OK I | Cancel | | Help

By default the values of the RGB band configuration appear :
Each row displays information for one band and by double clicking on them, it is possible to edit the value:

Enabled: Displays if the band is enabled or not for the selected band configuration.

Name: Name of the band for the band configuration.

Central Wave Length [mm]: Representative (most influential) wave length for the band.

Band Width [mm]: Width of the distribution related the central wawve length of the band.

Weight: How much value Pix4Dmapper gives to the selected band compared to other bands of the band configuration. These values only affect step 1. Initial
Processing. The sum of all weights should be 1.

And the action buttons:

Add...: Add one more band. The number of bands should match the number of channels present in the image.
Remowe: Deletes the selected row.

OK: Sawes the new band configuration.

Cancel: Does not save the band configuration.

Help: Opens the Pix4Dmapper help.

Edit...: Opens the Edit Band Configuration pop-up. It edits an existing band configuration:

| Edit Band Configuration 7 ®
Bands:
Enabled  Name i:“:;:“:::f Band Width Weight Add
1 Red 660.0 0.0 0.2126
2 Green 550.0 0.0 0.7152
3 880.0 0.0 0.7152
<
(0]4 Cancel | | Help

By default the values of the RGB band configuration appear :




Each row displays information for one band and by double clicking on them, it is possible to edit the value:

Enabled: Displays if the band is enabled or not for the selected Band configuration.

Name: Name of the band for the Band configuration.

Central Wave Length [mm]: Representative (most influential) wave length for the band.

Band Width [mm]: Width of the distribution related the central wave length of the band.

Weight: How much value Pix4Dmapper gives to the selected band compare to other bands of the band configuration. These values only affect step 1. Initial
Processing. All the weights should sum to 1.

And the action buttons:

Add...: Add one more band. The number of bands should match the number of channels present in the image.
Remowe: Deletes the selected row.

OK: Sawes the new band configuration.

Cancel: Does not save the band configuration.

Help: Opens the Pix4Dmapper help.

Remowe: Delete the selected band from the Band configurations table.
OK: Confirms/applies the changes.

Cancel: Does not save the changes.

Help: Opens the Pix4Dmapper help.

j Example: Examples of band configurations:
RGB: For images with 3 bands. The first band corresponds to Red, the second band corresponds to Green, and the third band corresponds to
Blue.
Blue, Green, NIR: For images with 3 bands. The first band corresponds to Blue, the second band corresponds to Green, and the third band
corresponds to Near Infrared.
NIR, Green, Blue: For images with 3 bands. The first band corresponds to Near Infrared, the second band corresponds to Green, and the third band
corresponds to Blue.
NIR, Red, Green: For images with 3 bands. The first band corresponds to Near Infrared (or Infrared), the second band corresponds to Red, and the
third band corresponds to Green.
Red edge, Green, Blue: For images with 3 bands. The first band corresponds to Red edge, the second band corresponds to Green, and the third
band corresponds to Blue.
Red, Green, NIR: For images with 3 bands. The first band corresponds to Red, the second band corresponds to Green, and the third band
corresponds to Near Infrared.

Camera Model Parameters

The Camera Model Parameters section includes all camera parameters and is enabled for editing if the Edit or New button has been clicked in the Camera
Model section. It displays the camera parameters of the selected Camera Model Name in the Camera Model section.

The Camera Model Parameters section has 3 action buttons (enabled if Edit or New has been clicked in the Camera Model section):

Clear: It clears all the fields except image width (pixel) and height (pixel).
Estimate from EXIF: Estimates the parameters from the EXF data if enough information about the camera model is found there.
Load Optimized Parameters: Enabled once at least step 1 has been completed, it changes the camera initial values to the optimized values.

It also has the Shutter Model dropdown list with the following options:

Global Shutter or Fast Readout
Linear Rolling Shutter

Global Shutter or Fast Readout
To be used if the camera has a global shutter: all light information is read at the same time for the whole sensor.
Linear Rolling Shutter

This option models the rolling shutter (the image is scanned line by line) of some cameras such as the GoPro or the standard DJI cameras. This can be enabled if
the camera's shutter is a rolling shutter and, the flight plan is linear: grid mission, building facade, etc...

The parameters can be defined or edited for a:

Perspective lens: When the camera model uses a perspective lens.
Fisheye lens: When the camera model uses a fisheye lens (ultra wide angle lens).

Perspective lens



[ Edit Camera Model

Camera Model

EXIF ID: CanonIXU5220H5_4.3_4000x3000

Camera Model Name: | & CanonIXUS220HS_4.3_4000x3000 -

Camera Model Bands

SavetoDB | | CancelEdit |

Bands: |RGB

*|| Edt. |

Camera Model Parameters

| Clear

| |Estimahe from E)(IF| |Load Optimized Parameters

Warning: wrong parameters can cause failure in the reconstruction. Read the Help for more information.

@ Perspective Lens

(") Fisheye Lens Shutter Model: | Global Shutter or Fast Readout |

() Image Width [pixel]:

Image Height [pixel]:

Focal Length [pixel]:

Principal Point x [pixel]:

Principal Paint v [pixel]:

4000 (®) Sensor Width [mm]: |6.19?6 |
3000 sensor Height [mm]: [ 4,6482 |

Pixel Size [um]: [ 1.5494 |
2839.64 FocalLength [mm]:  [4,39974 |
2019.76 Principal Point x [mm]: |3. 12942 |
1547 Principal Paint y [mml: [ 2,39692 |

Camera Model with Distortions: |5

Radial Distortion R.1:

Radial Distortion R2:

Radial Distortion R.3:

-0.042563 Tangential Distortion T1: | 0.00119993 |

0.0259073 Tangential Distortion T2: | 0.00169852 |

-0.00603853

I OK || Cancel || Help |

To edit values in pixels, select the radio button on the left of the Image width [pixels] text box. To edit values in millimeters, select the radio button on the left of

the Sensor width [mm] text box.

Internal Camera Parameters for Perspective lens

Camera Model Name
Image Width [pixel]
Image Height [pixel]
Focal Length [pixel]
Principal Point x [pixel]

Principal Paint y [pixel]

Sensor Width [mm]

Sensor Height [mm)]

Pixel Size [um]

Focal Length [mm]
Principal Point x [mm]

Name for the camera model.

The image width in pixels. This value cannot be edited. It is read from the image file information.

The image height in pixels. This value cannot be edited. It is read from the image file information.

The focal length in pixels.

The x image coordinate of the principal point in pixels. The principal point is located around the center of the image. The
coordinate system has its origin as displayed here:

0,0) X

Y

The y image coordinate of the principal point in pixels. The principal point is located around the center of the image. The
coordinate system has its origin as displayed here:

0,0) X

A
Y!

The sensor width in millimeters. If the sensor width is estimated from the EXIF and no information is in the image EXF data, the
sensor width is set to 36[mm].

The sensor height in millimeters. If the sensor height is estimated from the EXIF and no information is in the image EXF data, the
sensor width is set to 36 [mm] and the sensor height is computed in such a way that the ratio sensor width / sensor height in
millimeters equals the ratio image width / image height in pixels.

The size of the pixel is read from the EXF data if the information is available. If there is no information related to the pixel size,
then it is calculated in order to correspond to 36 x 24 mm sensor size.

The focal length in millimeters.

The x image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

0,0) X




Principal Point y [mm] The y image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

(0,0) X

Y
Radial Distortion K1: Radial distortion of the K1 lens.
Radial Distortion K2: Radial distortion of the K2 lens.
Radial Distortion K3: Radial distortion of the K3 lens.
Tangential Distortion T1: Tangential distortion of the T1 lens.
Tangential Distortion T2: Tangential distortion of the T2 lens.

Tip: If the radial and tangential distortions of the lens are not known, it is recommended to set the values for K1, K2, K3, T1, T2 to 0. For more
information about how to calibrate a perspective camera: 206065716.

l[B Note: For more information about how the intemal parameters for a perspective lens are defined: 202559089.

Fisheye lens

[ Edit Camera Model *

Camera Model
EXIF ID: HERO3+BlackEdition_2.8_4000x3000

Camera Model Name: | |2 HERO3+BlackEdition_2.8_4000x3000 -

Save toDB | | Cancel Edit |

Camera Model Bands

Bands: |RGB - Edt. |

Camera Model Parameters

| Clear | |Esh'mate from EXIF| Load Optimized Parameters

Warning: wrong parameters can cause failure in the reconstruction. Read the Help for more information.

() Perspective Lens (®) Fisheye Lens Shutter Model: | Global Shutter or Fast Readout |
() Image Width [pixel]: 4000 (®) Sensor Width [mm]: |6.2 |
Image Height [pixel]: 3000 Sensor Height [mm]: |4.65 |
Pixcel Size [um]: [1.55 |
Principal Peint x [pixel]l: | 2000 Principal Point x [mm]: |3, 1 |
Principal Paint v [pixel]: | 1500 Principal Point y [mm]: |2.325 |
Polynomial Coefficents: |x-1x-x-0 ~  [0.000145 NE |-0.007731 | |0.150831 0

[] camera Model with Symmetric Affine Transformation

Affine Transformation C: |2}'45 | Affine Transformation D: |0 |

Affine Transformation E: |0 | Affine Transformation F: |2?45 |

I OK || Cancel || Help |

To edit values in pixels, select the radio button on the left of the Image width [pixels] text box. To edit values in millimeters, select the radio button on the left of
the Sensor width [mm] text box.

Internal Camera Parameters for Fisheye lens

Camera Model Name Name for the camera model.

Image Width [pixel] The image width in pixels. This value cannot be edited. It is read from the image file information.

Image Height [pixel] The image height in pixels. This value cannot be edited. It is read from the image file information.

Principal Point x [pixel] The x image coordinate of the principal point in pixels. The principal point is located around the center of the image. The

coordinate system has its origin as displayed here:

(0,0) X



https://support.pix4d.com/hc/en-us/articles/206065716
https://support.pix4d.com/hc/en-us/articles/202559089

Principal Paint y [pixel]

Sensor Width [mm]

Sensor Height [mm)]

Pixel Size [pm]

Principal Point x [mm]

Principal Point y [mm]

Polynomial Coefficients

Camera Model with Symmetric

Affine Transformation

Affine Transformation C
Affine Transformation D
Affine Transformation E
Affine Transformation F

The y image coordinate of the principal point in pixels. The principal point is located around the center of the image. The
coordinate system has its origin as displayed here:

(0,0) X

Y

The sensor width in millimeters. If the sensor width is estimated from the EXIF and no information is in the image EXF data, the
sensor width is set to 36[mm].

The sensor height in millimeters. If the sensor height is estimated from the EXIF and no information is in the image EXF data, the
sensor width is set to 36 [mm] and the sensor height is computed in such a way that the ratio sensor width / sensor height

in millimeters equals the ratio image width / image height in pixels.

The size of the pixel is read from the EXF data if the information is available. If there is no information related to the pixel size,
then it is calculated in order to correspond to 36 x 24 mm sensor size.

The x image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

(0,0) o X

Y

The y image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

0,0 X

Y

4 different type of polynomials can be selected from a drop-down list, where 1,2 or 3 values are already pre-defined and cannot be
changed:

0-1-x-x-0

x-1-x-x-0

0-1-x-x-x: recommended

x-1-x-x-x: ignores an area around the image center. This is useful when the center is blurry or contains a lot of noise

If selected, the model is symmetric and C=D and E=F=0. This is useful when the circular image cannot be modeled by a sphere.

Affine transformation C value.
Affine transformation D value.
Affine transformation E value.
Affine transformation F value.

@ Note: For more information about how the intemal parameters for a fisheye lens are defined: 202559089.

@ Tip: For more information about how to calibrate a fisheye camera: 202557009.

Index > Interface > Menu Project > Image Properties Editor... > Selected Camera Model

© Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202559089
https://support.pix4d.com/hc/en-us/articles/202557009

Index > Interface > Menu Project > Image Properties Editor... © Previous | Next ©

& Access: On the Menu bar, click Project > Image Properties Editor...

& Access via the New Project wizard: When creating a new project, the Image Properties window appears after loading the images.

This table is used to describe and edit the information and the status of the images used for the project.

[ Image Properties Editor *

Image Geolocation

Coordinate System

° A5 Datum: World Geodetic System 1984; Coordinate System: WGS 84 Edit...
Geolocation and Crientation

o Geolocated Images: 127 out of 127 Clear From EXIF From File... To File...

Geolocation Accuracy: (®) Standard () Low () Custom

Selected Camera Model

@ © CanonIxUs220HS_4.3_4000x3000 (RGE) Edit...
Enabled ~ Image  Group ll:te::; Lf:g:::f it Bl s [do:;g] [de|;|:iee] ldK:;?lel :
IMG_1146JPG groupl 654318705 46.65611328 733.649 5.000 10.000 1.88489 B.719%9 90.81948
IMG_1147JPG groupl 654233243 46.65602724 778.432 5.000 10,000 -0.68792 437147 100.73300
IMG_1148JPG groupl 654153660 46.65609830 720.023 5.000 10,000 4.78740 2.96335 94.67581
IMG_114%JPG groupl 654066732 46.65609371 779153 5.000 10,000 4.56705 441950 101.12925
IMG_1150JPG groupl 653981693 46.65614777  780.264 5.000 10,000 4,35986 3.08310 90.84544
IMG_1151JPG groupl 653895543 46.65619302 779.011 5.000 10,000 441374 2.92TM1 93.45951
IMG_1152JPG groupl 653810604 46,65621426  781.004 5.000 10,000 4,89944 2.055831 94.70718
IMG_1153.JPG groupl 653723190 46,65624990 730.753 5.000 10,000 845570 347016 90.57303 -

Gl | [ e

The following actions can be performed on the table:

Sorting the table
Selecting Images
Editing Values

The table has as many rows as the amount of images in the project. Each row displays information for one image:

Status of the image (Enabled)
Image

Group

Camera model (Multi-camera model projects)
First coordinate

Second coordinate

Third coordinate

Accuracy Horz

Accuracy Vert

Omega

Phi

Kappa

Actions on the table

Sorting the table



By clicking the column title used to sort the table, it will be ordered from the smallest to the highest value. By clicking again the column title already used for
sorting, the sorting will switch from smallest to highest to higest to smaller and vice versa.

A triangle indicates which column title is used for sorting and the type of sorting:

— -
Image Image
IMG_1146.JPG IMG_1272JPG
IMG_1147JPG IMG_1271.JPG
IMG_1148JPG IMG_1270JPG
IMG_1149JPG IMG_1269.JPG
IMG_1150JPG IMG_1268.JPG
IMG_1151.JPG IMG_1267JPG
IMG_1152JPG IMG_1266.JPG
IMG_1153.JPG IMG_1265.JPG
Smallest to highest values. Highest to smallest values.

Selecting images
Selecting an image

Left click any of the image’s cells. The row corresponding to the selected image is displayed in blue.
Selecting multiple images

For images that are displayed one after the other: Press the Shift key and left click the first and last images to be selected. The rows corresponding to the
selected images are displayed in blue. Altematiwely, left click one image and while keeping the left button clicked, move the mouse up or down.

For images that are not displayed one after the other: Press the Control key and left click all the images to be selected. The rows corresponding to the selected
images are displayed in blue.

Editing values

Editing one image

For the Enabled column:
1. Click the box (the status switch between selected / unselected).
For the Group column:

1. Double click the cell.
2. Type the new value or click the left arrow to select among the existing values.
3. Click Enter or click outside the cell.

For the Latitude, Longitude, Altitude, Accuracy Horz or Accuracy Vert columns:

1. Double click the cell.
2. Type the new value.
3. Click Enter or click outside the cell.

Editing all the values for one column
For the Enabled column:

1. Right click one cell of the column.
2. Click Enabled All Images or Disable All Images.

For the Group column:

1. Right click one cell of the column.

2. Click Edit All Groups.

3. Type the new value or click the left arrow to select among the existing values.
4. Click Enter or click outside the cell.

For the Latitude, Longitude, Altitude, Accuracy Horz or Accuracy Vert columns:

1. Right click one cell of the column.

2. Click Edit All Altitudes / Horz. Accuracies/ Vert. Accuracies.
2. Type the new value.

3. Click Enter or click outside the cell.



Editing the selected rows values for one colum
Select multiple images and:
For the Enabled column:

1. Right click one of the selected cells of the column.
2. Click Enabled Selected Images or Disable Selected Images.

For the Group column:

1. Right click one of the selected cells of the column.

2. Click Edit Groups in Selected Rows.

3. Type the new value or click the left arrow to select among the existing values.
4. Click Enter or click outside the cell.

For the Latitude, Longitude, Altitude, Accuracy Horz or Accuracy Vert columns:

1. Right click one of the selected cells of the column.

2. Click Edit Altitudes / Horz. Accuracies/ Vert. Accuracies in Selected Rows.
2. Type the new value.

3. Click Enter or click outside the cell.

Status of the image (Enabled)

The status of the image is displayed in the Enabled column. It is defined by a box that indicates if the image is used for the processing or not. If the box is
selected, the image is enabled and is used for the processing.

To select or unselect an image: Left click on the box.

l[ﬂ Note: The disabled images are not deleted from the project in case of further need to use them.

Image

This column displays the name of the images. It cannot be edited.

Group
When processing images that belong to different groups, all images are processed together, generating:

One poaint cloud of automatic tie points for the whole project. The color of the automatic tie points will be mixed: some points will take color from the RGB images
and others from the NIRGB images.

One densified point cloud per group.

One DSM for the whole project.

One orthomosaic per group.

@ Important: Images taken by the same camera during different flights should not be grouped into different groups, unless there is need to generate different
orthomosaics for each data.

Tip: Use the groups to group images with different spectral signatures (RGB, NIRGB, etc). In this case different reflectance maps are generated that can
be used for index calculations. For more information about index calculations: 202558289.

By default the images that have the same number and type of bands as well as the images with the same pixel type (byte, float) will be grouped as group1.
Images with different bands and pixel type will be grouped as group2, group3, etc. To change the group of one image, double click on the corresponding cell and
edit the group. For more information about editing the group of multiple images: 202557949.

@ Important: When having more than one group, the Google files (Google Maps tiles and .kml) will only be generated if one of the groups is
named RGB (capital letters). Then the Google files will be generated only for this group. For more information about how to generate Google
files: 202558149.

Camera model (Multi-camera model projects)
For projects with more than one camera model, this column displays the camera model assigned to the corresponding images.

To change the camera model of one image, double click on the corresponding cell. Click on the arrow that appears and, from the drop-down list, choose the
desired camera model.

l[D Note: The camera model can only be chosen among a list of detected camera models for the project.



First Coordinate
The first coordinate is:

Latitude [degree]: If the coordinate system of the images is a geographic coordinate system.

X[m]: If the coordinate system of the images is a projected coordinate system. The unit is given in meters.
X[feet]: If the coordinate system of the images is a projected coordinate system. The unit is given in feet.

Local X[m]: If the coordinate system is defined by the user (local coordinate system). The unit is given in meters.

The coordinate columns are filled:

When importing the coordinates from the image EXF data if the information exists.
When importing the coordinates from the image geolocation file.
When manually editing the table: double click on the corresponding cell and enter the coordinate.

l[D Note: If no image geolocation has been imported then the value of the cells is zero (0.000).

Second coordinate
The second coordinate is:

Longitude [degree]: If the coordinate system of the images a geographic coordinate system.

Y [m]: If the coordinate system of the images is a projected coordinate system. The unit is given in meters.

Y [feet]: If the coordinate system of the images is a projected coordinate system. The unit is given in feet.

Local Y [m]: If the coordinate system is defined by the user (local coordinate system). The unit is given in meters.

The coordinate columns are filled:

When importing the coordinates from the image EXF data if the information exists.
When importing the coordinates from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the coordinate.

l[ﬂ Note: If no image geolocation has been imported then the value of the cells is zero (0.000).

Third Coordinate
The third coordinate is:

Altitude [m]: If the coordinate system of the images is a geographic coordinate system.

Z[m]: If the coordinate system of the images is a projected coordinate system. The unit is given in meters.

Z [feet]: If the coordinate system of the images is a projected coordinate system. The unit is given in feet.

Local Z[m]: If the coordinate system is defined by the user (local coordinate system). The unit is given in meters.

The coordinate columns are filled:

When importing the coordinates from the image EXF data if the information exists.
When importing the coordinates from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the coordinate.

@ Note: If no image geolocation has been imported then the value for the cells is zero (0.000).

Waming:
The Z coordinate must be given in the same unit as the (XY) coordinates (meters or feet).
All image geolocation coordinates have to be given in the same coordinate system.

Accuracy Horz

Defines the horizontal accuracy value (Accuracy Horz). The horizontal accuracy refers to the first and second coordinates (latitude, longitude, or XY) of the
images.

Very accurate image geolocation (latitude, longitude, or XY coordinates: Low accuracy value.
Non accurate image geolocation (latitude, longitude, or XY) coordinates: High accuracy value.

The higher the accuracy value, the less impact the image’s coordinates will have on the Initial Processing, compared to other images or GCPs with lower
accuracy values. The accuracy is a value between 0.001 and 10'000.

A Waming: The horizontal accuracy must be given in meters or feet according to the selected coordinate system.



To edit the horizontal accuracy of one image, double click on the corresponding cell and enter the new value. For more information about editing the horizontal
accuracy of multiple images, see Actions on the table.

Accuracy Vert
Defines the vertical accuracy value (Accuracy Vert). The vertical accuracy refers to the third coordinate (altitude or Z) of the images.

Very accurate image geolocation (altitude or Z) coordinate: Low accuracy value.
Non accurate image geolocation (altitude or Z) coordinate: High accuracy value.

The higher the accuracy value, the less impact the image’s coordinate will have on the Initial Processing, compared to other images or GCPs with lower
accuracy values. The accuracy is a value between 0.001 and 10'000.

A Waming: The \ertical accuracy must be given in meters or feet according to the selected coordinate system.

To edit the vertical accuracy of one image, double click on the corresponding cell and enter the new value. For more information about editing the \ertical
accuracy of multiple images, see Actions on the table.

Omega
Omega (w) is the rotation around the X-axis. It is given in degrees.
The rotation columns are filled:

When importing the angles from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the angle.

This value is optional as Pix4Dmapper does NOT require the orientation of the camera in order to process the projects.
For more information about how Pix4Dmapper defines the Omega - Phi - Kappa angles: 202558969.

Phi
Phi (o) is the rotation around the Y-axis. It is given in degrees.
The rotation columns are filled:

When importing the angles from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the angle.

This value is optional as Pix4Dmapper does NOT require the orientation of the camera in order to process the projects.
For more information about how Pix4Dmapper defines the Omega - Phi - Kappa angles: 202558969.

Kappa
Kappa (k) is the rotation around the Z-axis. It is given in degrees.
The rotation columns are filled:

When importing the angles from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the angle.

This value is optional as Pix4Dmapper does NOT require the orientation of the camera in order to process the projects.
For more information about how Pix4Dmapper defines the Omega - Phi - Kappa angles: 202558969.

Index > Interface > Menu Project > Image Properties Editor... © Previous | Next ©
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Index > Interface > Menu Project

& Access: On the Menu bar, click Project > GCP/MTP Manager...

The GCP/MTP Manager pop up window has the following 3 sections:

GCP Coordinate System: Section to select the coordinate system on which the GCPs/MTPs/Check Points position are based.
GCP/MTP Table: Section to:

Import, edit, add and remove GCPs/MTPs/Check Points

Export GCPs/Check Points coordinates and, optionally for GCPs, the accuracy of the coordinates.
Import or export a file with the image coordinates of the GCPs/MTPs/Check Points and on which images have been marked, in which position and at which zoom

lewel.

GCP/MTP Editor: Section to mark the GCPs/MTPs/Check Points on images.

And the action buttons:

OK: Confirms the changes.

Cancel: Does not sawe the changes.
Help: Opens the Pix4Dmapper help.

© Previous | Next ©

I GCP/MTP Manager

GCP Coordinate System

ff5 Datum: Warld Geodetic System 1984; Coordinate System: WGS 84

GCP/MTP Editor

paint marking.

(Recommended) Use the rayCloud
Editor after step 1.Initial Processing is
done. This allows a fast and precise

rayCloud Editor...

GCP/MTF Table
R e i I s R
8 900 3D GCP 46,65644157 6.33589498 573.325 0.020 0.020
4 9002 3D GCP 46,65693879 £.53511384 568.726 0.020 0.020
9 9004 3D GCP 46,65433476 £.33314731 565.699 0.020 0.020
18 9011 3D GCP 46,65337950 £6.54370093 473.329 0.020 0.020
24 902 3D GCP 46,65325332 6534184118 460.896 0.020 0.020
12 9016 3D GCP 46,65305217 £.53969390 455.266 0.020 0.020
25 9M7 3D GCP 46,65364415 £.54260020 465.026 0.020 0.020
7{7 GCPs with enough image marks Import Marks...

In order to compute the 30 position of & GCP/MTF, it needs to be marked on at least two images.

In order to take GCPs into account for georeferencing the project, at least 3 GCPs need to be marked.
Marking GCPs/MTPs after step 1. Initial Processing requires the user to run Process > Reoptimize,

The GCPs/MTFP accuracy can be verified in the Quality Repaort or in the rayCloud Editor.

Use the Basic Editor before step 1.
Initial Processing or when using non-
geolocated images or an arbitrary
coordinate system.

Basic Editor...

oK Cancel

Import GCPs...

Export GCPs...

Add Point

Remove Points

Export Marks...

Help

Index > Interface > Menu Project

© Previous | Next ©



Index > Interface > Menu Project > GCP/MTP Manager... © Previous | Next ©

& Access: On the Menu bar, click Project > GCP/MTP Manager...

The GCP Coordinate System section is used to define the coordinate system on which the GCPs/MTPs/Check Points position are based.

Datum: Represents the selected images' datum. By default the selected Datum is World Geodetic System 1984.
Coordinate system: Represents the selected images' coordinate system.
@ When the selected coordinate system is a Geographic Coordinate System.

G5 When the selected coordinate system is Projected Coordinate System.

Vertical coordinate system or Geoid Height Above the Ellipsoid: It is displayed in parenthesis. It represents the vertical coordinate system / Geoid Height Above
the used ellipsoid that will be used to convert the GCPs height from geoid to ellipsoidal. For more information about when to use this function: 202559459.
Edit...: Opens the Select GCP Coordinate System pop-up that allows the user to change the selected coordinate system.

For more information: 202558239.

I GCP/MTP Manager X

GCP Coordinate System
f5 Datum: Werld Geodetic System 1984; Coordinate System: WGS 84

GCP/MTP Table

~ ) ) ) Import GCPs...
Label Type Latitude Longitude Altitude Accuracy Accuracy
[degree] [degreel [m] Horz [m] Vert [m] Export GCPs...
8 9001 D GCP 4665644157  £.53580498 573.325 0.020 0.020
40002 D GCP 4665698879 £.53511384 568,726 0.020 0.020
9 00 3D GCP 4665483476 653314731 565.699 0.020 0.020
19 9011 3D GCP 46,65537950  6.54370093 473329 0.020 0.020 Add Paint
24 9012 3D GCP 4665325332 654184116 460.896 0.020 0.020 Remove Points
12 9016 3D GCP 4665305217 6.53969390 435,266 0.020 0.020
25 9017 3D GCP 4665364415 6.54260020 465.026 0.020 0.020
7{7 GCPs with enough image marks Import Marks... | |Export Marks...
GCP/MTP Editor

In order to compute the 3D position of 3 GCP/MTF, it needs to be marked on at least two images.

In order to take GCPs into account for georeferencing the project, at least 3 GCPs need to be marked.
Marking GCPs/MTFs after step 1. Initial Processing requires the user to run Process > Reoptimize.

The GCPs/MTP accuracy can be verified in the Quality Report or in the rayCloud Editor.

(Recommended) Use the rayCloud Use the Basic Editor before step 1.
Editor after step 1.Initial Processing is Initial Processing or when using non-
done. This allows a fast and precise geolocated images or an arbitrary
point marking. coordinate system.
rayCloud Editr... Basic Editor...
0K Cancel Help

Index > Interface > Menu Project > GCP/MTP Manager... © Previous | Next ©
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Index > Interface > Menu Project > GCP/MTP Manager... © Previous | Next ©

& Access: On the Menu bar, click Project > GCP/MTP Manager...

This section contains a GCP/MTP Table which displays all the GCPs/Manual Tie Points/Check Points of the projects together with their properties, and 6 action
buttons:

Import GCPs...: Allows the user to import a file with GCPs/Check points.

Export GCPs...: Allows the user to export GCPs/Check Points coordinates and, optionally for GCPs, the accuracy of the coordinates.

Add Point : Allows the user to manually add one by one GCPs/Manual Tie Points/Check Points.

Remowe Points : Allows the user to remowe the selected GCPs/Manual Tie Points/Check Points.

Import Marks...: Allows the user to import a file which contains, for each GCPs/Manual Tie Points/Check Points list of the marked images and, for each image,
the coordinates and zoom lewel.

Export Marks...: Allows the user to export a file which contains, for each GCPs/Manual Tie Points/Check Points list of the marked images and, for each image,
the coordinates and zoom level.

In the bottom left side, a status text appears indicating how many GCPs are implemented in the project and marked in at least 2 images.

.| GCP/MTP Manager >

GCP Coordinate System

ff5 Datum: Warld Geodetic System 1984; Coordinate System: WGS 84
GCP/MTF Table
= Impert GCPs...
el = T = S S S
Export GCPs...
8 5001 3D GCP 4665644157 653580408 573.325 0.020 0.020
49002 3D GCP 4665688879 653511384 568.726 0.020 0.020
9 9004 3D GCP 4665483476 6533147 565,699 0.020 0.020
19 9011 3D GCP 4665537950  6.54370093 473320 0.020 0.020 Add Point
24 9012 3D GCP 4665325332 654184116 460.896 0.020 0.020 FELTIE M
12 9016 3D GCP 4665305217 6.53969890 455,266 0.020 0.020
25 9017 3D GCP 4665364415 6.54260020 465.026 0.020 0.020
7{7 GCPs with enough image marks Import Marks... | |Export Marks...
GCP/MTP Editor

In order to compute the 3D pesition of a GCP/MTF, it needs to be marked on at least two images.

In order to take GCPs into account for georeferencing the project, at least 3 GCPs need to be marked.
Marking GCPs/MTPs after step 1. Initial Processing requires the user to run Process > Reoptimize,

The GCPs/MTP accuracy can be verified in the Quality Repart or in the rayCloud Editor.

(Recommended) Use the rayCloud Use the Basic Editor before step 1.
Editor after step 1.Initial Processing is Initial Processing or when using non-
done. This allows a fast and precise geolocated images or an arbitrary
point marking. coordinate system.
rayCloud Editor... Basic Editor...
QK Cancel Help

Index > Interface > Menu Project > GCP/MTP Manager... © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202557919
https://support.pix4d.com/hc/en-us/articles/204606405

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table

& Access: On the Menu bar, click Project > GCP/MTP Manager..., on the GCP/MTP Table section, click Import GCPs...

Pix4Dmapper can import a file with the coordinates of the GCPs. For more information about the file format: 202558539.

When clicking Import GCPs..., the Import Ground Control Points pop-up appears:

. Import Ground Centrol Points

Coordinates Order: |)t, Y2

File: |

It contains the following sections:

© Previous | Next ©

Coordinates Order: Allows the user to select the order of the coordinates of the file to be imported. Depending the coordinate system, there are the following

possibilities:

Latitude, Longitude, Altitude or Longitude, Latitude, Altitude (only if a geographic coordinate system is selected).

XY, ZorY, XZ

File: Displays the name of the selected file to be imported.

And the action buttons:

Browse...: Opens the Select GCPs File, a navigation window used to search for and select the file to be imported.

| Select GCPs File X
« = E v | searchs P
Organise + New folder =~ I @
# Quick access Marme Date modified Type Size
% OneDrive PixdDmapper 25/02/2016 16:47 File folder
& This PC
¥ Metwork
#& Homegroup
<
File name: v| |.brlﬁ|a5 (*.toct *.csv) V|
| Open | | Cancel |

Ok: Imports the selected file.

Cancel: Does not save the changes and exits the pop-up.

Help: Opens the Pix4Dmapper help.

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table

© Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202558539

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table

& Access: On the Menu bar, click Project > GCP/MTP Manager..., on GCP/MTP Table, click Add Point.

This button is used to manually add GCPs/MTPs/Check Points one by one.

l[_ﬂ Note: Before adding the points, their coordinate system needs to be defined. For more information: 202557749.

A Waming: All GCPs/MTPs/Check Points need to be defined in the same coordinate system.

© Previous | Next ©

The Add Paint button allows the user to add a new point in the GCP/MTP Table. The Type is by default set to Manual Tie Point. The label is automatically

generated and starts by "mtp" followed by a number that increases with the number of points added (e.g. mtp1, mtp2, mtp3, etc.). The labels are automatically
generated when adding a point in the GCP/MTP Manager by pressing the Add Point button or when adding a point or an object in the rayCloud. The point type
can be changed by double clicking on the Type cell and selecting the desired type.

For more information about the GCP/MTP Table properties: 202557919.

I GCP/MTP Manager

GCP Coordinate System

5 Datum: Warld Geodetic System 1984; Coordinate System: WGS 84

GCP/MTP Editor

paint marking.

(Recommended) Use the rayCloud
Editor after step 1.Initial Processing is
done. This allows a fast and precise

rayCloud Editar. ..

GCP/MTF Table
b Twe led eemed  dml hewim Ve

4 9002 3D GCP 4665698879 653511384 568.726 0.020 0.020

9 9004 3D GCP 4665433476 653314731 565.699 0.020 0.020

15 901 3D GCP 46,65537950  £.54370093 473.329 0.020 0.020

24 92 3D GCP 4665325332 654184116 460.896 0.020 0.020

12 9016 3D GCP 46,65303217  6.53969390 455.266 0.020 0.020

25 9M7 3D GCP 46,65364415  6.54260020 465.026 0.020 0.020

0 mtp8 Manual Tie P... v
7{7 GCPs with enough image marks Import Marks...

In order to compute the 30 position of & GCP/MTF, it needs to be marked on at least two images.

In order to take GCPs into account for georeferencing the project, at least 3 GCPs need to be marked.
Marking GCPs/MTPs after step 1. Initial Processing reguires the user to run Process > Reoptimize,

The GCPs/MTFP accuracy can be verified in the Quality Repaort or in the rayCloud Editor.

Use the Basic Editor before step 1.
Initial Processing or when using non-
geolocated images or an arbitrary
coordinate system.

Basic Editor...

e

Edit...

Import GCPs...

Export GCPs...

Add Point

Remove Points

Export Marks...

Help

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table

© Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202557919

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table

& Access: On the Menu bar, click Project > GCP/MTP Manager..., on GCP/MTP Table, click Remowe Points.

© Previous | Next ©

When clicking Remowe Points the GCPs/MTPs/Check Points that are displayed on the GCP/MTP Table can be removed. One or multiple points can be selected
from the GCP/MTP Table and be remowved by clicking Remowe Points. For more information about how to select a point on the GCP/MTP Table: 202557919.

e

GCP/MTP Manager

GCP Coordinate System

5 Datum: Warld Geodetic System 1984; Coordinate System: WGS 84

GCP/MTP Table
N Latitude Longitude Altitude Accuracy Accuracy
Label Type [degree] [degreel iml Horzlml  Vert[ml

& o001 3D GCP 46.65644157 £.53580498 573.325 0.020 0.020

4 9002 3D GCP 46.65698879 £.53511384 568.726 0.020 0.020

9 0004 3D GCP 46.65483476 £.53314731 565.609 0.020 0.020

19 9011 D GCP 4665537950 £.54370093 473,329 0.020 0.020

24 9012 D GCP 4665325332 6534184118 460.896 0.020 0.020

12 9016 D GCP 4665305217 £.53969890 455.266 0.020 0.020

25 9017 D GCP 4665364415 654260020 465.026 0.020 0.020
77 GCPs with enough image marks Import Marks...
GCP/MTP Editor
In order to compute the 30 position of 8 GCP/MTF, it needs to be marked on at least two images.
In order to take GCPs into account for georeferencing the project, at least 3 GCPs need to be marked.
Marking GCPs/MTPz after step 1. Initial Processing reguires the user to run Process > Reoptimize.
The GCPs/MTP accuracy can be verified in the Quality Report or in the rayCloud Editor.
{Recommended) Use the rayCloud Use the Basic Editor before step 1.
Editor after step 1.Initial Processing is Initial Processing or when using non-
done, This allows a fast and precise geolocated images or an arbitrary
paint marking. coordinate system.

rayCloud Editar. .. Basic Editor...
oK Cancel

Edit...

Import GCPs...

Export GCPs...

Add Point

Export Marks...

Help

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table
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https://support.pix4d.com/hc/en-us/articles/202557919

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table

© Previous | Next ©

& Access: On the Menu bar, click Project > GCP/Manual Tie Point Manager..., on GCP/Manual Tie Point Table, click Import / Export Marks...

L GCP/MTP Manager

GCP Coordinate System

f5 Datum: Werld Geodetic System 1984; Coordinate System: WGS 84

GCP/MTP Table
Label Type Latitude Longitude  Altitude Accuracy  Accuracy
[degreel [degreel [m] Horz [m] Vert [m]
8 9001 3D GCP 4665644157  £.53589498 573325 0.020 0.020
4 9002 3D GCP 4665608879 6.53511384  568.726 0.020 0.020
9 9004 3D GCP 4665483476 6.53314731  565.609 0.020 0.020
19 9011 3D GCP 4665537950  6.54370083 473329 0.020 0.020
24 9012 3D GCP 4665325332 6.54184116  460.896 0.020 0.020
12 9016 3D GCP 4665305217  6.53069890 435266 0.020 0.020
25 9017 3D GCP 4665364415  6.54260020 465026 0.020 0.020 y

77 GCPs with enough image marks

GCP/MTP Editor

(Recommended) Use the rayCloud
Editor after step 1.Initial Processing is
done, This allows a fast and precise
paint marking.

rayCloud Editor. ..

In order to compute the 30 position of a GCP/MTF, it needs to be marked on at least two images.
In order to take GCPs into account for georeferencing the project, at least 3 GCPs need to be marked.
Marking GCPs/MTPs after step 1. Initial Processing reguires the user to run Process = Reoptimize,
The GCPs/MTP accuracy can be verified in the Quality Report or in the rayCloud Editor.

Use the Basic Editor before step 1.

Import GCPs...

Export GCPs...

Add Point

Remove Points

Import Marks. .. | |Export Marks. ..

Initial Processing or when using non-

geolocated images or an arbitrary

coordinate system.

Basic Editor...

OK

Cancel

Help

X

Import Marks...

Pix4Dmapper can import a file with the image coordinates of the GCPs / Manual Tie Points. For more information about the file format: 202558539.

A Waming: The zoom level at which GCPs / Manual Tie Points are marked has an impact on the GCP / Manual Tie Point error obtained in the Quality
Report. Usually the higher the zoom lewel, the more precisely the GCP / Manual Tie Point is marked. These GCPs / Manual Tie Points will have a
bigger impact on the reconstructed model than GCPs / Manual Tie Points marked on a lower zoom level; lower error values are also expected for these
GCPs / Manual Tie Points. For example, when GCPs / Manual Tie Points are marked without zooming into the images, the GCP / Manual Tie Point error

can be 10 times higher than when the GCPs / Manual Tie Points are marked by zooming into the images.

When clicking Import Marks..., the Select Import Image Mark's File pop-up appears:


https://support.pix4d.com/hc/en-us/articles/202558539

. Select Image Marks File

« e

Organise = Mew folder

7 Quick access Name

PidDmapper
@ OneDrive i
g This PC
:_" Metwork

*& Homegroup

<

=

Search & 2

=~ ™ @

File name:

- | |t files (bt ".esv) v/

Open | | Cancel |

Navigation menu, to select the location to store the file.

On File name, type the name of the file.

The Save as type displays the file format used to sawe the file:

Pix4D marks files (*.txt, *.csv): 202558539.
Bingo text file (*.txt): 202558539.

XML structure (*.xml): 202558539.

Sawe: Saws the file.

Cancel: Does not sawe the file and exits the pop-up.

Export Marks

Once the GCPs / Manual Tie Points are marked on the images, Pix4Dmapper can export the image coordinates of the GCPs / Manual Tie Points. This
option allows the user to use the same GCPs / Manual Tie Points with the same images the next time the project has to be processed (e.g. merging with another
project, adding new images to the current project) without having to manually mark the GCPs / Manual Tie Points again.

A Waming: The zoom lewel at which GCPs / Manual Tie Points are marked has an impact on the GCP / Manual Tie Point error obtained in the Quality
Report. Usually the higher the zoom lewel, the more precisely the GCP / Manual Tie Point is marked. These GCPs / Manual Tie Points will have a
bigger impact on the reconstructed model than GCPs marked on a lower zoom lewel; lower error values are also expected for these GCPs / Manual Tie
Points. For example, when GCPs / Manual Tie Points are marked without zooming into the images, the GCP / Manual Tie Point error can be 10 times
higher than when the GCPs / Manual Tie Points are marked by zooming into the images.

When clicking Export Marks..., the Export Image Marks pop-up appears:


https://support.pix4d.com/hc/en-us/articles/202558539
https://support.pix4d.com/hc/en-us/articles/202558539
https://support.pix4d.com/hc/en-us/articles/202558539

. Export Image Marks

« v | S:\PixdDmapper ~| @& | Search PixdDmapper

Organise = Mew folder f== =

[ This PC (el MName Date modified Type Size

[ Desktop mining_guarry 03/03/2016 14:56 File folder
Documents
4 Downloads
) Music
[&=] Pictures
B Videos
s O5(C)
Data (D)

-

== Projects_for_Dar
:_" Metwork
o Hom egroup

v £

File name: | image_marks

Save as type: | PixdD marks files (*.bdt *.csv)

» Hide Folders Save | | Cancel

Navigation menu, to select the location to store the file.

On File name, type the name of the file.

The Save as type displays the file format used to sawe the file:

Pix4D marks files (*.txt, *.csv): 202558539.

Bingo text file (*.txt): 202558539.

XML structure (*.xml): 202558539.

When Pix4D marks files is selected, the Pix4D Marks File Options pop-up appears:

. PixdD Marks File Options ? *

Optional Data Data Separator

[ Marks' Zoom Level

[] 1mage Directory

[oc ]| concel |

Marks's Zoom Level check box: Exports the zoom level at which the GCPs / Manual Tie Points are marked on the images.

Image Directory check box: Exports the directory of the images.

Data Seperator. Sets the character used to separate the values in the file. The drop down list has the following options:
Comma (default)

Semicolon

Tab

Space

Sawe: Sawes the file.

Cancel: Does not sawe the file and exits the pop-up.

For step by step instructions about how to export the marks of the GCPs / Manual Tie Points: 204924709.

Index > Interface > Menu Project > GCP/MTP Manager... > GCP/MTP Table
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https://support.pix4d.com/hc/en-us/articles/202558539
https://support.pix4d.com/hc/en-us/articles/202558539
https://support.pix4d.com/hc/en-us/articles/202558539
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Index > Interface > Menu Project > GCP/MTP Manager...

& Access: On the Menu bar, click Project > GCP/MTP Manager...

© Previous | Next ©

. GCP/MTP Manager

GCP Coordinate System

f5 Datum: Werld Geodetic System 1984; Coordinate System: WGS 84

GCP/MTP Table
N Latitude Longitude Altitude Accuracy Accuracy  *
Label Type [degree]  [degreel ml Horzlml  Vert[m]

8 900 D GCP 46.65644157 £.535804403 573.325 0.020 0.020

4 9002 D GCP 46.65608379 £.53511384 568.726 0.020 0.020

9 0004 3D GCP 46.65483476 £.53314731 565.699 0.020 0.020

19 9011 3D GCP 46,6553 7950 £.54370093 473.329 0.020 0.020

24 9012 3D GCP 4665325332 654184116 460.896 0.020 0.020

12 9076 3D GCP 46.65305217 £.53969850 455.266 0.020 0.020

25 9017 3D GCP 46.65364415 £.54260020 465.026 0.020 0.020 e
77 GCPs with enough image marks Import Marks. ..
GCP/MTP Editor
In order to compute the 30 position of a GCP/MTF, it needs to be marked on at least two images.
In order to take GCPs into account for georeferencing the project, at least 3 GCPs need to be marked.
Marking GCPs/MTPs after step 1. Initial Processing reguires the user to run Process = Reoptimize,
The GCPs/MTP accuracy can be verified in the Quality Report or in the rayCloud Editor.
(Recommended) Use the rayCloud Use the Basic Editor before step 1.
Editor after step 1.Initial Processing is Initial Processing or when using non-
done, This allows a fast and precise geolocated images or an arbitrary
paint marking. coordinate system.

rayCloud Editor. .. Basic Editor. ..
oK Cancel

Import GCPs...

Export GCPs...

Add Point

Remove Points

Export Marks...

Help

Allows the user to mark/edit the GCPs/Manual Tie Points/Check Points in the initial images. There are 2 options:

rayCloud Editor...: Available only if step 1. Initial Processing has been completed. It opens the left sidebar of the rayCloud.
Basic Editor...: Available even if no processing step has been completed. It opens the Basic GCP/Manual Tie Points Editor.

Index > Interface > Menu Project > GCP/MTP Manager...
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Index > Interface > Menu Project
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Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic

Editor...

The Basic GCP/MTP Editor pop-up has the following 3 sections:

GCP/MTP Table: Section that allows the user to edit the GCPs/Manual Tie Points/Check Points values and status.
Images: A list with all the images.
Preview: Section where the GCPs / Manual Tie Points / Check Points are marked on the image.

And the action buttons:

GCP/MTP Manager: Closes the Basic GCP / Manual Tie Point Editor and goes back to the GCP/Manual Tie Point Manager.
OK: Confirms the changes.

Cancel: Does not save the changes and exits the pop-up.

Help: Opens the Pix4Dmapper help.

[ Basic GCP/MTP Editor

GCPMTP Table (WGS84)
o Latitude Longitude Altitude Accuracy Accuracy S
atact L [degree] [degreel [m] Horz [m] Vert [m]
8 9001 3D GCP 46.65644157 6.53589493 373.325 0.020 0.020
4 9002 3D GCP 46.65698379 653511384 368.726 0.020 0.020
9 9004 3D GCP 46.65483476 6.53314731 565.699 0.020 0.020
19 901 3D GCP 46.65537950 6.54370093 473.329 0.020 0.020
24 9012 3D GCP 46.65325332 6.54184116 460.896 0.020 0.020
12 9016 3D GCP 46.65305217 6.53969890 455.266 0.020 0.020
25 | 907 3D GCP 46.65364415 6.54260020 465,026 0.020 0.020 »
Images Preview
o @) =
IMG_1155JPG A al [=7] [
IMG_1154.JPG B
IMG_1158JPG et
IMG_1158JPG
IMG_1178JPG
IMG_1160JPG =
IMG_1179JPG 5
IMG_1156.PG =
IMG_1153.JPG .
IMG_1185JPG -
IMG_1177.JPG
IMG_1184.JPG
IMG_1186.JPG .,
< > ]
GCP/MTP Manager Cancel Help

Index > Interface > Menu Project
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Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic
Editor...

This section allows the user to view the GCPs/Manual Tie Points/Check Points, values and status.

I Basic GCP/MTP Editor >
GCP/MTP Table (WG534)
A - Latitude Longitude Altitude Accuracy Accuracy
[degreel [degreel [m] Horz [m] Vert [m]
8 9001 3D GCP 4665644157 £.53589498 573.325 0.020 0.020
4 9002 3D GCP 4665698879 £.53511384 568.726 0.020 0.020
9 9004 3D GCP 46,65483476 £.53314731 565.699 0.020 0.020
19 9011 30 GCP 4665537950 6.54370093 473.329 0.020 0.020
24 9012 30 GCP 4665325332 6.54184116 460.896 0.020 0.020
12 9016 30 GCP 46.65305217 6.53969890 455.266 0.020 0.020
25 9017 D GCP 46.65364415 6.54260020 465.026 0.020 0.020 9
Images Preview
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IMG_1155JPG ~
IMG_1154JPG
IMG_1159.JPG
IMG_1158.JPG
IMG_1178JPG
IMG_1160JPG
IMG_1179JPG
IMG_1156.JPG
IMG_1153.JPG
IMG_1183.JPG
IMG_1177.JPG
IMG_1184.JPG
IMG_1186.JPG ,
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GCP/MTF Manager Help

Next to the section title GCP/MTP Table, the coordinate system of the GCPs is displayed.

This section contains a Ground Control Points Table which displays all the GCPs of the projects together with their properties.

Index > Interface > Menu Project > Basic GCP/Manual Tie Point Editor © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202557919
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Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic
Editor...

This section displays a list of all the project images.
For each selected point on the GCP/MTP Table section, the Images section shows with:

Green color: The images on which the point has been marked.
Black color: The images on which the point has not been marked.

L Basic GCP/MTP Editor

GCP/MTP Table (WG584)

~

Label Type T

[degreel
8 900 3D GCP 4665644157

4 9002 3D GCP 4665698379
9 o004 3D GCP 4665483476
19 9011 3D GCP 46,65537930
24 902 3D GCP 46,65325332
12 9016 3D GCP 46.65305217

25 9M7 3D GCP 4665364415

Images Preview

2 [H] el

IMG_1155JPG ~
IMG_1154JPG
IMG_1158JPG
IMG_1158JPG
IMG_1178JPG
IMG_1160.JPG
IMG_1179.JPG
IMG_1156.JPG
IMG_1153.JPG
IMG_1183.JPG
IMG_1177.JPG
IMG_1184.JPG
IMG_1186.JPG .,

The images can be sorted according to three different criteria by clicking on the corresponding buttons:

A Sort Images by Name.
_;_l Sort Images by the Distance to GCP.
@l Sort Images by the Distance to the Marked Images.

There is one context menu for the Images section that can be accessed by right clicking on one image. The context menu gives access to the following action:

Remowe Mark: Deletes the marked point that appears on this image.

Sort Images by Name

The images are sorted alphabetically by name.

Sort Images by the Distance to GCP

The images are sorted by distance to the GCP (closest image to the GCP is displayed first). This sorting is selected by default when 2D GCPs, 3D GCPs or



Check points have been imported into the project. This sorting is recommended to easily find images on which GCPs or Check points may appear.

[[l] Note: Non geolocated images are displayed at the bottom of the list.

Sort Images by the Distance to the Marked Images

The images are sorted by distance to the marked images (closest image to the marked images is displayed first). This sorting is recommended to easily find
images on which Manual Tie Points appear. It can be used after having marked the Manual Tie Point on at least one image.

@ Note: Non geolocated images are displayed at the bottom of the list.

Index > Interface > Menu Project > Basic GCP/Manual Tie Point Editor © Previous | Next ©



Index > Interface > Menu Project > Basic GCP/Manual Tie Point Editor

Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic

Editor...

This section is used to mark the GCPs/Manual Tie Points/Check Points on the images.

@ Important: Each point needs to be marked on at least 2 images to be taken into account in processing. It is recommended to mark each point in at least

4-5 images.

@ Important: The zoom level at which GCPs are marked has an impact on the GCP error obtained in the Quality Report. Usually the higher the zoom lewel,
the more precisely the GCP is marked. These GCPs will have more impact on the reconstructed model than GCPs marked in a lower zoom level and
lower error values are expected for those GCPs. For example, when GCPs are marked without zooming into the images, the GCP error can be 10 times

higher than when GCPs are marked by zooming into the images.

[ Basic GCP/MTP Editor

GCPMTP Table (WE584)

=

Label Tige: Latitude Longitude Altitude Accuracy

[degree] [degreel [m] Horz [m]
8 9001 3D GCP 4665644157 6.53589498 573.325 0.020

4 9002 3D GCP 4665698379 653511384 568.726 0.020
9 9004 3D GCP 4665483476 653314731 565.699 0.020
19 9011 3D GCP 46.,65537930 654370093 473.329 0.020
24 92 3D GCP 46,65325332 654184116 460.896 0.020
12 906 3D GCP 46.65305217 6.53969890 455.266 0.020

25 9M7 3D GCP 4665364415 6.54260020 465.026 0.020

Accuracy
Vert [m]

0.020
0.020
0.020
0.020
0.020
0.020

0.020

Images Preview
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IMG_1160.PG
IMG_1179.PG
IMG_1156.JPG
IMG_1153.JPG
IMG_1183.JPG
IMG_1177.JPG
IMG_1184.JPG
IMG_1186.JPG .,

£ >

GCP/MTP Manager

Help

When the Basic GCP/MTP Editor is opened the first time, no image is displayed in the Preview section. Once points are imported from a file or once a new point

has been added, the first image is displayed in the Preview section.
The following actions are available:

Zoom in: Move the mouse scroll wheel forwards.

Zoom out: Mowe the mouse scroll wheel backwards.

Pan: Press the left mouse button and mowve the mouse.

Zoom in quickly to a specific point: With the mouse click on the point of interest and press the Alt key.
Zoom out instantly to zero zoom lewel: Press the Shift key.

Mark a point: Left click on the point on the image.

© Previous | Next ©




In the right part of the Preview section there is a control panel to navigate in the image:

e Left arrow button: Mowes to the left part of the image (when the image is zoomed in).

Sy Right arrow button: Moves to the right part of the image (when the image is zoomed in).
¢~ Up arrow button: Moves to the top part of the image (when the image is zoomed in).

g Down arrow button: Moves to the bottom part of the image (when the image is zoomed in).
m2 Reset view button: Zooms out to zero zoom level.

(@, Zoom in button: Zooms in.

Zoom slider: Zooms in or out.

In: Mowe the slider up.

Out: Mowe the slider down.

(5, Zoom out button: Zooms out.

Remowe button: Removes the marked point (if any) from the image displayed in the Preview section. If there is no mark in the image displayed in the Preview

=
[}

section, the Remowe button is grayed out.

Index > Interface > Menu Project > Basic GCP/Manual Tie Point Editor © Previous | Next ©
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& Access: On the Menu bar, click Project > Select Output Coordinate System...

@ Important: The output coordinate system does not need to be the same as the image geolocation coordinate system or the GCPs coordinate system.
By default, the output coordinate system is the same as the GCPs coordinate system if GCPs are used, otherwise it is the same as the image
geolocation coordinate system. If the coordinates system is WGS84, the output is given in the corresponding UTM zone.

If less than 3 images are geolocated and less than 3 GCPs are defined, then the output coordinates system is set to "Arbitrary".

The Select Output Coordinate System pop-up allows the user to choose the coordinate system of the outputs.

[ Select Qutput Coordinate System *

Selected Coordinate System

Datum: World Geodetic System 1984
7 Coordinate System: WGES 84/ UTM zone 32M

Coordinate System Definition

Unit: m v |

() Arbitrary Coordinate System [m]

() Auto Detected:  WGS84 / UTM zone 38M

(®) Known Coordinate System [m]

Q [wasa4 /UM zane 22n

[] Advanced Coordinate Options

QK || Cancel || Help |

For a full description of the Select Output Coordinate System pop-up: 202558239.

Index > Interface > Menu Project © Previous | Next O
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Index > Interface © Previous | Next ©

& Access: On the Menu bar, click Process.

There are 16 items that can be selected:

Reoptimize: Reoptimizes the camera positions using information from GCPs/ Manual tie points that are added after step.1 Initial Processing.

Rematch and Optimize: Computes more matches between the images (and therefore more Automatic Tie Points) and reoptimizes the intemal and external
camera parameters.

Quality Report...: Opens the Quality Report in a new window.

Open Results Folder...: Opens an explorer window with the path where the project outputs are stored.

Show Output Status...: Shows the status of the output files generated.

Generate Quality Report: Generates a new Quality Report that refers to the new reconstruction obtained after applying changes to the project after step.1 Initial
Processing.

Sawe Undistorted Images: Generates and saves an undistorted copy of each original image using the optimized distortion camera parameters.

Run Terrain/Object Point Cloud Classification (beta): Generates a Terrain point cloud and an Objects Point Cloud.

Generate 3D Textured Mesh: Generates a 3D Textured Mesh based on triangles using a a simplified Densified Point Cloud.

Generate DTM (beta): Generates a DTM using the points from the Terrain point group.

Import Point Cloud for DSM Generation...: Allows the user to import a point cloud that will be used to generate the DSM and orthomosaic.

Generate Google Maps, KML and Mapbox Tiles: Generates Google Maps tiles, Google Earth KML file and Mapbox tiles for the orthomosaic.

Generate Contour Lines: Generates the contour lines specified in the Processing Options using the raster DSM.

Send Elevation Data (DSM) to eMotion: (only if senseFly eMotion is installed) Sends a DSM generated in Pix4Dmapper to eMotion.

Send Map to eMotion: (only if senseFly eMotion is installed) Sends an Orthomosaic generated in Pix4Dmapper to eMotion.

Processing Options...: Opens a pop-up that allows the user to select the processing options and/or the processing options template.

I PidDmapper Pro - mining_guarry
Project | Process  View Map View Help

I Reoptimize
pm” E  Rematch and Optimize

|
[5  Quality Report...
G

7= Open Results Folder...

Welcome
[ E Qutput Status...
Map Vie Generate Quality Report
I/_, Save Undistorted Images
Run Terrain/Object Point Cloud Classification (Beta)
rayCloud
— Generate 30 Textured Mesh
@ Generate DTM (Beta)
nl;;st:rc Import Point Cloud for DSM Generation...
[— Generate Google Maps, KML and Mapbox Tiles
T=
X2 Generate Contour Lines
Index

Calculator Send Elevation Data (DSM) to eMotion
Send Map to eMotion

{} Processing Options...

Index > Interface © Previous | Next ©
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& Access: On the Menu bar, click Process > Reoptimize (enabled once step 1. Initial Processing has been completed).

[ PidDmapper Pro - mining_quarry

Project = Process  View  Map View Help
I Reoptimize

1 Rematch and Optimize

[%  Quality Report...

= Open Results Folder...

[E  OQutput Status...

Generate Quality Report

Save Undistorted Images

Run Terrain/Object Point Cloud Classification (Beta)
Generate 30 Textured Mesh

Generate DTM (Beta)

Import Point Cloud for DSM Generation...

Generate Google Maps, KML and Mapbox Tiles

Generate Contour Lines

Send Elevation Data (DSM) to eMotion
Send Map to eMotion

{3} Processing Options...

This process reoptimizes the intemal and exterrnal camera parameters. It should be used when changes have been applied to the project after step 1. Initial
Processing has been completed. Such changes can be:

Adding GCPs.

Adding Manual Tie points.
Adding Check points.
Changing coordinate systems.
Disable images.

@ Important: Disabled or uncalibrated ameras will not be taken into account. In order to calibrate uncalibrated cameras: 202560189.

A Waming:

Results generated during step 1. Initial Processing are overwritten.

The Quality Report is deleted. To generate a new Quality Report: 202558319.

If step 2. Point Cloud and Mesh and step 3. DSM, Orthomosaic and Index have been done as well, their results are remowved. These results need to be
saved by the user in order not to lose them.

Index > Interface > Menu Process © Previous | Next ©
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& Access: On the Menu bar, click Process > Rematch and Optimize (enabled once step 1. Initial Processing has been completed).

.| PixdDmapper Pro - mining_quarry

Project = Process  View  Map View Help
I Reoptimize

©  Rematch and Optimize

[%  Quality Report...

7 Open Results Folder..,

[E  OQutput Status...

Generate Quality Report

Save Undistorted Images

Run Terrain/Object Point Cloud Classification (Beta)
Generate 30 Textured Mesh

Generate DTM (Beta)

Import Point Cloud for DSM Generation...

Generate Google Maps, KML and Mapbox Tiles

Generate Contour Lines

Send Elevation Data (DSM) to eMotion
Send Map to eMotion

{3} Processing Options...

This process computes more matches between the images (and therefore more Automatic Tie Points) and reoptimizes the intemal and extemal camera
parameters. It is recommend to use it:

After manually calibrating cameras that were not initially calibrated.

For difficult projects where few matches were initially found.

To merge individual projects that do not share common images.

To optimize the step 1. Initial Processing by re-matching images. For projects with more than 500 images, this process is unselected and disabled in the
processing options.

[m Note: For large projects (more than 500 images), the Rematch and Optimize feature significantly increases processing time.

@ Important: Disabled or uncalibrated ameras will not be taken into account. In order to calibrate uncalibrated cameras: 202560189.

A Warming:

Results generated during step 1. Initial Processing are overwritten.

The Quality Report is deleted. To generate a new Quality Report: 202558319.

If step 2. Point Cloud and Mesh and step 3. DSM, Orthomosaic and Index have been done as well, their results are removed. These results need to be
saved by the user in order not to lose them.

Index > Interface > Menu Process © Previous | Next ©
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Access: On the Menu bar, click Process > Quality Report... (active once step 1. Initial Processing has been completed). The Quality Report opens in a

pop-up window.

Important:

For a detailed description about how to analyze the Quality Report: 202558689.

For a detailed description about the parameters described in the Quality Report: 202558679.
For a description about how to analyze the Quality Report: 202557339.

Example of a Quality Report available at the following link: Quality Report.

P
Il

I Quality Report

o & D

Quality Report >

X

EJ Online Support
~

[]

@ Important: Click on the different icons for:

@ Help to analyze the results in the Quality Report

o Additional information about the sections

@ Click here for additional tips to analyze the Quality Report

Summary i ]
Project mining_quarry
Processed 2016-03-10 16:12:00
Average Ground Sampling Distance (GSD) 8.82cm /347 in
Area Covered 0.5854 km2/ 58.5352 ha [ 0.2261 5q. mi. / 144.719 acres
Time for Initial Processing (without report) 23m:21s
Quality Check i ]
@ Images median of 35853 keypoints perimage Q
@ Dataset 127 out of 127 images calibrated (100%), all images enabled °
@ Camera Optimization 0.4% relative difference between initial and optimized internal camera parameters Q
@ Matching median of 13868.7 matches per calibrated image °
@) Georeferencing yes, 7 GCPs (7 30), mean RMS error = 0.046 m iy
@ Preview 0

Generated with non version 2.1.38

M 7

Display Automatically after Processing

Index > Interface > Menu Process
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https://support.pix4d.com/hc/en-us/articles/example_quarry_report.pdf

Index > Interface > Menu Process

& Access: On the Menu bar, click Process > Open Results Folder... The Results Folder in a new window.

@ mportant:
For a detailed description of the folder structure: 20255864.

For more information about the output files: 202558509.

Home Share Wiew

T | S\mining_guarry w | @
#F Quick access L Name
. 1_initial
¢@ OneDrive
2_densification
&3 This PC 3_dsm_ortho
4_index
:_" MNetwork -

mining_guarry.log
s Homegroup

5 items

Search

o =
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Index > Interface > Menu Process

& Access: On the Menu bar, click Process > Output Status

.... The QOutput Status pop-up appears.

[ PidDmapper Pro - mining_quarry

Project = Process  View Map View Help

Reoptimize

Rematch and Optimize
Quality Report...

Open Results Folder...
Output Status...

Generate Quality Report

Save Undistorted Images

Run Terrain/Object Point Cloud Classification (Beta)
Generate 30 Textured Mesh

Generate DTM (Beta)

Import Point Cloud for DSM Generation...

Generate Google Maps, KML and Mapbox Tiles

Generate Contour Lines

Send Elevation Data (DSM) to eMotion
Send Map to eMoticn

{3} Processing Options...

The Output Status pop-up displays:

The Processing Step that is being processed.
The Processing Steps that have already been processed.

The Processing Steps that cannot be processed with the current version of Pix4Dmapper. For more information: 204162839.

The Output Files that are selected to be generated.
The Output File that is being generated.
The Qutput Files that have already been generated.

The Output Files that can be generated with the current version of Pix4Dmapper. For more information: 204162839.

The formats of the Output Files selected to be generated.
The dependencies between the Output Files.
Information and links to the Processing Options and the Results Folders about the Output Files.

The Output Status pop-up consists of:

Processing Steps

Output Files

Display Options

Processing steps

© Previous | Next ©

The three Processing Steps, 1. Initial Processing, 2. Point Cloud and Mesh and 3. DSM, Orthomosaic and Index appear in the Output Status pop-up.


https://support.pix4d.com/hc/en-us/articles/204162839
https://support.pix4d.com/hc/en-us/articles/204162839

[ Output Status ? X

@ > Initial Processing > @ > Point Cloud and Mesh > @ > DSM, Orthomosaic and Index >

Advanced Close Help

The Processing Steps can be:

Transparent: If the Processing Step is not processed yet.

Orange: If the Processing Step is being processed.

Green: If the Processing Step is already processed.

Grayed out: If the Processing Step is not available in the current version of Pix4Dmapper. For more information: 204162839.

e D Smare | | @ ST

Processing  Processing Processing Processing
Step not Step being Step Step grayed
processed yet. processed. processed. out.

Important: When no Output Files are selected for step 3. DSM, Orthomosaic and Index, step 3. DSM, Orthomosaic and Index is grayed out and cannot
be processed.

Output Files
The Qutput Files can be:

White: If the Output File is not generated yet.

Orange: If the Output File is being generated.

Green: If the Output File is already generated.

Grayed out: If the Output File is not selected to be generated or the Output File is not available in the current version of Pix4Dmapper. For more
information: 204162839.

£ Output Status I Output Ststus L Output Status L Output Status
@ Initial Processing @ Initial Processing ()> . _ @ Initial Processing
[Quam Report - } I Quality Report v l [ Quaity Report v ] [Quahty Report N ]
[Camera Intemnals and Externals, AAT, BBA n W I Camera Internais and Externals, AAT, BBA v ] Camera Internals and Externals, AAT, B3A v l [Camera Internals and Externals, AAT, BBA N ]
[Ur\dwsmntd tmages R } |Ilmhsturled1mius ¢ I Undistrted Images \/]
Output File selected to Output File being Output File being Output File not selected to
be generated. generated. generated. be generated.

For each Processing Step, the following Output Files are displayed:
1. Initial Processing:

Quality Report


https://support.pix4d.com/hc/en-us/articles/204162839
https://support.pix4d.com/hc/en-us/articles/204162839

Camera Intemals and Extemals, AAT, BBA
Undistorted Images

L[ﬂ Note: The Camera Intemals and Extemals, AAT and BBA and the Undistorted Images are displayed only when the Advanced box is selected.

2. Point Cloud and Mesh:

Densified Point Cloud
3D Textured Mesh

3. DSM, Orthomosaic and Index:

Grid DSM
Raster DSM
Contour Lines
Orthomosaic
Google Maps Tiles and KML
Mapbox Tiles
Reflectance Map
Index Map
| Output Status ? >
@ > Initial Processing > @ > Point Cloud and Mesh > @ > DSM, Orthomosaic and Index>
[Qualit}-I Report - ] [Densiﬁed Point Cloud: LAS, LAZ, PLY, XYZ - ] Grid DSM: XYZ, LAS, LAZ - ]
Camera Internals and Externals, AAT, BEA - ] 3D Textured Mesh: OBJ - ] [Raster DsM - ]
Undistorted Images - ] | [Contour Lines: SHF, PDF, AutoCAD DXF - ]
Orthomesaic - ]
| [Google Maps Tiles and KML - ]
| Mapbox Tiles - ]
[Reﬂecianoe Map - ]
| [Index Map - ]
Display Options ¥ Advanced Help

In each Output File box, the different output file formats selected for the Output File are displayed.

f Example: For the Densified Point Cloud, the las, laz, ply and xyz file formats are selected.

@ > Point Cloud and Mesh >

Densified Point Cloud: LAS, LAZ, PLY, XYZ _ |

3D Textured Mesh: OBJ _ ]

Some Output Files are indented and connected to other Output Files with armrows. These arrows represent the dependencies between the different Output Files. If
the initial Output File is not selected, the depended one cannot be generated and it is grayed out.



ﬁ Example: The Google Maps Tiles and KML depends on the Orthomosaic to be generated.

@ > DSM, Orthomosaic and Index>

Grid DSM: XYZ, LAS, LAZ

Raster DSM -
I—' Contour Lines: SHP, PDF, AutoCAD DXxF -
Orthomosaic _
I—' Google Maps Tiles and KML _

I—' [Mapbox Tiles _ ]

[Reﬂedﬁnce Map _ ]

I—' [Index Map - ]

Clicking an Output File box, the box is extended. The extended box contains:

A description of the Output File.
A link to the Processing Options of this Output File.
A link to the Results Folder directory of the Output File.

@ Point Cloud and Mesh @ Point Cloud and Mesh @ Point Cloud and Mesh

Densified Point Cloud: LAS, LAZ, Densified Point Cloud: LAS, LAZ, Densified Point Cloud: LAS, LAZ,
PLY, XYZ PLY, XYZ PLY, XYZ

o] o] <
A 3D dense point doud (. a 3D set of paints): the X,Y,2 position A 3D dense point doud (. a 30 set of paints): th i . a 3 set of points): th
and for each point o the pont doud, and stored for each poin of the point dou. and for each poi

i
t dou.

For more information: 202559069 For more information: 202559069 For more information: 202559068

Descriotion of the Open the Processing Open the Results
b Options for this Output Folder for this Output
Output File. File File

Display Options
The Display Options drop down list selects the Output Files to be displayed. The Display Option can be:

Disabled: The Output Files not selected or not available in the current version of Pix4Dmapper are displayed.
To do: The Output Files selected to be generated are displayed.

In Progress: The Output Files being generated are displayed.

Done: The Output Files already generated are displayed.

If the Advanced box is selected, the Advanced Output Files are visualized. If the Advanced box is not selected, the Advanced Output Files are not visualized.

And the action buttons:

Close: Closes the Output Status pop-up.
Help: Opens the Pix4Dmapper help.
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& Access: On the Menu bar, click Process > Generate Quality Report (enabled once step 1. Initial Processing has been completed).
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{3} Processing Options...

This process generates a new Quality Report that refers to the new reconstruction obtained after applying changes to the project once step 1. Initial
Processing has been completed. Such changes can be:

Adding GCPs.

Adding Manual Tie points.

Adding Check points.

Changing coordinate systems.
Enabling/disabling images.

Running the Rematch and Optimize option.

@ Important: When adding GCPs, Manual Tie points, Check points, changing coordinate systems or enabling/disabling images, the Reoptimize option has
to be applied before generating the new Quality Report.
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& Access: On the Menu bar, click Process > Save Undistorted Images (active once step 1. Initial Processing has been completed).
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{3} Processing Options...

This process generates an undistorted copy of each original image using the optimized distortion parameters of the selected camera model.

@ Important:
This process is available only when processing images using a perspective lens camera model.
The undistorted images will only be generated for the calibrated images.

o Information: For more information about the camera distortion: 202559069.

Original image: The square grid is distorted because of the lens of the camera. Undistorted image: The square grid is now perfectly aligned.
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Access: On the Menu bar, click Process > Run Terrain /Object Point Cloud Classification (beta) (active once step 2. Point Cloud and Mesh has been
completed).
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{3} Processing Options...

@ Important: By default, the Terrain / Object Point Cloud Classification is not computed during processing step 2. Point Cloud and Mesh. It is possible to
compute the classification while processing step 2. Point Cloud and Mesh. For step by step instructions: 203186589.

This process computes a Point Cloud Classification using the densified point cloud generated during step 2. Point Cloud and Mesh. The deleted points are not
taken into account. This process classifies each point into Terrain / Objects groups:

Terrain: It consists of terrain points.
Objects: It consists of object points.

It is possible to set up the classification parameters, available on the processing options: 204644369.

For step by step instructions about how to compute the Point cloud Classification: 203186589.

@ Important: It is possible to edit the computed Terrain / Objects classification and move points from one group to another, delete them, mowve them into a
new group, etc. For step by step instructions: 202560499.

@ Note: Once a Terrain point group exist, it is possible to generate a DTM (beta). For step by step instructions: 203204259.
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& Access: On the Menu bar, click Process > Generate 3D Textured Mesh (active once step 2. Point Cloud and Mesh has been completed).

@ Important: The 3D Textured Mesh cannot be generated when selecting Use Semi-Global Global Matching (beta). This option is available on the Menu
bar, by clicking Process > Processing Options..., selecting Processing step 2. Point Cloud and Mesh, and selecting the tab Add-ons. For more
information: 205443205.
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{3} Processing Options...

This process generates a 3D Textured Mesh based on triangles using the Densified Point Cloud.

@ Important: By default, by clicking Process > Generate 3D Textured Mesh, the 3D Textured Mesh will be generated:
In .p4b format, only readable in the rayCloud:
project_name\2_densification\project_data\project_name_3d_mesh.p4b
In .obj format:
project_name\2_densification\3d_mesh\project_name_simplified_3d_mesh.obj

In order not to generate the .obj file and/or generate other outputs (.ply, .fox, .dxf, .obj, zipped .obj, .pdf) before clicking Process > Generate 3D Textured
Mesh, change the processing options and click OK. For more information: 202557799.

For step by step instructions about how to generate the 3D Textured Mesh: 202560669.

@ Important: The 3D Textured Mesh will be generated using the Densified Point Cloud. If any Processing Area and/or image annotation is defined, and if the
corresponding options are selected in the Point Cloud Filters options, they will also be used for the 3D Textured Mesh generation.

These options are available on the Menu bar, by clicking Process > Processing Options... and selecting 2. Point Cloud and Mesh. For more information:
202557799.


https://support.pix4d.com/hc/en-us/articles/202560669

3D Textured Mesh
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Access: On the Menu bar, click Process > Generate DTM (beta) (active once step 2. Point Cloud and Mesh has been completed and the point
group Terrain exists and contains points).

Note: The point group Terrain can be generated automatically by running Run Terrain/Object Point Cloud Classification (beta). For step by step
instructions: 203186589.
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{3} Processing Options...

This process generates a DTM using the points from the Terrain point group.


https://support.pix4d.com/hc/en-us/articles/203186589
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& Access: On the Menu bar, click Process > Import Point Cloud for DSM Generation... (active once step 1. Initial Processing has been completed).
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{3} Processing Options...

This process allows the user to import a point cloud to generate the DSM and the orthomosaic.
Once the point cloud has been imported, step 3. DSM, Orthomosaic and Index has to be started to generate the DSM and the orthomosaic.

It opens the Select Point Cloud pop-up, which allows to navigate to the path where the point cloud to be imported is stored and select it.
The accepted formats are:

Xyz
las
laz

It contains the action buttons:

Open: Confirms the importation of the selected file.
Cancel: Does not import any file and close the pop-up.

A Waming:

The exteral point cloud needs to be in the same coordinate system as the output coordinate system.
If step 3. DSM, Orthomosaic and Index has already been completed for this project, existing results are overwritten when running the step again. The
existing results need to be saved by the user in order not to lose them.

@ mportant:
The imported Point Cloud is not visualized in the rayCloud.

If step 2. Point Cloud and Mesh has been completed, its results are not used for the DSM and Orthomosaic generation.
The imported Point Cloud will be used to generate the DSM.
The original images are projected to the DSM in order to obtain the Orthomosaic.
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Access: On the Menu bar, click Process > Generate Google Maps, KML and Mapbox Tiles (active once step 3. DSM, Orthomosaic and Index has been
completed and if the outputs are selected in the processing options: 206860936).
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{3} Processing Options...

This process generates the Google Maps tiles, KML files and Mapbox tiles for the orthomosaic.

@ mportant:
When images are grouped in more than one group, the Google Maps, KML and Mapbox Tiles will only be generated if one of the groups is

named RGB (in capital letters). Then the Google Maps, KML and Mapbox tiles will be generated only for this group. For more information about the image
groups: 202557949.

The Google Maps, KML and Mapbox tiles are only generated for 3 bands with 8 bit per band images.

The Google Maps, KML and Meapbox tiles will only be generated for projects with georeference (image geolocation and/or GCPs).

For more information about the Google Maps tiles, the KML files and the Mapbox tiles files and how to use them: 202558499.

[Orihomosaic opacity: | [Z0%] [E0%] [700%] | Map | Satwlie



https://support.pix4d.com/hc/en-us/articles/206860936
https://support.pix4d.com/hc/en-us/articles/202558499
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Figure 2: KML
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Access: On the Menu bar, click Process > Generate Contour Lines (active once step 3. DSM, Orthomosaic and Index has been completed and if any
Contour Lines format is selected in the processing options). For step by step instructions: 202560639.
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{3} Processing Options...

This process generates the contour lines using the Raster DSM For more information about contour lines: 202559879.

@ Important: The option to generate the Contour Lines is grayed out if the option to merge the tiles of Raster DSM is disabled. For more information about
the options of the Raster DSM: 202557769.


https://support.pix4d.com/hc/en-us/articles/202560639
https://support.pix4d.com/hc/en-us/articles/202559879

Note:
If contour lines with the same Elevation Interval are already generated, they will be overwritten.
If the Contour Lines processing options have been configured when executing step 3. DSM, Orthomosaic and Index, the Contour Lines will be generated
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Contour lines
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& Access: On the Menu bar, click Process > Send Elevation Data (DSM) to eMotion. Only available when senseFly eMotion is installed on the same

device and step 2. Point Cloud and Mesh is completed.

@ Important:

The DSM sent to eMotion is not the same as the DSM generated during step 3. DSM, Orthomosaic and Index. The resolution of the DSM sent to

eMotion is set to 100 cm.
It is possible to generate the DSM that will be sent to eMotion only if the output coordinate system is not set to arbitrary.

The altitude of the DSM that will be sent to eMotion will refer to the ellipsoid. If the vertical coordinate system is set to a geoid model, a conversion will

take place.
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{3} Processing Options...

When clicking Process > Send Elevation Data (DSM) to eMotion, a pop-up appears:

[ PidDmapper 7 >

DSM resolution [cm]:

[100 E
care

The pop-up sets the DSM resolution for the DSM that is sent to eMotion.
The action buttons:

OK: Generates the DSM that will be sent to eMotion.
Cancel: Cancels the generation of the DSM.
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Access: On the Menu bar, click Process > Send Map to eMotion. Only available when Sensefly eMotion is installed on the same device, step 2. Point
Cloud and Mesh is completed and the Orthomosaic of step 3. DSM, Orthomosaic and Index is generated.

@ Important: It is possible to generate the Map that will be sent to eMotion only if the output coordinate system is not set to arbitrary.
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& Access: On the Menu bar, click Process > Processing Options

[ PidDmapper Pro - mining_quarry
Project = Process  View Map View Help
M Tl Reoptimize
5l @ Rematch and Optimize
O [%  Quality Report...

= Open Results Folder...

[— = Qutput Status...

Generate Quality Report

Map Viey
I}_‘) Save Undistorted Images
Run Terrain/Object Point Cloud Classification (Beta)
rayCloud
— Generate 30 Textured Mesh
@ Generate DTM (Beta)
Mosaic Import Point Cloud for DSM Generation...
Editor
[— Generate Google Maps, KML and Mapbox Tiles
3= Generate Contour Lines
Index
Calculator Send Elevation Data (DSM) to eMotion

Send Map to eMoticn

{3} Processing Options...

This feature allows to:

View/edit the processing options:

Selecting which outputs are generated and in which format.
Assigning hardware resources to the processing.

Select a Processing Options Template.

Create a new Processing Options Template.

Manage Processing Options Templates.

It contains three sections:

Processing steps and resources: Allows the user to select a step or the resources in order to visualize/edit options.

..., the Processing Options pop-up appears.

© Previous | Next ©

Tabs associated to the selected step or resources: Allows the user to visualize/edit the processing options, outputs and/or resources for the selected

step/resources.

Processing Options Template: Allows the user to select a template, save a custom template and manage templates.

And four actions:

OK: Confirms the changes.
Cancel: Does not sawe the changes.
Help: Opens the Pix4Dmapper help.

Advanced options: Displays/hides the advanced options tabs, available for 1. Initial Processing and 2. Point Cloud and Mesh.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 1. Initial Processing. By default, only
the General tab appears. On the bottom left, select the Advanced box to display other tabs.

1. Initial Processing

General

Allows the user to change the processing options and to select what the Quality Report will display. It contains 2 sections:

2. Point Cloud and Mesh

Matching

a

Calibration

Keypoints Image Scale: Allows the user to define the image size used to extract the keypoints.
Quality Report: Allows the user to select what the Quality Report will display.

3. DSM, Orthomosaic and Index

. Processing Options

1. Initial
Processing

2. Point Cloud
and Mezh

Orthomosaic
and Index

%
e
3.D5M,

Rescurces and
- Motifications

Current Options: Mo Template

General Matching Calibration
Keypoints Image Scale
® Ful
O Rapid
(O Custom

Image Scale: |1 (Original image size) -

Quality Report

Generate Orthomosaic Preview in Quality Report

| Load Template ,| | Save Template v| |Manage Templates...

Advanced

Il Cancel

Help

Resources and Notifications



Keypoints Image Scale
Allows the user to define the image size used to extract the keypoints. It is possible to select:

Full: It sets full Image Scale for precise results.

Rapid: It sets a lower Image Scale for fast results.

Custom: Allows the user to select the Image Scale. There are the following options:

Image Scale:
1 (Criginal image size): This is the recommended /mage Scale.
2 (Double image size): For small images (e.g. 640x320 pixels), a scale of 2 (double image size) should be used. More features will be extracted and it will
hawve a positive impact on the accuracy of the resullts.
1/2 (Half image size): For large projects with high overlap, a scale of 1/2 (half image size) can be used to speed up processing. This will, usually, result in a
slightly reduced accuracy as less features will be extracted. This scale is also recommended for blurry or low textured images, as it usually results in better
outputs than the full scale for such images.
1/4 (Quarter image size): For very large projects with high overlap, a scale of 1/4 (quarter image size) can be used to speed up processing. This will, usually,
result in a slightly reduced accuracy as less features will be extracted. This scale is also recommended for very blurry or very low textured images, as it
usually results in better outputs than the full scale for such images.
1/8 (Eighth image size): For very large projects with high overlap, a scale of 1/8 (eighth image size) can be used to speed up processing. This will, usually,
result in a slightly reduced accuracy as less features will be extracted.

Quality Report
Allows the user to select what the Quality Report will display.

Generate Orthomosaic Preview in Quality Report: The Quality Report will display a low resolution DSM and Orthomosaic. To display these elements, the Quality
Report generation takes longer. Disabling this option, the Quality Report generation is faster.

@ Important: The low resolution DSM is generated using the Automatic Tie Points. The low resolution Orthomosaic is generated based on this DSM.
Both outputs are expected to be of low quality and should not be used for further analysis.

Note: When processing images that belong to different groups, all images are processed together, generating only one DSM for the whole project,
but generating one Orthomosaic per group using the images associated to that group. For more information about the image groups: 202557949.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 1. Initial Processing. By default, only
the General tab appears. On the bottom left, select the Advanced box to display the Matching tab.

8 4

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

General Matching Calibration
Allows the user to change the processing options related to the keypoints matching for step 1. Initial Processing. It contains 2 sections:

Matching Image Pairs: Allows the user to select which pairs of images are matched.
Matching Strategy: Allows the user to determine how the images are matched.

. Processing Options bt

General Matching Calibration
1. Initial : :
v . Matching Image Pairs
Processing
(®) Aerial Grid or Corridor
() Free Flight or Terrestrial
. Point Clou ustom
o 2. Paint Cloud O Custo
% and Mesh
Use Capture Time

Number of Neighbaring Images: |2 =

Q 3. DSM, Use Triangulation of Image Geolocation
‘ Orthomosaic
M~ and Index Use Distance
Relative Distance Between Consecutive Images: | 0,00
Use Image Similarity

Rescurces and
4 Motifications Manimum Mumber of Pairs for Each Image Based on Similarity: |1 5

s MTPs

Maximum Mumber of Image Pairs per MTP: |5 =

UUse Time for Multiple Cameras

Matching Strategy

[ use Geometrically Verified Matching

Current Options: Mo Template

| Load Template _| | Save Template ,l |Manage Ternplates...|

Advanced QK I | Cancel | | Help

Matching Image Pairs



Allows the user to select which pairs of images are matched:

Aerial Grid or Corridor: Optimizes the pair matching for Aerial Grid or Corridor flight paths.

Free flight or Terrestrial: Optimizes the pair matching for Free-flight paths or Terrestrial images (for example, taking images around a house or a statue).
Custom (for advanced users): Specific pair matching parameters useful in specific projects. Suggested if one of the above options does not provide the desired
results. It contains the different pair matching parameters:

@ Important: Higher number of matches will increase the processing time and the quality of the results and may generate results in case of low quality
datasets that failed with the default matching options.

Use Capture Time: Matches images considering the time on which they were taken.

Number of Neighboring Images: It allows the user to set how many images (before and after in time) are used for the pair matching.

Use Triangulation of Image Geolocation: Only available if the images have geolocation. It is only useful for aerial flights. The geolocation position of the images is
triangulated. Each image is matched with images with which it is connected by a triangle.

Use Distance: Only available if the images have geolocation. It is useful for oblique or terrestrial projects. Each image is matched with images within a relative
distance.

Relative Distance Between Consecutive Images: It allows the user to set the relative distance.

Example: For Relative Distance Between Consecutive Images = 5 and average distance between consecutive images = 2 m:
Pix4Dmapper will multiple the average distance by 5 (2*5 = 10 m). It will create a sphere with center the image and radius 10 m and will
match this image with all other images included in the sphere.

Use Image Similarity: Uses the image content for pairs matching. Matches the n images with most similar content.

Maximum Number of Pairs for Each Image Based on Similarity: Maximum number of image pairs with similar image content to be matched.

Use MTPs: Images connected via a shared Manual Tie Point will be matched.

Maximum Number of Image Pairs per MTP: Maximum number of image pairs connected by a given MTP.

Use Time for Multiple Cameras: When having multiple flights without geolocation using the same flight plan over the same area, and having different camera
models for each flight, it matches the images from one flight with the ones from the other flight using the time information.

Matching Strategy
Allows the user to determine how the images are matched:

Use Geometrically Verified Matching: Slower but more robust. If not selected, matches are established using only the image content. If selected, the relative
camera positions are also taken into account to discard geometrically unrealistic matches. Useful when many similar features are present throughout the project:
rows of plants in a farming field, window comers on a building's facade, etc.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 1. Initial Processing. By default, only

the General tab appears. On the bottom left, select Advanced to display other tabs.

1. Initial Processing

General

Allows the user to change the processing options and desired outputs for step 1. Initial Processing. It contains 4 sections:

2. Point Cloud and Mesh

Matching

a

3. DSM, Orthomosaic and Index

Calibration

Targeted Number of Keypoints: Allows the user to set up the number of keypoints that is extracted.
Calibration: Allows the user to select how the camera intemal and extemal parameters are optimized.

Rematch: Allows the user to add more matches after the first part of the initial processing.

Export: Allows the user to select outputs.
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Targeted Number of Keypoints
Allows the user to set up the number of keypoints to be extracted.

Automatic (Default): Automatic way to select which keypoints are extracted.
Custom: Allows the user to restrict the number of keypoints.
Number of Keypoints: Maximum number of keypoints to be extracted per image.

Callibration
Allows the user to select how the camera intemal and external parameters are optimized.

The optimization step consists of running the Automatic Aerial Triangulation (AAT), Bundle Block Adjustment (BBA), and camera self-calibration steps multiple
times, till an optimal reconstruction is achieved:

Calibration Method

Standard (default)

Altemative: Optimized for aerial nadir images with accurate geolocation and low texture content and for relatively flat terrain, for example, fields.

Accurate Geolocation and Orientation: Optimized for project with very accurate image geolocation and orientation. This calibration method requires all images to
be geolocated and oriented.

Camera Optimization: This option defines which camera parameters are optimized.

Interal Parameters Optimization: Defines which interal camera parameters of the camera model are optimized.

All (default): Optimizes all the intemal camera parameters. Small cameras such as those used with UAVs, are much more sensitive to temperature or vibrations,
which affects the camera calibration. Therefore, it is recommended to select this option when processing images taken with such cameras.

None: Does not optimize any of the intemal camera parameters. It is recommended when using large cameras that are already calibrated and when these
calibration parameters are used for processing.

Leading: Optimizes the most important intemal camera parameters. This option is useful to process certain cameras such as cameras with a slow rolling shutter
speed.

Perspective lens camera models: The focal length and the first two radial distortion parameters.

Fisheye lens camera models: The polynomial coefficients.

All Prior: Forces the optimal intemal parameters to be close to the initial values. This option is useful for the rare cases in which two different optimal focal length
values are found.

Extemal Parameters Optimization: The position and orientation of the cameras. Defines how the external camera parameters are optimized.

All (default): Optimizes the rotation and position of the camera as well as the linear rolling shutter in case the camera model follows the linear rolling shutter
model.In this case the camera model should be defined accordingly: 202558159.

None: Does not optimize any of the external camera parameters. Only enabled when Accurate Geolocation and Orientation has been selected as Calibration
Method. Only recommended when the camera orientation and position are known and very accurate.

Orientation: Optimizes only the orientation of the cameras. Only enabled when Accurate Geolocation and Orientation has been selected as Calibration

Method. Only recommended when the camera position is known and very accurate but the orientation is not as accurate as the camera position.

@ Note:
The Camera Optimization processing options define which camera parameter are optimized. There are 2 types of camera parameters:

Internal camera parameters: The parameters of the camera model.
External camera parameters: The position and orientation of the cameras.

The optimization procedure starts with some initial values in order to compute the optimized values. The following initial values are used:

Intemal camera parameters: The initial values are extracted from the camera model that has been chosen.
Extemal camera parameters: The initial values are extracted from the Automatic Aerial Triangulation (AAT) during Step 1. Initial Processing or using the
geolocation and IMU when Accurate Geolocation and Orientation has been selected as Calibration Method.

After step 1. Initial Processing has been done, the optimized values for the intemal and extemal parameters are saved to file. For more information about
the output files generated during step 1. Initial Processing. 202558519.

The initial and optimized values for the intemal camera parameters are also displayed in the Quality Report.

Rematch
Allows the user to add more matches after the first part of the initial processing, which usually improves the quality of the reconstruction:

Automatic (Default): Enables rematching only for projects with less than 500 images.
Custom: Allows the user to select if rematch is done or not for the project.
Rematch: Enables the rematch option.

Export

Allows the user to select outputs:


https://support.pix4d.com/hc/en-us/articles/202558519

Camera Intemals and Extemals, AAT, BBA: When this option is selected, the results of the AAT, BBA, and optimized intemal and external camera

parameters are exported.
Undistorted Images: When this option is selected, an undistorted copy of each original image is generated using the optimized distortion parameters of the

selected camera model.
@ Important: This feature is only available when processing images using a perspective lens camera model.

If step 1. Initial Processing has already been done, it is possible to generate undistorted images without running step 1 again. For more
information: 202557929.

0 Information: For more information about the camera distortion: 202559069.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 2. Point Cloud and Mesh. By default,
only the Point Cloud and the 3D Textured Mesh tabs appear. On the bottom left, select the Advanced box to display other tabs.

1. Initial Processing

Point Cloud

4% 7§

2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index

3D Textured Mesh Advanced

Resources and Notifications

Add-ons

Allows the user to change the processing options and desired outputs for the Point Cloud that is generated during step 2. Point Cloud and Mesh. This
step increases the density of 3D points of the 3D model computed in step 1. Initial Processing, which leads to higher accuracy both for the DSM and the
Orthomosaic. This tab contains 2 sections:

Point Cloud Densification: Allows the user to define parameters for the point cloud densification.
Export: Allows the user to select the desired output formats for the densified point cloud.
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Point Cloud Densification
Allows the user to set parameters for the point cloud densification. It contains the following options:

Image Scale: The image scale defines the scale of the image at which additional 3D points are computed. From the drop-down list, it is possible to select:

1/2 (Half image size, Default): Half size images are used to compute additional 3D points. It is the recommended image scale.

1 (Original image size, Slow): The original image size is used to compute additional 3D points. More points are computed than with half image scale, especially in
areas where features can be easily matched (e.g. cities, rocks, etc.). This option may require four times more RAM and processing time than when choosing the
default value 1/2 (half image size), and usually it does not significantly improve the results.

1/4 (Quarter image size, Fast): Quarter size images are used to compute additional 3D points. Less points are computed than with the half image scale.
However, more points are computed in areas with features that cannot easily be matched such as vegetation areas. This scale is recommended for projects with
vegetation.

1/8 (Eighth image size, Tolerant): Eighth size images are used to compute additional 3D points. Less points are computed than with the half or quarter image
scale. However, more points are computed in areas with features that cannot easily be matched such as vegetation areas. This scale is recommended for
projects with vegetation.

Multiscale (default): When this option is activated, additional 3D points are computed on multiple image scales, starting with the chosen scale from the
Image scale drop down list and going to the 1/8 scale (eighth image size, tolerant). For example, if 1/2 (half image size, default) is selected, the
additional 3D points are computed on images with half, quarter, and eighth image size. This is useful for computing additional 3D points in vegetation
areas as well as keeping details in areas without vegetation.

l[ﬂ Note: The Image Scale has an impact on the number of 3D points generated. For more information: 203269885.

Point Density: This parameter defines the density of the densified point cloud. The point density can be chosen from the following options:

Optimal (Default): A 3D point is computed for every (4/ Image Scale) pixel. For example, if the Image Scale is set to 1/2 (half image size), one 3D point is
computed every 4/(0.5) = 8 pixels of the original image. This is the recommended point cloud density.

High (Slow): A 3D point is computed for every Image Scale pixel. The result will be an oversampled Point cloud that requires up to 4 times more processing time
and RAM than optimal density. Usually, this point cloud option does not significantly improve the results.

Low (Fast): A 3D point is computed for every (16//mage Scale) pixel . For example, if the Image Scale is set to 1/2 (half image size), one 3D point is computed
ewery 16/(0.5) = 32 pixels of the original image. The final point cloud is computed up to 4 times faster and uses up to 4 times less RAM than optimal density.

[m Note: The Point Density has an impact on the number of 3D points generated. For more information: 203269885.

Minimum Number of Matches: The minimum number of matches per 3D point represents the minimum number of valid re-projections of this 3D point to the
images. The minimum number of matches per 3D point can be:

3 (default): Each 3D point has to be correctly re-projected in at least 3 images.

2: Each 3D point has to be correctly re-projected in at least 2 images. This option is recommended for projects with small overlap, but it produces a point cloud
with more noise and artifacts.

4: Each 3D point has to be correctly re-projected in at least 4 images. This option reduces the noise and improves the quality of the point cloud, but it might
compute less 3D points in the final point cloud.

5: Each 3D point has to be correctly re-projected in at least 5 images. This option reduces the noise and improves the quality of the point cloud, but it might
compute less 3D points in the final point cloud. It is recommended for oblique imagery projects that have high overlap.

6: Each 3D point has to be correctly re-projected in at least 6 images. This option reduces the noise and improves the quality of the point cloud, but it might
compute less 3D points in the final point cloud. It is recommended for oblique imagery projects that have very high overlap.

Export
Allows the user to select the desired output formats for the Point Cloud.

The following formats can be chosen:

Note: It is possible to select more than one format in order to save the Point Cloud in multiple formats. When no output is selected, only a .p4b file is
generated. It is always generated, but can only be opened in the rayCloud of the Pix4Dmapper.

LAS (default): LIDAR LAS file with XY, Z position and color information for each point of the Point Cloud.

LAZ: Compressed LiDAR LAS file with XY, Z position and color information for each point of the Point Cloud.

PLY: PLY file with X'Y,Z position and color information for each point of the Point Cloud.

XYZ: ASCII text file with the XY,Z and color information for each point of the Point Cloud.

Delimiter: Defines the delimiter character of the file, used to separate the values. The drop down list has the following options:
Space

Tab

Comma

Semicolon

Merge Tiles: If several tiles have been generated, produces a single file with all the points.

For more information about the file formats and the software with which these files can be opened: 202558499.
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& Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 2. Point Cloud and Mesh. By default,
only the Point Cloud and the 3D Textured Mesh tabs appear. On the bottom left, select the Advanced box to display other tabs.
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1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

Point Cloud 3D Textured Mesh Advanced Add-ons

Allows the user to change the processing options and desired outputs for the 3D Textured Mesh of step 2. Point Cloud and Mesh. This tab contains 3 sections:

Generation: Allows the user to select the generation of the 3D Textured Mesh.
Settings: Allows the user to select parameters conceming the generation of the 3D Textured Mesh.
Export: Allows the user to select the desired output formats for the 3D Textured Mesh.
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Generate 3D Textured Mesh: Allows the user to the select whether the 3D textured mesh should be generated.
Settings

Allows the user to select the resolution for the 3D Textured Mesh generation.

@ Important:
The Point Cloud is used to generate a surface composed of triangles. The distance between the mesh and the points of the Point Cloud is optimized to

be minimal, but this means that points of the mesh do not necessarily comespond to points of the point cloud.

Since the mesh is 3D, it is unfolded onto a 2D plane in order to define the resolution (pixel size). Then the 3D position of the pixel is reprojected into the
original images to obtain the color. Blending is used instead of stitching to generate the texture of the 3D Textured Mesh.

The 3D Textured Mesh will be generated using the Point Cloud. If a Processing Area and/or Image Annotations are defined, and if the corresponding
options are selected in the Point Cloud Filters options, they will also be used for the generation of the 3D Textured Mesh.

The available parameters are:

High Resolution: High level of detail. Recommended to maximize the visual aspect of the 3D Textured Mesh. Computing time and size will increase significantly.
Medium Resolution (default): Default option. Recommended setting for most project. Strikes a good balance between size, computing time and level of detail for
the 3D Textured Mesh.

Low Resolution: Lower level of detail leading to faster computing time and lower size. Good compromise for sharing the 3DTextured Mesh.

Custom: Allows the user to select the options for the 3D Textured Mesh generation:

Maximum Octree Depth: To create the 3D Textured Mesh, the project is iteratively subdivided into 8 subregions. These are organized in a tree structure, and this
parameter indicates how many subdivisions should be created. Higher values mean that more regions will be created, hence each region will be small, leading to
higher resolution and higher computing times.

Texture Size [pixels]: Parameter used to define the resolution of the texture of the 3D Textured Mesh, affecting the pixel size.

Decimation Criteria: After the first step in the mesh creation, too many triangles are created and this parameter indicates how the spurious triangles should be
discarded.

Quantitative: Some triangles will be discarded till they reach the desired number:

Maximum Number of Triangles: Number of triangles in the final 3D Textured Mesh.

Qualitative: Some triangles will be discarded trying to maintain the original geometry.

Strategy: Indicates the strategy employed to discard the triangles:

Sensitive: The triangles selected have as priority to maintain the original geometry of the 3D Textured Mesh.

Aggressive: The triangles selected have as priority to maintain a lower number of triangles.

Use Color Balancing for Texture: The Color Balancing algorithm will be used for the generation of the texture of the 3D Texture Mesh. The Color Balancing
algorithm ensures that the texture will be homogeneous.

@ Note: For projects that are not very large, it may be that the resulting number of triangles is lower than the maximum set up in the options. The
maximum will only be reached if the project is large and could create a model with more triangles.

Important: The higher the parameters selected the longer the processing time. Using high definition parameters have more visual impact when zooming in
and \isualizing the model from close. This allows to better identify details in the model.

For step by step instructions about how to generate the 3D Textured Mesh: 202560669.

Export
Allows the user to select the desired output formats for the 3D Textured Mesh.

The following formats can be chosen:

Note: It is possible to select more than one format in order to save the 3D Textured Mesh in multiple formats. When no output is selected, only a .p4b
file is generated. It is always generated but can only be opened in the rayCloud of Pix4Dmapper.

PLY: PLY file with:

XY,Z position for each vertex of the 3D Textured Mesh

Texture information (using a .jpg texture file).

FBX FBXfile with:

XY,Z position for each vertex of the 3D Textured Mesh.

Texture information.

AutoCAD DXF: DXF file with:

XY,Z position for each vertex of the 3D Textured Mesh.

OBJ (default): OBJ file with:

XY,Z position for each vertex of the 3D Textured Mesh.

Texture information (using a .jpg and .mtl texture files).

Tiled Texture: Allows the user to tile the texture file to reduce the size of each individual file.
Zpped OBJ: ZP file containing the OBJ, .jpg and .mitl files.

3D PDF: PDF file containing a 3D model of the 3D Textured Mesh. The texture size of the 3D Textured Mesh that is displayed in the 3D PDF is 20002000 pixels.
Logo: Selects a logo (.jpg or .tif) that will be displayed on the 3D pdf.


https://support.pix4d.com/hc/en-us/articles/202560669

@ Important: The 3D Textured Mesh file is not georeferenced. It has coordinates on a local coordinate system centered around the project.
To visualize the 3D Textured Mesh with georeference: 204606535.

A Warming:

For .ply and .obj format, the texture is generated in a .jpg file, which contains a 2D planar RGB image of the values for each pixel of the triangles that
forms the 3D Textured Mesh.

In order to use the 3D Textured Mesh in other software, use both files, having them in the same folder and without renaming the texture .jpg file.

The .jpg texture file is associated to the .ply / .obj / .p4b generated while generating the attached .jpg file.

If new .ply / .obj / .p4b files are generated, they cannot use a .jpg file generated previously even if it is for the same project and same parameter values.
If having problems \isualizing the 3D textured Mesh in the rayCloud or extemal software due to lack of hardware resources, it is possible to resize the
.jpg file (reducing the same percentage for the width and hight) using any image editor. This requires less memory.

For step by step instructions about how to generate the 3D Textured Mesh: 202560669.

For more information about the file formats and the software with which these files can be opened: 202558499.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 2. Point Cloud and Mesh. By default,
only the Point Cloud and the 3D Textured Mesh tabs appear. On the bottom left, select the Advanced box to display other tabs.
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1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

Point Cloud 3D Textured Mesh Advanced Add-ons

Allows the user to change the advanced processing options for the Point Cloud and the 3D Textured Mesh of step 2. Point Cloud and Mesh. This tab contains 4
sections:

Point Cloud Densification: Allows the user to define parameters for the point cloud densification.

Image Groups: Allows the user to select which image groups are used for different outputs.

Point Cloud Filters: Allows the user to change options conceming the filtering of the point cloud.

Point Cloud Classification (beta): Allows the user to run the Terrain/Object Point Cloud Classification while processing the 2. Point Cloud and Mesh and to set up
the parameters used when computing the Point Cloud Classification. The Point Cloud Classification assigns each point to either the Terrain Point Group or the
Object Point Group. The Terrain Point Group can be used to generate a DTM.

3D Textured Mesh Settings: Allows the user to change options conceming the mesh generation.
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Point Cloud Densification
Allows the user to set parameters for the point cloud densification. It contains the following options:

Matching Windows Size: Size of the grid used to match the densified points in the original images.
7x7 pixels: Faster processing. Suggested when using aerial nadir images.
9x9 pixels: Finds a more accurate position for the densified points in the original images. Suggested when using oblique and / or terrestrial images.

Image Groups
Allows the user to define which image groups are used to generate each of three different outputs: the Point Cloud, the Mesh Geometry and the Mesh Texture.

Useful for projects that consist of images of different band configuration.

j Example: For a project that consists of both RGB and NIR images, the point cloud can be generated based on both the RGB and the NIR images, the
geometry of the Mesh can be computed using only the RGB images and the texture of the Mesh using only the NIR images.

This section consists of 3 fields:

Point Cloud: Image groups used for the Point Cloud generation.
Mesh Geometry: Image groups used for the computation of the geometry of the Mesh.
Mesh Texture: Image groups used for the texture of the Mesh.

Point Cloud Filters
Allows the user to select filters that will be taken into account for the Point Cloud and the 3D Textured Mesh generation. The following options are available:

Use Processing Area: If a Processing Area has been drawn, it will be used to filter the Point Cloud and the 3D Textured Mesh. For more information: 202558439.



Use Annotations: If Image Annotations have been created, they will be used to filter the Point Cloud and the 3D Textured Mesh. For more information and step by
step instructions: 202560549.
Limit Camera Depth Automatically: Prevents the reconstruction of background objects. Useful for oblique/terrestrial projects around objects.

Point Cloud Classification (beta)
Allows the user to run the Terrain/Object Point Cloud Classification and to set up the parameters used when computing the Point Cloud Classification.

The Point Cloud Classification classifies each point into either the Terrain or Objects point group. It uses all the points of the Point Cloud but not the points
assigned to the Deleted point group.

Terrain point group: It consists of points considered to be terrain points. It can be used to generate a DTM.
Objects point group: It consists of points considered to be object points.

Note:
lm During Point Cloud Classification a first process classifies the Point Cloud, generating a Terrain point group and an Objects point group.
During a second step, the Point Cloud Classification uses the user defined geometric constraints (parameters) to validate if the points of the Objects
point group can still be considered as belonging to an object, or if they should be moved to the Terrain point group.
Once a Terrain point group exists, it is possible to generate a DTM (beta). For step by step instructions: 202560579.

@ mportant:

At the end of the classification, points might not be classified correctly. Points might have been classified as belonging to the Objects point group
whereas they belong to the Terrain point group and vice versa.

It is possible to edit the computed Terrain / Objects classification and move points from one point group to another, delete them, move them into a new
point group, etc. For step by step instructions about how to edit the Point Cloud: 202560499.

If the Classify Point Cloud into Terrain/Object Points box is selected, the Point Cloud Classification will be computed during step 2. Point Cloud and Mesh.
The available parameters are:

Minimum Object Length [units]: Minimum expected length for the objects.
Maximum Object Length [units]: Maximum expected length for the objects.
Minimum Object Height [units]: Minimum expected height for the objects.

These parameters define geometric constraints that a group of points of the Objects point group should hawe in order to be \erified as being an object.

j Example:

Minimum Object Length = 0.1 [m]
Maximum Object Length = 100 [m]
Minimum Object Height = 0.1 [m]

The Objects point group will contain only objects with length between 0.1 and 100 meters and higher than 0.1 meter.

For step by step instructions about how to compute the Point Cloud Classification and generate a DTM: 202560579.
3D Textured Mesh Settings
Advanced options influencing the generation of the 3D Textured Mesh:

Sample Density Divider: The value goes from 1 (default) to 5. Increasing this value will create more triangles in regions with a lower density of points. However, this
might also create more unwanted triangles in noisy regions. To be used when there are holes in the mesh and the model is not too noisy.

Maximum Number of Triangles per Leaf: Value between 8 and 128. Higher values will lead to less detailed results (and faster computing times) since regions will
be subdivided less often.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 2. Point Cloud and Mesh. By default,
only the Point Cloud and the 3D Textured Mesh tabs appear. On the bottom left, select the Advanced box to display other tabs.
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2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index

3D Textured Mesh Advanced

Allows the user to select an add-on for the Point Cloud Densification. This tab contains 1 section:

Point Cloud Densification: Allows the user to select an add-on for the Point Cloud Densification.
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Use Semi-Global Matching (payable add-on): This option uses the Semi-Global Matching algorithm for the point cloud densification. It is a payable add-on feature.
It may give better results for projects with low / uniform texture images (roads, walls, roofs). Another possible use is when the expected output is a good
Orthomosaic of an urban area. In this last case, the Optimize for 2.5D DSM option (see below) should be selected. The Semi-Global Matching is optimized for

large frames images (larger than 40MP).

@ mportant:
The Use Semi-Global Matching (payable add-on) option DOES NOT allow the user to generate the 3D Textured Mesh.

The Use Semi-Global Matching (payable add-on) option is grayed out when a Fisheye Lens camera has been used. For more
information: 202558159.

Optimize for 2.5D DSM: It generates a 2.5D Point Cloud instead of a full 3D Point Cloud. It should be used when the expected output is a good Orthomosaic.
Ovwerlap Scenario: Only wisible for projects with images larger than 40MP. Allows to select the forward overiap (frontal overlap) and the sideward overlap (side
owerlap) of the project, to optimize the Semi-Global Matching algorithm to the selected overlap.

@ mportant:
When the Optimize for 2.5D DSM option is selected a 2.5D Point Cloud is generated.

The Optimize for 2.5D DSM option is not recommended for oblique projects because the result will be a 2.5D Point Cloud.

Note: The Semi-Global Matching option will use the selected options of the Point Cloud Densification section (Image Scale, Point Density,
Minimum Number of Matches). The Multiscale option is always used when Semi-Global Matching has been selected.
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& Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 3. DSM, Orthomosaic and Index.

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index

DSM and Orthomosaic Additional Outputs

Resources and Notifications

Index Calculator

Allows the user to change the processing options and desired outputs for DSM and Orthomosaic generation of step 3. DSM, Orthomosaic and Index. It contains 4

sections:

Resolution: Allows the user to define the spatial resolution used to generate the DSM and Orthomosaic.

DSM Filters: Allows the user to define parameters to filter and smooth the points of the Point Cloud used to obtain the DSM.

Raster DSM: Allows the user to select the output file format and options for the raster DSM.

Orthomosaic: Allows the user to select the output file format for the Orthomosaic as well as different options related to the Orthomosaic generation.

. Processing Options

DSM and Orthomosaic Additional Qutputs Index Calculator
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Processing
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Resolution
Allows the user to define the spatial resolution used to generate the DSM and Orthomosaic.

Automatic (default): By default one GSD is selected. One can also easily change the resolution to multiples of the GSD.
Custom: Allows to select any value for the resolution of the Raster DSM and the Orthomosaic generation.

DSM Filters

Allows the user to define parameters to filter and smooth the points of the Point Cloud used to obtain the DSM.
@ Important: The filtering and smoothing will not have any impact in the Point Cloud.

The following options are available:

Use Noise Filtering: The generation of the Point Cloud can lead to noisy and erroneous points. The noise filtering corrects the altitude of these points with the
median altitude of the neighboring points.

Use Surface Smoothing: Once the noise filter has been applied, a surface is generated using the points. This surface can contain areas with erroneous small
bumps. The surface smoothing corrects these areas by flattening them. This section allows the user to set the following parameter:

Type: Three smoothing types can be selected:

Sharp (default): Tries to presene the orientation of the surface and to keep sharp features such as comers and edges of buildings. Only quasi-planar areas are
flattened.

Smooth: Tries to smooth areas, assuming that sharp features exist because of noise and that they should be removed. Areas that are not very planar are
smoothed and become planar.

Medium: This is a compromise between the two other options. It tries to presene sharp features while flattening roughly planar areas.

Raster DSM
Allows the user to select whether the raster DSM is generated and to select the method with which the DSM will be generated:

GeoTIFF (activated by default): Saves the DSM as a GeoTIFF file. For most projects the DSM is split into several tiles and one GeoTIFF file is generated per tile.
Method: The method that is used for the Raster DSM generation. The method will affect the processing time and the quality of the results.

Inverse Distance Weighting: The inverse distance weighting algorithm is used to interpolate between points. This method is recommended for buildings.
Triangulation: The triangulation algorithm based on Delauney triangulation is used. This method is recommended for flat areas (agriculture fields) and stockpiles.

@ Important: The triangulation method can be up to 10 times faster than the Inverse Distance Weight Method, but the results may be worse
especially for buildings.

Merge Tiles (activated by default): Generates a single DSM GeoTIFF file by merging the individual tiles. When this option is not selected, the merged DSM file is
not generated.

Orthomosaic
Allows the user to select the output file format for the Orthomosaic as well as different parameters related to the Orthomosaic generation:

GeoTIFF (activated by default): Saves the Orthomosaic into a GeoTIFF file. For most projects, the Orthomosaic is split into several tiles and one GeoTIFF file is
generated per tile.

Merge Tiles (activated by default): Generates a single Orthomosaic GeoTIFF file by merging the individual tiles. When this option is deactivated, the merged
Orthomosaic file is not generated.

GeoTIFF Without Transparency: Generates a GeoTIFF file without transparency. For more information: 202558809.

o Information: For more information about the Orthomosaic algorithms: 202559429.

Google Maps Tiles and KML: This option allows the user to generate the Google Maps and Google Earth files for the Orthomosaic.
Mapbox Tiles: This option allows the user to generate the Mapbox Tiles for the Orthomosaic.

If step 3. DSM, Orthomosaic and Index has already been processed, it is possible to generate the Google Maps, KML and Mapbox Tiles without running
step 3 again. For more information: 202558149.

@ mportant:
When having images grouped in more than one group, the Google Maps Tiles and KML and the Mapbox Tiles will only be generated if one of the

groups is named RGB (capital letters). For more information about the image groups: 202557949.
The Google Maps Tiles and KML and the Mapbox Tiles are only generated for 3 band images with 8 bit per band.

@ Important: VWWhen having images grouped in more than one group, one Orthomosaic per group is generated. For more information about image
groups: 202557949.


https://support.pix4d.com/hc/en-us/articles/202558809
https://support.pix4d.com/hc/en-us/articles/202559429
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& Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 3. DSM, Orthomosaic and Index.

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index

DSM and Orthomosaic Additional Outputs

Resources and Notifications

Index Calculator

Allows the user to change the selected processing options and output files for the additional outputs to be generated during step 3. DSM, Orthomosaic and

Index. It contains 2 sections:

Grid DSM: Allows the user to select the output file format for the Grid DSM.

Contour Lines: Allows the user to generate the contour ILines using the Raster DSM and to select the processing options for the contour lines.

. Processing Options
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Grid DSM



Allows the user to select the desired file format for the DSM:

XYZ: ASCII text file with the XY,Z position and color information for each point of the Point Cloud.

Delimiter: It defines the delimiter character of the file, used to separate the values. The drop down list has the following options:

Space

Tab

Comma

Semicolon

LAS: LiDAR LAS file with XY,Z position and color information for each point of the Point Cloud.

LAZ: Compressed LiDAR LAS file with XY, Z position and color information for each point of the Point Cloud.

Grid Spacing [cm]: The spacing defines the distance between two 3D points in the DSM and is given in centimeters. For example: a grid spacing of 100
centimeters will generate one 3D point every 100 centimeters. The default value is 100 centimeters. One DSM with the selected spacing is generated in addition
to a DSM generated using the resolution selected in the DSM and Orthomosaic tab.

For more information about the file formats and the software with which these files can be opened: 202558499.

lm Note: It is possible to select more than one format in order to save the Grid DSM in more than one format.

Note: The Grid DSM is restricted to 256 million points. If the chosen grid spacing or resolution generates more than 256 million points, then the grid
sampling or resolution distance is doubled until the number of generated points does not exceed 256 million.

Contour Lines

Allows the user to generate contour lines using the Raster DSM. For more information about the concept of contour lines: 202559879.

@ Important: The option to generate the contour lines is grayed out if the option to merge the tiles of Raster DSM is disabled. For more information about
the options of the Raster DSM: 202557769.

SHP: When this option is selected, the contour lines file is generated in .shp format.

PDF: When this option is selected, the contour lines are saved in a .pdf format.

DXF: When this option is selected, the contour lines file is generated in .dxf format.

Contour Base [units]: It defines the relative altitude which is used as a contour line base. It can be in meters or in feet according to the coordinate system used.

/ Example: For a project with minimum altitude 315 meters, Contour Base = 30 meters means that the first contour line (the base) will be at 345
meters (315+30).

Elevation Interval [units]: It defines the contour lines elevation intenal. It can be in meters or in feet according to the coordinate system used. It can be any
positive value.

A Waming: The Elevation Interval must be smaller than (Maximum - Minimum) altitude of the DSM. For more information about the DSM
altitudes: 202557619.

j Example: For a project with Minimum altitude 400 meters and Maximum altitude 650 meters and Contour Base = 0 meters, Elevation Interval = 50
meters means that that contour lines will be generated at 400, 450, 500, 550, 600, and 650 meters.

l[ﬂ Note: The smaller the Interval value, the larger the size of the contour lines file and the more processing time will be needed for its generation.
Resolution [units]: It defines the horizontal distance for which an altitude value is registered. The higher the Resolution value, the smoother the contour lines.
/ Example: If the Resolution is set to 100 cm, an altitude value will be registered every 100 cm (horizontally).

Minimum Line Size [points]: It defines the minimum number of vertices that a contour line can have. Lines with less vertices will be deleted and less noise will be
produced.

ﬂ Example: If the Minimum Line Size [points] is set to 20, all contour lines that have less than 20 vertices will be deleted.

Note:
@ It is possible to select more than one format in order to save the contour lines in multiple formats.
If the step 3. DSM, Orthomosaic and Index has already been processed, it is possible to generate the Contour Lines without running step 3 again. For
more information: 202558469.
For step by step instructions about how to generate contour lines: 202560639.
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& Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 3. DSM, Orthomosaic and Index.

e V4

[

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

DSM and Orthomosaic Additional Outputs Index Calculator

Allows the user to change the processing options and outputs related to the Index Calculator. These are processed during step 3. DSM, Orthomosaic and Index.

These settings come in 4 sections:

Radiometric Calibration: Allows the users to calibrate and correct the image reflectance, taking the illumination and sensor influence into consideration.
Resolution: Allows the user to set the resolution as well as the downsampling method (if needed).

Reflectance Map: Allows the user to decide if the Reflectance Map(s) will be generated while processing step 3. DSM, Orthomosaic and Index, and if the Tiles will
be merged.

Indices: Shows the list of indices either from the database or created by the user. Allows the user to select which indices are generated while processing

step 3. DSM, Orthomosaic and Index. For the selected indices, the Index Map is saved as a GeoTIFF, the Index Map Grid as a .shp file, the Classes as a .shp
file and the Classes with color representation as a .jpg file.

Export: Allows the user to select some desired outputs.
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Radiometric Calibration

Allows the users to calibrate and correct the image reflectance, taking the illumination and sensor influence into consideration.

The camera used is displayed. Users can calibrate the sensor to perform an illumination adjustment in order to obtain more accurate reflectance values. If there

are more than one camera models in the project, all the cameras will be listed in the Radiometric Calibration section.

After clicking Calibrate for a camera model, the Radiometric Calibration pop-up appears:




. Radiometric Calibration - CanonlXUS220H5_4.3_4000x3000 (RGB)(1) ? *
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Reset
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The Radiometric Calibration pop-up has the 3 sections:

Image: The image section allows the user to browse the image that will be used for the radiometric calibration.
Albedo: The Albedo section allows the user to set the albedo values for the calibration target.
Callibration: The calibration section allows the user to perform the radiometric calibration based on the selected calibration target and the Albedo values selected.

Image

In File Name, the Browse button, opens the Select a radiometric calibration image pop-up. This pop-up allows the user to select the image in which the
radiometric calibration target appears.

When an image is browsed, the user can draw a region on the image that will define the radiometric calibration. The Reset button, resets the area drawn by the
user.



H Radiometric Calibration - CanonlXUS220H5_4.3_4000x3000 (RGE)(1) ? *
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Calibration

@ Camera calibrated.

Albedo
In the Albedo section the detected bands of the camera model appear. This section allows the user to type the albedo values for the calibration target for the
bands of the camera model selected.

. Important: The albedo values can be between 0.0 and 1.0.

For more information about the radiometric calibration target: 206494883.

Albedo

Red
Green
Blue

Calibration

In the Calibration section, there is an action button:

Calibrate: When a region is drawn and the albedo values are correctly set, the Calibrate button is enabled. It performs the radiometric calibration.
and the action buttons:

OK: Confirms the radiometric calibration.
Cancel: Does not sawe the radiometric calibration.
Help: Opens the Pix4Dmapper help.

Resolution

Allows the user to set the resolution for the reflectance map. If a resolution lower than 1 GSD is chosen, the downsampling method can be chosen among the
following options. Note that the window size will depend on the downsampling rate:


https://support.pix4d.com/hc/en-us/articles/206494883

Gaussian Average: Apply a Gaussian filter to the image.

Awerage: The pixel takes the average value of the window around it.

Median: The pixel takes the median value of the window around it.

75% Quantile: The pixel takes the value of the 75% quantile of the window around it.
Minimum pixel: The pixel takes the minimal pixel value of the window around it.
Maximum pixel: The pixel takes the maximal pixel value of the window around it.
Warp: The pixels are downsampled using a cubic spline interpolation method.

Reflectance Map
Allows users to generate and save the Reflectance Map in GeoTIFF format.

GeoTIFF: The Reflectance Map is generated and saved in GeoTIFF format during the step 3. DSM, Orthomosaic and Index.
Merge Tiles: For most projects, the Reflectance Map is split into tiles where every tile is in GeoTIFF format. This option generates a single Reflectance Map file
by merging all the individual tiles.

When this box is deselected, the merged Reflectance Map file is not generated, and users will only find smaller tiles in the result folder.
Indices

Allows the user to select which indices are generated while processing step 3. DSM, Orthomosaic and Index (If in the section Reflectance Map, Geotiff is
selected), and generates the Index Map Grid and the Classes for the selected indices. The resolution of the Index Map generated is the same as the Reflectance
Map.

Indices Box: All indices are displayed in the gray box with icons:

g: The index exists in the Pix4Dmapper index database. For more information about the Pix4Dmapper Index Database List: 202558379.
£,: The index was created / edited by the user in another project (on the same computer) that was closed and saved. :202560489.

[ The index was created / edited by the user in this project: 202560489.

Export
Allows the user to select some desired outputs:

Index Values as Point Shapefiles (.shp): This map is generated while generating the Index Map. The Index Map Grid is generated by placing a grid in the Index
Map. If a grid point lays on exactly 1 pixel, it takes the value of the pixel of the Index Map. If a point lays on seweral pixels, its value is interpolated with the values
of the neighboring cells of the Index Map.

Grid Size [unit/grid]: Defines the grid size. The default value is 200 cm/grid.

@ Note: The maximum value that can be entered is 10000.

Index Values and Rates as Polygon Shapefiles (.shp): Allows the user to export the index vales and rate regions as a .shp file.
Grid Size [unit/grid]: Defines the grid size. The default value is 400 cm/grid.

@ Note: The maximal value that can be entered is 10000.


https://support.pix4d.com/hc/en-us/articles/202558379
https://support.pix4d.com/hc/en-us/articles/202560489
https://support.pix4d.com/hc/en-us/articles/202560489
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& Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click Resources and Notifications.

5

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

Resources and Notifications

Allows the user to select the usage of the hardware resources and to select a notification for when processing is done. This can be useful when running multiple
projects on the same computer or when the computer is needed for tasks other than processing:

This tab contains two sections:

Maximum Resources Available for Processing: Allows to throttle the resources dedicated to the software
Notifications: Allows to trigger a notification when processing is completed.

Maximum Resources Available for Processing

RAM [GB]: By default all the available RAM memory is used. It is possible to reduce the amount of RAM assigned to the processing of the project by moving the
slider to a lower value.

CPU Threads: By default all the CPU threads are used. It is possible to reduce the amount of CPU threads assigned to the processing of the project by moving
the slider to a lower value.

NVIDIA CUDA Capable Devices:

ONLY when using NVIDIA Graphic card(s) compatible with CUDA, it is possible to activate / deactivate the use of the Graphic card(s) by selecting/deselecting the
box.

When using Cuda processing, the processing speed is increased and the impact is more significant for large projects.

Under NVIDIA CUDA capable devices list, the list of GPUs appears . The cards that hawe at least 2 GB RAM are selected by default.

| Processing Options > || I Processing Options X
Resources and Notifications Resources and Notifications
1. Initial Maximum Resources Available for Processing I Initial Maximum Resources Available for Processing
Processing ) . ! . ! . Processing :
RAM [GB]: 16 . RAM [GBI: 16 ‘
CPU Threads: 8 ' . . . . . . . CPU Threads: 8 ' . .
Lo 2. Point Cloud and v 2. Point Cloud and
o NVIDIA CUDA Capable Devices: S NVIDIA CUDA Capable Devices:
bl Mesh AR Mesh
GPU Device 1: [7] GeForce GTX 850M Ho NVIDIA CUDA capable devices found.
evice erorce Ensure that you use a CUDA compatble device with the atest drivers.
e 3.05M, Notifications Q 2.D5M, Notifications
VA Orthomosaic and [] send Email Hotification when Processing is Done. % Orthomosaic and [] Send Email Notification when Processing is Done.
[N Index /N Index
ﬂ Resources and Resources and
£ Notifications m Notifications
Current Options: ~ No Template Current Options: ~ No Template
| Load Template | | Save Template | Manage Templates.... | Load Template | | Save Template | Manage Templates....
Advanced [ o ]| concel || b | Advanced [k ]| cancl || el

NVIDIA CUDA Capable Devices available. NVIDIA CUDA Capable Devices not available.



@ Tip: When processing several projects of a given size at the same time, the first project starting step 2. Point Cloud and Mesh will use as much RAM as
possible. When another project starts processing step 2. Point Cloud and Mesh as well, less RAM will be available and processing might be slower.

Therefore, reducing the amount of RAM to be used so that the resources are shared between the projects running at the same time helps to reduce the
owerall processing time.

For example on a 64GB RAM computer, when running 2 projects, set the amount of RAM to 32GB for each project.

Notifications

If the notification box is selected, an email notification will be sent to the email address used to log in Pix4Dmapper when processing is done.
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& Access: On the Menu bar, click Process > Processing Options..., a pop-up appears.

[ Processing Options
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Current Options:  No Template

| Load Template v| | Save Template ,| |Manage Templates...

Advanced OK | | Cancel | |

Help

The Templates section allows to:

Load (select) a template.

Sawe a custom template.

Visualize the description of a template (Manage Templates).

Edit the name and description of a custom template (Manage Templates).
Delete a custom template (Manage Templates).

Import templates from the support site (Manage Templates).

It contains:

Current Options: Displays the selected Processing Options Template.
Load Template: Allows to select a Processing Options Template.

[m Note:
g Refers to Processing Options Templates existing by default.

9, Refers to Processing Options Templates created by the user.

© Previous | Next ©

& Refers to Processing Options Templates (existing by default or created by the user) that have been edited but are not saved.

Sawe Template: Displays 2 options:



Update "Template" with Current Options: Available when a Processing Options Template created by the user is selected and some options have changed, allows
to overwrite the Processing Options Template with the new selected options.

Create New Template with Current Options: Allows to save the selected processing options as new Processing Options Template. Opens the Create New
Template pop-up which allows to enter a Name and a Description for the new template:

[ Create New Template ? *

Mame: Al options

Destriplion: | wemplate with all processing options selected

el

Manage Templates...: Opens the Templates Manager pop-up:

.| Templates Manager ? *
B e 3D Maps
E 3D Models
£ Ag Multispectral Generate a DSM and an orthomosaic for mapping applications.
& Ag Modified Camera Inguit Bnages
B AgRGB
B 3D Maps - Rapid/Low Res Aerial images acquired using a arid flight plan with high overlap, mostly oriented towards the
2 3D Models - Rapid/Low Res it
& Ag Modified Camera - Rapid/Low Res Outputs
2 AgRGB - Rapid/Low Res
& Thermal Camera Orthomosaic DsM

e
=
z

Paint Cloud

Application examples

* Measure volumes

* Digitize houses and roads

* Generate contour lines

* Google Maps and Mapbox averlay

Mew Duplicate Remave

(] mport/Expart Cancel Help

It contains 2 sections:

List of existing Processing Options Templates:



l[_]] Note:
g Refers to Processing Options Templates existing by default.
&, Refers to Processing Options Templates created by the user.

& Refers to Processing Options Templates (existing by default or created by the user) that have been edited but are not saved.

Description of the selected Processing Options Template:
And the buttons:

New: Creates a new Processing Options Template with the selected processing options.
Duplicate: Duplicates an existing Processing Options Template with another name.
Removwe: Deletes a Processing Options Template.

Import/Export check box: Displays the buttons:

Import...: Allows to import a template (.tmpl files created with Pix4Dmapper).

Export: Allows to export a template as .tmpl.

Folder...: Opens the folder where the user Processing Options Template are saved.

[[D Note: More processing options templates (.tmpl) available here.

OK: Confirms the changes.
Cancel: Does not sawe the changes.
Help: Opens the Pix4Dmapper help.

l[ﬂ Note: For more information about the Processing Options Templates, their outputs and their selected processing options: 205319155.
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& Access: On the Menu bar, click View.

There are 2 items that can be selected / unselected:

Show View Toolbar: Show / hide the View toolbar. For more information: 202557839.
Show Sidebar: Show / hide the Sidebar. For more information: 202558389.

And 7 items that can be selected:

Welcome: Opens the Welcome View interface.

Map View: Opens the Map View, available when a project is created/opened.

rayCloud: Opens the rayCloud View, available when a project is created/opened.

Mosaic Editor: Opens the Mosaic Editor View, available once step 3. DSM, Orthomosaic and Index has been completed.
Index Calculator: Opens the Index Calculator View, available once step 1. Initial Processing has been completed.
Processing: Opens the Processing bar, available when a project is created/opened.

Log Output: Opens the Log Output bar, available when a project is created/opened.
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& Access: On the Menu bar, click View > Welcome.
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The Welcome View has 3 sections:

Projects
Help
Demo Project

Projects
Contains the items:

New Project...

Opens the wizard that guides the user to create a new project.

For step by step instructions about how to create a new project:202557309.

Open Project...

Opens an existing project. Opens a pop-up to navigate and select a .p4d project file (Pix4Dmapper project file format).
Recent Projects

Displays a menu with the 4 last projects that have been opened. By clicking on one of them, the project will open.

Tips

Displays information about the use of Pix4Dmapper. It opens the Knowledge Base articles containing a detailed description.
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[_t New Project... /. Open Project...
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project with your own dataset.
| mining_quarry.pdd i small_prj.p4d
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A Last modified: Tue Mar 1 2016 N Last modified: Thu Feb 25 2016
building .p4d ag.pdd
p, X4 U Last modified: Tue Mar 1 2016 143 images
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Processing
& Did you know...
LREint How to select/change the point cloud densificaction area
Processing
Options
Help

Contains the items:

Getting Started
Opens the Support site, displaying the Getting Started index. This guide explains how to get started with Pix4Dmapper. It shows the needed steps before using Pix4D to obtain a good dataset, how to create a project and how to start processing. It also shows
how to get started with advanced features such as Ground Control Points.

Pix4Dmapper Manual

Opens the Support site, displaying the Manual index.

Quick Links

Opens the Support site, displaying the Quick Links index.

Example Datasets

Opens the Support site, displaying the example datasets index.

Webinars

Opens the Support site, displaying the Webinars index.

Forum

Opens the Support site, displaying the Forum index page.

Tips

Displays information about the use of Pix4Dmapper. It opens the Knowledge Base articles containing a detailed description.
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& Did you know...
Log Qutput
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Processing
Options

How to select/change the point cloud densificaction area

Demo Project
Contains the items:

Pix4Dmapper Demo Project
Automatically loads a demo project, ready to be processed and opens in a browser window the demo project video that highlights the possibilities of Pix4Dmapper.

Tips
Displays information about the use of Pix4Dmapper. It opens the Knowledge Base articles containing a detailed description.

L PixdDmapper Pro - o X

Project Process View Help

5 2 @
B& o a &
Project Process

Pix4p

rayCloud

3 mapper

Editor

Projects Help Demo Project

Calculator

Pix4Dmapper Demo Project

Click to open and process a demo project.
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Processing
i) Did you know...
Log Output

O

Processing
Options

How to select/change the point cloud densificaction area
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Process
Project Information 8 x
¥ Project Su
Welcome o —
Dj] Project: ~
Name: guided_tour : .
e Type: Standard Pix4Dmapper V1.3 Guided Tour
p— Workspace:
i C:/Users/pix4d/Documents/pix4dmapp
- erftutorials/quided_tour/
rayCloud Qutput Datum: CH1903+
Qutput Coordinate System:
CH1903+ / LV85
. Qutput Georeferenced: YES
Masaic
Editor [ Processing: . .
1. Initial Processing Done: YES V 1 3 G d d T
Average Ground Sampling erslon & ul e ur
Index Distance (GSD) [cm/pixel]: 5.36523
Calculator Parameter Files Generated:
YES
2. Point Cloud and Mesh Dane:
NO
Image Scale: -
Point Densi

3. DSM, Orthomosaic and Index

Done: NO

Resolution [cm/pixel]: -

Raster DSM Generated: NO

Grid DSM Generated: NO

Orthomesaic Generated: NO

Google Maps Tiles and KML
Generated: NO

Images:

Enabled Images: 13 out of 13
Geolocated Images: 13 out of 13
Datum: World Geodetic System
1984

Coordinate System: WGS 84

Ground Control Points:

Number of GCPs With Enough Image
Marks: 4/4

Datum: CH1903+

Coordinate System: CH1903+ / LW95 «

Processing
—

W Frocessing *
=3
il 1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index W Layers
Log OUtpUE oy 0% Images
ol Total: 1. | 2. | 3. 0/23 GCPs
Processing Processing Area
Options Output Status... Start Cancel Help

WGS84 - (46.34379119, 8.02583992) CH1903+ / LVI5 - ( 2645206.144, 1132658.027) [m]

Map View with the demo project loaded Demo project video in Pix4D Support site

Index > Interface > Menu View
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& Access: On the Menu bar, click View > Map View.

. PixdDmapper Pro - mining_quarry
Project  Process | View  Map View Help

||:@ ~  Show View Toolbar
Pix Proj Show Sidebar
|
() 1 Welcome
Welcome Map View
e [ o
II]] ! rayCloud
Map View ] Mosaic Editor
i Index Calculator
rayCloud [ Processing
[_T_[] 45 Log Output

By selecting the Map View the following elements are displayed on the main window:

Menu bar entry: Displayed on the Menu bar.

Toolbar: The standard toolbar and some extra buttons related to the Map View.

2D View: Displayed in the main window. By default the Satellite view is displayed.

Project Information sidebar: Displayed on the right of the 2D Map. It contains two sections: Project Summary and Layers.
Status bar: Displayed at the bottom right of the Map View. Displays the coordinates when passing the mouse over the 2D View.

@ Important: The 2D Map displays the earth if the images are not geotagged.
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Project Information 5 X

¥ Project Summary

Project:
Mame: mining_guarry_withGCPS
Type: Standard
Workspace: 5:/
Output Datum: World Geodetic System 1584
Output Coordinate System: WGS 84 / UTM zone 32M
Cutput Georeferenced: YES

Processing:
1. Initial Processing Done: YES
Average Ground Sampling Distance (GSD)
[emfpixel]: 8.74304
Farameter Files Generated: YES
2. Point Cloud and Mesh Done: YES
Image Scale: multiscale, 12 (Half image size,
Default)
Point Density: Optimal
3. DSM, Orthomosaic and Index Done: YES
Resolution [em/pixel]: 8, 74304
Raster DSM Generated: YES
Grid DSM Generated: NO
Crthomosaic Generated: YES
Google Maps Tiles and KML Generated: YES

Images:
Enabled Images: 127 out of 127
Geolocated Images: 127 out of 127
Datum: World Geodetic System 1984
Coordinate System: WG5S 84

Ground Control Points:
MNumber of GCPs With Enough Image Marks: 7/7
Datum: World Geodetic System 1984
Coordinate System: WGES 84

W Layers

» Images
GCPs
[ Processing Area

6.54406428) WGS584 / UTM zone 32N - ([ 312104,502, 5170193.282) [m]

Menu bar entry

On the Menu bar, when clicking Map View, the following option is displayed:

Processing Area: Indicates the area of the project for which the different steps of processing will be applied.

|| Pix4Dmapper Pro - mining_quarry

Project Process View MapView Help

: | @ £ Processing Area
|
Project Process

Toolbar

The following toolbar buttons are displayed:

Standard toolbar buttons: For more information: 202557839.

Toolbar extra buttons:
Toolbar extra buttons

View
@, Zoom In: Zooms in the selected view.
@, Zoom Out: Zooms out the selected view.



Change Background Map: A drop-down list that changes the 2D View background displayed on the main window. It has the following options:

Satellite (default): Displays a satellite view of the project's location. If none of the images are geolocated, the whole earth is displayed.

Maps: Displays a map view of the project's location. If none of the images are geolocated, the whole earth is displayed. The background map displays the
standard OpenStreetMap map.

Orthomosaic: This option is available only if the Google Maps tiles and KML have been generated. It displays the orthomosaic that Pix4Dmapper generates in
step 3.DSM, Orthomosaic and Index.

l[_]] Note: To generate the Google Maps tiles and KML: 202558149.

o Information: The data displayed by OpenStreetMap is available under the Open Database License, the cartography is licensed as CC BY-SA.
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Figure 1. Satellite view
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Figure 2. Maps view
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Figure 3. Orthomosaic view

2D View



Section which displays the location of the project on earth and the project elements (images, GCPs, etc.). For more information: 202557979.

Project Information sidebar

Project Summary: Section with a summary of the project parameters and the processing progress.
Layers: Section with the project elements (images, GCPs, etc.) that are \isible in the 2D View.

For more information about the sidebar's display possibilities: 202558389.

Project Information 5 X

W Project Summary

Project:
Name: example_guarry
Type: Standard
Warkspace: Sif
QOutput Datum: World Geodetic System 1984
QOutput Coordinate System: WGS 84 [ UTM zone 32N
Qutput Georeferenced: yes

Local Processing:
1. Initial Processing Done: yes
Average Ground Sampling Distance (GSD) [cm/pixel]: 8.78856
Parameter Files Generated: yes
Point Cloud and Mesh Done: yes
Image Scale: multiscale, 12 (Half image size, Default)
Point Density: Optimal
D5M, Orthomosaic and Index Done: yes
Resolution [cm/pixel]: 8.73856
Raster DSM Generated: yes
Grid DSM Generated: no
Orthomosaic Generated: yes
Google Maps Tiles and KML Generated: no

ta

t

Images:
Enabled Images: 127 out of 127
Geolocated Images: 127 out of 127
Datum: World Geodetic System 1984
Coordinate System: WGS 84

Ground Control Points:
Number of GCPs With Enough Image Marks: 7/7
Datum: World Geodetic System 1984
Coordinate System: WGS 84

W Layers

I» Images
GCPs
4 [] Processing Areas
[] Paint Cloud Densification Area
[] oOrthomaosaic Area

Status bar

The coordinates of the current mouse position on the 2D View are displayed at the bottom right of the Map View. Two types of coordinates are displayed:
WS84 - (46.6508319, 6.54048085) WGS84 / UTM zone 32N - (0311802.23, 5169301.75) [m]
Geographical WGS84 coordinates

Latitude and longitude coordinates are displayed.
Selected Coordinate System

The Xand Y coordinates of the selected output coordinate system (202558239) are displayed .
Note: If the project has no georeference or it is georeferenced in an arbitrary coordinate system, only the geographical WGS84 coordinates are

displayed.

Index > Interface > Menu View © Previous | Next ©
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& Access: On the Menu bar, click View > Map View and then, on the Menu bar, click View > Processing Area.

[[B Note: Only one Processing Area can been used.

A Waming:

It is recommended to include areas cowvered by images in the Processing Area, so as to exclude areas of low overlap that can affect the resullts.

The Processing Area affects only the visualization of the Automatic Tie Points in the 3D View of the rayCloud. It does not affect the results of step 1.
Initial Processing.

When the Processing Area is defined before step 2. Point Cloud and Mesh is processed, it affects the Point Cloud visualized in the 3D View of the
rayCloud and the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index.

When the Processing Area is defined after step 2. Point Cloud and Mesh is completed, it only affects the Point Cloud visualized in the 3D View of the
rayCloud but not the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index.

When exporting the Point Cloud, it is possible to take into account the Processing Area, even if it is drawn after step 2 is processed. For more
information about how to export the Point Cloud: 203890769.

When the Processing Area is defined before step 3. DSM, Orthomosaic and Index is completed, only the results of step 3 will be affected.

A Waming:
In order to take the Processing Area into account for the visualization of the Point Cloud and / or the generation of the outputs of step 2. Point Cloud and
Mesh, the corresponding filter should be selected in the Processing Options. For more information: 204644369.

The Processing Area will be taken into account for the results of step 3. DSM, Orthomosaic and Index even if the Processing Areas box is not selected
in the Point Cloud Filters.

The Processing Area indicates the area of the project for which the different steps of processing will be applied. The area can only be defined in the Map View if
the project is georeferenced in a known coordinate system.

_"._—'_,J PirdDmapper Pro - mining_quarry
Project  Process  View  Map View Help

"ﬂ = {:} Processing Area  »
Dix4 :

Project Process

It contains 4 options:

Draw
Import...
Edit...
Remowe

Map View Help
Processing Area ¢ Draw

Process

Import...
Edit...

Remove

For step by step instructions about how to select / draw the Processing Area: 202560179.

Draw

By clicking Draw; the information i0012 pop-up appears with instructions about how to draw the area:


https://support.pix4d.com/hc/en-us/articles/203890769
https://support.pix4d.com/hc/en-us/articles/202560179

[ pueddmapper Ed

y drawing. Move your mouse, which
will draw a line to the next point of
your polygon. Click the right mouse
button to stop drawing. This will
automatically dose the polygon.

] Don't Display This Message Again

@ Information i0012: Left dick to start
k-

Right click inserts the last vertex of the Processing Area and stops the drawing.
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Import...

By clicking Import..., the Select file pop-up appears which allows the user to load the area from a vector file (.shp, .kml or .dxf):



o Select file Ed

« v ‘T‘| S:\PixdDmapper ~| & | Search PixdDmapper p

Organise v MNew folder == ~ [H o

7 Quick access Name

& OneDrive mining_guarry
g This PC
:_" Metwork

*& Homegroup

< >

File name: v| |Vectorfi|5 (*.shp *.kml *.dxf) V|

| Open | | Cancel |

Navigation window: Used to search for and select the vector file.
Open: Loads the file.
Cancel: Does not sawe the changes and closes the pop-up.

Note: The Vector file (.shp, .kml or .dxf) has to be a polygon file (not lines) and can be given in any coordinate system from Pix4Dmapper's coordinate
system database.

Edit...

Available only if a Processing Area has already been drawn / imported. By clicking Edit..., the Edit Area pop-up appears. It contains a table with the following
columns:

Vertex: Each vertex of the area drawn or imported.
Latitude: The latitude of each vertex.
Longitude: The longitude of each vertex.

. Edit Area *
Edit area vertices.
Vertex Latitude Longitude
Vertex 1 46,6569 653958
Vertex 2 46,6562 6.54641
Vertex 3 46,6529 £6.54585
Vertex 4 46,6516 £.54325
Vertex 3 46,6325 653332
Vertex 6 46,6547 £6.53092
Vertex 7 46,6367 £.52994
oK || Cancel || Heb

To edit the area, by changing the Latitude and/or Longitude values, double-click on the corresponding cells in the table.
The Edit Area pop-up also has 3 action buttons:

OK: Confirms the changes.
Cancel: Does not save the changes and closes the pop-up.
Help: Opens the Pix4Dmapper help.



Remowe

Available only if a Processing Area has already been drawn / imported. By clicking Remove, the previously drawn or imported area is deleted.

Index > Interface > Menu View > Map View © Previous | Next ©
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& Access: On the Menu bar, click View > Map View. The 2D View is displayed on the Main window.

The 2D View has 2 components:

Background map
Displayed elements

Background map

On the top of the 2D View there is a drop-down list indicating the type of the background map that has been selected.

@ Note: While loading a map, the drop-down list with the available maps is disabled.

.| PidDmapper Pro - mining_quarry — O *
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Project Information 5 X

W Project Summary

Project:

Mame: mining_guarry _withGCPS

Type: Standard

Workspace: 5:/

Output Datum: World Geodetic System
1934

Output Coordinate System: WGS 84
UTM zone 32N

Output Georeferenced: YES

Processing:
1. Initial Processing Done: YES
Average Ground Sampling Distance
(G5D) [cmfpixel]: & 74304
Parameter Files Generated: YES
2. Point Cloud and Mesh Done: YES
Image Scale: multiscale, 1,2 (Half
image size, Default)
Point Density: Optimal
3. DSM, Orthomosaic and Index
Daone: YES
Resolution [cm/pixel]: 8.74304
Raster D5M Generated: YES
Grid DSM Generated: NO
Crthomosaic Generated: YES
Google Maps Tiles and KML
Generated: YES

Images:
Enabled Images: 127 out of 127
Geolocated Images: 127 out of 127
Datum: World Geodetic System 1984
Coordinate System: WGES 84

Ground Control Points:
Mumber of GCPs With Enough Image
Marks: 7/7
Datum: World Geodetic System 1984
Coordinate System: WGES 84

W Layers

Images
GCPs
[ Processing Area

WGSBS - (46.65792368, 6.54703617) WGSB4 / UTM zone 32N - { 312328371, 5170074.099) [m]

By default when a project is loaded, the Satellite type is selected. To navigate the map:

Zoom in: Mowe the mouse scroll wheel forwards.
Zoom out: Use the mouse scroll wheel backwards.
Pan: Left click and move the mouse.



Click on the background drop down list to select a different type of map. The following background maps are available:

Maps
Satellite
Orthomosaic

Maps
The background map displays the standard OpenStreetMap map.

L[J] Note: The Maps background is loaded only if there is Intemet connection.

o Information: The data displayed by OpenStreetMap is available under the Open Database License, the cartography is licensed as CC BY-SA.
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WGSB4 - (46.65737876, 6.54261053) WGS84 / UTM zone 32N - ( 311987.885, 5170024.109) [m] .

Satellite


http://www.openstreetmap.org/copyright

The background map displays a satellite map.

lﬂ] Note: The Satellite background is loaded only if there is Intemet connection.
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WGS84 - (4665871896, 6.53586745) WGSE / UTM zone 32N - ( 311476.669, 5170189.148) [m]

Orthomosaic



The background map displays the Orthomosaic t

hat is generated in step 3. DSM, Orthomosaic and Index.

Note: This background map is available only if the Google Maps tiles and KML have been generated. To generate the Google Maps

tiles and KML: 202558149.
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WGSB4 - (46.65900430, 6.54248580) WGSBS / UTM zone 32N - ( 311983.991, 5170205.027) [m]

Displayed elements

The elements that are displayed are the following:

Images

Flight plan
GCPs
Processing Area

Images




The images of the project that are geolocated with a known coordinate system are displayed as dots on the 2D View. The first image is displayed as a larger
dot. The color of the dot indicates the phase of the processing:

Red: When a project is loaded before processing has started.

Gridded red: For the images that are disabled (not taken into account for processing).
Dark green: For images that have been calibrated after step 1. Initial Processing.
Blue: During step 2. Point Cloud and Mesh for the loaded images.

Luminous green: After step 2. Point Cloud and Mesh.

When howering over the image dots, the image name is displayed at the bottom part of the 2D View. When double clicking on an image dot, a pop-up appears
that displays the corresponding image.

@ Important: If the project has no georeference or it is georeferenced in an arbitrary coordinate system, the images are not displayed on the 2D View.
The 2D View displays the whole earth.
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1584 - (46.65238585, 6.53159738) WGS84 / UTM zone 32N - ( 311127.928, 5160495.684) [m]

The Images layer has a sub-layer:

Flight plan: It displays the flight plan that was used to take the images as a green line starting from the larger dot (first image).

GCPs



The GCPs of the project, if there are any, are displayed as crosses on the map:

Blue cross: GCPs that are marked on at least 2 images.
Red cross: GCPs that are marked on less than 2 images.

When howering over the GCP cross, the GCP name is displayed at the bottom of the 2D View. When double-clicking on a GCP cross, the GCP/MTP
Manager window opens and the corresponding GCP is selected.

Important: If the project has no georeference or it is georeferenced in an arbitrary coordinate system, the GCPs are not displayed on the 2D View. The
2D View displays the whole earth.
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Processing Area



The Processing Area, if defined, is displayed on the 2D View as transparent polygon with a red border.

Important: If the project has no georeference or it is georeferenced in an arbitrary coordinate system, the Processing Area is not displayed on the 2D
View. The 2D View displays the whole earth.
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& Access: On the Menu bar, click View > Map View to open the Map View. The Project Summary is displayed on the right of the main window. For
information about the sidebar's display possibilities: 202558389.

| PixdDmapper Pro - mining_quarry
Project  Process | View  Map View Help
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Welcome
Map View
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Muosaic Editor

Index Calculator

Processing

Log Output

On the left part of the Project Summary, there is an arrow that allows the user to show/hide the summary by clicking on it.

¥ projectsummary - BY default the Project Summary is Visible.
P Project Summary : The Project Summary is not visible.

There are 4 sections in the Project Summary:

Ground Control Points

¥ Project Summary

Project:
Name: example_quarry
Type: Standard
Workspace: S:f
Qutput Datum: World Geodetic System 1984
Qutput Coordinate System: WGES 84 f UTM zone 32N
Qutput Georeferenced: yes

Local Processing:

1. Initial Processing Done: yes
Average Ground Sampling Distance {G5D) [cm/pixel]: 8 78856
Farameter Files Generated: yes

2. Point Cloud and Mesh Done: yes
Image Scale: multiscale, 1,2 (Half image size, Default)
Point Density: Optimal

3. D3M, Orthomosaic and Index Done: yes
Resolution [cm/pixel]: 8. 783586
Raster D5M Generated: yes
Grid DSM Generated: no
Orthomosaic Generated: yes
Google Maps Tiles and KML Generated: no

Images:
Enabled Images: 127 out of 127
Geolocated Images: 127 out of 127
Datum: World Geodetic System 1384
Coordinate System: WGS 84

Ground Control Points:
Mumber of GCPs With Enough Image Marks: 77
Datum: World Geodetic System 1984
Coordinate System: WGS 84

Project
This section displays general information about the project:

Name: The name of the project.

Type: The type of the project (Aerial nadir, Alterative processing mode, Aerial oblique or terrestrial).
Workspace: The path to the folder where the .p4d project file is located and where the output folder is saved.
Output Datum: The datum of the outputs.

Output Coordinate System: The coordinate system of the outputs.

Output Georeferenced: Indicates whether the output is georeferenced.

Note: If no georeference is given to the project (non geolocated images and no GCPs, or non geolocated images and GCPs in Local coordinate
system), then the output coordinate system is set to Local and no datum is displayed:
Output coordinate system: Local


https://support.pix4d.com/hc/en-us/articles/202558389

Processing
This section describes the progress of each of the 3 steps of the local processing:

Step (1): Initial Processing

Initial Processing Done:

NO: If the initial processing has not been done.

YES: If step 1. Initial Processing has been processed.

Average Ground Sampling Distance [cr/pixel]:

- ¢ If Initial Processing has not been done.

"GSD": Where "GSD" is the average Ground Sampling Distance.

Parameter Files Generated: The parameter files contain the results of the AAT, BBA, and optimized intemal and external camera parameters:
NO: If if the parameter files have not been generated.

YES: If the parameter files have been generated.

Step (2): Point Cloud and Mesh

Point Cloud and Mesh Done:

NQ: If the step 2. Point Cloud and Mesh has not been processed.

YES: If the step 2. Point Cloud and Mesh has been processed.

Image Scale: Scale of the image with which additional 3D points are computed:

- : If the Point Cloud and Mesh has not been generated.

1/2 (half image size, default): Half size images are used to compute additional 3D points.

1 (original image size, slow): The original image size is used to compute additional 3D points.
1/4 (quarter image size, fast): Quarter size images are used to compute additional 3D points.
1/8 (eighth image size, tolerant): Eighth size images are used to compute additional 3D points.
Point Density:

Optimal: Computed with an optimal point density.

High: Computed with a high point density. Processing time will increase.

Low: Computed with a low point density. Processing time will decrease.

Step (3): DSM, Orthomosaic and Index

DSM and Orthomosaic Generation Done:

NO: If step 3. DSM, Orthomosaic and Index has not been processed.

YES: If step 3. DSM, Orthomosaic and Index has been processed.

Resolution [cnvpixel]:

-: If step 3. DSM, Orthomosaic and Index has not been processed.

"Resolution": Where "Resolution" is the resolution of the DSM and of the Orthomosaic if step 3. DSM, Orthomosaic and Index has been processed.
Raster DSM Generated:

NO: If the Raster DSM GeoTIFF file has not been generated.

YES: If the Raster DSM GeoTIFF file has been generated.

Grid DSM Generated:

NO: If the Grid DSM GeoTIFF file has not been generated.

YES: If the Grid DSM GeoTIFF file has been generated.

Orthomosaic Generated:

NO: If the orthomosaic GeoTIFF file has not been generated.

YES: If the orthomosaic GeoTIFF file has been generated.

Google Maps Tiles and KML generated:

NO: If the Google Maps tiles and KML files for the orthomosaic have not been generated.
YES: If the Google Maps tiles and KML files for the orthomosaic have been generated.

Images
This section displays information about the images of the project:

Enabled Images: The number of images that are going to be used for initial processing.
Geolocated Images: The number of images that have geolocation data.

Datum: The datum of the images' geolocation.

Coordinate System: The coordinate system of the image' geolocation.

Note: If the images are not geolocated or are given in a Local coordinate system, then the coordinate system is set to Local and no datum is
displayed:
Coordinate System: Local

Ground Control Points
This section displays information about the GCPs of the project and is shown only if GCPs are defined.

Number of GCPs With Enough Image Marks: The number of GCPs that are marked on at least 2 images and the total number of GCPs.
Datum: The datum of the GCPs.
Coordinate System: The coordinate system of the GCPs.

Note: If the images are not geolocated or are given in a Local coordinate system, then the coordinate system is set to Local and no datum is
displayed:
Coordinate System: Local



(D Important: If there are less than 3 GCPs with enough image points, the following waming message appears in red color:

"At least 3 GCPs must have enough image marks to be taken into account during processing."

Index > Interface > Menu View > Map View © Previous | Next ©
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& Access: On the Menu bar, click View > Map View to open the Map View. The Layers section is displayed on the Map View Project Information sidebar.
For information about the sidebar’s display possibilities: 202558389.
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On the left part of the Layers, there is an arrow that allows the user to show/hide the layers by clicking on it.

W Layers (default): The Layers section is visible.

P olayers - The Layers section is not visible.

Each layer corresponds to one element type that appears on the 2D Map in the main window. There are 3 main layers:

Images
GCPs
Processing Area

l[j] Note: Each layer object can be shown/hidden on the 2D Map by selecting / unselceting the box next to the layer name.

W Layers

hd Images
Flight Plan
GCPs
Processing Area

Images

Displays the images of the project on the 2D Map as dots. The first image is displayed as a larger dot. By default, the images are displayed. Unselect the Images
box to hide the images.

A context menu is available when right clicking on the /Images layer. The following option is available:

Image Properties Editor: Opens the Image Properties Editor that allows the user to edit the image properties. For more information about the Image Properties
Editor. 202557849.

The Images layer has a sub-layer:

Flight plan: Displays the flight plan that was used to take the images as a green line starting from the larger dot (first image) and then following the images in
time. By default the flight plan is displayed. Unselect the Images box or the Flight plan box to hide the flight plan.

GCPs

Displays the Ground Control Points (GCPs) of the project on the 2D Map. By default, if the project has GCPs, the GCPs are displayed. Unselect the GCPs box
to hide the GCPs.

A context menu is available when right clicking on the GCPs layer. The following option is available:

GCP/MTP Manager: Opens the GCP/MTP Manager that allows the user to add or edit GCPs. For more information about the GCP/MTP Manager : 202558329.


https://support.pix4d.com/hc/en-us/articles/202558389

Processing Area
Displays the Processing Area of the project on the 2D Map. By default, if an area is defined, it is displayed. Unselect the Processing Area box to hide the area.
A context menu is available when right clicking on the Processing Area layer. The following options are available:

Draw
Import...
Edit...
Remowe

For more information about the Processing Area: 202557659.

Index > Interface > Menu View > Map View © Previous | Next ©
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& Access: On the Menu bar, click View > rayCloud.
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The use of the rayCloud is optional and it can be used to:

Visualize the different elements of the reconstruction (Camera Positions, Reprojections (rays), GCPs, Manual / Automatic Tie Points, Processing Area, Clipping
Box, Densified Point Cloud, Terrain / Objects / other classes of points, 3D Textured Mesh, Objects, Video Animation Trajectories) and their properties.
Visualize point clouds / Triangle Meshes using point clouds created in other projects or with other software.

Georeference a project using GCPs and /or Scale and Orientation constraints.

Create Orthoplanes to obtain mosaics of any selected plane (for example, building facades).

Verify / improve the accuracy of the reconstruction.

Assign points of the point cloud to different classes.

Improve the visual aspect.

Create objects and measure distances (Polylines), surfaces, and volumes.

Create 3D Fly-trought animations (Video Animation Trajectories).

Export different elements (GCPs, Manual / Automatic Tie Points, Objects, Video Animation Trajectories).

Create point cloud files using points belonging to one or seweral classes.

When selecting the rayCloud the following elements are displayed on the Main window:

Menu bar entry: The standard Menu bar items and an extra item.

Toolbar: The standard toolbar and some extra buttons specific to the rayCloud.

Left Sidebar: Displayed on the left of the 3D View. It consists of two sections: the Create section and the Layers section. The Create section allows the user to
create a Processing Area, Objects, Scale and Orientation Constraints and Orthoplanes. The Layers section displays the list of layers and sub layers (elements)
which are displayed on the 3D View. It allows the user to edit the display options of existing elements as well as to insert or import elements on the 3D View, and
export elements to file.

3D View: Displayed in the Main view. Displays in 3D the different elements.

Right sidebar: Displayed on the right of the 3D View. Displays different information depending the selected element.

Status bar: Displayed on the bottom right of the rayCloud view. Displays the coordinates when passing the mouse over any element displayed in the 3D View.



PixdDmapper Pro - mining_quarry - O X

Project Process View | rayCloud | Help

S a0 E el H h|lEo @@L B i Assign SO
il Project Process View Na d i ud E
e W (Create Properties & X
()
= = 24 -
Welome | B |[FD)| - || &[N |E| 2 e
U:D Densified Point
Mumber of Images Visible In: 30
Map View
—— W Layers Computed Position [m]: 31197591, 5169680.91, 524,64
Ta
e Cameras Help
Leavdoud 5 e
@ [®] Tie Points
Point Clouds
fiosac v [&] Point Groups
@ Unclassified
[0 @ Deleted
o [] Trizngle Meshes
Calculator Objects ¥ Images
T . ImageSize ZoomLevel S
@ @ |l %) ] 1 @ a X
~
[
Processing
—
=
]
Log Output
—
Processing
Options € > =

More information:

Video Tutorial: Introducing the rayCloud: 202561469.
Video Tutorial: rayCloud Tutorial: 202561479.
Webinar: Using the rayCloud: 202561629.

Status bar
On the bottom right part of the 3D View, the following is displayed:
WGS84 / UTM zone 32N - (311684.29, 5169774.29, 496.97) [m]

Selected Coordinate System: Displays the selected coordinate system of the point.
Position: Displays the (XY, 2) coordinates in meters / feet of each point of the 3D View when passing the mouse owver any element. When passing the mouse
ower the displayed elements, the coordinates change.

@ Important: In the rayCloud, the coordinate system is the output coordinate system.
By default the output coordinate system is the same as the GCPs coordinate system, if GCPs are used, otherwise it is the same as the image

geolocation coordinate system. If the coordinates system is WGS84, the output is given in UTM. If less than 3 images are geolocated and less than 3
GCPs are defined, then the output coordinates system is set to "Arbitrary".

Index > Interface > Menu View © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202561469
https://support.pix4d.com/hc/en-us/articles/202561479
https://support.pix4d.com/hc/en-us/articles/202561629

Index > Interface > Menu View > rayCloud © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud, and then click rayCloud.

The following options are displayed:

Viewpoint

Navigation Mode
Perspective/Orthographic
Change Background
Enable Realistic Sky

New Scale Constraint

New Orientation Constraint
New Orthoplane

New Polyline

New Surface

New Volume

New Video Animation Trajectory
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Viewpoint
Allows the user to select pre-defined viewpoints for the 3D View. These predefined viewpoints are accessible:

Using the Menu bar rayCloud > Viewpoint.
Using the keyboard.

Using the Menu bar rayCloud > Viewpoint.

View All: Mowes the viewpoint in order to fit all the layers in the 3D View.

Focus on Selection: Mowes the viewpoint in order to display in detail the selected element (point, camera).

Top: Mowes the viewpoint in such a way that the layers are viewed from the top and fits all the layers in the 3D View.

Front: Mowes the viewpoint in such a way that the layers are viewed from the front and fits all the layers in the 3D View.

Back: Mowes the viewpoint in such a way that the layers are viewed from the back and fits all the layers in the 3D View.

Left: Mowves the viewpoint in such a way that the view looks towards the left part of the layers and fits all the layers in the 3D View.
Right: Mowes the viewpoint in such a way that the view looks towards the right of the layers and fits all the layers in the 3D View.
Home: Movwes the viewpoint to the default viewpoint when opening the rayCloud and fits all the layers in the 3D View.

Using the keyboard

View All: Press "C" to mowe the viewpoint in order to fit all the layers in the 3D View.

Focus on Selection: Press "F" to mowe the viewpoint in order to display in detail the selected element (point, camera)

Top: Press "7" to mowe the viewpoint in such a way that the layers are viewed from the top and fit in the 3D View.

Front: Press "" to mowe the viewpoint in such a way that the layers are viewed from the front and fit in the 3D View.

Back: Press "Ctrl" + "1" to move the viewpoint in such a way that the layers are viewed from the back and fit in the 3D View.
Left: Press "3" to mowe the viewpoint in such a way that the layers are viewed from the left and fit in the 3D View.

Right: Press "Ctrl" + "3" to mowe the viewpoint in such a way that the layers are viewed from the right and fit in the 3D View.
Home: Press "0" to mowe the viewpoint to the default viewpoint when opening the rayCloud and fits all the layers in the 3D View
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Navigation Mode
Allows the user to change the way to navigate in the 3D View, which defines how the 3D \iew reacts when using the mouse or keyboard:

Standard: Pix4D standard navigation mode.

Trackball: The camera movements are defined relatively to a ball placed at the center of the iew. Recommended to efficiently navigate around a single centered
object.

First Person: Allows the user to interact with the view by simulating piloting the camera rather than manipulating the model. Recommended for close inspection
and complex models requiring more degrees of freedom.

For more information and full description of all the possible actions to navigate in the 3D View using the mouse or keyboard: 205360675.

Perspective/Orthographic

Defines the projection used to display the layers in the 3D View. By default the perspective projection is used. It is possible to switch between perspective and
orthographic projection by clicking on the Perspective/Orthographic option of the rayCloud Menu bar.

It is also possible to change the view type from perspective to orthographic using the keyboard by pressing "5".

Perspective projection: Parallel lines don't look parallel and further objects appear smaller. This is what human eyes see.
Orthographic projection: Parallel lines stay parallel. Therefore the size of objects does not depend on the distance. This view mode is recommended for technical
drawing.

Perspective projection vs Orthographic projection
For more information about Perspective/Orthographic projections:

Wiki Orthographic projection
Wiki Perspective projection

Change Background
Allows the user to change the color of the background in the 3D View.

The Select Color pop up appears:


https://support.pix4d.com/hc/en-us/articles/205360675
https://support.pix4d.com/hc/en-us/articles/205360675
https://support.pix4d.com/hc/en-us/articles/205360675
https://support.pix4d.com/hc/en-us/articles/205360675
http://en.wikipedia.org/wiki/Orthographic_projection
http://en.wikipedia.org/wiki/Perspective_projection

Select Color

Basic colors

|
Custom colors
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Sat: |EI = | Green: |255 :l

N O

val: 255 2| Blue: 255

-
-

Add to Custom Colors

Cancel

The Select Color pop-up has the following sections:

Basic colors: Selects a basic color.

Palette: Selects / modifies a color using the palette.

Color Properties Values: Modifies a color typing the color properties values (Hue,
Display of the selected color.

Sat, Val, Red, Green, Blue).

Add color to custom colors: Adds the selected color to custom colors, available for other projects.

And the action buttons:

OK: Confirms the changes.
Cancel: Does not sawe the changes.

Enable Realistic Sky

Allows the user to display a realistic sky gradient in the horizon of the plane where the project is based.
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Realistic Sky Disable

New Scale Constraint

Realistic Sky Enable

A Scale Constraint is a an line with known real Cartesian distance between 2 points, allowing to set up a local scale of the model.

It is a mathematical constraint over the geometry of the project.
It is used when:

No GCPs are not being used.



No good image geolocation is used for the images.

It is used to improve the relative accuracy (202556259) by adding a local scale to the project, by defining the real distance between 2 known points.

@ Important:
It is recommended to use the several Scale Constraint and distribute them along the project.
Once the Scale Constraints objects are added, it is needed to repotimize.

A Waming: When creating Scale Constraints, if the project does not have image geolocation, it is suggested as well to create Orientation Constraints to

set up an local orientation for the model.

j Example: In the real model, the user knows that the Cartesian distance between point 1 and point 2 is 5 meters, then, it is possible to create a scale

constraint (line) having as \ertices the Points A and B and setting up the distance between the points to 5 meters.

Right click on Objects and clicking New Scale Constraint allows the user to create a new 3D Scale Constraint.
For step by step instructions about how to draw a new Scale Constraint: 205360375.

Once a new Scale Constraint is created, the right sidebar displays the following information: 202558219.

3. Enter the Jwitia/ Length and its accuracy.

52 Objects 4. dlick Apply to save the changes.
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New Orientation Constraint

A Orientation Constraint is a line that represents a known axis, allowing to set up an local orientation of the model.
It is a mathematical constraint over the geometry of the project.

It is used when:

No GCPs are not being used.
No good image geolocation is used for the images.

It is used to awid a rotated model or to force a certain orientation for the model, by defining one or more desired axes (Xand /or Y and / or 2).


https://support.pix4d.com/hc/en-us/articles/202556259
https://support.pix4d.com/hc/en-us/articles/205360375

@ mportant:

In case of using seweral Orientation Constraint, if they represent a different axis (X Y, Z), they must be placed with 90° between each other to awid a

deformed model.

It is possible to create more than one Orientation Constraint for one axis (for example, X), then, the average value will be used.

Once the Orientation Constraints objects are added, it is needed to repotimize.

A Waming: When creating Orientation Constraints, if the project does not have image geolocation, it is suggested as well to create Scale Constraints

to set up a local scale of the model.

j Example: In the real model, the user knows that the desired orientation regarding the axis X Y, and Z then, it is possible to create 3 Orientation
constraint having 90° with each other and selecting which object represents which axis, defining a 3 dimensions coordinate system basis.

Right click on Objects and clicking New Orientation Constraint allows the user to create a new 3D Orientation Constraint.

For step by step instructions on how to draw a new Scale Constraint: 205360385.

Once a new Scale Constraint is created, the right sidebar displays the following information: 202558219.
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New Orthoplane

An Orthoplane is a tool to create one or several orthophotos of arbitrary areas of the model without having any impact / modifications in the model.

It is created by defining orthoprojection areas that allows to set up:

Area of interest (surface and depth).
Location.
Orientation and direction of the projection.

@ Important: It is important to define properly the box (orthoprojection area):
Area of interest (surface and depth).
Location.
Orientation and direction of the projection.

Only the geometry inside the box (points of the densified point cloud) will be used to find the projection surface.

Right click on Objects and clicking New Orthoplane allows the user to create a new 3D Orthoplane.


https://support.pix4d.com/hc/en-us/articles/205360385

For step by step instructions about how to draw a new Scale Constraint: 204664359.

Once a new Scale Constraint is created, the right sidebar displays the following information: 202558219.
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New Polyline

A Polyline Object is a continuous line composed of one or more sub-ines. It is created by specifying the vertices of each line. For more information about the
concept of Polyline: 202559829.

Right click on Objects and clicking New Polyline allows the user to create a new 3D Polyline, i.e. a polyline where each vertex has 3 coordinates.
For step by step instructions about how to draw a new Polyline: 202560309.

Once a new Polyline is created, the right sidebar displays the following information: 202558219.


https://support.pix4d.com/hc/en-us/articles/204664359
https://support.pix4d.com/hc/en-us/articles/202559829
https://support.pix4d.com/hc/en-us/articles/202560309
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New Surface

A Surface is an object that can be used to define planar areas such as a road, the roof of a building, etc. It can also be used to correct the DSM and generate a
better orthomosaic on these surfaces.

Right click on Objects and clicking New Surface allows the user to create a new 3D planar Surface, i.e. a surface where each vertex has 3 coordinates.

For step by step instructions about how to draw a new Surface: 202560269.

Once a new Surface is created, the Sidebar displays following information: 202558219.


https://support.pix4d.com/hc/en-us/articles/202560269
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New Volume

A Volume is an object that can be used for volume calculations. It is defined by a 3D Surface called base. The wlume is computed between the base and the

terrain surface.

Right click on Objects and clicking New Volume allows the user to create a new volume by defining the base.

For step by step instructions about how to draw a new volume: 202560319.

Once a New Volume is created, the Sidebar displays the following information: 202558219.


https://support.pix4d.com/hc/en-us/articles/202560319
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New Video Animation Trajectory
An Animation trajectory is a 3D Fly-trough Animation created as a video.

Right click on Objects and clicking New Video Animation Trajectory allows the user to create a new Video Animation Trajectory by defining the path of the
recording by creating waypoints.

For step by step instructions about how to create a 3D Fly-trough Animation: 202560299.

Once a new Animation Trajectory is created, the right sidebar displays the following information: 202558219.


https://support.pix4d.com/hc/en-us/articles/202560299
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Index > Interface > Menu View > rayCloud Previous | Next

& Access: On the Menu bar, click View > rayCloud.

PixdDmapper Pro - mining_guarry - O X

Project Process View rayCloud Help

e - a -, ~ J R— z S —
||__@ Lok Y 5 <’__|> <F—_|> @ @\ EC }{ 4, age E @ | t&l'] @«;” {#| = | | ~ Undassified Assign n l:l

Project Process View Mavigation Clipping Paint ¢ d Editing

1] View lavigatior L] oint Cloud

Index
Calculator

O

Processing

;|

sl
Log Cutput

°

Processing
Options

The following Toolbar buttons are displayed:

Standard Toolbar: For more information: 202557839.
Toolbar extra buttons:

Toolbar extra buttons

View

@, Zoom In: Zooms in the selected view.

@, Zoom Out: Zooms out the selected view.

&2 View All: Mowves the viewpoint in order to fit all the layers in the 3D View.

e Focus on Selection: Moves the viewpoint in order to display in detail the selected element (point, camera).

4} View from Top: Mowes the viewpoint in such a way that the layers are viewed from the top and fits all the layers in the 3D View.
Navigation

46 Set standard camera
@J Set trackball camera

<@ Set first person camera
Clipping
[ﬂ] Note: For step by step instructions about how use the clipping box in the rayCloud: 204048035.

@ Clip Point Cloud: Applies the Clipping Box in the 3D View and visualizes only the area contained in the Clipping Box.
‘EI’] Edit Cliping Box: Visualizes the Clipping Box in the 3D View, visualize the Clipping Box properties in the right sidebar and allows the user to edit it in the 3D
b

View and / or the right sidebar.

Point Cloud Editing


https://support.pix4d.com/hc/en-us/articles/205360675
https://support.pix4d.com/hc/en-us/articles/205360675
https://support.pix4d.com/hc/en-us/articles/205360675
https://support.pix4d.com/hc/en-us/articles/204048035

Note: The points of the Point Cloud can be edited by assigning them into a different point group. For step by step instructions about how to
edit the point cloud points in the rayCloud: 202560499.

Edit Densified Point Cloud: Enters / exits the Edit Point Cloud Densification mode, enabling / graying out the editing toolbar buttons below.
Add Points to Selection: Allows the user to select the points to be edited.

B Remowe Points from Selection: Allows the user to unselect the points to be edited.
o

Select All: Allows the user to select all the visible points to be edited.

D Clear Selection: Allows the user to dlear all the points selected to be edited.

%(Zg Invert Selection: Converts the selected points to be edited into unselected and vice versa.
i

Allows the user to select the Point Group to which the selected points will be assigned. The options are:

Unclassified: Selected by default. It contains points that do not belong to any other point group. By default, all the points are Unclassified.

Deleted: Points that will not be used for the step 3. DSM, Orthomosaic and Index. When processing step 3. DSM, Orthomosaic and Index, only the points
belonging to the point group Deleted will not be used.

(optional) Terrain: Generated automatically when running the Run Terrain/Object Point Cloud Classification or when step 2. Point Cloud and Mesh has been
completed while the processing option Classify Point Cloud into Terrain/Object Points is selected. It can also be created manually. When using the option
Generate DTM (beta), only the points belonging to the group Terrain will be used.

(optional) Objects: Generated automatically when running the Run Terrain/Object Point Cloud Classification or when the step 2. Point Cloud and Mesh has been
completed while the processing option Classify Point Cloud into Terrain/Object Points is selected. It can also be created manually.

(optional) Others: Any other Group created manually by the user.

New Point Group: Option to create new Point Groups. By clicking New Point Group, a pop-up appears, type the new point group name and click OK. The created
group is selected.

Assigns the selected points to the selected Point Group.

Index > Interface > Menu View > rayCloud © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202560499

Index > Interface > Menu View > rayCloud © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The left sidebar is displayed on the left of the main window.
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The left sidebar consists of the sections :

Create: This section allows the user to create a Processing Area, Orientation Constraints, Scale Constraints, Orthoplanes, Video Animations, Lines, Surfaces
and Volumes.
Layers: This section groups all the group of objects that can be displayed on the 3D View.

The left sidebar can be shown / hidden by dragging and dropping the left side border of the 3D View.

Index > Interface > Menu View > rayCloud © Previous | Next ©



Index > Interface > Menu View > rayCloud > Left sidebar © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Create section in the left sidebar is displayed on the left of the main window.

The Create section consists of icons that allow the user to create a Processing Area, Scale Constraints, Orientation Constraints, Orthoplanes, Polylines,

Surfaces and Volumes.

The Create section consists of the following icons:
imj Create Processing Area: Allows the user to create a Processing Area. This icon is grayed our once a Processing Area is created. For step by step

instructions: 202560179.
E Create a New Scale Constraint: Allows the user to create a new 3D Scale Constraint. For step by step instructions: 205360375.

{I_ Create a New Orientation Constraint: Allows the user to create a new 3D Orientation Constraint. For step by step instructions: 205360385.
@j Create a New Orthoplane Constraint: Allows the user to create a new 3D Orthoplane. For step by step instructions: 204664359.

%) . Create a New Video Animation Trajectory: Starts the New Video Animation Trajectory wizard. For step by step instructions: 202560299

i1 Create a New Polyline Object: Allows the user to create a new 3D Polyline. For step by step instructions: 202560309.

Create a New Surface Object: Allows the user to create a new 3D planar Surface. For step by step instructions: 202560269.

—o
[

Create a New Volume Object: Allows the user to create a new Stockpile. For step by step instructions: 202560319.

Index > Interface > Menu View > rayCloud > Left sidebar © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202560179
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Index > Interface > Menu View > rayCloud > Left sidebar Previous | Next

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

A layer is a group of objects that can be displayed on the 3D View. The Layers section of the left sidebar contains the following layers:

Cameras: Contains all the cameras of the project. One camera is associated to each image.

Rays: Allows the user to show / hide the rays between selected points in the model and the cameras where the point has been found. Contains the rays display
properties.

Tie Points: Contains the Manual Tie Points, GCPs, Check Points and Automatic Tie Points.

Processing Area: Contains the Processing Area.

Point Clouds: Contains point clouds (Densified Point Cloud and loaded external point clouds).

Point Groups: Contains the different groups of points (each point of the densified point cloud is assigned to one group).

Triangle Meshes: Contains Triangle Meshes (generated in Pix4D or imported).

Objects: Contains any drawn object: Polylines, Surfaces, Volumes, Video Animation Trajectories, Orthoplanes, Scale Constraints and Orientation Constraints.

Characteristics:

By clicking on the left arrow of a layer, the sub-layers and layer properties are shown or hidden.

By clicking on the a layer's check box, the corresponding layer is shown or hidden in the 3D View.
The different layer properties can be edited.

Some layers hawe a context menu that can be accessed by right clicking on the corresponding layer.
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Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

The Cameras layer contains the following sub-layers:

Display Properties: Displays properties for all the cameras.

Calibrated Cameras: The cameras that have been used for the reconstruction of the model.

Uncalibrated Cameras: The cameras that have not been used for the reconstruction. These cameras are cameras for which the optimized position could not be
computed during initial processing and that have been discarded from the reconstruction.

Disabled Cameras: The cameras that have been disabled by the user.
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Display Properties
The Display Properties layer allows to edit the display properties for all the cameras. The following properties can be edited:

Computed position: View/hide the calibrated (optimized) camera position sphere (this property affects only the Calibrated cameras).

Radius: Increases/decreases the computed camera positions' sphere radius (this property affects only the Calibrated cameras).

Color: Selects the computed camera positions' sphere color, the color for the projection lines (between the computed position and the comers of the thumbnails),
and the color for the thumbnails borders(this property affects only the Calibrated cameras).

Projection: View/hide projection lines between the computed camera positions and the thumbnails (this property affects only the Calibrated cameras).
Thumbnail: View/hide a thumbnail of the original images (this property affects only the Calibrated cameras).

Projection Distance: Increases/decreases the distance between the computed camera positions and the thumbnails (this property affects only the Calibrated
cameras).

Initial Position: View/hide the initial camera position sphere.

Radius: Increases/decreases the initial camera positions sphere radius.

Callibrated Color: Selects the initial camera positions' sphere color for the Calibrated Cameras (cameras used for the reconstruction).

Uncalibrated color: Selects the initial camera positions' sphere color for the Uncalibrated Cameras (cameras not used for the reconstruction).

Projection: View/hide projection lines between the computed camera positions and an hypothetical thumbnails (the thumbnail box appears but empty).



Projection Distance: Increases/decreases the distance between the computed camera positions and the hypothetical thumbnails.

Position Error: View/hide a line between initial and computed camera positions (this property affects only the Calibrated cameras).

Color: Color for the line between initial and computed camera positions (this property affects only the Calibrated cameras).

Calibrated Cameras

The Calibrated Cameras layer contains the list of Calibrated Cameras.

On the left of each camera name, the (5, icon is displayed to indicate that the camera is calibrated.
Uncalibrated Cameras

The Uncalibrated Cameras layer contains a list of Uncalibrated Cameras.

On the left of each camera name, the g, icon is displayed to indicate that the camera is uncalibrated.
Disabled Images

The Disabled images layes contains a list of the images disabled by the user.

On the left of each camera name, the (5, icon is displayed to indicate that the camera is disabled.

Index > Interface > Menu View > rayCloud > Left sidebar > Layers

© Previous | Next ©



Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.
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l[l] Note: Even if the layer Rays is selected, if the layer Cameras is not selected, the rays will not be visible.

The Cameras layer contains the following sub-layer:

Display Properties: Displays properties for all the rays.

Display Properties
The following properties can be edited:

Computed Ray Color: Selects the ray color for the projection lines between the selected 3D point and the calibrated cameras where the 3D point was visible but
not marked, crossing the thumbnail in the 3D point where the point is found in the original image.

Marked Ray Color: Selects the ray color for the projection lines between the selected 3D point and the calibrated cameras where the 3D point was marked,
crossing the thumbnail in the point where the 3D point is found in the original image.

Uncalibrated Ray Color: Selects the ray color for the projection lines between the selected 3D point and the not calibrated cameras.

Show Non Marked Rays: View/hide the rays for calibrated cameras where the 3D point was Visible but not marked.

Show Uncalibrated Rays: View/hide the rays for uncalibrated cameras.

Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©



Index > Interface > Menu View > rayCloud > Left sidebar > Layers Previous | Next

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

The Tie Points layer contains the following sub-layers:

Manual / GCPs: All the Manual Tie Points, 2D GCPs, 3D GCPs, and Check Points of the project.
Automatic: The Automatic Tie Points computed during initial processing. Only Tie Points \isible in at least 3 images are displayed.
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Manual / GCPs
The Manual / GCPs layer has the following structure:

Display Properties: Displays properties of all Manual Tie Points and GCPs.

Computed Position: View/hide the points optimized position.

Minimum Pixel Size: Defines the size of the points' computed positions on the screen (not the real size of the points with respect to the model). This property
allows the points to be visible both when \isualizing the model from very close and from very far. When the zoom lewel is abowve the given zoom lewel defined by the
Minimum size property, the points keep the same size on the screen independently from the zoom level. When zooming in closer to the model, below the zoom
level defined by the Minimum size property, the size of the points on the screen will increase each time the user zooms in so that the points remain visible even if
the view is close to the model.

Minimum Physical Size: Defines the minimum physical size of the points on the 3D View. This defines the zoom level below which the points need to be
displayed with their real size with respect to the model so that the points remain visible even when zooming in very close to the model.

Marked Color: Cross color of the points' computed positions for points marked on at least 2 images.

Non marked color: Cross color of the points' computed positions for points marked in less than 2 images.

Initial Position: View/hide the points' initial positions (this property affects only the GCPs and Check points).

Minimum Pixel Size: Defines the size of the points' initial positions on the screen (not the real size of the points with respect to the model). This property allows
the points to be \isible both when visualizing the model from very close and from very far. When the zoom lewel is abowe the given zoom level defined by the
Minimum size property, the points keep the same size on the screen independently from the zoom level. When zooming in closer to the model, below the zoom
level defined by the Minimum size property, the size of the points on the screen will increase each time zooming in so that the closer to the model the view gets,
the points remain visible.

Minimum Physical Size: Defines the physical minimum size of the points on the 3D View. This defines the zoom lewel below which the points need to be



displayed with its real size with respect to the model so that the points remain visible even when zooming in very close to the model.

Color: Cross color of the points' initial positions for GCPs.

Checkpoint Color: Cross color of the points' initial positions for Check Points.

Position error: View/hide the line between the points' initial and computed positions (this property affects only the GCPs and Check points).

Color: Color for the line between the points' initial and computed positions (this property affects only the GCPs and Check paints).

Show Error Ellipsoid: View/hide the ellipsoid formed by the theoretical error. For more information: 202559139.

Color: Color for the error ellipsoid.

Physical Size Scale: Defines the minimum physical size of the ellipsoid on the 3D View. This defines the zoom level below which the ellipsoid need to be
displayed with their real size with respect to the model so that the ellipsoid remain visible even when zooming in very close to the model.

List of Manual Tie Points, 2D GCPs, 3D GCPs and Check points: Each point has the following sub-element:

Display Properties: This layer allows the user to edit the display properties for the corresponding point. The properties that can be edited are the same than the
properties for all the points.

On the left of each point's name, an icon is displayed that indicates the type of the point. The type can be:

4, Manual Tie Point
o 2D GCP

+, 3D GCP

+, Check Point

By right clicking on the Manual / GCPs layer, a context menu with the following action appears:

Export Points: Opens the Export pop-up, allowing the user to export Manual Tie Points and/or, export initial and/or computed GCPs position.

l[l] Note: If the model does not have GCPs or Manual Tie Poaints, the option Export Points will be grayed out.

. Export ? Ed
Export Initial GCPs position Export Computed GCPs position Export Manual Tie Points
Look in; | 5:\Pix4Dmapper = |° O G @E]
‘ My Computer mining_quarry
a pixdd
File name: | | Save
Files of type: |EE'.R_I Shapefiles (*.shp) - | | Cancel

The available formats are:
AutoCad DFX (*.dfx)

ESRI Shapefiles (*.shp)

Keyhole Markup Language (*.kml)
Microstation DGN (*.dgn)

On the top of the Export pop-up there are 3 check-boxes that allow the user to select what kind of points to export:

Export Initial GCPs position : Exports the initial position of the GCPs.
Export Computed GCPs position: Exports the computed position of the GCPs.
Export Manual Tie Points: Export the Manual Tie Points.

By right clicking on a point layer, a context menu with the following actions appears:

Rename: Rename the point.
Remowe: Remowes the point.

Automatic

This layer displays the Automatic Tie Points that are computed during initial processing. Each Tie Point is \visible in at least 3 images. The Automatic layer has
the following sub-element:


https://support.pix4d.com/hc/en-us/articles/202559139

Display Properties: Displays properties of the Automatic Tie Points.
Point Size: Size for each point in the 3D View .

Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©
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& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.
The Processing Area layer appears on the Layers section of the left sidebar once a Processing Area is drawn.

Waming:

A It is recommended to include areas covered by images in the Processing Area, so as to exclude areas of low overlap that can affect the results.
The Processing Area affects only the visualization of the Automatic Tie Points in the 3D View of the rayCloud. It does not affect the results of step 7.
Initial Processing.
When the Processing Area is defined before step 2. Point Cloud and Mesh is processed, it affects the Point Cloud visualized in the 3D View of the
rayCloud and the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index.
When the Processing Area is defined after step 2. Point Cloud and Mesh is completed, it only affects the Point Cloud visualized in the 3D View of the
rayCloud but not the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index.
When exporting the Point Cloud, it is possible to take into account the Processing Area, even if it is drawn after step 2 is processed. For more
information about how to export the Point Cloud: 203890769.
When the Processing Area is defined before step 3. DSM, Orthomosaic and Index is completed, only the results of step 3 will be affected.

A Waming:
In order to take the Processing Area into account for the visualization of the Point Cloud and / or the generation of the outputs of step 2. Point Cloud and
Mesh, the comresponding filter should be selected in the Processing Options. For more information: 204644369.

The Processing Area will be taken into account for the results of step 3. DSM, Orthomosaic and Index even if the Processing Areas box is not selected
in the Point Cloud Filters.

lﬂ] Note: For step by step instructions about how to select a Processing Area: 202560179.
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By right clicking on the Processing Area layer a context menu with the following option appears:

Remove: Allows the user to remowe the Processing Area. The Create Processing Area icon in the Create section of the left sidebar can be used again to create a

new Processing Area. The Processing Area layer of the Layers section of the left sidebar is removed.

The Processing Area has the following sub-element:

Display Properties: Allows the user to edit the display properties for the Processing Area. The following properties can be edited:

Color: Color of the top, bottom, and side planes that define the area.

Vertex Color: Color of the spheres that represent the vertices of the middle plane of the area.

Vertex Radius: Radius of the spheres that represent the ertices of the middle plane of the area.

Line Color: Color of the lines between the \ertices of the planes (bottom, middle, and top planes) of the area.
Line Width: Width of the lines between the \ertices of the planes (bottom, middle, and top planes) of the area.

Index > Interface > Menu View > rayCloud > Left sidebar > Layers

© Previous | Next ©



Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

The Point Cloud layer contains the following sub-layers:

Densified Point Cloud: The point cloud that is generated after step 2. Point Cloud and Mesh.
External Point Clouds: Any other exteral point cloud(s) loaded into the project by dragging and dropping a point cloud file.

Note: By default, the different point clouds are not loaded or displayed:
The name of a loaded point cloud is displayed standard format, while the name of point clouds that are not loaded are displayed in italics.

4 Point Clouds
I» Display Properties
4 Densified Point Cloud
[ [ mining_guarry_densified_point_cloud

By clicking on the point cloud's check box, the corresponding point cloud's visibility is toggled in the 3D View.
Once step 2 is completed, when reopening a project, or when a point cloud has been unloaded:
The point clouds are not loaded in the rayCloud. The next time that the point cloud's check box is selected, the Information i0014 pop-up message

appears:

.| pixddmapper “

Information i00 14:

@ Layer "mining_quarry_densified_point_cloud” is not loaded.

Do you want to load it now?

["] Don't Display This Message Again

| ok | cancel

OK: Loads and displays the mentioned layer in the rayCloud.
Cancel: Closes the pop-up message and does not perform any action.
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Densified Point Cloud

The Densified Point Cloud layer has a sub-layer that displays the name of the available point cloud(s). If the point cloud has been generated by splitting it into
multiple parts, each part is displayed as one layer. On the left of the point cloud name there is an icon indicating that the layer is a point cloud: «;.

The loaded point cloud layer has the following sub-elements:

Display Properties: Allows to the user edit the display properties for the densified point cloud. The following property can be edited:

Point Size: Size of each point for the densified point cloud in the 3D View.

Shader: Defines the points shape and color in the 3D View. The different options are:

Screen Aligned Quads (default): Each point is drawn as a flat square where the point is located. It is the fastest to render but produces many artifacts when
changing the viewpoint. The color for each point comes from the reconstruction.

Spherical Paints: Each point is drawn as a non-perspective corrected sphere, for example, an approximated ball. It reduces the artifacts when moving the view but
is not correct when the points are very close to the viewpoint. It gives the best compromise between rendering speed and image quality. The color for each point
comes from the reconstruction

Spherical Points (HD): Each point is drawn as a perspective corrected sphere. This gives the highest image quality but it is very slow to render. The color for each
point comes from the reconstruction.

Screen aligned quads, Altitude (Red,Green,Blue): The same as Screen Aligned Quads but the color for each point is given by the altitude.

Spherical Paints, Altitude (Red,Green,Blue): The same as Spherical Points but the color for each point is given by the altitude.

Spherical Points (HD), Altitude (Red,Green,Blue): The same as Spherical Points (HD) but the color for each point is given by the altitude.

Screen aligned quads, Thermal: Useful for thermal project. The same as Screen Aligned Quads but the color for each point is given by the value of the channel in
the Ironbow palette.

Spherical Points, Thermal: Useful for thermal project. The same as Spherical Points but the color for each point is given by the value of the channel in the Ironbow
palette.

By clicking on an specific densified point cloud's check box, the corresponding point cloud is shown or hidden in the 3D View.
By right clicking on an specific densified point cloud's name, a context menu with the following action appears:

Load Layer: Visible if the point cloud is not loaded, loads the point cloud in the rayCloud.
Unload Layer: Visible if the point cloud is loaded, unloads the point cloud from the rayCloud.

@ Tip: Loaded layers consume RAM and GPU memory. Unloading layers that are not needed increases the speed using the rayCloud.



Export Point Cloud: Allows the user to export a Densified Point Cloud of all the selected Point Groups, with the selected properties, in the selected formats and
with the desired path / file name.

@ Important: If a Processing Area exists, only points withing the processing area are exported.

Useful in cases where:

The Point Cloud has been modified using the rayCloud (deleted points, changed or created the Processing area).
The intent is to export only one/some Point Groups.

Some point cloud format files were not generated (not selected in the processing options).

Change output options: Sawe/discard colors.

By clicking Export Point Cloud, the Export Point Cloud pop-up appears:

. Export Point Cloud *

Exported Data
Save Colors

Merge Tiles into One File
Export Groups
Unclassified

Format
LAS
Oiaz
] pry

[ xyz Delimiter: Space -

File Mame: hmh'onfpoint_doud,{rnining_quarryjmupl_densiﬁedjoint_doud| | Browse... |

ok || caneel | Help |

It contains 2 sections:
Exported Data: Allows the user to configure some parameters for the exporting and allows to select the Point Groups to export.
Sawe Colors: Selected by default, this saves the color values for each point of the Point Cloud of the .PLY file.

l[D Note: .las and .laz files always have color information. .xyz files do not have color.

Merge Tiles Into One File: Not selected by default. In case the Point Cloud output files were divided in parts, this forces to export all parts within the same file by
merging the parts.

A Waming: When generating the Point Cloud, if the file is too large and the computer memory cannot process the full file, it is divided in parts.

When exporting a point cloud and selecting Merge Tiles Into One file, the software requires less memory than when generating them. Howe\er, if the
computer resources are not sufficient, it may fail.

Export Groups: Allows the user to select which Point Groups will be exported for the Densified Point Cloud. By default, all the Point Groups are selected. When a
classification has been created (by creating Point Groups and assigning points to the groups or by using Terrain/Objects Point Cloud Classification (beta), more
point groups appear in the Export Groups section. By selecting the box next to the point group name, the point group will be exported.

A Waming: The exported Densified Point Cloud will contain all the Point Groups selected. By default all the Point Groups are
selected. The Deleted Point Group cannot be exported.

Format: Allows the user to select the different formats in which the Point Cloud is exported. It is possible to select:
LAS

LAZ

PLY

XYZ (it is possible to use as delimiter: Space, Tab, Comma and Semicolon).

And:

File Name: Displays the path and name where the Point Cloud will be stored. By default, this is the project folder where the Point Cloud is stored after step 2.
Point Cloud and Mesh.



Browse...: Allows the user to select the path/name where the the exported Point Cloud will be stored.

A Waming: If the exported Point Cloud file is saved with the same name in the same folder where an existing file exists, it will replace the existing Point
Cloud.

OK : Sawes the project and exports the selected formats with the selected parameters.
Cancel: Closes the pop-up message and does not perform any action.

External Point Clouds

It is possible to visualize other point clouds by selecting the point cloud file and dragging and dropping it onto the Point Clouds layer. A new sub-layer is added to
the Point Clouds layer with the path to the loaded file as name. The loaded point cloud has the following sub-element:

Properties: Displays properties for the corresponding point cloud.

Point Size: Size of each point for the corresponding point cloud in the 3D View.

Shader: Defines the points shape and color in the 3D View. The different options are:

Screen Aligned Quads (default): Each point is drawn as a flat square where the point is located. It is the fastest to render but produces many artifacts when
changing the viewpoint. The color for each point comes from the reconstruction.

Spherical Points: Each point is drawn as a non-perspective corrected sphere, for example, an approximated ball. It reduces the artifacts when moving the view but
is not correct when the points are very close to the viewpoint. It gives the best compromise between rendering speed and image quality. The color for each point
comes from the reconstruction

Spherical Points (HD): Each point is drawn as a perspective corrected sphere. This gives the highest image quality but it is very slow to render. The color for each
point comes from the reconstruction.

Screen aligned quads, Altitude (Red,Green,Blue): The same as Screen Aligned Quads but the color for each point is given by the altitude.

Spherical Points, Altitude (Red,Green,Blue): The same as Spherical Points but the color for each point is given by the altitude.

Spherical Points (HD), Altitude (Red,Green,Blue): The same as Spherical Points (HD) but the color for each point is given by the altitude.

The following formats can be loaded:

las
laz

Loaded point clouds are displayed in the right position if it is a Pix4Dmapper file or an extemnal file using the same coordinate system as the output coordinate
system selected in Pix4Dmapper.

Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©



Index > Interface > Menu View > rayCloud > Left sidebar > Layers Previous | Next

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.
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The Point Groups layer contains the following sub-layers:

Unclassified: Selected by default. It contains points that do not belong to any other point group. By default, all the points are Unclassified.

Deleted: Points that will not be used for the step 3. DSM, Orthomosaic and Index. When processing step 3. DSM, Orthomosaic and Index, only the points
belonging to the point group Deleted will not be used.

(optional) Terrain: Generated automatically when running the Run Terrain/Object Point Cloud Classification or when step 2. Point Cloud and Mesh has been
completed while the processing option Classify Point Cloud into Terrain/Object Points is selected. It can also be created manually. When using the option
Generate DTM (beta), only the points belonging to the group Terrain will be used.

(optional) Objects: Generated automatically when running the Run Terrain/Object Point Cloud Classification or when the step 2. Point Cloud and Mesh has been
completed while the processing option Classify Point Cloud into Terrain/Object Points is selected. It can also be created manually.

(optional) Others: Any other Group created manually by the user.

By clicking on an specific Point Group check box, the corresponding Point Group is shown or hidden in the 3D View.
By right clicking on an specific Point Group, a context menu with the following action appears:

Rename: Allows to change the Point Group name.
Removwe: Deletes the selected Point Group.

For:

Unclassified: Rename and Remowe are grayed out.
Deleted: Rename and Remowe are grayed out.
(optional) Terrain: Rename is grayed out.

(optional) Objects: Rename and Remowe are available.
(optional) Others: Rename and Remowe are available.

By right clicking on the Point Groups layer, a context menu with the following action appears:



New Point Group: Option to create new Point Groups. By clicking New Point Group, a new point group named Group1 will be created in the Point Groups sub-
layer.

Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©



Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

The Triangle Meshes layer can display a 3D Textured Mesh.

By default, the 3D Textured Mesh (if generated) is not loaded in the rayCloud. If it has been generated, by selecting it, it will be loaded and displayed in the
rayCloud.
By clicking the triangle mesh's check box, the corresponding triangle mesh is shown or hidden in the 3D View.

The Triange Meshes layer can also display a 2.5D Triangle Mesh of any point cloud file that has been loaded by dragging and dropping it on the Triangle
Meshes layer. The following formats can be dragged and dropped:

las
laz

It displays a 2.5D triangle mesh. Displayed in the right position if it is a Pix4Dmapper file or extemal file using the same coordinate system than the output
coordinate system selected in Pix4Dmapper.

A Waming: DO NOT drag and drop a point cloud to generate the Triangle Mesh while a project is processing: the processing may stop.

Once step 2. Point Cloud and Mesh is completed, when reopening a project, or when a triangle mesh has been unloaded:
The Triangle Meshes are not loaded in the rayCloud. Next time that the triangle mesh's check box is clicked, the triangle mesh is loaded again.
The Triangle Meshes layer contains the following sub-layers:

Display Properties: Displays properties for all the triangle meshes.
List of triangle meshes: All the triangle meshes loaded in the project.

Display Properties
Displays properties for all the triangle meshes.
Allows the user to edit the display properties for all the triangle meshes. The following properties can be edited:

Color: The color of all the triangles of the triangle meshes. The color is only applied to the monochrome shader. The default color is gray.

Shader: Specifies the way each triangle of the mesh is colored. The color is related to the 3D position of each triangle. The mesh can be colored in different ways:
Textured: Selected by default for the 3D textured Mesh generated for the project. Not available for dragged and dropped triangle meshes. The triangles are colored
with the texture file generated when generating the 3D Textured Mesh.

Monochrome: The triangles are colored with a color-to-black scale that depends on an angle measured with respect to a virtual sun positioned 45 degrees from
the north-east horizon. It uses the color selected abowe.

Color: The triangles are colored with an RGB scale. The color of a triangle depends on an angle measured with respect to 3 virtual suns that have Red, Green, and
Blue illumination. The color of each triangle is the combination of the light received by the three virtual suns. This shader displays a slope map if the model is
viewed from abowe. It gives information about the orientation of each surface.

Altitude (Red, Green, Blue): The triangles are colored with an RGB scale. The color of a triangle depends on the altitude of the triangle.

Altitude (Topography): The triangles are colored with a default scale. The color of a triangle depends on the altitude of the triangle.

Thermal: Useful for thermal project. The triangles are colored according to the channel value in the Ironbow palette.
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List of triangle meshes

By default, the 3D Textured Mesh (if generated) is not loaded in the rayCloud. If it has been generated, by selecting it, it will be loaded and displayed in the
rayCloud. By clicking the triangle mesh's check box, the corresponding triangle mesh is shown or hidden in the 3D View.

By right clicking on an specific triangle mesh's name, a context menu with the following action appears:

Load Layer: Visible if the triangle mesh is not loaded, load the triangle mesh in the rayCloud.
Unload Layer: Visible if the triangle mesh is loaded, unload the triangle mesh from the rayCloud.

Each triangle mesh layer has the following sub-element:

Displays Properties: Displays properties for the corresponding triangle mesh and only apply to the corresponding triangle mesh. The same properties are available
for all triangle meshes.

On the left of the triangle mesh name, there is an icon indicating that the layer is a triangle mesh: g, .

4 b Mesh mining_quarry_simplified_3d_mesh
4 Display Properties

Color |

Shader Textured v

Index > Interface > Menu View > rayCloud > Left sidebar > Layers Previous | Next



Index > Interface > Menu View > rayCloud > Left sidebar > Layers Previous | Next

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.
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The Objects layer contains the following sub-layers:

Polylines: Contains the list of polylines added to the project. A Polyline object is a continuous line composed of one or more sub-lines. It is created by specifying
the vertices of each line. For more information about the concept of polyline: 202559829.

Surfaces: Contains the list of surfaces added to the project. A Surface object can be used to define planar areas such as a road, the roof of a building, etc. It can
also be used to correct the DSM and generate a better orthomosaic on these surfaces.

Volumes: Contains the list of volumes added to the project. It can be used for volume calculation. It is defined by a 3D surface called a base. The volume is
computed between the base and the terrain surface.

Animation Trajectories: Contains the list of Animation Trajectories added to the project. The animation Trajectories consist of waypoints that define the path for
an imaginary camera that records the scene.

Orthoplanes: Contains the list of Orthoplanes added to the project. The Orthoplane is a tool to create one or several orthophotos of arbitrary areas of the model
without having any impact / modifications in the model.

Scale Constraints: Contains the list of Scale Constraints added to the project. The Scale Constraint is a line with known real Cartesian distance between 2
points, allowing to set up a local scale of the model.

Orientation Constraints: Contains the list of Orientation Constraints added to the project. The Orientation Constraints is a line that represents a

known axis, allowing to set up an local orientation of the model.


https://support.pix4d.com/hc/en-us/articles/202559829
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Figure 1. Polyline object
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Polylines

Contains the list of polylines added to the project. A Polyline object is a continuous line composed of one or more sub-lines. It is created by specifying the
\ertices of each line. For more information about the concept of Polyline: 202559829.

The Polylines layer has the following structure:

Display Properties: This layer allows the user to edit the display properties all the polylines.

Vertex Color: Color of the spheres that represent the vertices of the polylines.

Vertex Radius: Radius of the spheres that represent the vertices of the polylines.

Line Color: Color of the lines between the \ertices of the polylines.

Line Width: Width of the lines defining the polylines.

List of Polylines: Each Polyline has the following sub-element:

Display Properties: This layer allows the user to edit the display properties of the line. The properties that can be edited are the same than the Display properties
of the Polylines listed above.

By right clicking on the Polylines sub-layer, a context menu with the following options appears:

New Polyline: Allows the user to draw a new polyline. For step by step instructions: 202560309.
Export All Polylines: Opens the Export pop-up that allows the user to export the corresponding components from the polyline into a file.

@ Important: A Polyline is composed of lines and vertices to which Manual Tie Points are associated.

The following file formats can be selected for export:
AutoCad DFX(.dfx).

ESRI Shapefiles (.shp).

Keyhole Markup Language (.kml).

Microstation DGN (.dgn).

The type of components to export can be selected. The following components can be exported:

Export Vertices: Exports the ertices of the the Polylines.
Export Lines: Exports the lines of the the Polylines.

@ mportant:
The option Export All Polylines is enabled only if at least one Polyline has been drawn.

Surfaces
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Contains the list of surfaces added to the project. A Surface object can be used to define planar areas such as a road, the roof of a building, etc. It can also be
used to correct the DSM and generate a better Orthomosaic on these surfaces.

The Surfaces layer has the following structure:

Display Properties: This layer allows the user to edit the display properties for all the surfaces.

Vertex Color: Color of the spheres that represent the vertices of the surfaces.

Vertex Radius: Radius of the spheres that represent the \ertices of the surfaces.

Line Color: Color of the lines between the \ertices of the surfaces.

Line Width: Width of the line defining the surface areas.

Base: View/hide the base of the surfaces.

Color: Color of the base of the surfaces.

Shader: Specifies the way each triangle of the base surfaces is colored. The color is related to the 3D position of each triangle. 2 ways of coloring the triangles
are available:

Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a virtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected above.

Color: The triangles are colored with a RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and

Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.

List of Surfaces: Each Surface has the following sub-element:

Display Properties: This layer allows the user to edit the display properties of a surface. The properties that can be edited are the same than the Display
Properties of the Surfaces listed abowe.

By right clicking on the Surfaces sub-layer, a context menu with the following options appears:

New Surface: Allows the user to draw a new surface. For step by step instructions: 202560269.
Export All Surfaces: Opens the Export pop-up that allows the user to export the corresponding components from the surface into a file.

@ Important: A Surface is composed of surfaces, lines and vertices to which Manual Tie Points are associated.

The following file formats can be selected for export:
AutoCad DFX(.dfx).

ESRI Shapefiles (.shp).

Keyhole Markup Language (.kml).

Microstation DGN (.dgn).

The type of components to export can be selected. The following components can be exported:

Export Vertices: Exports the ertices of the Surfaces.
Export Lines: Exports the lines of the Surfaces.
Export Surfaces: Exports the surface meshes of the Surfaces.

@ Important:
The options Export All Surfaces is enabled only if at least one Surface has been drawn.

Volumes

Contains the list of volumes added to the project. It can be used for volume calculation. It is defined by a 3D surface called a base. The wolume is computed
between the base and the terrain surface.

The Volumes layer has the following structure:

Display Properties: This layer allows the user to edit the display properties for all the volumes.

Vertex Color: Color of the spheres that represent the vertices of the bases of the volumes.

Vertex Radius: Radius of the spheres that represent the vertices of the bases of the volumes.

Line Color: Color of the lines between the vertices of the bases of the volumes.

Line Width: Width of the lines defining the bases of the volumes.

Base: View/hide the basex of the volumes.

Color: Color of the bases of the volumes.

Shader: Specifies the way each triangle of the bases of the volumes is colored. The color is related to the 3D position of each triangle. There are 2 ways of
coloring the triangles available:

Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a virtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected above.

Color: The triangles are colored with an RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and

Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.

Terrain: View/hide the triangles defining the terrain. These triangles are generated using the base of the volume and the points above and below that surface.
Color: Color of the triangles defining the terrain. These triangles are generated using the base surface and the points above and below that surface (this property
only affects Volume objects).

Shader: Specifies the way each triangle defining the terrain is colored. The color is related to the 3D position of each triangle. 2 ways of coloring the triangles are
available:
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Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a \irtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected abowe.

Color: The triangles are colored with a RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and

Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.

List of Volumes: Each object has the following sub-element:

Display Properties: This layer allows the user to edit the Display Properties of a Volume. The properties that can be edited are the same as the Display
Properties of the Volumes listed abowe.

By right clicking on the Volumes sub-layer, a context menu with the following options appears:

New Volume: Allows the user to draw a new wlume. For step by step instructions: 202560319.
Import Volume: Opens the Import Volume pop-up that allows the user to import Volumes created previously with Pix4Dmapper for the same area of study or
created manually.

@ mportant:
To import a wolume created previously with Pix4Dmapper, it has to be a .shp file that contains surfaces (name_surfaces.shp) or vertices
(name_vertices. shp).
To import a wolume created with an extemal software, it has to be a .shp file that contains a 3D polygon (surface) or 3D ertices.
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Contains the sections:

Navigation window: Used to search for and select the file to be imported.
File name: Displays the name of the selected file to be imported.
Files of type: Displays the possible formats accepted for the input file: Shape files (.shp) are accepted.

And the action buttons:

Open: Imports the selected file.
Cancel: Does not import the Volume and exits the pop-up.
Help: Opens the Pix4Dmapper help.
Export All Volumes: Opens the Export pop-up that allows the user to export the corresponding components from the volume into a file.

@ Important: A Volume is composed of volume meshes, lines, and \ertices to which Manual Tie Points are associated.

The following file formats can be selected for export:
AutoCad DFX (.dfx).

ESRI Shapefiles (.shp).

Keyhole Markup Language (.kml).

Microstation DGN (.dgn).

The type of components to export can be selected. The following components can be exported:
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Export Vertices: Exports the ertices of the Volumes.
Export Surfaces: Exports the surface meshes of the Volumes.
Export Meshes: Exports the volume meshes of the Volumes.

@ Important:
The options Export All Volumes is enabled only if at least one Volume has been drawn.

List of objects
Each object layer has the following sub-element:

Display Properties: Displays properties of the corresponding objects. The properties that can be edited are not the same for all the objects.
l[D Note: Changing the Display Properties of the selected object, affects only to the selected object.

On the left of the object name, there is an icon indicating the type of the object:

Polyline
Surface

Volume

o—n
™
o—g

[l 15§

By right clicking on a specific object's layer, a context menu with the following options appears:

Insert Vertices: Insert \ertices on the line between existing ertices of the object.

Append Vertices: Insert \ertices after the last vertex inserted for the object.

Rename: Rename the object.

Export: Opens the Save objects pop-up that allows the user to export the corresponding components from the selected object into a file.

@ mportant:
A Polyline is composed of lines and vertices to which Manual Tie Points are associated.

A Surface is composed of a surface mesh and vertices to which Manual Tie Points are associated.
A Volume is composed of a surface mesh, volume meshes and \ertices to which Manual Tie Points are associated.

The following file formats can be selected for export:
AutoCad DFX (.dfx).

ESRI Shapefiles (.shp).

Keyhole Markup Language (.kml).

Microstation DGN (.dgn).

The type of components to export can be selected. Depending on the object types, not all type of components are available. The following components can
be exported:

For a Polyline it is possible to:

Export Vertices: Exports the ertices of the the Polyline.
Export Lines: Exports the lines of the the Polyline.

For a Surface it is possible to:
Export Vertices: Exports the ertices of the Surface.
Export Surfaces: Exports the surface mesh of the Surface.

For a Volume it is possible to:

Export Vertices: Exports the vertices of the Volume.
Export Surfaces: Exports the surface mesh of the Volume.
Export Meshes: Exports the volume mesh of the Volume.
Remowe: Remowes the selected object.

@ mportant:
The option Remove do not delete the Manual Tie Points generated when drawing the object (when drawing an object Polyline, Surface or Volume,

the vertices create Manual Tie Points).

Animation Trajectories

Contains the list of Animation Trajectories added to the project. The Animation Trajectories consist of waypoints that define the path for an imaginary camera that
records the scene.

The Animation Trajectories layer has the following structure:



Display Properties: Displays properties of the corresponding objects. The properties that can be edited are:

Start Vertex Color: Color of the spheres that represent the first waypoints.

Vertex Color: Color of the spheres that represent the waypoints.

Vertex Radius: Radius of the spheres that represent the waypoints.

Line Color: Color of the lines between waypoints.

Line Width: Width of the line defining the path between waypoints.

List of Animation Trajectories: Each Animation Trajectory has the following sub-element:

Display Properties: This layer allows the user to edit the display properties of the Animation Trajectories. The properties that can be edited are the same than the
Display properties of the Animation Trajectories listed abowe.

By right clicking on the Animation Trajectories sub-layer, a context menu with the following options appears:

New Video Animation Trajectory: Allows the user to create a new Animation Trajectory. For step by step instructions: 202560299.
Import...: Opens the Import Video Animation Trajectory pop-up that allows the user to import Animation Trajectories created previously with Pix4Dmapper for
the same area of study or created manually.

For step by step instructions about how to import an Animation Trajectory with the rayCloud: 202560569.
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Contains the sections:

Navigation window: Used to search for and select the file to be imported.
File name: Displays the name of the selected file to be imported.
Files of type: Displays the possible formats accepted for the input file: .csvand .txt are accepted.

And contains the action buttons:

Open: Imports the selected file.
Cancel: Does not import the animation and exits the pop-up.
Help: Opens the Pix4Dmapper help.

@ Important: Manually created Animation Trajectories must have the same format and extension than files generated when exporting an Animation
Trajectory with Pix4D.

List of Animation Trajectories
On the left of the object name, there is an icon indicating the type of the object:

[+ls] imati 1
oe Animation Trajectory

By right clicking on a specific object's layer, a context menu with the following options appears:
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Rename: Rename the object.
Remowe: Removwes the selected object.
Export...: Opens the Export Video Animation Trajectory pop-up that allows the user to export the selected Animation Trajectory.

For step by step instructions about how to export an Animation Trajectory with the rayCloud: 203123429.
Contains the action buttons:

Sawe: Confirms the path and name to export the animation and opens the Video Animation Trajectory File Parameters pop-up:

| Video Animation Trajectory File Parameters ~ — O *

i |

Comment Character | # |

Separator Character

[] write Interpolated Points

ok || caneel || Hep |

Contains the option:
Separator Character: Character to be used as separator for the different information for each waypoint / interpolated Point:
Time [s], Position X, Position Y, Position Z, Rotation X, Rotation Y, Rotation Z.

l[_]] Note: The default value for separator ";" in Microsoft Excel is read as Tab and will place each separated text on one column.

Comment Character: Character to be used as first character for the comment lines which include information about the video animation options:

Name, Time computation, Interpolation, Max speed, Duration, Number of points, Distance unit of measure, Angle unit of measure.

Wiite Interpolated Points [m]: By default it is not selected. Only the video animation options, the created waypoints and its coordinates are stored. Select White
Interpolated Points [m] to store as well intermediate points between consecutive waypoints.

By default, the value is 1, and it will crate one intermediate point every each meter.

Cancel: Does not export the animation and exits the pop-up.
Help: Opens the Pix4Dmapper help.

@ Important: It is possible to export Animation Trajectories as CSV files which can be opened with any text editor or spreadsheets editor.

Orthoplanes

Contains the list of orthoplanes added to the project. An Orthoplane is a tool to create one or several orthophotos of arbitrary areas of the model without having
any impact / modifications in the model.

The Orthoplanes layer has the following structure:

Display properties: This layer allows the user to edit the display properties for all the orthoplanes.

Color: Color of the top, bottom, and side planes that define the area.

XHandle Color: Color of the Xlocation arrow and X dimension sphere.

Y Handle Color: Color of the Y location arrow and Y dimension sphere.

Z Handle Color: Color of the Z location arrow and Z dimension sphere.

Near Plane Edge Color: Color of the lines that define the surface that represents the origin of the projection.

Far Plane Edge Color: Color of the lines that define the surface that represents the limit of the projection.

List of Orthoplanes: Each object has the following sub-element:

Display Properties: This layer allows the user to edit the display properties for the orthoplane. The Display Properties that can be edited are the same as the
Display Properties of the Orthoplanes listed above.

By right clicking on the Orthoplanes sub-layer, a context menu with the following options appears:
New Orthoplane: Allows the user to create a new 3D Orthoplane. For step by step instructions: 204664359.
By right clicking on a specific object's layer, a context menu with the following options appears:

Rename: Rename the object.
Remowe: Remowes the selected object.

Scale Constraints

Contains the list of Scale Constraints added to the project. A Scale Constraints object is a line with known real Cartesian distance between 2 points, allowing to
set up a local scale for the model.

The Scale Constraints layer has the following structure:
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Display Properties: This layer allows the user to edit the display properties for all the Scale Constraints.

Vertex Color: Color of the spheres that represent the \ertices of the Scale Constraints.

Vertex Radius: Radius of the spheres that represent the ertices of the Scale Constraints.

Line Color: Color of the lines between the \ertices of the Scale Constraints.

Line Width: Width of the line defining the distance between vertices of the Scale Constraints.

List of Scale Constraints: Each object has the following sub-element:

Display Properties: This layer allows the user to edit the Display Properties of the Scale Constraint. The properties that can be edited are the same as the
Display Properties for the Scale Constraint listed above.

By right clicking on the Scale Constraints sub-layer, a context menu with the following options appears:
New Scale Constraint: Allows the user to create a new 3D Scale Constraint. For step by step instructions: 205360375.
By right clicking on a specific object's layer, a context menu with the following options appears:

Remowe: Remowes the selected object.

Orientation Constraints

Contains the list of Orientation Constraints added to the project. An Orientation Constraints object is a line that represents a known axis, allowing to set up an
local orientation for the model.

The Orientation Constraints layer has the following structure:

Display properties: This layer allows the user to edit the display properties for all the Scale Constraints.

Vertex Color: Color of the spheres that represent the vertices of the Orientation Constraints.

Vertex Radius: Radius of the spheres that represent the ertices of the Orientation Constraints.

Line Width: Width of the line defining the Orientation Constraints.

List of Orientation Constraints: Each object has the following sub-element:

Display Properties: This layer allows the user to edit the Display Properties of the Orientation Constraint. The Display Properties that can be edited are the
same as the Display Properties for the Orientation Constraints listed above.

By right clicking on the Orientation Constraints sub-layer, a context menu with the following options appears:
New Orientation Constraint: Allows the user to create a new 3D Orientation Constraint. For step by step instructions: 205360385.
By right clicking on a specific object's layer, a context menu with the following options appears:

Remowe: Remowes the selected object.

Index > Interface > Menu View > rayCloud > Left sidebar > Layers © Previous | Next ©
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Index > Interface > Menu View > rayCloud Previous | Next

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The 3D View is displayed in the center of the main window.

The 3D View displays the different objects defined in a project, such as the cameras, the GCPs, etc.The different layers that are displayed in the 3D View and that are
also visible in the Layers section of the left sidebar are:

Cameras: This layer groups all the cameras of the project (calibrated, uncalibrated and disabled). One camera is associated to each image of the project. It is defined by
its initial position (if known), the optimized position and orientation.

Rays: They are displayed when clicking on a 3D point on the 3D View if the Cameras and the Rays layers are shown. The 3D point is projected to all the calibrated
cameras in which the point is visible. The rays cut the thumbnails of the cameras at the location where the point is Misible in the original images.

Tie Points: This layer groups all the Manual Tie Points, GPCs, Check Points, and Automatic Tie Points. The Automatic Tie Points are computed during initial processing.
Processing Area: This layer display the Processing Area defined in the Map View or the rayCloud.

Point Clouds: This layer groups all the point clouds. It contains the Densified Point Cloud and the dragged-and-dropped point clouds.

Triangle Meshes: This layer groups the 3D Textured Mesh and triangle meshes generated by triangulating a point cloud that is loaded as a triangle mesh.

Objects: This layer groups all the objects defined by the user. These objects can be Polylines, Surfaces, Volumes, Animation Trajectories, Orthoplanes, Scale
Constraints and Orientation Constraints.

Clipping Box: This tool allows to visualize only the points included in the Clipping Box. This tool is not visible in the Layers section of the left sidebar.

The layers can be shown/hidden using the Layers sections of the left sidebar, which can also be used to change the display properties (color, size, etc.) of each layer.

For more information about the Layers section of the left sidebar: 202558089.

@ Important: It is possible to change the Points Density by Press "Alt" + "+" or "AltGr" + "- " in order to increase or decrease the density, "Alt" + "0" reset the
Points Density to default values.

@ Important: The navigation in the 3D View (how the 3D view reacts when using the mouse or keyboard) depends on the Navigation Mode selected. For more
information and full description of all the possible actions to navigate in the 3D View using the mouse or keyboard: 205360675.

@ Important: Several predefined viewpoints exist such as top view, front view, etc. These predefined viewpoints are accessible using the keyboard and are using the
Menu bar rayCloud > Viewpoint. For more information about the available viewpoints: 202558069.


https://support.pix4d.com/hc/en-us/articles/205360675
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By default, the Camera layers are displayed on the 3D View as:

Blue sphere: Initial camera positions (GPS coordinates).

Green sphere: Optimized camera positions.

Red sphere: Initial camera positions (GPS coordinates) for Uncalibrated Cameras for which Pix4Dmapper could not find optimized positions and therefore were not used
for the reconstruction.

Pale Red sphere: Initial camera positions (GPS coordinates) for Uncalibrated Cameras that were disabled by the user and were not used for the reconstruction.

Green line: Distance between initial and optimized positions.

Green lines: Projection lines between the optimized camera positions and the original image thumbnails.

Green squares: Borders of the original image thumbnails.
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Rays

By default, the rays can hawe the following colors:

Green rays: The rays that connect the selected 3D point and the calibrated cameras in which the 3D point was \isible but not marked.

Orange rays: The rays that connect the selected 3D point and the calibrated cameras in which the 3D point was marked.

Red ray: The rays that connect the selected 3D point and the not calibrated cameras.

Light Blue ray. The ray that connects the selected 3D point with the image that is currently selected in the Image View, and on which the point is visible but not marked.
Light Purple ray. The ray that connects the selected 3D point with the image that is currently selected in the Image View, and on which the point has not been marked.
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Rays

Tie Points

By default, the Tie Points are displayed on the 3D View as:

Green cone: Optimized position of Manual Tie Points, GCPs, Check Points, and \ertices of the Objects drawn in the 3D View that are marked in at least 2 images.
Orange cone: Vertices of the Objects drawn in the 3D View that are marked in less than 2 images.

Blue cone: Original position of GCPs and Check Points.

Colored point: Automatic tie point computed at step 7. Initial Processing colored using the original images.
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Processing Areas

By default, a Processing Area is displayed on the 3D View as:

Gray spheres: Vertices of the middle plane of the 3D Processing Area.

Gray lines: Lines between the vertices of the planes (bottom, middle, and top planes) of the 3D Processing Area.

Transparent gray planes: Top, bottom, and side planes that form the 3D Processing Area.

Transparent light gray planes: Top, bottom, and side planes that form the 3D Processing Area when howering over the area in the 3D View.

White lines: Lines between the vertices of the planes (bottom, middle, and top planes) of the 3D Processing Area when selecting the area in the 3D View.
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Processing Area: Point Cloud Densification Area

Point Clouds
By default, the Point Clouds are displayed on the 3D View using the 3D coordinates of their points as computed by Pix4Dmapper.

The coordinates of a given point are displayed on the bottom right part of the main window when the point is selected in the 3D View.
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Densified Point Cloud

Triangle Meshes

By default, the 3D Textured Mesh is displayed using the Texture shader and other triangle meshes are displayed using the Monochrome shader with gray color. For
more information about the Display Options of the Triangle Meshes: 202558079.
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Objects

By default, the Objects are displayed on the 3D View as:

For Palylines, Surfaces, Volumes and Video AnimationTrajectories:

Green sphere: Object vertices for Polylines, Surfaces and Volumes. Waypoints for Animation Trajectories.
Green Arrow. Orientation of the camera in the waypoint (only for Animation Trajectories).

Blue sphere: First Waypoint in Animation Trajectories (only for Animation Trajectories).

Blue Arrow. Orientation of the camera in the first waypoint (only for Animation Trajectories).

Green surface: Base surface for Surfaces and Volumes.

Green lines: Lines between \ertices/waypoints from the same object. For Polylines, Surfaces, Volumes and Animation Trajectories.
Red Terrain: Triangles below and abowve the base surface and the terrain defined by the Point Cloud (only for Volumes).
For Scale Constraints:

Light Blue double arrow. Scale Constraints.

For Orientation Constraints:

Dark Blue single arrow; Orientation Constraints.

For Orthoplanes:

Red sphere: Allows to increase the 3D orthoplane in the X Dimension.

Blue sphere: Allows to increase the 3D orthoplane in the Y Dimension.

Green sphere: Allows to increase the 3D orthoplane in the Z Dimension.

Red cone: Allows to mowe the 3D orthoplane in the X Dimension.

Blue cone: Allows to move the 3D orthoplane in the Y Dimension.

Green cone: Allows to move the 3D orthoplane in the Z Dimension.

Gray lines: Lines between the vertices of the planes of the 3D orthoplane.

Light gray lines: Defines the frontal surface of the 3D orthoplane (face that will be mapped).

Transparent light blue planes: Side planes that form the 3D orthoplane.
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Clipping Box

Pink spheres: Allows to increase the 3D area in the Xdimension.

Light blue spheres: Allows to increase the 3D area in the Z dimension.
Light green spheres: Allows to increase the 3D area in the Y dimension.
Light purple sphere: Allows to rotate the 3D area.

Transparent light blue planes: Side planes that form the 3D area.
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Index > Interface > Menu View > rayCloud

Previous | Next



Index > Interface > Menu View > rayCloud Previous | Next

Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
For information about the sidebar’s display possibilities: 202558389.
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The rayCloud right sidebar displays different information for the element that is currently selected in the 3D View. The elements that can be selected in the 3D
View are:

Clipping box

Cameras

GCPs and Manual Tie Points
Automatic Tie Points
Processing Area

Point Clouds

Objects: Polylines, Surfaces, Volumes, Animation Trajectories, Orthoplanes, Scale constraints and Orientation Constraints

Index > Interface > Menu View > rayCloud Previous | Next


https://support.pix4d.com/hc/en-us/articles/202558389

Index > Interface > Menu View > rayCloud > Right sidebar Previous | Next

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. In the toolbar, click the button ,EI,] . The right sidebar is displayed on the right of
by

the main Window.
The Clipping Box is displayed in the 3D View and the Clipping Box Properties are displayed in the right sidebar.

Note: The Clipping Box only affects the display, not the results of any outputs of step 1. Initial Processing, the Densified Point Cloud or step 3. DSM,
Orthomosaic and Index.
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The following information is displayed:

Center X[m]: Relative X coordinate of the center of the Clipping Box.
Y [m]: Relative Y coordinate of the center of the Clipping Box.

Z[m]: Relative Z coordinate of the center of the Clipping Box.

Size X[m]: Size in meters of the X side of the Clipping Box.

Y [m]: Size in meters of the Y side of the Clipping Box.

Z[m]: Size in meters of the Z side of the Clipping Box.

Rotation Z [degree]: Represents the angle between:

The Xaxis of the model and the Xaxis of the Clipping Box.

The Y axis of the model and the Y axis of the Clipping Box.

OOXXOOOOOOIXIGOXNIMXNIIOOOMXMXIOOIOMIINXXXX If we have time it would be nice to change this screenshot. It is not
very sharp.


https://support.pix4d.com/hc/en-us/articles/207642636

Rotation 0° Rotation 45°

Below that information there are four buttons:

Expand: Creates a new Clipping Box which cowers the full model.

Apply: Applies the changed in the values of the properties of the C;ipping Box.
Cancel: Cancels the changes in the values of the properties of the Clipping Box.
Help: Opens the Pix4Dmapper help.

lﬂ] Note: On the toolbar, click @ to apply the Clipping Box in the 3D View and \isualize only the area contained in the Clipping Box.

For step by step instructions about how to use the Clipping Box: 204048035.

Index > Interface > Menu View > rayCloud > Right sidebar Previous | Next


https://support.pix4d.com/hc/en-us/articles/204048035
https://support.pix4d.com/hc/en-us/articles/207642636

Index > Interface > Menu View > rayCloud > Right sidebar © Previous | Next ©

& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Sidebar is displayed on the right of the main window.
The camera information is displayed on the right sidebar when clicking in the 3D View:

Initial camera position (for calibrated and uncalibrated cameras for which the initial position is known).

Calibrated camera position (for calibrated images).

Camera associated image thumbnail (for calibrated images).

The camera information is also displayed when selecting a given camera in the Layers section of the left sidebar.

The displayed camera information is different for:

Calibrated images
Uncalibrated images

Calibrated images

The following information is displayed in the Selection section:

Camera: Name of the image associated to the selected camera.

Camera Model: Camera model associated to the selected camera, including Image size in pixels (widthxheight) and band configuration.
Number of Marked MTPs and GCPs: Number of Manual Te Points / GCPs marked on the image.

Number of Automatic Tie Points: Total number of matched keypoints found on the image.

Computed Position [units]: X Y, Z computed position of the camera.

Buttons:

Disable: Disables the image. In order to remowve the camera from the reconstruction, the project needs to be reoptimized. This button is shown for enabled
cameras.

Enable: Enables the image. In order to include the camera in the reconstruction, the project needs to be reoptimized. This button is shown for disabled cameras.
Uncalibrate: In order to recalibrate a camera it is necessary to uncalibrate it first. This option should be chosen if the user is not confident about the calibration of
the camera.

Help: Opens the Pix4Dmapper help.

Apply Annotation: (available when the Image Annotation tool is used): Applies the image annotation to the Densified Point Cloud.

Note:
@ The Image Annotation tool does not affect the results obtained when running:
Step 1. Initial Processing
Process > Reoptimize
Process > Rematch and Optimize
If step 2. Point Cloud and Mesh has been completed:
By running again Step 2. Point Cloud and Mesh: A new Densified Point Cloud including the annotations is generated.

l[l] Note:
For step by step instructions about how to calibrate a camera: 202560189.
For step by step instructions about how to annotate images: 202560549.

Image preview: Displays the image associated to the calibrated camera.

Orange cross: Represents the position of an automatic keypoint that has been matched with a keypoints from other images.
Yellow cross: Represents a Manual tie point or a GCP marked on the image.

Right slider: Allows the user to select the minimum number of images with which a keypoint has been matched.

@, Zoom in: Zoom in on the image.

@, Zoomout: Zoom out of the image.

& Image Annotation: Activates the Image Annotation mode. For step by step instructions about how to annotate images: 202560549.

Q Tip: For the selected image:
In order to zoom in/out: Place the mouse over the location on which to zoom, and move the mouse scroll button forwards/backwards.
In order to pan: Place the mouse over the location on which to pan, and press the left mouse button while dragging the mouse.
By placing the mouse over an image and typing space, the image is displayed in full screen, where is possible to zoom, pan, click, etc.
When using the full screen mode, by typing:
Space: Minimizes the image and keeps the full screen zoom and panning level.
Esc: Minimizes the image and keeps the previous zoom and panning.


https://support.pix4d.com/hc/en-us/articles/207642636
https://support.pix4d.com/hc/en-us/articles/202560189
https://support.pix4d.com/hc/en-us/articles/202560549
https://support.pix4d.com/hc/en-us/articles/202560549

Images section

When double clicking on a cross in the Image preview (Automatic/Manual Tie Point or GCP), the Images section displays the images where the point can be
found (including the currently selected image). For more information: 202558459.

Uncalibrated images
When selecting an uncalibrated camera, it can be manually calibrated.

The following information is displayed in the Selection section:

.Proper-ties

¥ Selection

Initial Position and Orientation

IMG_1237.JPG (Camera) UNCALIBRATED
Camera Model:
MNumber of Marked MTPs and GCPs:
Mumber of Automatic Tie Points{Inliers/Total):

Computed Position [m]:

CanonIXUS220H5_4.3_4000x3000 (RGE)
1
72919

nfa

Initial Position [m]:

311238.31, 5169689.35, 781.48

Initial Accuracy (Horizontal, Vertical) [m]:  5.00, 10.00
Tie Points
A Latitude Longitude  Altitude  Accuracy  Accuracy
fale) Type [degree]  [degree] [m] Horz[m]  Vert [m]
8 9004 3D GCP 466534835 6533147 565.699 0.020 0.020

S—

B O &

=

| 15

Calibrate Close

Camera: Name of the image associated to the selected camera.

Camera Model: Camera model associated to the selected camera, including Image size in pixels (widthxheight) and band configuration.
Number of Marked MTPs and GCPs: Number of Manual Te Points / GCPs marked on the image.

Number of Automatic Tie Points (Inliers/Total): Inlier points and total number of matching keypoints found on the image.

Computed Position [units]: X Y, Z position of the computed camera. Since there is no computed position, it appears as n/a.

Help |

Buttons:

Disable: Disables the image. In order to remowe the camera from the reconstruction, the project needs to be reoptimized. This button is shown for enabled
cameras.

Calibrate: Allows the user to calibrate an uncalibrated camera. This button is enabled only if more than 20 Manual Tie Points and Automatic Tie Points are
considered as being inliers.

Close: Exits the manual calibration mode.

Help: Opens the Pix4Dmapper help.

Apply Annotation: (available when the Image Annotation tool is used): Applies the image annotation to the Densified Point Cloud.


https://support.pix4d.com/hc/en-us/articles/202558459

Note:
@ The Image Annotation tool does not affect the results obtained when running:
Step 1. Initial Processing
Process > Reoptimize
Process > Rematch and Optimize
If step 2. Point Cloud and Mesh has been completed:
By running again Step 2. Point Cloud and Mesh: A new Densified Point Cloud including the annotations is generated.

[[D Note:
For step by step instructions about how to calibrate a camera: 202560189.
For step by step instructions about how to annotate images: 202560549.

Image preview: Displays the image associated to the uncalibrated camera.

Red cross: Represents the position of an automatic keypoint that was not matched with keypoints from other images.

Orange crosses: Represents the position of an automatic keypoint which has a high probability of being accurately matched with keypoints of other images.
Yellow crosses: Represents a Manual tie point or a GCP marked on the image.

Right slider: Allows the user to select the minimum number of images with which a keypoint could be matched.

@ Zoom in: Zoom in on the image.

(1, Zoom out: Zoom out of the image.

&z Image Annotation: Activates the Image Annotation mode. For step by step instructions about how to annotate images: 202560549.

Q Tip: For the selected image:
In order to zoom in/out: Place the mouse over the location on which to zoom, and move the mouse scroll button forwards/backwards.
In order to pan: Place the mouse over the location on which to pan, and press the left button while dragging the mouse.

By placing the mouse over an image and typing space, the image is displayed in full screen, where is possible to zoom, pan, click, etc.
When using the full screen mode, by typing:

Space: Minimizes the image and keeps the  full screen zoom and panning level.
Esc: Minimizes the image and keeps the previous zoom and panning.

Tie Paints section: Displays in a table information about the Manual Tie Points and GCPs that are marked on the selected image. The table allows the user to
edit the information about the Tie Points by double clicking on the corresponding cell. For detailed information: 202557919.

Apply: When clicking on this button, the new marks or changes for the displayed Manual Tie Points and GCPs are added to the project.

Images section

When double clicking on a cross in the Image preview (Automatic / Manual Tie Point or GCP), the Images section displays the images where the point can be
found (including the currently selected image). For more information: 202558459.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The GCP or Manual Tie Point information is displayed when selecting a given 2D GCP, 3D GCP, Check point or Manual Tie Point in the 3D View or in

the Layers section of the left sidebar.

Properties g X
¥ Selection

9001 (3D GCP)

Label: | 9001 |

Type: |30 GCP -

Latitude [degree]: | 45,65644157 |

Longitude [degree]: |&,53535493
Altitude [m]: | 573.325
Horizontal Accuracy [m]: | 0.020 |
vertical Accuracy [m]: | 0.020 |
Mumber of Marked Images: 8
Se* [pixel]: 1.3013

Theoretical Error 5(X,Y,Z) [m]:

Maximal Orthogonal Ray Distance DX, Y,Z) [m]:
Error to GCP Initial Position [m]:

Initial Position [m]:

Computed Position [m]:

0.029, 0.041, 0.108
0.054, 0,133, -0.050
-0.063, -0.063, -0.515
311470.855, 5169936,032, 573.325
311470.918, 5169936.095, 573.840

|Automatic Marking : Apply Cancel Help
¥ Images
‘5 up Image Size Zoom Level
£ ¥ @ Q M

lﬂﬁ«
o i

The following information is displayed:

Name (type): The name and the type of the point (3D GCP, 2D GCP, Check point, Manual Tie Point).

Label: The name of the point.

Type: The type of the point (3D GCP, 2D GCP, Check point, Manual Tie Point).

First Coordinate:

Latitude [degree]: If the coordinate system of the GCPs is a geographic coordinate system.

X[m]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in meters.

X[feet]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in feet.

Arbitrary X[m]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in meters.
Arbitrary X[feet]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in feet.
Second Coordinate:

Longitude [degree]: If the coordinate system of the GCPs is a geographic coordinate system.

Y [m]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in meters.



Y [feet]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in feet.

Arbitrary Y [m]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in meters.

Arbitrary Y [feet]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in feet.

Third coordinate:

Altitude [m]: If the coordinate system of the GCPs is a geographic coordinate system.

Z[m]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in meters.

Z [feet]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in feet.

Arbitrary Z [m]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in meters.

Arbitrary Z [feet]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in feet.

Horizontal Accuracy [units]: The horizontal accuracy defined for the 2D and 3D GCPs. For more information: 202557919.

Vertical Accuracy [units]: The vertical accuracy defined for the 3D GCPs. For more information: 202557919.

Marks in images: The number images on which the point is marked.

So? [pixel]: A posteriori variance component of all the marked points for a given 3D point. For more information: 202559199.

Theoretical Eror S(XY,2)[units]: Theoretical error estimation. For more information: 202559139.

Maximal Orthogonal Ray Distance D (x,y,z)[units]: Maximal distance from the estimated 3D point and all the rays used to compute that 3D point. The distance is
measured between the 3D point and the point defined by the line perpendicular to the ray passing through the 3D point. For more information: 202559179.

Error to GCP Initial Position [units]: Error in X Y, Z between the original 3D position and the estimated 3D position. This information does not appear for Manual
Tie Points.

Initial Position [units]: The initial XY,Z position of the 3D GCP, Manual Tie Point or Check point. The initial X Y position of the 2D GCP.

Computed Position [units]: The computed X Y, Z position of the 3D GCP, Manual Tie Point or Check point. The computed X Y position of the 2D GCP.

Below the table there are four buttons:

Automatic Marking: Allows the user to automatically mark the 3D point in the images that have not been marked. This button is activated when the 3D point has
been marked in at least two images.

Apply: This button is active when the image marks have been modified, i.e. when a new image has been marked or when an existing mark has been updated or
removed. When clicking this button, the new marks are taken into account and the 3D position of the corresponding point is recomputed. This button is also
active when a change is done in the information regarding the point.

Cancel: Does not save the changes made to the marks of the point in the images or the information of the point.

Help: Opens the Pix4Dmapper help.

The Images section: Displays the selected image and the other images where the point can be found. For more information: 202558459.

@ Important: The zoom level at which GCPs / Manual Tie Points are marked has an impact on the GCP / Manual Tie Point error obtained in the Quality
Report. Usually the higher the zoom level, the more precisely the GCP / Manual Tie Paint is marked. These GCPs / Manual Tie Points will have a
bigger impact on the reconstructed model than GCPs / Manual Tie Points marked on a lower zoom lewel; lower error values are also expected for these
GCPs / Manual Tie Points. For example, when GCPs / Manual Tie Points are marked without zooming into the images, the GCP / Manual Tie Point error
can be 10 times higher than when the GCPs / Manual Tie Points are marked by zooming into the images.
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& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The Automatic tie points information is displayed when an Automatic tie point is selected in the 3D View.
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The following information is displayed:

Automatic Tie Point name (Automatic Tie Point): A unique name that identifies the Automatic Tie Point: ATP [number], where number is unique.

Number of Images Marked On: Number of calibrated images on which the point has been automatically marked (identified as the same 2D keypoint).

Number of Images Visible In: Number of calibrated images on which the 3D automatic tie point has been reprojected (number of calibrated images where the
computed 3D point is vsible).

Soz[pixel]: A posteriori variance component of all the marked points for a given 3D point. For more information: 202559199.

Theoretical Error S(XY,2)[units]: Theoretical error estimation. For more information: 202559139.

Maximal Orthogonal Ray Distance D(XY,Z)[units]: Maximal distance from the estimated 3D point and all the rays used to compute that 3D point. The distance is

measured between the 3D point and the point defined by the line perpendicular to the ray passing through the 3D point. For more information: 202559179.
Computed Position [units]: X Y, Z position of the selected point.

Below this information there is one button:
Help: Opens the Pix4Dmapper help.

The Images section: Displays the images where the point is marked on and visible in. For more information: 202558459.
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& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The Processing Area information is displayed when the Processing Area is selected in the 3D View.

A Waming:

It is recommended to include areas cowvered by images in the Processing Area, so as to exclude areas of low overlap that can affect the resullts.

The Processing Area affects only the visualization of the Automatic Tie Points in the 3D View of the rayCloud. It does not affect the results of step 1.
Initial Processing.

When the Processing Area is defined before step 2. Point Cloud and Mesh is processed, it affects the Point Cloud visualized in the 3D View of the
rayCloud and the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index.

When the Processing Area is defined after step 2. Point Cloud and Mesh is completed, it only affects the Point Cloud visualized in the 3D View of the
rayCloud but not the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index.

When exporting the Point Cloud, it is possible to take into account the Processing Area, even if it is drawn after step 2 is processed. For more
information about how to export the Point Cloud: 203890769.

When the Processing Area is defined before step 3. DSM, Orthomosaic and Index is completed, only the results of step 3 will be affected.

A Waming:

In order to take the Processing Area into account for the visualization of the Point Cloud and / or the generation of the outputs of step 2. Point Cloud and
Mesh, the comresponding filter should be selected in the Processing Options. For more information: 204644369.

The Processing Area will be taken into account for the results of step 3. DSM, Orthomosaic and Index even if the Processing Areas box is not selected
in the Point Cloud Filters.

lﬂ] Note: For step by step instructions about how to select a Processing Area: 202560179.
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The section Selection displays the following information:

Maximum Altitude[units]: Altitude of the top plane of the Processing Area.
Minimum Altitude[units]: Altitude of the bottom plane of the Processing Area.
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@ Important: Maximum Altitude should be higher than Minimum Altitude.

[m Note: The Maximum Altitude and Minimum Altitude can be edited by:
Selecting the text box and:
Clicking Page Up/Page Down keys: Increase/Decrease the value by 10 units.
Clicking Up Arrow/Down Arrow keys: Increase/Decrease the value by 1 unit.
Clicking Up Arrow/Down Arrow text box buttons: Increase/Decrease the value by 1 unit.
Typing a new number in the text box.

Below that information there are 2 buttons, grayed out by default, enabled once the values for Minimum or Maximum Altitude are modified.

Apply: Sawves the new values for the Minimum/Maximum Altitude and applies the new filters.
Cancel: Does not save the new values for the Minimum/Maximum Altitude.
Help: Opens the Pix4Dmapper help.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The Point Clouds information is displayed when a point of a point cloud is selected in the 3D View.
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The following information is displayed:

Number of Images Visible In: Number of calibrated images on which the selected point has been reprojected (number of calibrated images where the computed

3D point is \isible).
Computed Position [units]: X Y, Z position of the selected point in the 3D View.

Below this information there is one button:

Help: Opens the Pix4Dmapper help.
The Images section: Displays the selected image and the other images where the point can be found. For more information: 202558459.
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& Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The object information is displayed when an object is selected in the 3D View, or when an object is selected in the Layers section of the left sidebar.

There are 7 type of objects:

Polylines

Surfaces

Volumes

Animation Trajectories
Orthoplanes

Scale Constraints
Orientation Constraints

Note: A Manual Tie Point is associated to each vertex of the objects. The Sidebar allows the user to mark these Manual Tie Points on the images. Each
ertex that is marked in a least 2 images is taken into account in step 1. Initial Processing if it is started from scratch or if the reconstruction is re-

optimized.
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The following information is displayed:

Object name (object type): The name of the Polyline and its type (Polyline).

Number of Vertices: Number of vertices used to draw the Polyline.

Measurements

Terrain 3D length[units]: 3D length of the Polyline, taking into account the three coordinates of the vertices. For more information: 202559819.
Projected 2D length[units]: 2D length of the Polyline, taking into account the (XY) coordinates of the vertices. For more information: 202559839.

[[i| Note: When the polyline is created, next to the measurements, "error n/a (i ] " appears indicating that the measurement accuracy cannot be
calculated till all the vertices of the polyline are marked on at least 2 images. For step by step instructions: 202560609.
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The buttons:

Copyto Clipboard: Copy the selected information to the clipboard that can be pasted into a text editor or spreadsheet by opening the destination file and pasting.
Apply: This button is active when the image marks for the Manual Tie Points associated to the Polyline vertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or removed. When clicking this button, the new marks are taken into account and the 3D position of the
corresponding \ertices is recomputed.

Cancel: This button is active when the image marks for the Manual Tie Points associated to the polyline vertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or remowed. It cancels the modifications of the image marks.

Help: Opens the Pix4Dmapper help.

The Images section: Displays the images where the object can be found. For more information: 202558459.

For step by step instructions about how to draw a new Polyline: 202560309.
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The following information is displayed:

Object name (object type): The name of the Surface and its type (Surface).

Number of Vertices: Number of vertices used to draw the object.

Measurements

Terrain 3D Length[units]: 3D length of the line that has been used to draw the Surface taking into account the three coordinates of the vertices. For more
information: 202559819.

Projected 2D Length[units]: 2D length of the line that has been used to draw the Surface taking into account the (XY coordinates of the vertices. For more
information: 202559839.

Enclosed 3D Area[units?]: 3D area that is enclosed by this surface, taking into account the three coordinates of the vertices.
Projected 2D Area[units?]: 2D area that is enclosed by this surface, taking into account the (X,Y) coordinates of the \ertices.

lﬂ] Note: When the surface is created, next to the measurements, "error n/a i ] " appears indicating that the measurement accuracy cannot be

calculated till all the vertices of the surface are marked on at least 2 images. For step by step instructions: 202560609.

Used for DSM: When this box is selected, the surface is used to improve the DSM model.

And the buttons:
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Copy to Clipboard: Copy the selected information to the clipboard that can be pasted into a text editor or spreadsheet by opening the destination file and pasting.
Apply: This button is active when the image marks for the Manual Tie Points associated to the surface \ertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or removed. When clicking on this button, the new marks are taken into account and the 3D position of
the corresponding \ertices is recomputed.

Cancel: This button is active when the image marks for the Manual Tie Points associated to the surface vertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or remowed. It cancels the modifications of the image marks.

Help: Opens the Pix4Dmapper help.

The Images section: Displays the images where the object can be found. For more information: 202558459.

For step by step instructions about how to draw a new Surface: 202560269.
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The following information is displayed:

Object name (object type): The name of the Volume and its type (Volume).

Number of Vertices: Number of vertices used to draw the Volume.

Measurements

Terrain 3D Length[units]: 3D length of the line that has been used to draw the Volume's base surface taking into account the three coordinates of the vertices. For
more information: 202559819.

Projected 2D Lenght[units]: 2D length of the line that has been used to draw the volume's base surface taking into account the (XY) coordinates of the

\ertices. For more information: 202559839.

Enclosed 3D Area[unitsz]: 3D area that is enclosed by the wlume's base surface, taking into account the 3 coordinates of the vertices.
Projected 2D Area[unitsz]: 2D area that is enclosed by the wlume's base surface, taking into account the (XY) coordinates of the vertices.
Terrain 3D Area[unitsz]: Area that is defined by all the triangles of the wlume's surface. These triangles are computed with respect to the densified point cloud.

Cut Volumeunits3]: Volume that is above the volume base. The volume is measured between the volume's base and the surface defined by the densified point
cloud.

Fill Volume[units3]: Volume that is below the wolume base. The volume is measured between the volume base and the surface defined by the densified point
cloud.

Total Volume[units3]: Total wolume, Total Volume = Cut volume + Fill volume.

l[ﬂ Note: When the wlume is created, next to the measurements (except Cut, Fill, and Total volume), "error n/a (] " appears indicating that the
measurement accuracy cannot be calculated till all the vertices of the volume are marked on at least 2 images. For step by step
instructions: 202560609.
If step 2. Point Cloud and Mesh has not been done, next the Cut, Fill, and Total volume, it appears "emor n/a [ ] " indicating that the densified point
cloud is required and step 2. has to be run.
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Base surface settings: Sets the base plane for the wolume calculation. There are six different options:

Triangulated: Selected by default. Connects all the vertices and triangulates the volume above and below the base surface.
Fit plane: Fits a plane to the \ertices, so that all vertices are at the minimum distance from the base surface.

Align with average altitude: The base surface is parallel to the XY plane with altitude at the average altitude of all vertices.
Align with lowest point: The base surface is parallel to the XY plane with altitude at the lowest altitude of all vertices.

Align with highest point: The base surface is parallel to the XY plane with altitude at the highest altitude of all vertices.
Custom altitude [units]: The base surface is parallel to the XY plane with altitude at a custom altitude.

And the buttons:

Update Measurements: Computes and displays the measurements of the object in the Sidebar and in the 3D view.

Copy to Clipboard: Copy the selected information to the clipboard that can be pasted into a text editor or spreadsheet by opening the destination file and pasting.
Apply: This button is active when the image marks for the Manual Tie Points associated to the wlume \ertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or removed. When clicking on this button, the new marks are taken into account and the 3D position of
the corresponding \ertices is recomputed, but the measurements are not calculated and displayed in the Sidebar and in the 3D view only when clicking

on Update Measurements.

Cancel: This button is active when the image marks for the Manual Tie Points associated to the volume vertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or removed. It cancels the modifications of the image marks.

Help: Opens the Pix4Dmapper help.

The Images section: Displays the images where the object can be found. For more information: 202558459.

For step by step instructions about how to draw a new Volume: 202560319.

Animation Trajectories
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Under Selection in the main frame the name of the Animation trajectory and 4 sections appear:

Waypoints

Video Animation Options
Playback Controls
Video Rendering

And the button:

Help: Opens the Pix4Dmapper help.

Waypoints


https://support.pix4d.com/hc/en-us/articles/202558459
https://support.pix4d.com/hc/en-us/articles/202560319

The following actions can be performed on the table:

Inserting Waypoints: Right click on any cell and click on one of the followings:

Insert Current Viewpoint as Waypoint Before Selection: Inserts the actual viewpoint in the 3D View as waypoint before the selected row (selected waypoint).

Insert Current Viewpoint as Waypoint After Selection: Inserts the actual viewpoint in the 3D View as waypoint after the selected row (selected waypoint).

Insert Displayed Computed Cameras Position as Waypoint Before Selection: Inserts ALL the cameras that are actually \visible in the 3D View as waypoints before
the selected row (selected waypoint) by placing them (if more than one camera is inserted, the order is defined considering the exif information from the cameras).
Insert Displayed Computed Cameras Position as Waypoint After Selection: Inserts ALL the cameras that are actually \isible in the 3D View as waypoints after
the selected row (selected waypoint) by placing them (if more than one camera is inserted, the order is defined considering the exif information from the cameras).
Deleting Waypoints: Right click on any cell, and click on Remowe Selected Waypoints.

Editing Values: Double click on the cell and edit the value. Timestamp cannot be edited manually, the values can be changed by changing the Duration,
Maximum Speed or selecting/unselecting the Use Interpolation checkbox.

The table has as many rows as there are waypoints in the Animation Trajectory. Each row displays information for one waypoint.

Label: Name of the waypoint.

Timestamp [s]. Time at which the animation passes through the waypoint.
X coordinate [units]

Y coordinate [units]

Z coordinate [units]

Rotation in X Axis [degrees]

Rotation in Y Axis [degrees]

Rotation in Z Axis [degrees]

Video Animation Options
This section allows the user to change the time of the animation and use or not use interpolation between waypoints:

Duration [s]: Total length in seconds for the animation.

Maximum Speed [m/s]: Maximum speed of the movement of the fly-trough camera in meters/second. The speed is not constant since the software recognizes
changes in direction and orientation and reduces the speed in that sectors to allow smother camera movements.

Use Interpolation: Ensure a smooth transitions between waypoints.

@ Note:
If the Use Interpolation checkbox is NOT selected, the path between waypoints will be straight lines.
If the Use Interpolation checkbox is selected, the path between waypoints will be cuned lines. The angle of the cune is related to the angle
between consecutive lines.

This section contains 2 action buttons:

Apply: Sawes the changes done in the sections Waypoints or Video Animation Options.
Cancel: Rewerts the changes to restore the saved Animation Trajectory.

Playback Controls
This sections allows the user to display the animation in the 3D View.

[> Play animation

[] Stop animation

Video Rendering
This sections allows the user to create a video file and set up different video rendering properties:

File Name: Displays the path and the name where the Video will be rendered and saved.

Format: Video file format. The available options are: MPEG4 and MPEG2.

Frame Rate: Frames per second to be stored in the video. The available options are: 24, 30 and 60 fps.

Resolution: Total width and height of the video in pixels. The available options are: 800x600, 1024x768, 1280x720 and 1920x1080.

Encoding Quality: Defines the pixel size within the video, the higher the encoding quality the higher definition

Show Visible Area: Displays / does not display in the 3D View a frame allowing to see which part of the 3D View fits in the scene to be recorded according to the
resolution. Elements outside the visible area do not appear in the recorded video

Pix4Dmapper Logo: When rendering and creating the video, it displays/ does not display the Pix4Dmapper logo in the bottom right of the video.

This section contains 4 action buttons:

Browse... : Opens the Save Video As window which allows to choose the video's folder.

Render: Convwerts the animation Trajectory into a video, saved in the selected path and using the Video properties selected.
Cancel: Enabled while Rendering is in progress, allows to cancel the rendering of an Animation Trajectory into Video.
Help: Opens the Pix4Dmapper help.

For step by step instructions about how to create an Animation Trajectory: 202560299.


https://support.pix4d.com/hc/en-us/articles/202560299

Orthoplanes
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Under Selection in the main frame appears 3 sections:

Object name (object type): The name of the Orthoplane and its type (Orthoplane).

Position X[units]: Position in Xof the reference comer with respect to the origin of the output coordinate system.

Y [units]: Position in Y of the reference comer with respect to the origin of the output coordinate system.

Z [units]: Position in Z of the reference comer with respect to the origin of the output coordinate system.

Width [units]: Size in Xof the orthoplane area in output coordinate system units.

Height [units]: Size in Y of the orthoplane area in output coordinate system units.

Clipping Distance [units]: Size in Z of the orthoplane area in output coordinate system units.

Orientation: Defines the rotation of the orthoplane area with respect to the axes of the coordinate system.

Yaw [degrees]: Rotation around the Y axis.

Pitch [degrees]: Rotation around the X axis.

Roll [degrees]: Rotation around the Z axis.

Flip: Changes the orientation and direction of the projection.

Alignment tool (optional): Allows the user to align the orthoplane with a Surface Object.

Surface1: Allows the user to select the surface object to use for alignment.

Align: Aligns the Orthoplane to the selected surface by using the perpendicular vector to the surface as direction of the projection and using the base of the
surface as middle point of the Z of the Orthoplane.

Orthomosaic Generation Options: Options related to the output files.

Resolution [cm/pixel]: This value can be modified before generating the new Orthoplane mosaic and indicates the spatial resolution of the Orthomosaic.
Generate DSM: When the checkbox is selected, a DSM file is generated with the Orthoplane Mosaic. Processing options are optimized for facades (sharp
Surface Smoothing and Noise Filtering for the DSM filters, Raster DSM method set to Inverse Distance Weighting).

Output File: Path where the Orthoplane and optionally the DSM will be stored.

.... Selects the path where the Orthoplane and optionally the DSM wiill be stored.

And the buttons:

Apply: Enabled when there has been any change in the properties of the object. It applies the changes.
Cancel: Cancels the changes in the properties since the last time that apply has been clicked.

Generate: Generates the Orthomosaic and optionally the DSM for the selected orthoplane in the selected path.
Help: Opens the Pix4Dmapper help.

The Instructions section displays instructions about how to draw a new orthoplane.

For step by step instructions about how to draw a new orthoplane: 204664359.


https://support.pix4d.com/hc/en-us/articles/204664359

Scale Constraints

1 PixdDmapper Pro - mining_quarry - m} X
Project  Process View rayCloud Help
@ % B a0 F 806 K d eeEe @@ & B - ks 7 Asn S
pm’ Project Process View Mavigation Clipping Point C|0L_Id_EdIDEg_
o ¥ (reate g -~ s = Properties 8 x
= ] FE) ] = ¥ Selection
e [0 E) @ BN E 2]
m] Scale 1 (Scale Constraint)
T GCP/MTP Labels: mtpi7, mtp1d
W
—— V¥ Layers Computed Length [m]: 0.000 £0.000
O 1 Cameras Titial Length [m]: [ 20961 [3] oo [
rayCloud | - Rays S ——
@ > [m] Tie Points ey EolE |—|HEIP
_ > [ IZl Processing Area W Instructions
”E‘;S;C 3 Point Clouds j
v Point Groups To scale a project:
© Unclassified 1. Draw the Scale Constrainton the point doud.
@ Deleted A Scale Consfraintis defined by a line connecting 2 vertices.
Index > [ Triangle Mesh 2. Mark both end points (vertices) on at least 2 images.
Calculator rla.ng Sl 3. Enter the Jitia/ Length and its accuracy.
A Objects 4, Click Apply to save the changes.
> Polylines 5. (Optional) Add more Scale Constraints.
3 e 6. Click Process > Reoptimize to scale the project.
» Volumes
> Animation Trajectories ¥ Images
> Orthoplanes Image Size  Zoom Level
v Scale Constraints

> » Blol %l g & 2>

> Display Properties
> o B e

» Orientation Censtraints

A5 2 5

WGS84 / UTM zone 32N - (311903.77, 5169740.21, 526.25) [m]

Contains 3 sections:

Selection
Instructions
Images

Under Selection in the main frame appears:

Object name (object type): The name of the Scale and its type (Scale Constraint).

GCP/MTP Labels: When creating a Scale Constraint, the vertices of the line representing the scale constraint are associated to Manual Tie Points. This label
displays the names of the Manual Tie Points associated to the object.

Computed Length [units]: Length measured in the 3D model. The Computed Length Error is given by the difference between the Computed Length and the Initial
Length.

Initial Length [units]: Length measured in the field representing the real length of the scale constraint. The accuracy of the Initial Length is the accuracy of the
measurements in the field.

And the buttons:

Apply: Enabled when there has been any change in the properties of the object or a new marking in the images. It applies the changes.
Cancel: Cancel the changes in the properties or in the marking since the last time that apply has been clicked.
Help: Opens the Pix4Dmapper help.

The Instructions section: Displays instructions about how to draw a new Scale Constraint.
The Images section: Displays the images in which the object is \visible. For more information: 202558459.

For step by step instructions about how to draw a new Scale Constraint: 205360375.

COrientation Constaints


https://support.pix4d.com/hc/en-us/articles/202558459
https://support.pix4d.com/hc/en-us/articles/205360375
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Contains 3 sections:

Selection
Instructions
Images

Under Selection in the main frame appears:

Object name (object type): The name of the Orientation and its type (Orientation Constraint).

GCP/MTP Labels: When creating an Orientation Constraint, the vertices of the arrow representing the scale constraint are associated to Manual Tie Points. This
label displays the names of the Manual Tie Points associated to the object.

Computed Angular Error [degree]: Angular difference between the computed axis and the axis that was drawn.

Axis: Name of the axis that the Orientation Constraint represents.

Flip: Changes the direction of the Orientation by rotating it by 180°.

Angular Accuracy [degree]: Angular accuracy of the measurements in the field.

And the buttons:

Apply: Enabled when there has been any change in the properties of the object or a new marking in the images has been done. It applies the changes.
Cancel: Cancels the changes in the properties or in the marking since the last time that apply has been clicked.
Help: Opens the Pix4Dmapper help.

The Instructions section: Displays instructions to draw a new Orientation Constraint.
The Images section: Displays the images where the object can be found. For more information: 202558459.

For step by step instructions about how to draw a new Orientation Constraint: 205360385.

Index > Interface > Menu View > rayCloud > Right sidebar © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/202558459
https://support.pix4d.com/hc/en-us/articles/205360385

Index > Interface > Menu View © Previous | Next ©

& Access: On the Menu bar, click View > Mosaic Editor (available only if step 3. DSM, Orthomosaic and Index has been completed).
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A The Mosaic Editor may be used to manually correct artifacts in the Orthomosaic resulting from Step 3. DSM, Orthomosaic and Index and in order to
improwe its visual aspect.
The changes applied in the Mosaic Editor affect a local copy, not the mosaic resulting from Step 3. DSM, Orthomosaic and Index.
In order to obtain the edited mosaic, the mosaic needs to be exported: 202560079. The orthomosaic resulting from Step 3. DSM, Orthomosaic and
Index will then be overwritten. The Grid DSM as well as the different orthomosaic formats (GeoTIFF, Google Maps Tiles, etc.) will be generated if
selected in the processing options.
For more information about the Mosaic Editor processes workflow: 204829349.

For step by step instructions about how to improve the visual aspect of the orthomosaic: 202559939 (for buildings), 202559959 (for bridges).
The use of the Mosaic Editor is optional and it can be used to:

Visualize the DSM (raster GeoTIFF Digital Surface Model).
Visualize the Mosaic.
Improve the visual aspect of the orthomosaic.

When selecting the Mosaic Editor view the following elements are displayed on the Main window:

Menu Bar Entry: Extra entry displayed on the Menu bar.

Toolbar: The standard toolbar and some extra buttons specific to the Mosaic Editor.

Mosaic View: Displayed in the main window. By default the Orthomosaic is displayed. The Mosaic Editor can also be used to visualize the DSM (Elevation).
Sidebars: Displayed on the right of the Mosaic View. By default the Mosaic editing sidebar is displayed.

Status bar: Displayed on the bottom right of the Mosaic View. Display the coordinates when passing the mouse over the orthomosaic / DSM.

For step by step instructions related to the use of the Mosaic Editor: 202558709.


https://support.pix4d.com/hc/en-us/articles/202560079
https://support.pix4d.com/hc/en-us/articles/204829349
https://support.pix4d.com/hc/en-us/articles/202559939
https://support.pix4d.com/hc/en-us/articles/202559959
https://support.pix4d.com/hc/en-us/articles/202558709
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Figure 1. Mosaic Editor with DSM view



.| PixdDmapper Pro - mining_quarry — O *

Project  Process View Mosaic Editor  Help

1 e 1 > K7 | [ 1 I

ﬁ‘f @ G B a e 8 @@ il Mol - S& O
g Project Process Wiew Edit Mosaic

e Mosaic Editing B x

¥ Regions

i Draw | Delete Delete Al

W Images

(") Ortho Projection (® Flanar Projection

[y
L]

Log Output
—

&

Processing
Options bl

WGSB4 / UTM zone 32N - (311722.66, 5170265.62, -10000.00) [m]

Figure 2. Mosaic Editor with Orthoimage view

Menu bar entry

On the Menu bar, by clicking Mosaic Editor the following options are displayed:

[ PixdDmapper Pro - mining_quarry

Project Process View Mosaic Editor  Help

i ] R
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Visualization 2
©

View: Shows the view options of the Mosaic View.
Mosaic Editing: Opens the Mosaic Editing sidebar.
Visualization: Opens the Visualization sidebar.

Toolbar
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M W= {,} @ & {'_j E‘_l’ ® 9 ;i Mosaic [groupl] - & m
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The following Toolbar buttons are displayed:

Standard Toolbar: For more information: 202557839.
Toolbar extra buttons:
View

@ Zoom In: Zooms in the selected view.



@, Zoom Out: Zooms out the selected view.
n2 View All: Mowes the viewpoint in order to fit the model in the Mosaic View.

Edit Mosaic

®\ G)\ EC Mosaic [groupl] -
View Mosaic [r_']rc:u 1]

Element to be displayed in the Mosaic View, by default the Mosaic [group1] is displayed. If there are more than one groups of images, one Mosaic is generated
per group of images. It is possible to display the different generated mosaics as well as the DSM.

Mosaic View

By default the Mosaic view is selected and the mosaic is displayed. If the DSMview is selected, the DSM is displayed.
When passing the mouse over the orthomosaic / DSM, the Mosaic Status bar displays the coordinates of the hovered point.
The following mouse interactions are available:

Left click on the mosaic and move the mouse: Pan the mosaic.

Left click on a Region vertex while moving the mouse: Allows to mowe the vertex of the region.
Moving the mouse scrall forwards: Zoom in on the mosaic.

Moving the mouse scroll backwards: Zoom out of the mosaic.

Sidebar
There are two sidebars:

Mosaic editing sidebar : Allows the user to edit the mosaic.
Visualization sidebar: Allows the user to visualize the mosaic or the DSM.

Status bar
On the bottom right part of the Mosaic View, the following is displayed:
WGS84 / UTM zone 32N - (311684.29, 5169774.29, 496.97) [m]

Selected Coordinate System: Displays the selected coordinate system of the point.
Position: Displays the (XY) coordinates in meters / feet of each point of the orthomosaic / DSM. When passing the mouse ower the orthomosaic / DSM the
coordinates change.

@ Important: The geographic (ellipsoid) projection coordinates are used in meters / feet, instead of geographic (ellipsoid) coordinates in degrees,
considering the output coordinate system selected.

By default the output coordinate system is the same as the one of the GCPs if GCPs are used. Otherwise it is the same as the one of the images. If the
coordinates system is WGS84, the output is given in UTM.

If less than 3 images are geolocated and less than 3 GCPs are defined, then the output coordinates system is "Arbitrary".

l[D Note: The Status Bar displays the position for the whole area covered by the Orthomosaic / DSM and the area without data. When passing the mouse
ower areas Where there is no data, the no data altitude value -10000 is displayed.

Index > Interface > Menu View © Previous | Next ©



Index > Interface > Menu View > Mosaic Editor

© Previous | Next ©

Access: On the Menu bar, click View > Mosaic Editor, in the Mosaic Editor, on the Menu bar click Mosaic Editor and select the menu

option View (available only if step 3. DSM, Orthomosaic and Index has been completed).
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The View options affect the Mosaic View. The following options are available:

Show Mosaic [Group]
Show DSM

Show Region

Show Edited Mosaic
Show Processing Area
Show Mosaic Tiles

Show Mosaic [Group]

This option is selected by default.

Ctrl+1
Ctrl+2

Ctrl+3
Ctrl+4
Ctrl+5
Ctrl+6

It displays the mosaic generated using the images that belong to the corresponding group. The default group is group1. For more information about the image

groups: 202557949.

The mosaic can be edited by creating regions and by assigning another image to them or selecting another projection for each region. The edited mosaic will be
edited and visualized in real time. Once the editing has been completed, the mosaic needs to be exported in order to generate the new output files for the

mosaic.
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Show DSM

It displays the DSM using by default an RGB color map for the altitude values.
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Show Region

This option is activated by default. It displays the drawn Regions.
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Show Edited Mosaic
This option is activated by default. It displays the edited mosaic.
When it is not activated, the Mosaic View displays the content of the mosaic stored in file.
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This option is deactivated by default. It displays the Processing Area, which is the area for which the Orthomosaic is generated.

For more information about the Processing Area: 207968273.

I PixdDmapper Pro - mining_quarry
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Show Mosaic Tiles

This option is deactivated by default. It displays the GeoTIFF mosaic tiles that will be generated when exporting the mosaic. When the Processing Area is

modified, the mosaic tiles are modified as well.
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Access: On the Menu bar, click View > Mosaic Editor, on the Menu bar click Mosaic Editor > Mosaic Editing (available only if step 3. DSM,
Orthomosaic and Index has been completed).

For information about the sidebar's display possibilities: 202558389.

| Pix4Dmapper Pro - mining_quarry

Project  Process  View | Mosaic Editor | Help

I, .
. (IS List '
p@ﬁ Project . Masaic Editing 1

Yisualization 2
i

é. A

The Mosaic Editing sidebar contains the following sections:

Regions: Allows the user to select, draw or delete regions.

Images: Allows the user to select which projection and which image can be used for each region.
Export: Allows the user to:

Sawe locally the changes (saves changes in the Mosaic Viewin intemal temporal files).

Reset the displayed mosaic.

Export an edited mosaic by exporting the interal temporal files saved copy).

Mosaic Editing g x
W Regions

Draw | [ Delete | [ Deleteal

W Images

(7) Ortho Projection @) Planar Projection

IMG_1250.JPGRegion1

IMG_1224.JPGRegion1]

W Export

[sme ] [remt ] oo

Regions
Allows the user to select, draw or delete regions.
Contains the following buttons:

Region[number]: Available once one region has been drawn. Allows the user to select a Region.
Draw: Allows the user to draw a region. For step by step instructions: 202560079.

Delete: Allows the user to delete the selected region.

Delete All: Allows the user to delete all the existing regions.

Images
Allows the user to:

Display the different projections available for the selected region.


https://support.pix4d.com/hc/en-us/articles/202558389
https://support.pix4d.com/hc/en-us/articles/202560079

Display the selected projection type and image for the selected region.
Change the projection type and image to be used for the selected region.

It is possible to select:

Ortho Projection: Displays a list of original images in ortho projection.
Planar Projection: displays a list of original images in planar projection.

Note:

l[ll Ortho Projection: The ortho projection presenes distances and can be used for mosaics dedicated to measurement applications.
Planar Projection: The planar projection does not presene distances, but has less distortions than the ortho projection on sharp transitions such as
building edges. Therefore, it is not recommended to use planar images for mosaics dedicated to measurement applications. Its basic use is to improve
the visual aspect of the orthomosaic.

Export

Waming:

A The Mosaic Editor may be used to manually correct artifacts in the Orthomosaic resulting from Step 3. DSM, Orthomosaic and Index and in order to
improwe its visual aspect.
The changes applied in the Mosaic Editor affect a local copy, not the mosaic resulting from Step 3. DSM, Orthomosaic and Index.
In order to obtain the edited mosaic, the mosaic needs to be exported: 202560079. The orthomosaic resulting from Step 3. DSM, Orthomosaic and
Index will then be overwritten. The Grid DSM as well as the different orthomosaic formats (GeoTIFF, Google Maps Tiles, etc.) will be generated if
selected in the processing options.
For more information about the Mosaic Editor processes workflow: 204829349.

Allows the user to:

Sawe locally the changes (saves changes in the Mosaic Viewin intemal temporal files).
Reset the displayed mosaic.
Export an edited mosaic by exporting the interal temporal files saved copy).

Contains the following buttons:

Sawe: Sawes the changes in the mosaic: Overwrites in the Edited Mosaic only the areas comesponding to the existing regions using the selected projections for
them.

The saved Edited Mosaic will be used when exporting and when opening the mosaic editor again.

Reset: Resets the Edited Mosaic with the Generated Mosaic (which is stored as output).
Export: The selected Edited Mosaic overwrites the Mosaic generated at step 3. DSM, Orthomosaic and Index.
Help: Opens Pix4Dmapper help.

Index > Interface > Menu View > Mosaic Editor © Previous | Next ©
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Index > Interface > Menu View > Mosaic Editor
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Access: On the Menu bar, click View > Mosaic Editor, on the Menu bar click Mosaic Editor > Mosaic Editing (available only if step 3. DSM,

Orthomosaic and Index has been completed).

For information about the sidebar's display possibilities: 202558389.

.| PidDmapper Pro - mining_quarry

Project  Process  View = Mosaic Editor  Help
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Edit Mosaic

— O *
Visuglization g X
¥ Band Information
Name Min Max Pixel
Band1 1} 255 byte
Band2 1} 255 byte
Band3 1} 255 byte
Band1 Band2 Band3
it S 4 2711
W (Color Mapping
RGBA
Mo Color Mapping
RedBand:  Bandl x| 0.0 255.0
Green Band: |Band2 T8 0.0 255.0
BlueBand: Band3 + 0.0 255.0
[] single Band
Data Band: |Bamdl  + | 0.0 255.0
Palette: ¥
Shading: Disabled >
Ordering: | Min to Max e
¥ Apply
| Update || Hep
WGS84 / UTM zone 32N - (311418.46, 5170520.02, -10000.00) [m]

@ Important: This View is very useful for non standard original images (16 bits per band). It allows the user to specify which band is considered as red,

green and / or blue.

The Mosaic Editing sidebar contains the following sections:

Band Information: Displays information for the different bands of the mosaic group or DSM.
Color Mapping: Allows the user to change the values to be considered for visualization for each pixel and the visualization rules.
Apply: Allows the user to apply the changes. It considers the visualization parameters to be used in the Mosaic View.

Band Information

It displays information for the different bands of the mosaic group or DSM.


https://support.pix4d.com/hc/en-us/articles/202558389

¥ Band Information

Name Min Max Pixel
Band1 0 255 byte
Band2 0 255 byte
Band3 0 255 byte

Band1 Band2 Band3

The following information is displayed:

Name: Name of the band.

Min: Minimum pixel value for all the pixels of the band.

Max: Maximum pixel value for all the pixels of the band.

Pixel: Data type, how many bytes are used to store the information of each band.

The band histogram section has one tab per band.

The histogram displays how many pixels in the model have a certain value for each band.

Color Mapping

Allows the user to change the values to be considered for isualization for each pixel and the visualization rules.

W Color Mapping
RGEA
Mo Color Mapping
RedBand: |Bandl + |0.0 255.0
GreenBand: Band2 = (0.0 255.0
Blue Band: |[Band® =+ 0.0 255.0
[] single Band
DataBand: Bandl = 0.0 255.0
Palette: -
Shading: Disabled ¥
Ordering: | Min to Max >

It contains 2 sections:

RGBA

Selected by default for Mosaics.

It uses always 3 bands: The final color visualized will be the combination of the values for the 3 bands.
It is possible to select:

No color mapping: Selected by default. It takes the values from the original mosaic file.

Red band: Grayed out unless No color mapping is not selected. It allows the user to select which band is considered as the red band for the visualization.
Green band: Grayed out unless No color mapping is not selected. It allows the user to select which band is considered as the green band for the visualization.
Blue band: Grayed out unless No color mapping is not selected. It allows the user to select which band is considered as the blue band for the visualization.

Single Band
Selected by default for the DSM.
It is possible to use only one band. The final color visualized will consider only the values of one band.

Data band: Allows the user to select which band will be used for visualization.
Palette: Allows the user to select the palette of colors for the Visualization of the values of the selected band. The different available options are:
Atlas: It uses the Atlas standard palette. Selected by default for DSM. It uses a palette using blue for low values, yellow for middle values and red for high values.



HSV: It uses the HSV standard palette.

RdYIGn: Low values are red, medium values are yellow and high values are green, used for agriculture.

Thermal: Low values are blue, high values are red. It is used for temperature measurements.

Spectral: It uses all the colors from the visual spectrum. It is used when many different values need to be distinguished.
Grays: It uses a gray scale.

Blues: It uses blue scale.

Red: It uses red scale.

Shading: Allows the user to disable / enable shading using illumination based on the values of each pixel on the model. For more information: How Hillshade
works. The different options available are:

Enabled: Selected by default, it uses shading.

Disabled: It does not use shading.

Ordering: Allows the user to invert the selected colors distribution. The different options available are:

Min to Max: Selected by default. It uses the standard colors distribution for the selected palette.

Max to Min: It inverts the selected colors distribution for the selected palette.

Apply

¥ Apply

| Update | Hep

Contains the following buttons:

Update: It applies the changes and considers the \isualization parameters to be used in the Mosaic View.
Help: It opens Pix4Dmapper help.

Waming:

A The Mosaic Editor may be used to manually correct artifacts in the Orthomosaic resulting from Step 3. DSM, Orthomosaic and Index and in order to
improwe its visual aspect.
The changes applied in the Mosaic Editor affect a local copy, not the mosaic resulting from Step 3. DSM, Orthomosaic and Index.
In order to obtain the edited mosaic, the mosaic needs to be exported: 202560079. The orthomosaic resulting from Step 3. DSM, Orthomosaic and
Index will then be overwritten. The Grid DSM as well as the different orthomosaic formats (GeoTIFF, Google Maps Tiles, etc.) will be generated if
selected in the processing options.
For more information about the Mosaic Editor processes workflow: 204829349.

Index > Interface > Menu View > Mosaic Editor © Previous | Next ©


http://edndoc.esri.com/arcobjects/9.2/net/shared/geoprocessing/spatial_analyst_tools/how_hillshade_works.htm
https://support.pix4d.com/hc/en-us/articles/202560079
https://support.pix4d.com/hc/en-us/articles/204829349

Index > Interface > Menu View © Previous | Next ©

& Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed).

. PixdDmapper Pro

Project Process | View  Map View Help

||=@ ~  Show View Toolbar
D Proj ¥ Show Sidebar

|
1 Welcome
Ul Map View
2 rayCloud

Muosaic Editor
5]  Index Calculator

[ Processing

45 Log Output

Note:
@ A DSM is used to generate the Reflectance Maps.
One Reflectance Map is generated for each band of each group of images, but only one DSM is generated, regardless the number of images' groups.
The Reflectance Maps contain the reflectance values of each pixel and are used to generate the Index Maps.
The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.
If a Region is drawn, the Index Maps and Colored Index Maps will be generated only for this region.
Colored Index Maps are generated by applying the defined coloring rules to the Index Maps. They are raster files with RGB values.
If a Colored Index Map already exists, creating a new Colored Index Map will overwrite the existing one.

@® mportant:
For more information about the files that are generated, under which action and where they are stored: 202558739.
All the outputs will be stored in: ...\project_name\4_index
For more information about the project folder structure: 202558649.

A Waming: Once the Index Calculator has been used and results are generated, all the outputs from the Index Calculator will be DELETED if any of the
following steps / actions is started: step 1. Initial Processing, step 2. Point Cloud and Mesh, step 3. DSM, Orthomosaic andlndex, Reoptimize, Rematch
and Optimize.

The existing results need to be backed up to not be overwritten.

The use of the Index Calculator is optional and can be used to:

Generate an Index Map / Index Grid where the "color" of each pixel is computed using a formula that combines different bands of the Reflectance Map(s).
Visualize the Index Map as a Colored Index Map by applying a color mapping to it.

Export a georeferenced Colored Index Map.

Annotate the classes of the Index Map to generate an Application Map.

Export an Application Map as a shape file to be imported in any tractors consoles.

When selecting the Index Calculator view the following elements are displayed on the main window:

Menu bar entry: Extra entry displayed on the Menu bar.

Toolbar: The standard toolbar and some extra buttons related to the Index Calculator.

Index View: Displayed in the main window. When opening the Index Calculator for a project for the first time, it is blank. Once at least an Index Map has been
generated, it displays by default the last index that was displayed before the project was closed.

Index Calculator sidebar: By default, it is displayed on the right of the Index View. Displays information about the Reflectance Map(s), the Index Map, and
provides tools to generate and edit the Index Maps.

Status bar: Displayed on the bottom right of the main window. Displays the Index Value, the coordinate system and the coordinates when passing the mouse
ower the Reflectance Map/ Index Map.

For more information:

For step by step instructions about how to use the Index Calculator: 202558729.


https://support.pix4d.com/hc/en-us/articles/202558739
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Index Calculator 5 X

W 1. Reflectance Map
Generate Help
Band nm Min Avg Max Stdev var
red 625 0.00 99.72 251.78 28.04 786.19
green 560 0.00 99.03 268.31 28.78 828.31
nir 850 0.00 93.30 190.32 23.72 562.66
W 2. Regions
Whole Map + Draw Clear ° Regions... Help
¥ 3. Index Map
Name Formula
B ndvi ¥ | = |(nir -red) [ (nir +red) °
Edit... Indices... « Generate Help
Band Min Avg Max Stdev Var
band1 -0.96 -0.03 0.97 0.07 0.01
W 4. Color Maps and Prescription
MNumber of Classes EI Equal Area - Help
Min/Max |-0.25 | - [0.19 | 2] Clamped
Color Min Max Area [ha] Area [%]
-0.00 0.19 8.28 19,98
-0.04 -0.00 8.29 20.00
-0.06 -0.04 8.29 20.01
B -0.07 -0.06 8.2 .01
B 0.25 0.07 8.2 20.00
. IF‘.d‘ﬂGn * [ nvert Prescription...
W 5. Export
Index Values and Rates as Polygon Shapefiles (SHP) with Grid Size [cmjf Export
Colored Index Map (GeoTIFF) and GeolPG {IFG) Export
Help

Figure 1. Index Calculator

Menu bar entry

On the Menu bar, by clicking on Index Calculator the following option is displayed:

| PixdDmapper Pro
Project Process View | Index Calculator Help

! y “:@1 {:} «~  Show Color Scale
,ﬁ 1 View Al c

Show Color Scale: By default it is selected. View/hide the color scale graphic of the Index Map that is displayed on the top right of the Index View.
View All: Zoom in and out, so that the full Reflectance Map or Index Map is displayed in the Index View.

l[j] Note: For information about the files that are generated, under which action and where they are stored: 202558739.

Toolbar

@\ @\ EC Reflectance Map [red] - Show Index Map Lock Regions

View Reflectance Map Index Map Regions
The following Toolbar buttons are displayed:

Standard toolbar: For more information: 202557839.
Toolbar extra buttons:
View:

@ Zoom In: Zooms in the selected view.


https://support.pix4d.com/hc/en-us/articles/202558739

@, Zoom Out: Zooms out the selected view.

n2 View All: Zooms in and out, so that the full Reflectance Map or Index Map is displayed in the Index View.

Reflectance map:

E PixdDmapper Pro

Log Output
|

Processing

Project Process  VWiew  Index Calculator
f ||=@ {:} @ ﬁ L_j E (‘E{ e\ Eg Reflectance Map [red] | [] Show Index Map Lock Regions
m‘w Project Process View Index Map Regions
- Reflectance Map [green]

Reflectance Map [nir]
Hide Reflectance Map

WG584 / UTM zone 17N - (509641.25, 4853286.25) [m]

By default the Reflectance Map of the first band is displayed. The drop-down list gives the option to hide the Reflectance Map and select the Reflectance Map of a

different band.

Index Map:

L PidDmapper Pro

Project Process View IndexCalculator Help

Project Process View Reflectance Map

B @9 B S0 B QO MM | B D
Pix4

- [u] X || & pdDmapper Pro - O X
Project Process View Index Calculator Help
5 @ € B A O @ @ Q [ |RefectanceMapfed] v | []ShonIndexMap [ Lock Regions N
i
Index Map Regions

Index Map Regions Project Process View Reflectance Map

Log Output Log Output
Processing Processing
Options ‘Options:
'WGS84 / UTM zone 17N - (509727.50, 4853272.50) [m] 'WGS84 / UTM zone 17N - (509512.50, 4853277.50) [m]
Index Map display Index Map not display

By default, the Show Index Map box is selected. This option controls whether the generated Index Map will be displayed and overlaid on top of the reflectance

map.



Regions:

L Pix4Dmapper Pro - [u] X || &/ Pix4Dmapper Pro - [m] X

Project Process View Index Calculator  Help Project Process View Index Calculator  Help

il @ & B S5 0 @ @ O ] |Reflecancemapled] ~ | [ showIndexMap [ Lock Regions
Pixa|

Project Process View Reflectance Map Index Map Regions

= BH|RE D B|a a i | o [
P Project Process

View Reflectance Map Index Map Regions

WGS84 / UTM zone 17N - (510173.75, 4853163.75) [m] WGSB4 / UTM zone 17N - (509971.25, 4853117.50) [m]

Regions locked Regions unlocked

By default the Lock Regions box is selected. After the regions are drawn: 203937289, they will be displayed in the Index View. If the Lock Regions box is
selected, the region frame will be locked in the position. Unselect the Lock Regions box to enable the editing of previously drawn regions by dragging the whole
region or a certain vertex.

Index View

When opening the Index Calculator for a project for the first time, it is blank. Once at least an Index Map has been generated, it displays by default the last index
that was displayed before the project was closed.

Navigating on the Index View using the mouse:

Pan: Right/Left click and move the mouse (a hand icon appears representing the focus point for the movement).
Zoom in: Move the scroll wheel forward while positioning the mouse over the Index View.
Zoom out: Mowe the scroll wheel backwards while positioning the mouse over the Index View.

Index Calculator sidebar
The side bar displays the information about the Reflectance Map(s) and the Index Map as well as provides tools to generate and edit the Index Maps.
For details about the Index Calculator Sidebar: 202558249.

P 1. Reflectance Map

P 2. Regions
P 3.Index Map

P 4.classes

P 5 Export
Status bar
On the bottom right part of the main window, if a Reflectance Map / Index Map is loaded in the Index View, the following information is displayed:
WGS84 / UTM zone 17N - (510197.50, 4853252.50) [m]

Index Value: Displays the pixel value of the Index under the current mouse location. When passing the mouse over the Index View, the value changes.

Output Coordinate System: Displays the selected output coordinate system.

Coordinates: Displays the (XY) coordinates in meters / feet of each point of the Reflectance Map / Index Map. When passing the mouse over the Reflectance
Map/ Index Map the coordinates change.

[[l] Note: Coordinates of the area covered by the Reflectance Map / Index Map and of the areas without data are displayed.

Index > Interface > Menu View © Previous | Next ©
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.

The Index Calculator Sidebar contains the following sections:

1. Reflectance Map: Used to:

Generate the Reflectance Map(s) used to generate the indices. One Reflectance Map is generated per group of images (RGB, NIR, etc.).
Displays information about the Reflectance Map(s) bands.

2. Regions: Used to:

Define specific areas that the index calculation will be applied to.

3. Index Map: Used to:

Generate, View, edit indices or select the index to be displayed in the Index View.
Displays information about the selected index.

4. Color Maps and Prescription: Used to:

Classify the Index Map, based on the indices values.

5. Export: Used to:

Export the index values and prescription rates as polygon shapefiles.

Export the selected Index Map using the selected classes for the color mapping.

Index Calculator |+
W 1. Reflectance Map
Generate Help
Band nm Min Avg Max Stdev Var
red 625 0.00 99.72 251.78 28.04 786.19
green 560 0.00 99.03 268.31 28.78 828.31
nir 850 0.00 93.30 190.32 23.72 562,60
W 2. Regions
Whole Map ~ Draw Clear ° Regions... Help
W 3. Index Map
Name Formula
B ndvi * | = |{nir - red) / (nir + red) °
Edit.... Indices. .. \f Generate Help
Band Min Avg Max Stdev Var
band1 -0.96 -0.03 0.97 0.07 0.01
W 4, Color Maps and Prescription
Mumber of Classes IZI Equal Area - Help
Min/Max |-0.25 |- [0.13 | & Clamped
Color Min Max Area [ha] Area [%%]
-0.00 0.19 8.28 19.98
-0.04 -0.00 8.29 20.00
-0.06 -0.04 8.29 20.01
B 0.07 -0.06 8.29 20.01
B 0.25 0.07 8.79 20.00
. IRd\"IGn * [ nvert Prescription. ..
¥ 5. Export
Index Values and Rates as Polygon Shapefiles (SHP) with Grid Size [cm/ Export
Colored Index Map (GeoTIFF) and GeolPG (IPG) Export
Help
l[_]] Note:

One Reflectance Map is generated for each band of each group of images.

The Reflectance Maps contain the reflectance values of each pixel are used to generate the Index Maps.

The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.

If a Region is drawn, the Index Maps and Colored Index Maps will be generated only for this region.

Colored Index Maps are generated by applying the defined coloring rules to the Index Maps. They are raster files with RGB values.

If a Colored Index Map already exists, creating a new Colored Index Map will overwrite the existing one.


https://support.pix4d.com/hc/en-us/articles/202558389

@ Important:
For information about the files that are generated, under which action and where they are stored: 202558739.

All the outputs will be stored in: ...\project_name\4_index
For more information about the project folder structure: 202558649.

Index > Interface > Menu View > Index Calculator © Previous | Next ©
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& Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.

[ PuedDmapper Pro
Project Process  View Map View Help

i A
U Proj

Show View Toolbar

AN

Show Sidebar
|
CT i1 Welcome
Welcome Il Map View
—
Iz rayCloud

I
Map View
%8

rayCloud L Processing

Mosaic Editor

]|

Index Calculator

Bl

On the left part of section 1. Reflectance Map, there is an arrow that allows the user to show/hide the section by clicking on it:

Log Output

W 1. Reflectance Map BY default section 7. Reflectance Mep is visible.
P 1 Reflectance Map Section 7. Reflectance Map is not visible.

W 1. Reflectance Map
Generate Help
Band nm Min Avg Max Stdev Var
red 625 0.00 99,72 251.78 28.04 786.19
green 560 0.00 99.03 268.31 28.78 828.31
nir 850 0.00 93.30 190.32 23.72 562.66

And the

Generate: Generates the Reflectance Map if not generated.

Note: The Reflectance Map is generated based on the selected Processing Options: 203891879. For more information about the generated files and
where they are stored: 202558739.

Help: Opens the Pix4Dmapper help.

The section 1. Reflectance Map also displays information for each band of the generated Reflectance Map(s) for each group of images The following information
is displayed:

Band: Name of the band. If more than one group exists and the same band name exists in different groups, the bands are displayed as "Groupname_band."
Min: Minimum pixel value per band.

Awg: Average pixel value per band.

Max: Maximum pixel value per band.

Stdev. Standard deviation of pixel values per band.

Var: Variance of pixel values per band.

If the Reflectance Map(s) are not generated, it displays: "Reflectance Map not yet generated.”

¥ 1. Reflectance Map ¥ 1 Reflectance Map
Generate Help
Generate Help
Band am Hin Avg Max  Stdev var,
Band Min Avg Max Stdev Var | red 625 0.00 %9.72 5178 28.04 786.19

Reflectance map not yet generated oreen 560 0.00 9.03 6831 B8 828.31
850 0.00 9330 190,32 272 56266

Reflectance Map not generated Reflectance Map generated
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Note:
@ One Reflectance Map is generated for each band of each group of images.
The Reflectance Maps contain the reflectance values of each pixel are used to generate the Index Maps.
The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.
If a Region is drawn, the Index Maps and Colored Index Maps will be generated only for this region.
Colored Index Maps are generated by applying the defined coloring rules to the Index Maps. They are raster files with RGB values.
If a Colored Index Map already exists, creating a new Colored Index Map will overwrite the existing one.

Index > Interface > Menu View > Index Calculator > Sidebar © Previous | Next ©
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.
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On the left part of section 2. Regions, there is an arrow that allows the user to show/hide the section by clicking on it:

¥ 2. Regions BY default section 2. Regions is expanded and visible.
P 2 Regions Section 2. Regions is collapsed and hidden.

Index Calculator |+

| 3 1. Reflectance Map

¥ 2. Regions

|Region1 v| | Draw | | Clear | o | Regions. .. | | Help

P 3.Index Map

} 4. Color Maps and Prescription

P 5. Export
The following information is displayed:

Selected region: Allows the user to select the region to be highlighted with orange color in the Index View and to be used for the index classification.
Draw: Allows the user to draw the selected region in the Index View.

Clear: Allows the user to clear the drawn region in the Index View. Enabled if the selected region is drawn.

Formula Status icon: Next to the button Clear appears:

(@] The region exists and is valid.

(%] The region has not been drawn or the drawn area is incorrect (its edges intersect).

Regions...: Opens the Region List pop-up, which allows the user to manage the regions:
Add a new region.

Delete an existing region.

Edit the name of a region.

Display some properties of the region.

Import / export the regions.

Help: Opens the Pix4Dmapper help.

Regions...


https://support.pix4d.com/hc/en-us/articles/202558389

When the button Region... is clicked, the following pop-up appears:

£ Region List X
Regions
Region Area [hal %
© Region 1 37 53.07
© Region2 328 4693
Import... || Export.. | | Add | Remove
[ ok ] cancel || Hep

It contains the section Regions:

Regions table: Contains the columns:

Region: Name of the region, by double clicking on it, it is possible to edit the name.
Area [units]: Surface cowvered by the region.

% Percentage of the total area occupied by the region.

Import...: Allows to import regions from a .shp files.

Export...: Allows to export the regions to a .shp file.

Add: Creates a new region.

Remove: Deletes the selected region.

And the buttons:

OK: Confirms the changes.
Cancel: Does not sawe the changes.
Help: Opens the Pix4Dmapper help.

Index > Interface > Menu View > Index Calculator > Sidebar © Previous | Next ©
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& Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is

displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.
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On the left part of section 3. Index Map, there is an arrow that allows the user to show/hide the section by clicking on it:

¥ 3_Index Map BY default section 3. Index Map is visible.
P 3 IndexMap Section 3. Index Map is not visible.

Index Caloulator |
W 1. Reflectance Map
Generate Help
Band nm Min Avg Max Stdev Var
red 625 0.00 99,72 251.78 25.04 786.19
green 560 0.00 99.03 208.31 23.78 828.31
nir 850 0.00 93.30 190.32 23.72 562,60
W 2. Regions
Whole Map = Draw Clear o Regions... Help
W 3. Index Map
Hame Formula
B ndvi * | = |{nir -red) / (nir +red) °
Edit... Indices... \f Generate Help
Band Min Avg Max Stdev Var
sand1 -0.96 -0.03 0.97 0.07 0.01
W 4. Color Maps and Prescription
Mumber of Classes IZI Equal Area - Help
Min/Max [-0.25 | - [0.19 | [ Clamped
Color Min Max Area [ha] Area [%]
-0.00 0.19 3.28 19.98
-0.04 -0.00 8.29 20.00
-0.06 -0.04 8.29 20.01
B 0.07 -0.06 8.29 20.01
B 0.25 0.07 8.29 20.00
. IRd\"IGn = | [ tvert Prescription. ..
W 5. Export
Index Values and Rates as Polygon Shapefiles (SHP) with Grid Size [cm/f Export
Colored Index Map (GeoTIFF) and GeolPG (IPG) Export
Help

An Index Map is a single band image where each pixel value is computed using a mathematical formula combining the bands of the Reflectance Map(s). The

Index Map gives some information about the captured area.

The following information is displayed:


https://support.pix4d.com/hc/en-us/articles/202558389

Name: List of available indices. By clicking on the selected index the list of available indices appears. If the icon shown before the index name is:
g The index exists in the Pix4Dmapper index database.

For more information about the Pix4Dmapper index database list: 202558379.

& The index was created / edited by the user in this project.

, The index was created / edited by the user in another project (on the same computer) that was closed and saved.

Formula: Displays the formula associated with the selected index.

Formula Status icon: Next to the Formula there is an icon:

@ The formula is valid.

@ The formula is incomplete or contains undefined band names.

Index Status icon: If next to the Generate button there is
‘/ The index has been generated.

Edit...: Grayed out when the selected index belongs to the Pix4Dmapper database. Enabled when the selected index was created by the user. Opens the /ndex
Maps window that allows the user to edit the formula that corresponds to the selected index.

For detailed information: 202558279.

Indices...: Opens up the Index List window which displays the existing indices and allows the user to add, edit, or remowe indices. For detailed

information: 202558299.

Generate: Generates a single band GeoTiff image. Each pixel's value is computed by applying the formula to the corresponding pixel of the Reflectance Map(s). It
is grayed out if the user defined index formula is not valid.

Help: Opens the Pix4Dmapper help.

@ Important: For more information about the generated files and where they are stored: 202558739.

The section 3. Index Map also displays information about the generated index band. The following information is displayed:

Band: The Index Map has only one band to be displayed (band?).
Min: Minimum pixel value.

Avg: Average pixel value.

Max: Maximum pixel value.

Stdev. Standard deviation of pixel values.

Var: Variance of pixel values.

If the selected index has not been generated, it displays: "Selected idex map not yet generated.”

¥ 3.Index Map W 3. Index Map
Name Formula Name Formula
[Bawr  ~| = redifnirered) | @ = (nir -red) / (nir +red) (]
Edit... Index List... Generate Hell
— = [ | [ e |
Band Min Avg Madx Stdev Var
Selected index map not yet generated Band Min Avg Max Stdev Var
band1 -0.54 0.58 0.7 0.21 0.04
Index Map not generated Index Map generated
l[B Note:

One Reflectance Map is generated for each band of each group of images.

The Reflectance Maps contain the reflectance values of each pixel are used to generate the Index Maps.

The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.

If a Region is drawn, the Index Maps and Colored Index Maps will be generated only for this region.

Colored Index Maps are generated by applying the defined coloring rules to the Index Maps. They are raster files with RGB values.

If a Colored Index Map already exists, creating a new Colored Index Map will overwrite the existing one.

Index > Interface > Menu View > Index Calculator > Sidebar © Previous | Next ©
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. In section 3. Index Map, click Edit to edit the selected index (available for user defined indices).
The Index Map pop-up is used to easily edit the formula associated to the user defined index. The name of the index that is edited is displayed in the window title.
It contains 3 sections:

Reflectance Map Band Selection
Operations
Formula

And 3 action buttons:

OK: Confirms the changes.
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help.

. Index Map - ndvi_copy ? >

Reflectance Map Band Selection

Band nm Min Avg Max Stdev Var
625 0.00 99,72 25178 23.04 785,19
S5e0 0,00 99.03 268.31 28.78 828.31
|I| 850 0.00 93.30 190.32 23.72 S562.66
Operations
L+« J - (0= J0 ¢ = ]
T T A - L
| oS | | tan | | asin | | acos | | atan |
Formula

{nir -red) / (nir +red)

Valid Formula

Ok || Cancel || Hep

Reflectance Map Band Selection
Displays information for each band of each group of images of the generated Reflectance Map(s). The following information is displayed:

Band: Name of the band . If more than one group exists and the same band name exists in different groups, the bands are displayed as "Groupname_band."
nm: Wawelength of the band in nano-meters.

Min: Minimum pixel value per band.

Awg: Average pixel value per band.

Max: Maximum pixel value per band.

Stdev. Standard deviation of pixel values per band.

Var: Variance of pixel values per band.

By clicking a band button, the band name will be automatically inserted in the Formula text box at the current cursor position.

Operations
Buttons that allow the user to automatically insert mathematical operations in the formula text box at the current cursor position.

The available operations are:



Symbol  + - * / A ( )

Action addition subtraction multiplication division exponentiation open parenthesis close parenthesis
Symbol sart log sin cos tan asin acos atan
Action square root natural logarithm sine  cosine tangent arcsine arcosine arctangent
Formula

Text box to edit/write the Formula associated to the Index.
Under the text box appears a message indicating the formula validation status:

Valid formula.

Undefined "band_name" band.
Incomplete formula.

Syntax error.

@ Important: The formulas' expression is case sensitive: Distinguish between Capital and non-capital letters.

Index > Interface > Menu View > Index Calculator > Sidebar > 3. Index Map © Previous | Next ©
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is

displayed on the right of the main window. On section 3. Index Map, click Indices...

| PixdDmapper Pro

Project  Process | View rayCloud Help

B |+ Show View Toolbar
pﬁ“ﬁ Proj | ¥ Show Sidebar
0 ¥ o i Welcome
Welcome E 1 Map View
1 rayCloud

— 9 Mosaic Editor
pm— W LAY [ |ndex Calculator

> .
rayCloud | - O Processing
v 148 Log Output

Mame Formula

= |(nir -red) [ {nir +red) °
v [ ] ]

Band Min Avg Max Stdev Var
band1 -0.50 -0.02 0.94 0.07 0.00

The Index List pop-up is used to:

View the indices and their properties.
Edit user defined indices.

Duplicate indices. In order to modify an index from the Pix4Dmapper index database, it has to be duplicated. The copy will be a user defined index and can be

edited.

Add new user defined indices.
Removwe user defined indices.
Select an index.

o Index List ?
Indices
Name Formula

B red O red

B green © green

B nir O nir

B grayscale @ 0.0722 *red + 0.2126 * green + 0.7152 * nir

v B ndvi (nir - red) / (nir + red)

Edt | Dupicate || Add

Remaowve

[ ok | cancel

Help

The section Indices contains the Index table:



Status: The first column displays a green check \/ if the index has been generated and is empty if the index has not been generated.
Name: Displays:

An icon that shows if:

g The index exists in the Pix4Dmapper index database.

For more information about the Pix4Dmapper index database list: 202558379.

[ The index was created / edited by the user in this project.

&, The index was created / edited by the user in another project (on the same computer) that was closed and saved.
The index name.

Formula: Displays:

An icon that shows:

@ If the formula is valid.

@ If the formula is incomplete or contains undefined band names.

The Formula expression.
And the buttons:

Edit: Enabled for user defined indices. Opens the /ndex Map pop-up allowing the user to edit the currently selected index formula.

Duplicate: Duplicates the selected index with the name: selectedindex_copy. The duplicated index will be user defined even if it is duplicating an index from the
Pix4Dmapper index database.

Add: Creates a new user defined index. Opens the Index Map pop-up to enter the new formula. By default, it adds it with the name: unnamed. If the name already
exists, it will be created with the name: unnamed?2.

Remove: Enabled for user defined indices. Deletes the selected index.

@ Important: User defined indices created for a project will be available for other projects on the same computer.

Available actions on the table:

Select an Index: By clicking on a cell, the row will be selected and depending on the type of index (from the Pix4Dmapper database or user defined) some
buttons will be available or grayed out (see abowe for more information).

Edit Index name: Available only for user defined indices. Double click on a user defined index name and edit it.

Edit Formula: Available only for user defined indices. Double click on a user defined formula expression and edit it.

@ Important: The formulas expression is case sensitive: Distinguish Capital and non-capital letters.

The Index List pop-up has as well the following action buttons:

OK: Closes the Index List pop-up and the marked index is selected in the Name of the 3. Index Map section of the Index Calculator Sidebar.
Cancel: Closes the Index List pop-up without selecting an index.
Help: Opens the Pix4Dmapper Help.

Index > Interface > Menu View > Index Calculator > Sidebar > 3. Index Map © Previous | Next ©
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar’s display possibilities: 202558389.
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On the left part of section 4. Color Maps and Prescription, there is an arrow that allows the user to show/hide the section by clicking on it:

¥ 4. Color Maps and Prescription By default section 4. Classes is expanded and \isible.
} 4. Color Maps and Prescription Section 4. Classes is collapsed and hidden.

W 4. Color Maps and Prescription

Mumber of Classes |5 | [Equal Area =

Min/Max |-0.23 | = |0.1B | [+] Clamped
B 0.10 0.18 0.52 19.95
.02 0.10 0.52 20.00
0.04 0.02 0.52 20.01
B .06 0.04 0.52 20.01
B 0.23 0.06 0.52 20.02

B e~ O

The following information is displayed:

Number of Classes: Number of classes to classify the model. The default value is 5, the minimum value 2 and the maximum value 32.

Method of classification: It is possible to classify the area (classify the pixels in intenals based on their index value and represent each intenval using one class
and therefore one color) considering:

Equal Spacing: Selected by default, all classes have the same range.

Equal Area: All classes represents the same area in the model.

Jenks: Uses the Jenks natural breaks optimization method. For more information: Wikipedia.

Equal Spacing Equal Area Jenks

Use Min/Max:

Enter the minimum and maximum index values to ignore the values outside this range. By default it is unselected and the values are the min/max values from the
calculated results.

Clamped: Displays the pixels that have an index value outside the selected range (Min/Max) with the color of the minimum or maximum selected index values. It


https://support.pix4d.com/hc/en-us/articles/202558389
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is selected by default. If not selected, the pixels that have an index value outside the selected range (Min/Meax), will be displayed with transparency.
Classes description: It displays the properties of the classes.

Color: Color used in the Index View to represent the class.

Min / Max: Index value range used for each class.

Area [units]:Surface cowered by the class.

Area [%)]: Percentage of the total area occupied by the region.

Colors Distribution: Contains the palettes that can be used for the colors of the classes.

RdYIGn: Low values are red, medium values are yellow and high values are green, used for agriculture.

Thermal: Low values are blue, high values are red, used for temperature measurements.

Spectral: Uses all the colors of the visual spectrum, used when it is needed to distinguish many different values.

Grays: Uses a gray scale.

Blues: Uses a blue scale.

Reds: Uses a red scale.

Invert: Unselsected by default, it allows to invert the selected colors' distribution.

Prescription...: It displays some classes' parameters and allows to set the application rate and add comments:

Color: Color used in the Index View to represent the class.

Area [units]: Surface cowvered by the class.

Area [%)]: Percentage of the total area occupied by the region.

Rate: It allows to enter the application rate for each class of crops. This rate value should be filled after the on-site scouting is done. The rate units can be
whatever the tractor software can read. For chemicals and fertilizer, it could be kg/hectare, grams/hectare, liter/hectare etc. For seeds, it could be seed/hectares.
Quantity: Area[units] x Rate.

Comment: It allows to add comments for each class. These descriptions could be notes from the on-site scouting.

I Prescription 7 x
¥ Region 1
Color Area [ha] Area [3] Rate Quantity Comment &
0.50 19.38 10,00 5.05 Healthiest
0.27 10.46 20,00 545
0.78 30.06 30,00 23,49 Moderate Stress
B 1.02 39.14 40,00 078
. 0.02 0.96 0.00 0.00 Problematic Region
Total: 2 A0 100 00 TATT v
P Region 2
ok || cancel || Hep

Help: Opens the Pix4Dmapper help.
Index > Interface > Menu View > Index Calculator > Sidebar © Previous | Next ©
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.
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On the left part of section 5. Export, there is an arrow that allows the user to show/hide the section by clicking on it:

w 5 Export By default the 5. Export is expanded and visible.
P s.Export  Section 5 Export is collapsed and hidden.

W 5. Export
Index Values and Rates as Polygon Shapefiles (SHP) with Grid
Colored Index Map (GeoTIFF) and GeolPG (IPG)

Help
The following information is displayed:

Index Values and Rates as Polygon Shapefiles (.shp) with Grid Size [unit/grid]
Exports the classes as a .shp file (polygon and grid) based on the seletced Processing Options: 203891879. One shapefile will be exported for each Region. This
file can be imported directly into the tractor's displays for field (fertilizer) application.

Colored Index Map GeoTIFF (.tif) and GeoJPG (.jpg)
Exports a Colored Index Map that is generated by applying the defined coloring rules to the Index Map. It is a raster file with RGB values. One Colored Index Map
will be exported for all the regions.


https://support.pix4d.com/hc/en-us/articles/202558389
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Access: On the Menu bar, click View > Processing (enabled once a project has been loaded or created). The Processing bar is displayed at the bottom
of the main window. For information about the displayed bars: 202558389.
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The Processing bar allows the user to process a project.
It contains 1 section:

Processing

It also contains 2 Progress bars:

Current
Total

and the buttons:

Output Status: Opens an explorer window with the path where the project outputs are stored.
Start: Starts the processing of the selected processing steps.xxxx
Help: Opens the Pix4Dmapper help.

W Processing E3
1. Initial Processing 2. Point Cloud and Mesh 3. D5M, Orthomosaic and Index

Current: 0%

Total: 1. | 2. | 3. 0/23

Output Status... Cancel Help

Processing
The Processing section contains 3 subsections:

1. Initial Processing: Automatically extracts keypoints from the images to compute the interal and extemal camera parameters using the software's advanced
Automatic Aerial Triangulation (AAT) and Bundle Block Adjustment (BBA). A sparse 3D point cloud is computed and a low resolution DSM and orthomosaic are
generated and displayed in the Quality Report. For more information about the files generated during the /nitial Processing: 202558519.

Waming: When reprocessing this step for a project, the existing outputs from this step are deleted and overwritten and outputs from steps 2 and 3
(if previously completed) are deleted.

2. Point Cloud and Mesh: Generates a dense 3D point cloud and a 3D textured mesh. For more information about the files generated during the Point Cloud and
Mesh: 202558549.

A Warmning: When reprocessing this step for a project, the existing outputs from this step are deleted and overwritten and outputs from step 3 (if
previously completed) are deleted.

3. DSM, Orthomosaic and Index: Generates the DSM, orthomosaic, reflectance map and index map. For more information about the files generated during the
DSM, Orthomosaic and Index. 202558559.

A Waming: When reprocessing this step for a project, the existing outputs from this step are deleted and overwritten.

Current
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It displays the processing status of each substep as a percentage.

W Processing x
1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index

Current: Group groupl, duster 1: finalizing 216154 points 0%

wa: [ 2 | 3. 8/25
& I o] [

[m Note: When the project is processing, information about the substep that is currently running is displayed in the Current bar.

Total
It displays the processing status of all steps of processing that have been selected as the number of completed substeps.

W Processing x
1. Initial Processing 2. Point Cloud and Mesh 3. D5M, Orthomosaic and Index

Current: Group groupl, duster 1: finalizing 216154 points 0%

wa: [ 2 | 3. 8/25
QI o ][ ]

[[B Note: When the project is processing, the processing steps (1, 2, 3) that have been selected are displayed in the Total bar.
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Access: On the Menu bar, click View > Log Output (enabled once Pix4Dmapper is open). The Log Output bar is displayed at the bottom of the main
window. For information about the displayed bars: 202558389.
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The Log Output bar displays useful information about the processing of the project. It describes the steps and substeps of processing, the actions made by the
user, warnings and errors during the processing.

@ Important:
Pix4Dmapper exports the log file (project_name.log). It is stored at the output folder project_name.

The log file displayed at the Log Output bar is cleared each time that Pix4Dmapper closes. The next time that the software will be opened, the log file will
start registering the different actions from scratch.

It consists of the:

Lewels drop-down list: Allows the user to define the level of details of the log displayed on the main window.
Options drop-down list: Allows the user to set the displaying options for the log on the main window.

Search Engine: Allows the user to search for specific text / numbers in the log displayed on the main window.
Clear Log: Clears (deletes) the log displayed on the main window.

Main window: Displays the log.

Lewels
There are the following lewels of details:

[Info]: Displays general information that is printed in the log file. The text is displayed in black.
j Example: It displays the used version of Pix4Dmapper: [Info]: Version = <2.1.32>.
[Waming]: Displays the processing warming messages that are printed in the log file. The text is displayed in yellow.
j Example: [Waming]: Some geotags were invalid and therefore removed.
[Error]: Displays the error processing messages that are printed in the log file. The text is displayed in red.
/ Example: [Error]: Failed to open file <file_directory>!.
[Processing]: Displays the processing steps and substeps that are printed in the log file and their status. The text is displayed in green.
j Example: [Processing]: Substep Camera calibration started.
[UI): Displays the actions that the user does in the User Interface. The text is displayed in blue.

j Example: It displays [Ul]: Open Results Folder clicked, when the user clicks the button Open Results Folder...

Options
There are the following options:

Full Headers: It displays the full headers (Date, Time, % RAM, % CPU).
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Wrap Lines: It wraps the lines when the main window is too small.

Search Engine

It allows the user to search for specific keywords, characters of numbers. The results of the searching are displayed in the main window.

Clear Log

It clears (deletes) the log that is displayed in the main window.

Important:
The log file stored at the output folder project_name will not be deleted.
The Clear Log action can not be retrieved. Once the log is deleted from the main window, there is no way to bring it back.

Main window

It displays the log. The displayed information depends on the selected Levels and Options. If a keyword, character or number is used in the Searching Engine, the
displayed log shows only the strings that contain these elements.

Log Cutput | Levels '|| Options '| |Filter || Clear Log || Help x

[Processing]: Substep Camera calibration finished. ~
[Processing]: Substep Rematch started.
[Processing]: Read keypoints,
lj [Processing]: Read pairs.
[Processing]: Read matches. .
Processing  [Frocessing]: Generating pairs
[Processing]: Generating pairs
= [Processing]: Add matches.
e [Processing]: Rematch init.
Log Qutput [Frocessing]: Rematch images.
[ Processing): Add matches.
G [Processing]: Optimize with gecinformation.
[Processing]: Check consistency.
Processing | [Processing): Filter automatic tie points
Options [Provcessinn]: Suhsten Rematrh finished. hd
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& Access: On the Menu bar, click Help.

The Help menu has 6 items that can be selected:

Help Contents: Opens Pix4Dmapper help for the current View.

Online Support: Opens the Online support site in a browser.

Forum: Opens the Support site, displaying the forum index page.

Personal Support: Opens the Online form to submit a request to the Support Team in a browser.

Settings...: Opens the Settings window that gives the user access to the proxy and camera database settings.
About...: Provides information about the version, License, Terms of service, Privacy policy and third party licenses.

. PixdDmapper Pro
Project  Process  View  Map View | Help

. i {:} i & [ [0 HelpContents F1
P Project Proces 51 Online Support

O

Forum

Personal Support

Welcome
—
[U] Settings...
About...

Help Contents

The Pix4Dmapper help provides full and detailed information about the current View (Welcome, Map View; rayCloud, Mosaic Editor, Index Calculator).

Online Support

Opens a browser pointing to the extensive Knowledge Base which contains numerous articles with step by step instructions and answers to frequently asked
questions as well as news, updates, tutorials, user cases, etc.

Forum
The forum contains the following topics:

Projects, Experiences and Opinions: Contains posts about user projects, experiences and opinions.

Hardware (Computers, Cameras, Drones): Contains posts about hardware to use for processing, cameras and drones.

Optimized projects and image acquisition: Contains posts related to the inputs in order to obtain the best results.

Georeference (GCPs, Geolocation, Coordinate System): Contains posts regarding the use of GCPs, image geolocation and coordinate systems.

Processing Troubleshooting: Contains posts regarding: quality report, failed quality report, failed processing, processing options and bad / inaccurate results.
Outputs (Editing with Pix4Dmapper or using them in other Software): Contains posts related to the use of the Pix4Dmapper outputs:editing within Pix4Dmapper,
using in other software, etc.

Pix4Dcapture: Contains posts related to the use of the Pix4DCapture Application: hardware, tricks, experiences, opinions, troubleshooting, etc.

Pix4Dmapper Mesh: Contains posts related to the use of the Pix4Dmapper Mesh: hardware, tricks, experiences, opinions, troubleshooting, etc.

Personal Support

Contact the dedicated support team for personal support.


https://support.pix4d.com/hc/en-us/articles/200278225
https://support.pix4d.com/hc/en-us/articles/200266949
https://support.pix4d.com/hc/en-us/articles/200278205
https://support.pix4d.com/hc/en-us/articles/200266959
https://support.pix4d.com/hc/en-us/articles/200266979
https://support.pix4d.com/hc/en-us/articles/200266969
https://support.pix4d.com/hc/en-us/articles/200278215
https://support.pix4d.com/hc/en-us/articles/200288349

New ticket ¥ apply macro

Reguester | |

Start typing and we'll lock up matching users. - or add a new user

cc| |

Start typing and we'll look up matching users. - or add a new user

Share |

Subject
Status Type Priority Group Assignee License Ticket Level Owner
New - BT | M E E
Solving Time (minutes)  Edition APP  Reseller HNo Support SF_ID
| [~ = | |
Description (required)

-

Tags

Aftach file »

Create ticket (ctrks)




. Important: If you are not logged in, the following page appears:

DixaD

simply powerful

Please log in to continue

Email

Password

Don't have an account? - Sign up now
| forgot my password

Type the usemame and password and click Log In.

Settings...
Opens the Settings pop-up that gives the user access to the proxy and camera database settings.
It has 4 Tabs:

Proxy

Camera database
Language

Help Improving the Software

And 3 action buttons:

OK: Confirm the changes.
Cancel: Exit without saving.
Help: Open the Pix4Dmapper help.

Proxy



This tab allows the user to configure the Intemet connection.
The first drop down list allows the user to select how to connect to the proxy:

No Proxy (default): If no proxy sener is used.

Use Systems Settings: Uses the system wide settings.
Socks5

Hitp

The following fields are displayed:

Host: Proxy host name.

Port: Proxy port number.
Username: Proxy user name.
Password: Proxy password.

In order to enter the proxy settings: 202560089.

. Settings bt

Proxy Camera Database Language Help Improving the Software

Mo Proxy

Use Systems Settings
Socks5

Http

ok || cancel || Help

Camera database
This tab allows the user to clear the user camera model database or to import/export it from/to a file. It also displays the built-in database that is used.

The camera database tab has 2 sections:

User database: This section has the following action buttons:

Clear: Clears the user camera model database (cameras added or modified by the user).
Import...: Loads a camera database file *.xml with cameras added or modified by the user.
Export...: Exports cameras added or modified by the user to a camera database file *.xml.
Built-in database: Displays the date and the version of the last built-in camera database update.

| Settings X

Proxy Camera Database Language Help Improving the Software
User Database
C:/Users/pix4d/AppData/Local fpix4d /common 17 fucmdb. xml

ot | [ Bt

Built-In Database

2016:02:17:10:31 ‘iersion 17

Ok || Caneel || Help

Language


https://support.pix4d.com/hc/en-us/articles/202560089

This tab allows the user to set up the language.

The following languages are available:
English - U.S. Engdlish (default)
Spanish (Spain) - espariol de Espafa
Chinese (China)- 3¢ (ch[H)
Chinese (Taiwan)- 13 (& &
German (Germany)- Deutsch
Japannese (Japan)-BA:E (&)

| Settings

Proxy Camera Database Language Help Improving the Software

Select the User Interface Language:
English - U.5. English
Changes will take effect when the application is restarted.

e

Help

Help Improving the Software

I Settings

Proxy Camera Database Language Help Improving the Software

Help Improving the Software
Changes will take effect when the application is restarted.

Help us improve our products by sending anonymous processing logs.

processing parameters, crashes, error messages, etc.

products and will not be shared with any third parties.

We value your privacy. The processing logs are anonymous and do not indude personal
nformation about your computer, your computer name, IF, or geolocalization or your projects.
This data are sent using a modern encryption technigue to our servers. We will not use this
nformation for marketing purposes, it will be used solely by Pix4D SA for the improvement of its

Sharing processing logs with Pix4D 5A directly contributes to the improvement of Pix4Dmapper by
helping us to better understand how our customers use our products in the real world.

Processing logs indude camera information, processing time, number of images, options chosen,

e

Help

About...




It provides information about the version, license type, license key, license account, Terms of Use, Privacy Policy and third party licenses.

License Type
License Key

License Account: Pix4D user account to which the license is bound.

About PixdDmapper

A
Dix4p

Pix4Dmapper Pro

From Revision 2.1.34 - 64 bit

License Type: One-time charge

License Kev:h
License Account: [

Terms of Use AMD Privacy Policy

The program is provided AS IS with NO WARRANTY OF ANY KIND, INCLUDING
THE WARRANTY OF DESIGN, MERCHANTABILITY, AND FITNESS FOR A
PARTICULAR PURFOSE.

. . ~
Third Party Licenses:
Pix4Dmapper is based on proprietary technology developed by Pix4D. However it also
relies on open-source and free software that are acknowledged below:
Boost website show license
Ceres Solver website show license
Chromium website show license
]

Index > Interface
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http://pix4d.com/terms_use/
http://pix4d.com/privacy/

Index © Previous | Next ©

The Pix4D Software License is a floating license which allows the user to:

Be logged in one or more computers (devices) at the same time, according to the License type and the authorized device number as specified in the License
Certificate. For more information: 204162839.
Have Pix4Dmapper installed in any number of computers.

Pix4Dmapper Pro, is licensed to run at the same time on:

A laptop: It can be used for Rapid/Low Resolution Processing Templates while being still in the field.
A desktop machine: It can be used for higher quality processing.

The license has no limitations in both machines. All features, tools, processing steps can be used by both machines.
For more information about how to download and install the software: 202557299.
With the floating license it is possible to log out the license on one computer in order to log in on ancther. It is not needed to uninstall Pix4Dmapper:

In order to Log Out a license on a computer (steps 1 to 4): 202559999.
In order to Log In the license to another computer (steps 10 to 14): 202557299.

Index © Previous | Next ©


https://support.pix4d.com/hc/en-us/articles/204162839
https://support.pix4d.com/hc/en-us/articles/202559999

Index
The following shortcuts are available:

General shortcuts
Basic GCP/Manual Tie Point Editor shortcuts
Log output

rayCloud shortcuts
Layers Sidebar

3D View

Right Sidebar

Mosaic Editor shortcuts
View

Right Sidebar

Index Calculator

General shortcuts

Category Action Shortcut
Pix4Dmapper Help Open the Pix4Dmapper help F1
Project New project Ctd + N
Open project Ctl+0
Sawe project Ctd +S
Sawe project as Ctrl + Shift + S
Exit Ctl +Q

Basic GCP/Manual Tie Point Editor shortcuts

Category  Action

Note

Does not save the changes done in the Mosaic Editor

Shortcut  Note

Preview Remove marked GCP in currently displayed image Del The mouse needs to hover over the image
Zoom out of the image as long as the key is pressed Shift The mouse needs to hover over the image
Zoom in the image as long as the key is pressed Alt The mouse needs to hover over the image
Log output
Category Action Shortcut Note
View Open find bar Cil+F
Close find bar Esc
rayCloud shortcuts
Category Action Shortcut Note
Layers Sidebar
Tie Points > Rename point F2 A point needs to be selected
Manual/GCPs Remove point Del A point needs to be selected
Processing Areas Remowe area Del An area needs to be selected
Objects Rename object F2 An object needs to be selected
Remowe object Del An object needs to be selected
3D View
Viewpoints View All C
Focus on Selection F
Top 7
Front 1
Back Ctrl + 1
Left 3
Right Ctl +3
Home 0
Navidation Modes Standard Ctl+Y
Trackball Ctl+T
First Person Ctl+H
Navigation Modes > Zoomin +

Standard Zoom in faster Ctrl +

nyn

© Previous



Navigation Modes >
Trackball

Zoom out
Zoom out faster

Move forward parallel to the

ground plane

Mowe forward parallel to the

ground plane faster

Mowe backward parallel to
the ground plane

Move backward parallel to
the ground plane faster

Mowe up
Move up faster

Move down

Move down faster

Rotate view down
Rotate view down faster
Rotate view up

Rotate view up faster
Rotate view left

Rotate view left faster
Rotate view right

Rotate view right faster

Zoom in
Zoom in faster

Zoom out
Zoom out faster

Navigation Modes > First Mowe forward

Person

Mowe backward
Mowe left

Move right
Mowe up

Mowve down
Look up

Look down

Look left
Look right

Ctrl + "
Amow Up

Ctrl +
Arrow Up
Arrow
Down
Ctrl +
Arrow
Down
Page Up
Ctrl +
Page Up
Page
Down
Ctrl +
Page
Down

8

Ctrl + 8
2

Ctrl + 2
4

Cil +4
6

Ctrl + 6

+
Ctrl +
oy

Cirl + "

w
Amow Up
S

Arrow
Down

A

Arrow
Left

D

Arrow
Right
Page Up
Page
Down

I

Perspective/Orthographic Switch between perspective 5

Paint cloud density

Edit Densified Point
Cloud

Right Sidebar
Images section

Mosaic Editor shortcuts

and orthographic projection

Increase point density
Decrease point density

Delete points
Select all
Clear selection
Invert selection

Focus on selection
Pop up and maximize
thumbnail

Alt + "+
Alt + "0

Del

Ctl + A
Cin+C
Ctrl + 1

P
Space

Decreases the number of points \isible (improves performance on slow computers)
Increases the number of points visible (requires better computers)

Must be in Edit mode and points must be selected
Must be in Edit mode
Must be in Edit mode
Must be in Edit mode

The mouse needs to hover over the image or the image needs to be selected

Maximizes the image under the mouse cursor. Pressing Space again docks the image again
keeping the new point of view. Pressing Escape docks the image and keep previous point of view.

Insert Cell Insert a new cell after having added the last vertex.InsThe insert Cell mode needs to be activated and the vertices need to be created / marked

CategoryAction
View

Shortcut Note



View Show Ctrl + 1 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
Mosaic mosaics - 1. For example, if two mosaics are generated, the shortcut to display the second mosaic is Ctrl + 2
Show DSM Ctrl + 2  If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
mosaics - 1. For example, if two mosaics are generated, the shortcut to display the DSM is Ctrl + 3

Show Ctrl + 3 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
Region mosaics - 1. For example, if two mosaics are generated, the shortcut to display the regions is Ctrl + 4
Show Edited Ctrl + 4  If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
Mosaic mosaics - 1. For example, if two mosaics are generated, the shortcut to display the edited mosaic is Ctrl + 5
Show Ctrl + 5 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
Mosaic Area mosaics - 1. For example, if two mosaics are generated, the shortcut to display the mosaic area is Ctrl + 6
Show Cirl + 6  If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
Mosaic Tiles mosaics - 1. For example, if two mosaics are generated, the shortcut to display the mosaic tiles is Ctrl + 7

Right Sidebar

Right Mosaic 1
Sidebar Editing
Visualization2

Draw region F2 Start drawing a region. Like clicking on the Draw button
Finish Right  End drawing a region and insert it in the list

drawing Click

region

Cancel Esc

region

drawing

Index Calculator

Category Action Shortcut Note
View View the whole map C
Delete the selected region or region vertex Del The region/region vertex must be selected and the option Lock Regions must be deselected
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